runit stopt Systemstart

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von MadBSE, 02.09.2008.

  1. #1 MadBSE, 02.09.2008
    Zuletzt bearbeitet: 02.09.2008
    MadBSE

    MadBSE compuphob n00b

    Dabei seit:
    24.06.2006
    Beiträge:
    48
    Zustimmungen:
    0
    Ort:
    /home/berlin
    Hallo zusammen,

    ich habe gestern runit_1.8.0-5ubuntu2_i386 und runit-run_0.8.1_all installiert und seit dem laesst sich mythbuntu nicht mehr starten.:(

    Also erst wird /etc/runit/1 geladen:

    Code:
    #!/bin/sh
    # system one time tasks
    
    PATH=/sbin:/bin:/usr/sbin:/usr/bin
    
    /etc/init.d/rcS
    /etc/init.d/rmnologin start
    
    rm -f /sbin/runit.old
    touch /etc/runit/stopit
    chmod 0 /etc/runit/stopit
    
    Dann /etc/runit/2:
    Code:
    #!/bin/sh
    
    PATH=/usr/local/bin:/usr/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/X11R6/bin
    
    runsvchdir default >/dev/null
    
    exec env - PATH=$PATH \
    runsvdir -P /var/service 'log: ...........................................................................................................................................................................................................................................................................................................................................................................................................'
    
    Zuletzt hilft nur noch ein warmstart.X(

    Vielleicht kann mir einer von euch sagen was an den skripten zu aendern ist, damit ich mein System wider starten kann.

    Oder jemand weiss wie ich die Pakete ueber eine live CD deinstallieren kann?

    Ich freue mich ueber eure Vorschlaege.:hilfe2:
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Heureka!!!:rolleyes:

    Also ich hab jetzt alles ueber Knoppix geregelt.

    Dabei habe ich mich groessten teils an die vorgehensweise von folgendem Foreneintrag gehalten:
    http://forum.ubuntuusers.de/topic/zugriffsrechte-aendern-im-shell-von-live-cd/

    1.Partition eingebunden platte schiebbar gemacht (bequem ueber den Desktop:D).
    2.Mit Strg+Alt+F1 auf das erste Terminal gewechselt.
    3.Mit passwd ein neues root Passwort erstellt.
    4.Konsole im Systemverwaltungsmodus geoeffnet
    5.Mit chroot /media/sdb2 dann die Zugriffsrechte geaendert.
    6.Und zu guter Letzt mit dpkg -r runit runit-run die stoerenden Pakete entfernt.

    Jetzt lüpt wieder alles.:finger:

    Gruss MadBSE:winke:
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

runit stopt Systemstart