RPM - Propleme

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Psilophil, 12.06.2007.

  1. #1 Psilophil, 12.06.2007
    Psilophil

    Psilophil Jungspund

    Dabei seit:
    27.05.2007
    Beiträge:
    19
    Zustimmungen:
    0
    Da ich mit der neusten Wine Verion nicht mehr zu den Steamservern connecten kann, möchte ich die gut laufende 0.9.37 wieder instalieren.

    Habe mir die entpr. rpm herutnergeladen, und versucht mit
    Code:
    sudo rpm -i wine-0.9.37-13.1.jacklab.1.src.rpm
    zu instalieren.

    leider bricht der Vorgang nach der Ausgabe von
    Code:
    warning: user ed does not exist - using root
    warning: user ed does not exist - using root
    warning: user ed does not exist - using root
    warning: user ed does not exist - using root
    warning: user ed does not exist - using root
    
    erfolglos ab.

    Wer weiß rat? :))

    Lieben Gruß
    Psilophil
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Mitzekotze, 12.06.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Hast du denn ganzen Vorgang schon mal als angemeldeter Root ausgeführt?
    Also vorher mit "su" zum Benutzer Root wechseln und dann nochmal denn Befehl eingegeben.

    EDIT: Auch glaube ich das das RPM Archiv was du da hast nur den Quelltext enthält. Man kann das auch über den rpm glaub ich übersetzen aber die Syntax fällt mir gerade nicht ein.
     
  4. #3 Psilophil, 12.06.2007
    Zuletzt bearbeitet: 12.06.2007
    Psilophil

    Psilophil Jungspund

    Dabei seit:
    27.05.2007
    Beiträge:
    19
    Zustimmungen:
    0
    Als root passiert leider genau das selbe...:think:
     
  5. #4 hofmannc11, 12.06.2007
    hofmannc11

    hofmannc11 der der mit dem Tux tanzt

    Dabei seit:
    17.01.2007
    Beiträge:
    332
    Zustimmungen:
    0
    Ort:
    Bad Langensalza
    Ich bin mir nicht sicher, aber ich glaube zum direkten kompilieren unter Suse war es der befehl rpm --build packet.src.rpm oder wenn schon eine Version drauf ist rpm --rebuild packet.src.rpm. schau einfach mal in die Manpage oder rpm --help. Hast du auch schon die neuere Wine Version entfernt? Wenn nein wirst du es schwer haben eine ältere Version drauf zu bekommen :)
     
  6. #5 grandpa, 12.06.2007
    grandpa

    grandpa CLOSED

    Dabei seit:
    31.08.2005
    Beiträge:
    147
    Zustimmungen:
    0
    evtl. hilft dir das (klick) weiter
     
  7. #6 Psilophil, 12.06.2007
    Zuletzt bearbeitet: 12.06.2007
    Psilophil

    Psilophil Jungspund

    Dabei seit:
    27.05.2007
    Beiträge:
    19
    Zustimmungen:
    0
    Danke soweit... :) ....die alte neue Wineversion is natrl runter..

    Leider ist die fehlerausgabe nach beim rpmbuild noch grausliger als zuvor:

    Code:
    sudo rpmbuild --rebuild wine-0.9.37-13.1.jacklab.1.src.rpm
    root's password:
    Installing wine-0.9.37-13.1.jacklab.1.src.rpm
    warning: user ed does not exist - using root
    warning: user ed does not exist - using root
    warning: user ed does not exist - using root
    warning: user ed does not exist - using root
    warning: user ed does not exist - using root
    error: Failed build dependencies:
            cups-devel is needed by wine-0.9.37-13.1.jacklab.1.x86_64
            fontforge is needed by wine-0.9.37-13.1.jacklab.1.x86_64
            .
            .zich zeilen..
            .
            Mesa-devel is needed by wine-0.9.37-13.1.jacklab.1.x86_64
    --build statt --rebuild gibt wunderlicherweise 'unknown option'

    Soll ich erstmal alle beanstandeten pakete von hand installieren? Von Bison bis Xorg?? kann doch nich...
     
  8. #7 reni, 12.06.2007
    Zuletzt von einem Moderator bearbeitet: 12.06.2007
    reni

    reni Guest

    Zum Selberkompillieren müssen natürlich diverse devel-RPMs installiert sein ... die fehlen dir, wie man sieht ;)

    Wenn ich allerdings deinen Anfangspost lese, bezweifle ich, dass du wirklich selbst kompillieren willst.

    Sauge dir das rpm und NICHT das src.rpm ... oder noch besser:
    Ergänze dir das JackLab-Verzeichnis als Installationsquelle im Paketmanager deiner Wahl (das geht ... ich weiß es ;) )

    EDIT:
    Und noch was der Vollständigkeithalber.
    "warning: user ed does not exist - using root" <= das ist KEIN Fehler, sondern nur eine Warnung!
    => Das Paket wurde als User "ed" gebaut, den auf es auf deinem System nicht gibt.
    Darum wird die Aktion bei dir als User root erledigt.
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. #8 Psilophil, 12.06.2007
    Psilophil

    Psilophil Jungspund

    Dabei seit:
    27.05.2007
    Beiträge:
    19
    Zustimmungen:
    0
    Dank dir reni... :))

    hab noch ne normale rpm datei gefunden...jetzt klappts :) thx!!!!!
    Das erspart mit viel...

    PS: Obwohl es eine warnung und keine fehler war, kam die installation ja nicht zusatande.
     
  11. reni

    reni Guest

    Glaub ich nicht.
    Die kam sehr wohl zustande, nur siehst du bei einem src.rpm nicht gleich etwas davon.

    Aber schau mal nach /usr/src/packages/
    Da hast du nun sicherlich unter SPEC/ ein Spec-File und in SOURCES/ die Quellen liegen ;)
     
Thema:

RPM - Propleme

Die Seite wird geladen...

RPM - Propleme - Ähnliche Themen

  1. Netzwerkpropleme allgemein in openSUSE 11 "achtung Newbie"

    Netzwerkpropleme allgemein in openSUSE 11 "achtung Newbie": Dies sind meine ersten Schritte mit Linux. Hab zwar schon den Server umgestellt, der Kablegebunden mit SUSE10.1 wunderbar läuft. Nun wollte ich...
  2. knoppix propleme mit pcmcia :-(

    knoppix propleme mit pcmcia :-(: ich weiß gar nicht wirklich ob ich hier richtig bin mit meinem knoppix problem... i hope so :-) und zwar kann ich nur von der knoppix cd booten...
  3. zeit propleme

    zeit propleme: Hallo liebe Forengemeinde Nach mühevollem Googeln und blutigen Man-pages lesen und Howto wälzen bin ich mit meinem latein am Ende. Um mein...