Root-User Probleme!

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von TerrorTino, 06.06.2007.

  1. #1 TerrorTino, 06.06.2007
    TerrorTino

    TerrorTino Jungspund

    Dabei seit:
    15.01.2007
    Beiträge:
    14
    Zustimmungen:
    0
    servus,

    dummerweise hab ich mein root PW vergessen...ja ich weiss das ist unschön,

    hab in div. seiten gelesen wie man angeblich das wieder hinbiegen kann also über die /etc/passwd Datei das "x" rausnehmen oder in der shadow-Datei den Hashwert löschen...

    alles schön und gut ABER: opensuse startet ich logge mich mit den normalen user acc ein alles ohne probs: start Terminal und mache su dann kommt:

    "User Root does not exist" ? häää was da los?

    2.) bei aufruf vom Yast arbeitet er kurz und dann bricht er ab und es ist so als hätte ich den yast nie aufgerufen. , der KDE Netzwerkmanager geht auch nimmer..


    Bitte sagt mir nicht das ich das System neu machen muss*heul*
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 z-shell, 06.06.2007
    z-shell

    z-shell Debianator

    Dabei seit:
    30.05.2007
    Beiträge:
    434
    Zustimmungen:
    0
    Ort:
    /home/z-shell
    Nicht oder. Beides!
    In der /etc/passwd nimmst du das x raus, und in der /etc/shadow ersetzt du den hash mit einem "!"

    Dann hast du was falsch gemacht.
    Nimm ne Live-CD, und schau in den genannten Dateien nach.
    ggf ändern.
    Falls root wirklich nicht existieren sollte:
    Code:
    echo "root::0:0::/:/bin/sh" >> /etc/passwd
    Nachdem du dich eingeloggt hast, machst du als root:
    Code:
    passwd root
     
  4. #3 TerrorTino, 06.06.2007
    Zuletzt bearbeitet: 06.06.2007
    TerrorTino

    TerrorTino Jungspund

    Dabei seit:
    15.01.2007
    Beiträge:
    14
    Zustimmungen:
    0
    also in passwd gibt es nen root eintrag und auch in der shadow Datei hab die änderungen wie von dir beschrieben gemacht.

    das steht in der passwd:

    root::0:root:/root:/bin/bash

    das in der shadowdatei:

    root:!:13580::::::

    neu booten dann kommt die anmeldemaske: als User geb ich root an und Passwort lasse ich leer: -> anmeldung fehlgeschlagen

    dummerweise kann ich mich als root nicht einloggen :-( und so kann ich das passwd root ned neu setzen ;-(


    ich bin dann in die Konsole gewechselt: dz09 login: root enter
    dann kommt Passwort: was soll ich da eingeben?

    mein User account geht ja zum login

    thx schonmal
     
  5. #4 z-shell, 06.06.2007
    z-shell

    z-shell Debianator

    Dabei seit:
    30.05.2007
    Beiträge:
    434
    Zustimmungen:
    0
    Ort:
    /home/z-shell
    Garnichts. Ruth hat ja kein pw mehr ;)
    Wenn das so nicht geht, erstelle mittels einer Live-CD einen user mit rootrechten:
    Code:
    mount /systempartition /mnt
    echo "h4xxor::0:0::/:/bin/sh" >> /mnt/etc/passwd
    reboot
    (wobei "Systempartition" wahrscheinlich hda1 ist)
    Dann loggst du dich mit "h4xxor" ein, und gibst root ein neues pw:
    Code:
    passwd root
    Danach kannst du "h4xxor" ja wieder löschen.
     
  6. #5 bitmuncher, 06.06.2007
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    1. Live-CD(z.B. Knoppix) booten.
    2. Linux-Partition mounten.
    3. 'chroot /mountpoint/wo/die/linux-part/eingehaengt/ist' ausführen
    4. Mit 'passwd' das root-Passwort neu setzen.
    5. Mit 'exit' die chroot-Umgebung wieder verlassen.
    6. Rebooten und einloggen.
     
  7. #6 TerrorTino, 06.06.2007
    Zuletzt bearbeitet: 06.06.2007
    TerrorTino

    TerrorTino Jungspund

    Dabei seit:
    15.01.2007
    Beiträge:
    14
    Zustimmungen:
    0
    user ist in passwdfile drin, bei der anmeldemaske geb ich den namen ein lasse pw leer und es kommt :

    anmeldung fehlgeschlagen...grrr

    verdammt Ruth X(
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    passwd root geht ned weil er sagt unknown user root :-(


    achja ich starte das Linux um das zeugs zu ändern im Failsafemodus mit der option vmlinux init=/bin/sh

    und die Datein kann ich so ja ändern
     
  8. #7 z-shell, 06.06.2007
    z-shell

    z-shell Debianator

    Dabei seit:
    30.05.2007
    Beiträge:
    434
    Zustimmungen:
    0
    Ort:
    /home/z-shell
    Nein, du musst ne Live-CD nehmen. (was für eine, ist Wurscht)
    Dann mounten, und in die Umgebung chrooten.
    Code:
    mount /systempartition /mnt
    chroot /mnt/ /bin/bash
    Und dann wie beschrieben vorgehen.
     
  9. #8 TerrorTino, 06.06.2007
    TerrorTino

    TerrorTino Jungspund

    Dabei seit:
    15.01.2007
    Beiträge:
    14
    Zustimmungen:
    0
    also mit diesem h4xxor user komme ich dann zum login auf der kommandoebene, da kann ich diesem user und meinem normalen user die PW`s ändern..sage ich aber

    passwd root kommt

    unknown user root...

    lol..ah ne ist nicht mehr zum lachen :-(
     
  10. #9 z-shell, 06.06.2007
    z-shell

    z-shell Debianator

    Dabei seit:
    30.05.2007
    Beiträge:
    434
    Zustimmungen:
    0
    Ort:
    /home/z-shell
    Dann lass "root" mal weg.
    Einfach:
    Code:
    passwd
     
  11. #10 TerrorTino, 06.06.2007
    Zuletzt bearbeitet: 06.06.2007
    TerrorTino

    TerrorTino Jungspund

    Dabei seit:
    15.01.2007
    Beiträge:
    14
    Zustimmungen:
    0
    ahhh ich MUSS ne Live Cd nehmen..hm ok dann probier ich es damit mal...

    Danke :-) aber durch diese Übungen wird man ja a bisl fitter und es macht langsam spass das Linux :-)
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    hab ich ja dann will er das pw für h4xxor ändern weil der er letzte user ist der in dem pw file drin steht in der letzten zeile---wenn ihn das interessiert - ist mal so ne vermutung meiner wenigkeit :-)
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    http://www.chip.de/c1_forum/thread.html?bwthreadid=966917


    deshalb hab i den weg mal probiert
     
  12. #11 z-shell, 06.06.2007
    z-shell

    z-shell Debianator

    Dabei seit:
    30.05.2007
    Beiträge:
    434
    Zustimmungen:
    0
    Ort:
    /home/z-shell
    Hrrg..
    Wenn du als user "h4xxor" angemeldet bist, und
    Code:
    passwd
    eingibst, änderst du auch sein pw.
    Mit
    Code:
    passwd root
    änerst du dann das rootpasswort.

    Wenn du den login als root hast, reicht ein
    Code:
    passwd
    .
     
  13. #12 TerrorTino, 06.06.2007
    Zuletzt bearbeitet: 06.06.2007
    TerrorTino

    TerrorTino Jungspund

    Dabei seit:
    15.01.2007
    Beiträge:
    14
    Zustimmungen:
    0
    so habs mit knoppix gerade probiert...problem wenn ich nur passwd in dem Terminal eingebe will der das PW für h4xxor ändern, sage ich passwd root kommt unbekannter user, die rootpartition ist eingehängt unter /mnt

    hm ich versteh das ned..
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .


    er kennt den user root aber ned :-)
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    also ich bin im textmodus als h4xxor mit id sehe ich unter gid=0(root)

    gebe ich nun passwd ein ändert er es ja für den h4xxor account schön mache ich...


    gebe ich passwd root ein kommt immernoch unknown user `root`:hilfe2:
     
  14. #13 Bâshgob, 06.06.2007
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    Das "Unknown user root" resultiert mit Sicherheit daher als das du mehr gelöscht hast in der /etc/passwd und/oder der /etc/shadow als gesund ist.

    Poste mal bitte die Abschnitte aus beiden Dateien.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 TerrorTino, 06.06.2007
    Zuletzt bearbeitet: 06.06.2007
    TerrorTino

    TerrorTino Jungspund

    Dabei seit:
    15.01.2007
    Beiträge:
    14
    Zustimmungen:
    0
    hm komisch mit einmal ist in der passwd kein root mehr drin uppps...

    und nu verdammte axt...
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    so user root gibt es wieder, login funktioniert aber nicht. Gebe ich im Terminal meines Useraccounts su an kommt incorrect passwort..? hä ich konnte ja ned mal ein su pw angeben...

    ach ja ein xterminal login des root mit PW geht auch nicht

    ich denke ich werde das system neu machen :-(
     
  17. #15 Bâshgob, 06.06.2007
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    Du könntest dir arbeit ersparen würdest du die beiden Dateien mal herzeigen.

    Aber mach, wie du denkst. Verschwende deine Zeit.
     
Thema:

Root-User Probleme!

Die Seite wird geladen...

Root-User Probleme! - Ähnliche Themen

  1. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  2. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...
  3. Forscher analysieren Durchsatzprobleme im Linux-Scheduler

    Forscher analysieren Durchsatzprobleme im Linux-Scheduler: Eine Gruppe von Forschern hat Fälle identifiziert, in denen der Scheduler im Linux-Kernel falsche Entscheidungen trifft und die CPUs nicht so gut...
  4. München: LiMux als Sündenbock für IT-Probleme?

    München: LiMux als Sündenbock für IT-Probleme?: Im Münchner Stadtrat soll später in diesem Jahr erneut über den Einsatz von Linux in der Stadtverwaltung diskutiert werden. Die Grünen vermuten,...
  5. BSI-Audit findet keine akuten Probleme in OpenSSL

    BSI-Audit findet keine akuten Probleme in OpenSSL: Das Bundesamt für Sicherheit in der Informationstechnik hat OpenSSL auf seine Sicherheit untersuchen lassen. Die Analyse zeigt vor allem, dass die...