Remote Login mit KDM

Dieses Thema im Forum "KDE" wurde erstellt von miketech, 08.01.2004.

  1. #1 miketech, 08.01.2004
    miketech

    miketech Routinier

    Dabei seit:
    03.04.2003
    Beiträge:
    403
    Zustimmungen:
    0
    Hi zusammen,

    ich habe hier 2 Linux (Gentoo) Rechner. Ich möchte gerne erreichen, dass ich mich von Rechner B Remote in Rechner A einloggen kann. Ich hab schon im Internet gegoogelt, aber ich werde daraus nicht schlau. Ich benutze KDM und möchte also, dass wenn X auf Rechner B startet, auch erstmal der KDM dargestellt wird. Ich habe das bis jetzt wie folgt versucht zu lösen:

    Auf Rechner B starte ich als root:

    X -query IPvonRechnerA


    Unter Rechner A habe ich in der Xaccess in /etc/X11/xdm folgende Zeile aus dem Kommentar gelöscht:

    * #any host can get a login window

    Dann habe ich in der xdm-config folgende Zeile mittels ! auskommentiert:

    ! DisplayManager.requestPort: 0

    Und dann noch in der /usr/kde/3.1/share/config/kdm/kdmrc

    [Xdmcp]
    Enable=true
    Willing=
    Xaccess=/etc/X11/xdm/Xaccess

    eingetragen. Aber wenn ich nun auf Rechner B versuche X zu starten kommt zwar X, aber kein KDM. Da seh ich nur den schwarzen Cursor und das wars. Weiß jemand woran das liegen kann? Hab ich irgendwas vergessen?

    Danke

    Mike
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bartlaby, 09.01.2004
    bartlaby

    bartlaby Tripel-As

    Dabei seit:
    18.02.2003
    Beiträge:
    150
    Zustimmungen:
    0
    Ort:
    Haren, Niedersachsen (Immer dem Schnaps nach)
    in der /etc/rc.conf kdm als normalen DM eingetragen?
     
  4. #3 miketech, 09.01.2004
    miketech

    miketech Routinier

    Dabei seit:
    03.04.2003
    Beiträge:
    403
    Zustimmungen:
    0
    Hi,

    yup ist eingetragen. Noch eine Idee?

    MfG

    Mike
     
  5. nikros

    nikros Grünschnabel

    Dabei seit:
    17.11.2004
    Beiträge:
    1
    Zustimmungen:
    0
    Ein kleiner Schritt für die Menschheit ....

    Nicht wirklich denn auch ich hänge fest. Allerdings einen Schritt weiter: Ich bekomme ein Loginfenster von KDM zu sehen. Kann mich einloggen und warte vergebens...

    Aber hier die Info um weiter zu kommen:
    ---------- Konfigurationsdateien Server
    UDP port 177 wird vom X11 Server benutzt darf von Firewall nicht geblockt sein.

    # nano -w /etc/X11/xdm/xdm-config

    DisplayManager.requestPort: 0
    soll zu
    ! DisplayManager.requestPort: 0

    nano -w /etc/X11/xdm/Xaccess

    %hostlist rechner-a rechner-b
    * CHOOSER %hostlist

    nano -w /etc/X11/xdm/Xservers
    :0 local /usr/X11R6/bin/X
    oder ähnlich sollte nicht geändert werden. Es müssen aber die Clients wie folgt nachgetragen werden:

    rechner-a:0 foreign
    rechner-b:0 foreign


    nano -w /etc/X11/xdm/Xresources
    In Xresources werden das Layout, die Fenstergröße und Farben des Login-Fensters definiert. Ich habe daran (noch) nichts verändert.


    Startscript xdm
    xdm automatisch nach dem Bootvorgang starten sonst kann auch nix kommen.
    # rc-update add xdm default
     
  6. Cyber

    Cyber .:DISTORTED:.

    Dabei seit:
    16.05.2003
    Beiträge:
    999
    Zustimmungen:
    0
    Ort:
    D -> BW -> Karlsruhe
    Hui, der Thread ist zwar schon über ein dreiviertel-jahr alt, aber ich bin auch gerade dran das einrichten zu wollen. Gleiche Ausgangssituation, 2xGentoo mit jeweil 2xKDE.

    Allerdings habe ich vor, das ganze über NoMachine zu realisieren, damit bin ich dann auch etwas unabhängiger vom KDE, da auch andere DM unterstützt werden.

    Möge der schnellere Erfolg vermelden :]

    //EDIT:

    Und herzlich willkommen !
     
  7. hopfe

    hopfe Haudegen

    Dabei seit:
    01.04.2003
    Beiträge:
    733
    Zustimmungen:
    0
    Ort:
    Aachen
    @nikros, hast du auf einen der beiden Geräte ein Firewall laufen? Wenn ja kontrolliere mal die Logs hatte beim Remote-X-Zugriff ein ähnliches Problem. Erst nach den Freigeben eines Ports gings nach der Anmeldung weiter, leider kann ich dir nicht mehr sagen welcher das genau war :(.

    @Cybermarc,
    Habe auch mal einen NX-Server installiert, ist eigentlich relativ Problemlos. Wobei bei mir klappte die Verbindung irgendwie nicht, da beide Geräte jeweils über mehrere Router liefen :(.
     
  8. #7 Sir Auron, 17.11.2004
    Sir Auron

    Sir Auron Routinier

    Dabei seit:
    26.04.2004
    Beiträge:
    482
    Zustimmungen:
    0
    Du musst die Router per Link Port verbinden und gegebenfalls IP-Adressen und Netmasks anpassen oder sehe ich das falsch?
     
  9. hopfe

    hopfe Haudegen

    Dabei seit:
    01.04.2003
    Beiträge:
    733
    Zustimmungen:
    0
    Ort:
    Aachen
    Mein Probelm war, das Server und Client nur über Internet verbunden waren und jeder von Beiden min, über einen Router oder Firewall hinweg mit den Inet verbunden war.

    Wenn du Erfolg haben solltest, kannst mir ja verraten was du anpassen mußtest, wobei ich immer noch nicht verstehe warum es nicht klappt, da eine ssh Verbindung kein Problem ist.
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. Cyber

    Cyber .:DISTORTED:.

    Dabei seit:
    16.05.2003
    Beiträge:
    999
    Zustimmungen:
    0
    Ort:
    D -> BW -> Karlsruhe
    @hopfe:

    Ich geb Dir auf jeden Fall bescheid, dauert allerdings noch ein paar tage.
     
  12. #10 Shellcrawler, 09.09.2005
    Shellcrawler

    Shellcrawler Grünschnabel

    Dabei seit:
    09.09.2005
    Beiträge:
    1
    Zustimmungen:
    0
    Hallo Ihr Linux Freaks

    Um kdm richtig zu aktivieren, muss die Datei /etc/X11/kdm/Xaccess ebenfalls ins Konfigurationsverzeichnis des KDE kopiert werden (/opt/kde/share/config/kdm).
    Diese und kdmrc noch etwas bearbeitet und dann sollte der kdm funktionieren.
    Steht eine Firewall dazwischen, sollten Ports 177/UDP (outgoing) und 6000/TCP (incoming) freigeschaltet sein.

    Danach muss nach das Programm genkdmconf (Bestandteil des KDE) aufgerufen werden.

    Chears Shellcrawler

    :) :D

    X11 rocks ...
     
Thema:

Remote Login mit KDM

Die Seite wird geladen...

Remote Login mit KDM - Ähnliche Themen

  1. Remote Login Historie

    Remote Login Historie: Hallo, wie kann ich auf einem SuSE 9.2 sehen, wer sich wann von welchem Rechner remote z.B. per SSH eingeloggt hat? In welchem Log-File kann...
  2. [HP-UX] "Remote Login" Option in der CDE Anmeldemaske

    [HP-UX] "Remote Login" Option in der CDE Anmeldemaske: Moin, weiss jemand wie ich in die CDE Anmeldemaske eine "Remote Login" Option bekomme? Bei Solaris 10 ist das standardmäßig vorhanden....
  3. Server mit VM Servern und Remote Login (debian?)

    Server mit VM Servern und Remote Login (debian?): Ich bin neu hier im Board und hoffe, dass ich diesen Thread auch richtig gepostet habe. Mein Problem, ich will ein Netzwerk absichern, habe aber...
  4. Root user remote login verbieten??

    Root user remote login verbieten??: Hi, Habe es bereits auf mehreren System gesehen, nun wollte ich wissen wie und wo man das einstellen kann. Und zwar das man nicht direkt über...
  5. Remote Login

    Remote Login: Moin. Kennt jemand von euch ne Möglichkeit, wie ich in einer ssh-session einen Prozeß bzw. Programm starten kann, welches aber nach meinem LogOut...