rechte für diverse dev's

Dieses Thema im Forum "Laufwerke / Speichermedien" wurde erstellt von snax, 16.06.2004.

  1. snax

    snax Doppel-As

    Dabei seit:
    31.03.2004
    Beiträge:
    140
    Zustimmungen:
    0
    Ort:
    BaWü
    kurze frage (die aber möglicherweise eine lange antwort erfordert :D)

    also ich habe hier ein noch recht frisches arch linux, bisher kann ich nur als root mein cd/dvd laufwerk und usb stick mounten.

    wie und wo muss ich eigentlich die rechte einstellen, sodass ich auch als user mounten kann?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. tig

    tig Tripel-As

    Dabei seit:
    09.02.2004
    Beiträge:
    229
    Zustimmungen:
    0
    Du musst in deiner fstab jeweils in den Mount-Optionen die umasks der user angeben. z.B.
    Code:
    umask=0022
    gib einfach mal
    Code:
    umask
    ein.
     
  4. #3 snax, 16.06.2004
    Zuletzt bearbeitet: 16.06.2004
    snax

    snax Doppel-As

    Dabei seit:
    31.03.2004
    Beiträge:
    140
    Zustimmungen:
    0
    Ort:
    BaWü
    hm...

    also die entsprechenden einträge in meiner fstab sehen so aus:

    cdrom
    /dev/cdroms/cdrom0 /mnt/cd iso9660 ro,exec,user,noauto,unhide,umask=0022 0 0
    dvd
    /dev/cdroms/cdrom0 /mnt/dvd udf ro,exec,user,noauto,unhide,umask=0022 0 0
    stick
    /dev/sda /mnt/usbstick vfat user,noauto,umask=0022 0 0

    dann hab ich mit mount -a die fstab neu eingelesen. cdrom eingelegt und als user versucht zu mounten, ergebnis war: mount: only root can do that.

    hm vll mal neu starten? :D

    edit: ne neustart bringt auch nichts..
     
  5. #4 snax, 16.06.2004
    Zuletzt bearbeitet: 16.06.2004
    snax

    snax Doppel-As

    Dabei seit:
    31.03.2004
    Beiträge:
    140
    Zustimmungen:
    0
    Ort:
    BaWü
    also das mounten des usb stick's als user klappt schonmal :)

    aber mount /mnt/cd klappt nicht. hier nochmal die entsprechenden zeilen aus meiner fstab:

    /dev/cdroms/cdrom0 /mnt/cd iso9660 noauto,user,ro,exec,umask=0022 0 0
    /dev/cdroms/cdrom0 /mnt/dvd udf noauto,user,ro,exec,umask=0022 0 0
    /dev/sda /mnt/usbstick vfat noauto,user,umaks=0022 0 0

    also mount /mnt/cd erzeugt folgenden fehler:

    mount: Falscher Dateisystemtyp, ungültige Option, der Superblock von /dev/cdroms/cdrom0 ist beschädigt oder sind zu viele Dateisysteme eingehängt.

    also ich glaube "ungültige Option" kann man schonmal ausschliessen. "zu viele Dateisysteme" auch. bleiben noch "Falscher Dateisystemtyp" und "Superblock ist schrott" 8o

    edit: ok dvd kann ich auch mounten, nur cd erzeugt den fehler :frage:
     
  6. #5 qmasterrr, 17.06.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    Ort:
    Germany/NRW/Wesel
    versuch es doch mal mit einer anderen cd

    btw: keine musiccd
     
  7. #6 NiceDay, 17.06.2004
    NiceDay

    NiceDay Aushilfe

    Dabei seit:
    17.05.2003
    Beiträge:
    1.314
    Zustimmungen:
    0
    Ort:
    Elmshorn
    Musik-CDs mit Dateninhalt musste tatsächlich als root wie folgt mounten: "mount /dev/cdroms/cdrom0 /mnt/cd -t iso9660" - "/mnt/cd" solltest du danach aber auch als normaler User nutzen können (z.B. um ein auf der befindliches Musik-Video abspielen zu können etc.).
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. #7 snax, 17.06.2004
    Zuletzt bearbeitet: 17.06.2004
    snax

    snax Doppel-As

    Dabei seit:
    31.03.2004
    Beiträge:
    140
    Zustimmungen:
    0
    Ort:
    BaWü
    ich kann nur dvd's mounten 8o habe jetzt einige cd's getestet: audio, daten, einige live cd's, selbstgebrannte. immer selbe fehlermeldung (auch als root).

    das check ich nicht, denn ich habe linux schliesslich mit selbstgebrannten cd's installiert und jetzt kann ich keine mehr lesen?? ist das vll ein treiber prob? ...aber das laufwerk wird korrekt erkannt.

    bah, warum passieren mir immer solch unerklärliche dinge :D na ich pruckel und google mal weiter.

    edit: aha wenn ich jetzt als root die cd mit der option -t mounte, so wie's NDO beschrieben hat, klappt es (meldung: mount: block device /dev/cdroms/cdrom0 is write protected, mounting read-only). hm "-t" wird aber nicht in der fstab akzeptiert.
     
  10. snax

    snax Doppel-As

    Dabei seit:
    31.03.2004
    Beiträge:
    140
    Zustimmungen:
    0
    Ort:
    BaWü
    noch etwas interessantes, das aufklärung bedarf (zumindest bei mir) :D

    wenn ich als root "mount /mnt/cd" ausführe bekomme ich die übliche fehlermeldung: "wrong fs type, bad option, bad superblock on /dev/cdroms/cdrom0, or too many mounted file systems".

    aber... mounte ich als root wie folgt, klappt es "mount /dev/cdroms/cdrom0 /mnt/cd".
     
Thema:

rechte für diverse dev's

Die Seite wird geladen...

rechte für diverse dev's - Ähnliche Themen

  1. Pioneer Awards der EFF für den Einsatz für Privatsphäre und Grundrechte

    Pioneer Awards der EFF für den Einsatz für Privatsphäre und Grundrechte: Die Electronic Frontier Foundation (EFF) wird am 24. September ihre Pioneer Awards 2015 an mehrere Personen und Organisation verleihen. Der Preis...
  2. Samba-Dateiserver, Zugriffsrechte für Netzlaufwerke

    Samba-Dateiserver, Zugriffsrechte für Netzlaufwerke: Hallo liebe Community Ich bin ein absoluter Samba-Anfänger, habe also kein technisches Hintergrundwissen in Sachen Samba. Meine Frage zu...
  3. Schreibrechte für Ordner

    Schreibrechte für Ordner: Hallo Zusammen, ich habe ein altes Debian Webserver-Testsystem neu aufsetzen müßen und leider sind beim Kopieren die Rechte verloren gegangen....
  4. Samba-Rechte für User

    Samba-Rechte für User: Hallo, ich hab mich grad verrannt und komme nicht weiter:think:, ich möchte folgendes auf meinen Samab-Server umsetzen::hilfe2: Folgene...
  5. Beste Zugriffsrechte für Webordner

    Beste Zugriffsrechte für Webordner: Ich wusste nicht, wie ich das Thema nennen soll. Jedenfalls ist mir ein kleines missgeschick passiert. Und zwar wollte ich verhindern, dass jeder...