rc.local macht nicht, was es soll

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von flowflow, 26.06.2008.

  1. #1 flowflow, 26.06.2008
    flowflow

    flowflow Grünschnabel

    Dabei seit:
    26.06.2008
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo,

    ich habe eine funktionierende Installation unter Ubuntu 6 & OOO 2.0
    In etc/rc.local habe ich eine Datei /Verzeichnis/ooo.sh & eingetragen
    Diese Datei läßt soffice an Port 8100 lauschen:

    xvfb-run -a /usr/lib/openoffice/program/soffice -headless -accept="socket,port=8100;urp;" > /dev/null

    Das funktioniert alles wunderbar! Mit ps augx finde ich auch den passenden Prozess!

    Jetzt möchte ich das gleiche unter Ubuntu 8 & OOO 2.4 installieren:
    Nach meiner Meinung wird alles identisch installiert. Alle Rechte und User- & Gruppenzuordnungen sind gleich.

    Den Inhalt der Datei ooo.sh habe ich geändert. Er lautet jetzt:
    /usr/bin/soffice -headless -accept="socket,port=8100;urp;" > /dev/null
    Diese Änderung dürfte es aber nicht sein, denn...

    ...wenn ich die Datei ooo.sh manuell an der Shell aufrufe, funktioniert auch alles.

    Nur eben nicht, wenn ich den blöden PC boote! Mit ps augx sehe ich auch nichts!

    Es sieht so aus, als ob die rc.local einfach nicht ausgeführt wird.

    Hilfe! Verzweiflung! Ich darf niemandem erzählen, wie lange ich an dem Problem schon zu knabbern habe!

    Kann jemand meine Verzweiflung in ein Glücksgefühl verwandeln?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. karru

    karru OSX'ler

    Dabei seit:
    02.05.2006
    Beiträge:
    338
    Zustimmungen:
    0
    Hi flowflow,

    Pack mal ein "touch /tmp/ooo.sh" am Ende der Datei und starte den betreffenden Computer nochmal.
    Um zu gucken ob das Skript überhaupt ausgeführt wird.

    Gruß
     
  4. #3 supersucker, 26.06.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Und vor allem poste mal deine komplette rc.local.....
     
  5. #4 flowflow, 26.06.2008
    flowflow

    flowflow Grünschnabel

    Dabei seit:
    26.06.2008
    Beiträge:
    5
    Zustimmungen:
    0
    Wow, Ihr seid ja schnell!
    Also die Geschichte mit touch habe ich gerade ausgeführt. Eine entsprechende Datei findet sich in tmp.

    Meine Datei rc.local sieht so aus:

    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.

    /usr/local/test/ooo.sh &

    exit 0

    Da die Sache mit touch klappt und der Shell-Aufruf klappt, sollte es daran nicht liegen.

    Habe aber gerade noch eine Sache gemacht & gemerkt:
    Habe mich einmal als root eingeloggt und versucht, OpenOffice als Anwendung zu starten. Das hat geklappt. Aber...

    ... dann habe ich mich noch einmal als Normaler User eingeloggt und jetzt kommt die Nachricht, dass eine andere Instanz von Openoffice.org auf meine persönlichen Einstellungen zugreift oder diese nicht wieder freigegeben hat. Dann muß man sich entscheiden, ob man abbrechen möchte oder trotzdem öffnen will.

    Vielleicht passiert so etwas ähnliches auch, wenn der Prozess gestartet werden soll?

    Hilft das schon weiter? Soll ich einmal mein outout von ps augx posten - einfach so oder kann man das noch irgendwie besser einbinden?

    Bin sehr neugierig!
     
  6. #5 supersucker, 26.06.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Ah,

    das könnte wirklich der Grund sein.

    Probier mal folgenden Aufruf in der rc.local:

    Code:
    su dein_user_name -c /usr/local/test/ooo.sh &
     
  7. #6 flowflow, 26.06.2008
    flowflow

    flowflow Grünschnabel

    Dabei seit:
    26.06.2008
    Beiträge:
    5
    Zustimmungen:
    0
    Habe den Code gleich ausprobiert!
    Leider keine Veränderung!
    Hat jemand noch eine Idee?
     
  8. #7 supersucker, 26.06.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Nimm mal das exit 0; noch raus.
     
  9. #8 Aqualung, 26.06.2008
    Zuletzt bearbeitet: 26.06.2008
    Aqualung

    Aqualung Routinier

    Dabei seit:
    12.02.2008
    Beiträge:
    404
    Zustimmungen:
    0
    http://wiki.ubuntuusers.de/rc.local

    Trag mal in Deine rc.local ein

    Code:
    env > /tmp/env.tmp
    und poste den Inhalt von /tmp/env.tmp.

    Vermutlich braucht OO ein DISPLAY.
    Kannst mal an den Anfang von rc.local setzen:

    Code:
    export DISPLAY=:0
    Ist eigentlich sinnfrei, weil noch kein X-Server läuft.
     
  10. #9 Goodspeed, 26.06.2008
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Ich tippe mal darauf, dass Du das "xvfb-run" trotzem brauchst.
    Alternativ kannste das "> /dev/null" ja erstmal weglassen und die Ausgabe in einen vernünftige Datei umleiten ...
     
  11. karru

    karru OSX'ler

    Dabei seit:
    02.05.2006
    Beiträge:
    338
    Zustimmungen:
    0
    Sehr wahrscheinlich wirst du xvfb-run noch benötigen.
    Den zum Zeitpunkt des Systemstarts läuft X noch nicht.

    Test it!
     
  12. #11 flowflow, 27.06.2008
    flowflow

    flowflow Grünschnabel

    Dabei seit:
    26.06.2008
    Beiträge:
    5
    Zustimmungen:
    0
    Also ich habe env > /tmp/env.tmp in die rc.local eingetragen. Heraus kommt:

    runlevel=2
    QUIET=yes
    UPSTART_JOB=rc2
    UPSTART_JOB_ID=5
    TERM=linux
    PATH=/sbin:/bin:/usr/sbin:/usr/bin
    RUNLEVEL=2
    DISPLAY=:0
    PREVLEVEL=N
    UPSTART_EVENT=runlevel
    previous=N
    PWD=/
    VERBOSE=no

    Sagt mir nicht wirklich viel.

    Es scheint tatsächlich an dem Display irgendwie zu liegen:

    Habe in der Datei ooo.sh folgenden Aufruf gestartet:

    /usr/bin/soffice -headless -accept="socket,port=8100;urp;" > /tmp/office.log 2>&1

    Als Ergebnis kam das heraus:

    javaldx: Could not find a Java Runtime Environment!
    Failed to open display
    I18N: Operating system doesn't support locale ""
    I18N: Operating system doesn't support locale "en_US"
    /usr/lib/openoffice/program/soffice.bin X11 error: Can't open display: -headless
    Set DISPLAY environment variable, use -display option
    or check permissions of your X-Server
    (See "man X" resp. "man xhost" for details)

    Weder "Java Runtime Environment" noch "Operating system doesn't support locale" dürften die Ursache sein, da diese Meldungen auch beim manuellen Aufruf erscheinen!

    Ich habe schon einmal die -display option eingebaut, hat aber nicht funktioniert!
    Wie kann ich denn die Rechte für den X-Server testen?

    In der rc.local am Anfang (also nach den auskommentierten Zeilen)
    hat leider noch nicht geholfen.

    @ karru: ich habe noch einmal meine ursprüngliche Zeile getestet:
    Hat leider nicht geklappt - nicht einmal mehr manuell ;-(

    Noch jemand nicht ratlos?
     
  13. #12 Aqualung, 27.06.2008
    Aqualung

    Aqualung Routinier

    Dabei seit:
    12.02.2008
    Beiträge:
    404
    Zustimmungen:
    0
  14. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  15. #13 flowflow, 28.06.2008
    flowflow

    flowflow Grünschnabel

    Dabei seit:
    26.06.2008
    Beiträge:
    5
    Zustimmungen:
    0
    Autostart ist nicht das, was ich suche. Das Ganze soll letztlich auch ohne Login funktionieren, also PC an und Kommunikation über http.

    Sonst noch jemand eine Idee?

    Da das Thema sich nun auf X11 display X-Server xauth xvfb irgendwie reduziert hat, soll ich noch einmal einen neuen Thread anfangen?
     
  16. #14 Aqualung, 28.06.2008
    Aqualung

    Aqualung Routinier

    Dabei seit:
    12.02.2008
    Beiträge:
    404
    Zustimmungen:
    0
    Die Zeile

    Code:
    xvfb-run -a /usr/lib/openoffice/program/soffice -headless -accept="socket,port=8100;urp;" > /dev/null
    
    ist evtl. so funktioneller:

    Code:
    xvfb-run -a[B][COLOR="Red"] "[/COLOR][/B]/usr/lib/openoffice/program/soffice -headless -accept=[B][COLOR="Red"]'[/COLOR][/B]socket,port=8100;urp;[COLOR="Red"][B]'[/B][/COLOR][COLOR="Red"][B]"[/B][/COLOR] > /tmp/err.xyz
    Du willst ja nicht, dass "-headless" eine Option für xvfb-run ist.

    Du muss vllt. noch die ' durch \" oder ... ersetzen.

    Die Fehlermeldung

    Code:
    /usr/lib/openoffice/program/soffice.bin X11 error: Can't open display: -headless
    Set DISPLAY environment variable, use -display option
    
    sagt das etwas verklausuliert.

    Die Fehlermeldungen würde ich nach > /tmp/err.xyz, nicht nach /dev/null.

    Ein eigenes Startskript, dass nach dem Xserver gestartet wird, ist keine Option für Dich?
     
Thema:

rc.local macht nicht, was es soll

Die Seite wird geladen...

rc.local macht nicht, was es soll - Ähnliche Themen

  1. Google Chrome macht das halbe Hundert voll

    Google Chrome macht das halbe Hundert voll: Chrome 50 wurde in den stabilen Release-Kanal übernommen und will die Ladezeiten von Webseiten mit einer Preload-Funktion verbessern. Weiterlesen...
  2. OpenMandriva macht sich von ROSA unabhängig

    OpenMandriva macht sich von ROSA unabhängig: Das OpenMandriva-Projekt betreibt jetzt unabhängige Build-Server und ist damit komplett eigenständig. Auch eine Server-Distribution ist in Arbeit....
  3. Let' s Encrypt macht Fortschritte

    Let' s Encrypt macht Fortschritte: Das Projekt »Let's Encrypt«, das die Anzahl verschlüsselter Webseiten erhöhen will, indem es kostenfreie, sich automatisch installierende und...
  4. Canonical macht Markenrichtlinien GPL-konform

    Canonical macht Markenrichtlinien GPL-konform: Nach langen Verhandlungen mit der Free Software Foundation und der Software Freedom Conservancy hat Canonical seine Markenrichtlinien so...
  5. Opensuse macht einen Sprung: Opensuse Leap 42

    Opensuse macht einen Sprung: Opensuse Leap 42: Das Opensuse-Entwicklerteam hat sich auf den Namen und die Versionsnummer der nächsten Ausgabe der Distribution geeinigt. Demnach dürfen die...