RaLink RT2570 USB für Fedora 8

Dieses Thema im Forum "RedHat,Fedora & CentOS" wurde erstellt von MrB, 12.02.2008.

  1. MrB

    MrB Grünschnabel

    Dabei seit:
    05.02.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo zusammen,

    Möchte mich mal an euch wenden weil ich wirklich nicht mehr weiterkommen bei der Installation meines USB WLAN Sticks. Ich hoffe einfach mal einer von euch kann mir helfen.

    Versuche den Treiber für den RT2570 Chipsatz (USB) auf meinem Fedora 8 System ans laufen zu bekommen aber beim ausfüren des Makefile kommt folgender Fehler hoch:

    [root@localhost ~]# cd rt2570-1.1.0-b2/
    [root@localhost rt2570-1.1.0-b2]# cd Modul
    bash: cd: Modul: Datei oder Verzeichnis nicht gefunden
    [root@localhost rt2570-1.1.0-b2]# cd Module
    [root@localhost Module]# make
    make[1]: Entering directory `/usr/src/kernels/2.6.23.1-42.fc8-i686'
    CC [M] /root/rt2570-1.1.0-b2/Module/rtusb_main.o
    /root/rt2570-1.1.0-b2/Module/rtusb_main.c: In function »usb_rtusb_probe«:
    /root/rt2570-1.1.0-b2/Module/rtusb_main.c:1905: Fehler: »dev_base« nicht deklariert (erste
    Benutzung in dieser Funktion)
    /root/rt2570-1.1.0-b2/Module/rtusb_main.c:1905: Fehler: (Jeder nicht deklarierte Bezeichner wird
    nur einmal aufgeführt
    /root/rt2570-1.1.0-b2/Module/rtusb_main.c:1905: Fehler: für jede Funktion in der er auftritt.)
    /root/rt2570-1.1.0-b2/Module/rtusb_main.c:1905: Fehler: »struct net_device« hat kein Element
    namens »next«
    make[2]: *** [/root/rt2570-1.1.0-b2/Module/rtusb_main.o] Fehler 1
    make[1]: *** [_module_/root/rt2570-1.1.0-b2/Module] Fehler 2
    make[1]: Leaving directory `/usr/src/kernels/2.6.23.1-42.fc8-i686'
    rt2570.ko failed to build!
    make: *** [module] Fehler 1
    [root@localhost Module]


    Kann mir da jemand helfen oder hatte jemand schon mal das selbe Problem ?
    Muss dazu sagen das ich wirklich LINUX Anfänger bin aber eigentlich glaube alles richtig gemacht zu haben.

    Naja...hoffe mal....jemand kennt das Problem.

    Für jede Hilfe Danke ich im Voraus.

    Gruß

    B
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Gast1

    Gast1 Guest

    USB-ID des Sticks?

    Auf jeden Fall ist aber der Treiber zu alt für den verwendeten Kernel.

    Fragt sich nur, ob das Gefrickel überhaupt nötig ist, ich vermute, daß es da fertige Pakete gibt.

    Greetz,

    RM
     
  4. #3 kostjaXP, 12.02.2008
    kostjaXP

    kostjaXP =[KT]=SUpOrt GUnNer=[KT]=

    Dabei seit:
    09.02.2007
    Beiträge:
    388
    Zustimmungen:
    0
    Ort:
    /home
  5. Gast1

    Gast1 Guest

    *Hüstel*

    Code:
    make[1]: Entering directory `/usr/src/kernels/[B]2.6.23.1-42.fc8[/B]-i686'
    => http://rpm.pbone.net/index.php3/stat/6/idpl/5336384

    Code:
    //lib/modules/2.6.23.1-42.fc8/kernel/drivers/net/wireless/rt2x00
     /lib/modules/2.6.23.1-42.fc8/kernel/drivers/net/wireless/rt2x00/rt2400pci.ko
     /lib/modules/2.6.23.1-42.fc8/kernel/drivers/net/wireless/rt2x00/rt2500pci.ko
     /lib/modules/2.6.23.1-42.fc8/kernel/drivers/net/wireless/rt2x00/rt2500usb.ko
     /lib/modules/2.6.23.1-42.fc8/kernel/drivers/net/wireless/rt2x00/rt2x00lib.ko
     /lib/modules/2.6.23.1-42.fc8/kernel/drivers/net/wireless/rt2x00/rt2x00pci.ko
     /lib/modules/2.6.23.1-42.fc8/kernel/drivers/net/wireless/rt2x00/rt2x00usb.ko
     /lib/modules/2.6.23.1-42.fc8/kernel/drivers/net/wireless/rt2x00/rt61pci.ko
     /lib/modules/2.6.23.1-42.fc8/kernel/drivers/net/wireless/rt2x00/rt73usb.ko
    Eine USB-ID wäre jetzt aber noch interessanter (bevor man überhaupt an ein Kernelupdate denkt bzw. irgendwas selbst zusammenzuklöppelt).

    Treiber wäre jedenfalls schonmal da.

    Greetz,

    RM
     
  6. #5 kostjaXP, 12.02.2008
    Zuletzt bearbeitet: 12.02.2008
    kostjaXP

    kostjaXP =[KT]=SUpOrt GUnNer=[KT]=

    Dabei seit:
    09.02.2007
    Beiträge:
    388
    Zustimmungen:
    0
    Ort:
    /home
  7. Gast1

    Gast1 Guest

    Ja, ein interessanter Thread, vor allem das hier:

    http://rt2x00.serialmonkey.com/phpBB2/viewtopic.php?t=4393&sid=00079dba1449b41c665fce2b2c0a677e

    Und das wäre nicht das erste Mal, daß ein "RT2570" sich als "RT2571" (aka rt73-Chip) "entpuppt".

    Genau _deshalb_ will ich ja auch die USB-ID sehen, egal, was auf der Schachtel steht.

    Der rt73usb braucht eine Firmware und wenn diese fehlt, dann kann der TE so viele Treiber kompilieren wie er lustig ist.

    Also wieso nicht zuerst nachsehen, ob es mit den schon mitgelieferten Treibern im 2.6.23er funktioniert und eben nur die Firmware fehlt?

    Greetz,

    RM
     
  8. MrB

    MrB Grünschnabel

    Dabei seit:
    05.02.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Wow.....
    Erst mal herzlichen Dank für die ganzen Posts. Habe es jetzt mal wie vorgeschlagen mit diesen hier versucht:

    http://rt2x00.serialmonkey.com/rt2570-cvs-daily.tar.gz

    Die liessen sich zumindest schon mal fehlerfrei installieren bzw. kompilieren.

    Mein USB ID...zumindest was auf dem Stick steht lautet:

    WNC-0301
    USB06070915723-v3

    Es handelt sich um ein LevelOne Gerät.
    Hilft das ?

    Kann unter meiner Fedora immer noch nicht meine WLAN Konfigurieren also sehe den Stick im Netzwerkmanager nicht so das SSID ect konfigurieren kann, aber habe das gefühl das es an meinem unvermögen Linux seitig liegt.
    Werde mich also erst mal mit Modprobe und iwconfig beschäftigen bevor ich euch wieder belästige....
    Auf jeden Fall schon mal vielen Dank

    Gruß
    B
     
  9. #8 kostjaXP, 12.02.2008
    kostjaXP

    kostjaXP =[KT]=SUpOrt GUnNer=[KT]=

    Dabei seit:
    09.02.2007
    Beiträge:
    388
    Zustimmungen:
    0
    Ort:
    /home
    sollte mit dem befehl
    Code:
    lsusb
    klappen
     
  10. MrB

    MrB Grünschnabel

    Dabei seit:
    05.02.2008
    Beiträge:
    4
    Zustimmungen:
    0
    OK,
    Habe jetzt mal ein wenig rumprobiert.....bekomme den Device im Network Configuration Tool aber nicht angezeigt. Modprobe kennt das Modul aber.
    Weis nicht was ich falsch mache :-(

    lsusb wirft folgendes aus:

    Code:
    [root@localhost ~]# modprobe rt2570
    [root@localhost ~]# lsusb
    Bus 002 Device 001: ID 0000:0000
    Bus 008 Device 002: ID 046d:c517 Logitech, Inc.
    Bus 008 Device 001: ID 0000:0000
    Bus 007 Device 001: ID 0000:0000
    Bus 006 Device 001: ID 0000:0000
    Bus 001 Device 003: ID 148f:2573 Ralink Technology, Corp.
    Bus 001 Device 002: ID 04a9:1718 Canon, Inc.
    Bus 001 Device 001: ID 0000:0000
    Bus 005 Device 001: ID 0000:0000
    Bus 004 Device 001: ID 0000:0000
    Bus 003 Device 001: ID 0000:0000
    
    Liegt es vielleicht daran das der Ralink dort ein 2573 ist ?
    Bin mal wieder auf eure Hilfe angewiesen.

    Gruß

    B
     
  11. #10 kostjaXP, 12.02.2008
    Zuletzt bearbeitet: 13.02.2008
    kostjaXP

    kostjaXP =[KT]=SUpOrt GUnNer=[KT]=

    Dabei seit:
    09.02.2007
    Beiträge:
    388
    Zustimmungen:
    0
    Ort:
    /home
    ok probieren mit dem anderen treiber..was sonst?? EDIT: ok ok dann halt nicht..kompilieren macht aber spaß..
    vorher hat man kein plan ...
    http://www.linkremoved.it
     
  12. Gast1

    Gast1 Guest

    Sprech ich eigentlich Kisuaheli, daß keine Sau meine Postings liest?

    Saggelzement LUJA sog I!

    Code:
    modinfo rt73usb|grep 2573
    alias:          usb:v[B]148F[/B]p[B]2573[/B]d*dc*dsc*dp*ic*isc*ip*
    Da ist der Vogel doch!

    rt2x00-firmware-1.1-1.noarch.rpm=> Installieren.

    Greetz,

    RM
     
  13. #12 kostjaXP, 13.02.2008
    kostjaXP

    kostjaXP =[KT]=SUpOrt GUnNer=[KT]=

    Dabei seit:
    09.02.2007
    Beiträge:
    388
    Zustimmungen:
    0
    Ort:
    /home
    Kisuaheli ist das, ok..

    zumindest mir ist das völlig wurscht, so bekommt man wenigstens Übung beim kompilieren :)) :O
     
  14. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  15. MrB

    MrB Grünschnabel

    Dabei seit:
    05.02.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Ok, schon mal heißen Dank für die enorme Hilfe. Bin fast durch. Der rt73 wars...Firmware habe ich trotzdem nochmal drauf gehauen. Vielen Dank dafür....
    Sehe den Device zwar immer noch nicht im GNOME Netzwerk Manager aber kann über die Konsole nach Netztwerken Scannen und bekomme glaube ich sogar zutritt zu meinem.
    Problem ist nur...irgendwie zieht sich mein WLAN0 Device nur eine IPV6 Adresse...habe die Vermutung das da irgend eine Kleinigkeit noch nicht stimmt. Könnt Ihr mir nochmal helfen ?

    Schöne Grüße
    B
     
  16. Gast1

    Gast1 Guest

    Nein, bei dieser "Informtionsdichte" sicher nicht.

    Sollte das Ding allerdings wirklich mit dem "Legacy"-Treber rt73.ko und nicht mit dem schon vorher vorhandenen rt73usb.ko betrieben werden, dann kannst Du Dir den NetworkManager eh abschminken.

    Greetz,

    RM
     
Thema:

RaLink RT2570 USB für Fedora 8

Die Seite wird geladen...

RaLink RT2570 USB für Fedora 8 - Ähnliche Themen

  1. Wireless Sound Modem/Router mit Ralink RT5350

    Wireless Sound Modem/Router mit Ralink RT5350: Hai, ich habe hier ein Wireless Sound Modem/Router-Modul mit einem Ralink RT5350. Beim Booten meldet es: Starting kernel ... LINUX...
  2. Ralink vervollständigt Linux-WLAN-Treiber

    Ralink vervollständigt Linux-WLAN-Treiber: Der taiwanesische Hersteller Ralink hat damit begonnen, Verbesserungen zum Linux-Treiber für seine eigenen WLAN-Chips direkt beizutragen....
  3. Prob. Ralink

    Prob. Ralink: Hey Leute ich habe Pobleme mit meiner WLAn karte auf meiN Medion Akoya E1210. (Die KArte ist von Ralink). Also ich habe sie unter Ubuntu 8.04...
  4. WLAN: Ralink RT2561 wird unter Netzwerkeinstellungen (Debian) nicht angezeigt

    WLAN: Ralink RT2561 wird unter Netzwerkeinstellungen (Debian) nicht angezeigt: Hallo zusammen, nachdem ich jetzt schon den 3. abend bzw. tag in n foren x seiten gelesen habe, hoffe ich, das mir hier jemand helfen kann (wie...
  5. Conceptronic C54Ri mit Ralink RT2561/RT61 läuft unter openSuse 10.3 nicht

    Conceptronic C54Ri mit Ralink RT2561/RT61 läuft unter openSuse 10.3 nicht: Hallo Zusammen, bin umgezogen und möchte nun ein WLAN einrichten. Ich habe es auch schon zum laufen gebracht - und zwar sowohl mit Kubuntu 7.10...