Raid mit HPT370

Dieses Thema im Forum "Gentoo" wurde erstellt von Micke, 23.09.2005.

  1. Micke

    Micke Grünschnabel

    Dabei seit:
    23.09.2005
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo,

    ich suche schon seit ewig im Internet aber finden tuh ich nix :-(

    Nun zu meinem Problem:

    Habe 2 80GB Platten die ich mit dem Controller HPT370 als Mirror zusammen gefasst habe.

    Nun will ich darauf mein Gentoo installieren mit der Live-CD Uni.

    Meinen Kernel starte ich so:
    Code:
    Kernel command line: initrd=gentoo.igz root=/dev/ram0 init=/linuxrc looptype=squashfs loop=/livecd.squashfs dokeymap cdroot BOOT_IMAGE=gentoo doraid doataraid doscsi
    
    also eigentlich alles eingebunden.

    aber am ende finde ich nur eine hde und ne hdg Platte eine auf ide2 und die andere ide3. Jedoch sollten sie zusammen gefasst sein.

    ich habe auch keine weiteren Ordner in /dev/

    erkannt wird der controller laut dmesg

    Code:
    HPT370: IDE controller at PCI slot 0000:00:13.0
    ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 15
    PCI: setting IRQ 15 as level-triggered
    ACPI: PCI Interrupt 0000:00:13.0[A] -> Link [LNKC] -> GSI 15 (level, low) -> IRQ 15
    HPT370: chipset revision 3
    HPT37X: using 33MHz PCI clock
    HPT370: 100% native mode on irq 15
        ide2: BM-DMA at 0xe800-0xe807, BIOS settings: hde:DMA, hdf:pio
        ide3: BM-DMA at 0xe808-0xe80f, BIOS settings: hdg:DMA, hdh:pio
    Probing IDE interface ide2...
    hde: Maxtor 6Y080L0, ATA DISK drive
    ide2 at 0xd800-0xd807,0xdc02 on irq 15
    Probing IDE interface ide3...
    hdg: Maxtor 6Y080L0, ATA DISK drive
    ide3 at 0xe000-0xe007,0xe402 on irq 15
    Probing IDE interface ide1...
    Probing IDE interface ide4...
    Probing IDE interface ide5...
    hde: max request size: 128KiB
    hde: 160086528 sectors (81964 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
    hde: cache flushes supported
     hde: hde1 hde2 hde3
    hdg: max request size: 128KiB
    hdg: 160086528 sectors (81964 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
    hdg: cache flushes supported
     hdg: hdg1 hdg2 < hdg5 hdg6 >
    hda: ATAPI 24X CD-ROM CD-R/RW drive, 1024kB Cache, DMA
    
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Schau mal ob das modul ataraid wirklich geladen wurde (notfalls per hand nachladen).
     
  4. #3 Micke, 23.09.2005
    Zuletzt bearbeitet: 23.09.2005
    Micke

    Micke Grünschnabel

    Dabei seit:
    23.09.2005
    Beiträge:
    3
    Zustimmungen:
    0
    Na gut,

    das habe ich gemacht und ist auch keine Fehlermeldung gekommen,
    aber in /dev/ habe ich dadurch noch keine änderungen festgestellt.

    Müsste ja sowas wie "md" oder in der art auftauchen.

    es sind auch nur ide platten macht hoffentlich jetzt kein unterschied zu sata

    ps

    in /dev/rd/

    habe ich nur 0-15 stehen
     
  5. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Schau mal mit "dmesg" ob er nach manuellem laden von ataraid was meldet ...
     
  6. Micke

    Micke Grünschnabel

    Dabei seit:
    23.09.2005
    Beiträge:
    3
    Zustimmungen:
    0
    ich habe jetzt mal die dmesg dran gehängt

    aber ich habe nix davon gefunden

    Code:
     
    Linux version 2.6.12-gentoo-r6 (root@poseidon) (gcc version 3.3.5-20050130 (Gentoo 3.3.5.20050130-r1, ssp-3.3.5.20050130-1, pie-8.7.7.1)) #1 SMP Wed Aug 3 20:26:57 UTC 2005
    BIOS-provided physical RAM map:
     BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)
     BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
     BIOS-e820: 0000000000100000 - 000000002fff0000 (usable)
     BIOS-e820: 000000002fff0000 - 000000002fff3000 (ACPI NVS)
     BIOS-e820: 000000002fff3000 - 0000000030000000 (ACPI data)
     BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
    0MB HIGHMEM available.
    767MB LOWMEM available.
    On node 0 totalpages: 196592
      DMA zone: 4096 pages, LIFO batch:1
      Normal zone: 192496 pages, LIFO batch:31
      HighMem zone: 0 pages, LIFO batch:1
    DMI 2.3 present.
    ACPI: RSDP (v000 VT8371                                ) @ 0x000f7ce0
    ACPI: RSDT (v001 VT8371 AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x2fff3000
    ACPI: FADT (v001 VT8371 AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x2fff3040
    ACPI: DSDT (v001 VT8371 AWRDACPI 0x00001000 MSFT 0x0100000c) @ 0x00000000
    Allocating PCI resources starting at 30000000 (gap: 30000000:cfff0000)
    Built 1 zonelists
    Kernel command line: initrd=gentoo.igz root=/dev/ram0 init=/linuxrc looptype=squashfs loop=/livecd.squashfs dokeymap cdroot BOOT_IMAGE=gentoo doataraid doraid doscsi
    Local APIC disabled by BIOS -- you can enable it with "lapic"
    mapped APIC to ffffd000 (01645000)
    Initializing CPU#0
    CPU 0 irqstacks, hard=c0409000 soft=c0401000
    PID hash table entries: 4096 (order: 12, 65536 bytes)
    Detected 700.407 MHz processor.
    Using tsc for high-res timesource
    Speakup v-2.00 CVS: Wed Mar 2 20:22:02 EST 2005 : initialized
    Console: colour VGA+ 80x25
    Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
    Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
    Memory: 758708k/786368k available (2263k kernel code, 27068k reserved, 596k data, 192k init, 0k highmem)
    Checking if this processor honours the WP bit even in supervisor mode... Ok.
    Calibrating delay loop... 1368.06 BogoMIPS (lpj=684032)
    Mount-cache hash table entries: 512
    Couldn't initialize miscdevice /dev/synth.
    CPU: After generic identify, caps: 0183f9ff c1c7f9ff 00000000 00000000 00000000 00000000 00000000
    CPU: After vendor identify, caps: 0183f9ff c1c7f9ff 00000000 00000000 00000000 00000000 00000000
    CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
    CPU: L2 Cache: 64K (64 bytes/line)
    CPU: After all inits, caps: 0183f9ff c1c7f9ff 00000000 00000020 00000000 00000000 00000000
    Enabling fast FPU save and restore... done.
    Checking 'hlt' instruction... OK.
    ACPI: setting ELCR to 0008 (from 9c08)
    CPU0: AMD Duron(tm) Processor stepping 01
    SMP motherboard not detected.
    Local APIC not detected. Using dummy APIC emulation.
    Brought up 1 CPUs
    CPU0 attaching sched-domain:
     domain 0: span 01
      groups: 01
      domain 1: span 01
       groups: 01
    checking if image is initramfs... it is
    Freeing initrd memory: 16420k freed
    NET: Registered protocol family 16
    EISA bus registered
    PCI: PCI BIOS revision 2.10 entry at 0xfb430, last bus=1
    PCI: Using configuration type 1
    mtrr: v2.0 (20020519)
    ACPI: Subsystem revision 20050309
    ACPI: Interpreter enabled
    ACPI: Using PIC for interrupt routing
    ACPI: PCI Root Bridge [PCI0] (0000:00)
    PCI: Probing PCI hardware (bus 00)
    Boot video device is 0000:00:11.0
    ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
    ACPI: PCI Interrupt Link [LNKA] (IRQs 1 3 4 5 6 7 10 11 *12 14 15)
    ACPI: PCI Interrupt Link [LNKB] (IRQs 1 3 4 5 6 7 *10 11 12 14 15)
    ACPI: PCI Interrupt Link [LNKC] (IRQs 1 3 4 5 6 7 10 11 12 14 *15)
    ACPI: PCI Interrupt Link [LNKD] (IRQs 1 3 4 5 6 7 10 *11 12 14 15)
    Linux Plug and Play Support v0.97 (c) Adam Belay
    pnp: PnP ACPI init
    pnp: PnP ACPI: found 9 devices
    SCSI subsystem initialized
    PCI: Using ACPI for IRQ routing
    PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
    inotify device minor=63
    Squashfs 2.1 (released 2004/12/10) (C) 2002-2004 Phillip Lougher
    SGI XFS with ACLs, security attributes, realtime, large block numbers, no debug enabled
    SGI XFS Quota Management subsystem
    Initializing Cryptographic API
    PCI: Disabling Via external APIC routing
    isapnp: Scanning for PnP cards...
    isapnp: No Plug & Play device found
    PNP: PS/2 controller doesn't have AUX irq; using default 0xc
    PNP: PS/2 Controller [PNP0303:PS2K] at 0x60,0x64 irq 112
    serio: i8042 AUX port at 0x60,0x64 irq 12
    serio: i8042 KBD port at 0x60,0x64 irq 1
    Serial: 8250/16550 driver $Revision: 1.90 $ 48 ports, IRQ sharing enabled
    ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    mice: PS/2 mouse device common for all mice
    io scheduler noop registered
    io scheduler deadline registered
    RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
    loop: loaded (max 8 devices)
    Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    VP_IDE: IDE controller at PCI slot 0000:00:07.1
    PCI: Via IRQ fixup for 0000:00:07.1, from 255 to 0
    VP_IDE: chipset revision 16
    VP_IDE: not 100% native mode: will probe irqs later
    VP_IDE: VIA vt82c686a (rev 22) IDE UDMA66 controller on pci0000:00:07.1
        ide0: BM-DMA at 0xc000-0xc007, BIOS settings: hda:DMA, hdb:pio
    Probing IDE interface ide0...
    input: AT Translated Set 2 keyboard on isa0060/serio0
    hda: CD-RW CRX100E, ATAPI CD/DVD-ROM drive
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    HPT370: IDE controller at PCI slot 0000:00:13.0
    ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 15
    PCI: setting IRQ 15 as level-triggered
    ACPI: PCI Interrupt 0000:00:13.0[A] -> Link [LNKC] -> GSI 15 (level, low) -> IRQ 15
    HPT370: chipset revision 3
    HPT37X: using 33MHz PCI clock
    HPT370: 100% native mode on irq 15
        ide2: BM-DMA at 0xe800-0xe807, BIOS settings: hde:DMA, hdf:pio
        ide3: BM-DMA at 0xe808-0xe80f, BIOS settings: hdg:DMA, hdh:pio
    Probing IDE interface ide2...
    hde: Maxtor 6Y080L0, ATA DISK drive
    ide2 at 0xd800-0xd807,0xdc02 on irq 15
    Probing IDE interface ide3...
    hdg: Maxtor 6Y080L0, ATA DISK drive
    ide3 at 0xe000-0xe007,0xe402 on irq 15
    Probing IDE interface ide1...
    Probing IDE interface ide4...
    Probing IDE interface ide5...
    hde: max request size: 128KiB
    hde: 160086528 sectors (81964 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
    hde: cache flushes supported
     hde: hde1 hde2 hde3
    hdg: max request size: 128KiB
    hdg: 160086528 sectors (81964 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
    hdg: cache flushes supported
     hdg: hdg1 hdg2 < hdg5 hdg6 >
    hda: ATAPI 24X CD-ROM CD-R/RW drive, 1024kB Cache, DMA
    Uniform CD-ROM driver Revision: 3.20
    EISA: Probing bus 0 at eisa.0
    Cannot allocate resource for EISA slot 4
    Cannot allocate resource for EISA slot 5
    Cannot allocate resource for EISA slot 6
    EISA: Detected 0 cards.
    NET: Registered protocol family 2
    IP: routing cache hash table of 4096 buckets, 64Kbytes
    TCP established hash table entries: 131072 (order: 9, 2097152 bytes)
    TCP bind hash table entries: 65536 (order: 7, 786432 bytes)
    TCP: Hash tables configured (established 131072 bind 65536)
    NET: Registered protocol family 1
    NET: Registered protocol family 17
    Freeing unused kernel memory: 192k freed
    usbcore: registered new driver usbfs
    usbcore: registered new driver hub
    usbcore: registered new driver hiddev
    usbcore: registered new driver usbhid
    drivers/usb/input/hid-core.c: v2.01:USB HID core driver
    Initializing USB Mass Storage driver...
    usbcore: registered new driver usb-storage
    USB Mass Storage support registered.
    USB Universal Host Controller Interface driver v2.2
    ohci_hcd: 2004 Nov 08 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
    sl811: driver sl811-hcd, 19 May 2005
    ieee1394: Initialized config rom entry `ip1394'
    sbp2: $Rev: 1219 $ Ben Collins <bcollins@debian.org>
    libata version 1.11 loaded.
    device-mapper: 4.4.0-ioctl (2005-01-12) initialised: dm-devel@redhat.com
    NCR53c406a: no available ports found
    scsi: <fdomain> Detection failed (no card)
    GDT-HA: Storage RAID Controller Driver. Version: 3.04
    GDT-HA: Found 0 PCI Storage RAID Controllers
    qlogicfas: no cards were found, please specify I/O address and IRQ using iobase= and irq= optionsFailed initialization of WD-7000 SCSI card!
    NCR53c406a: no available ports found
    imm: Version 2.05 (for Linux 2.4.0)
    sym53c416.c: Version 1.0.0-ac
    Fusion MPT base driver 3.01.20
    Copyright (c) 1999-2004 LSI Logic Corporation
    Fusion MPT SCSI Host driver 3.01.20
    ReiserFS: hda: warning: sh-2021: reiserfs_fill_super: can not find reiserfs on hda
    VFS: Can't find ext3 filesystem on dev hda.
    VFS: Can't find an ext2 filesystem on dev hda.
    SQUASHFS error: Can't find a SQUASHFS superblock on hda
    FAT: bogus number of reserved sectors
    VFS: Can't find a valid FAT filesystem on dev hda.
    ISO 9660 Extensions: Microsoft Joliet Level 3
    ISO 9660 Extensions: RRIP_1991A
    
    
     
  7. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    ataraid & hptraid
    sind diese beiden module geladen ? dann solltest du auch nen raid device haben ...

    schau mal in /dev/ataraid/...
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Raid mit HPT370

Die Seite wird geladen...

Raid mit HPT370 - Ähnliche Themen

  1. Fedora Core & HPT370 RAID0

    Fedora Core & HPT370 RAID0: Morgen, ich wollte mir mal dieses neue Fedora installieren aber es hackt an folgenden Punkten: 1. 1) Preparation Users need to...
  2. »Tomb Raider« für Linux veröffentlicht

    »Tomb Raider« für Linux veröffentlicht: Knapp drei Jahre nach der initialen Vorstellung steht das Abenteuerspiel »Tomb Raider« auch allen Linux- und SteamOS-Spielern zur Verfügung. Tomb...
  3. RAID-fähiges Cubieboard5 rechnet mit Achtkern-CPU

    RAID-fähiges Cubieboard5 rechnet mit Achtkern-CPU: Die Cubitech Limited, ein chinesischer Mini-PC-Hersteller, hat mit dem Cubieboard5 seine Produktpalette um einen weiteren Platinenrechner...
  4. Raid5 spare nach rebuild "verschwunden"?

    Raid5 spare nach rebuild "verschwunden"?: Moin hätte da ne Frage die für Leute die sich damit auskennen wohl recht einfach zu beantworten sein sollte, allerdings spiele ich gerade das...
  5. Daten UND Betriebssystem, alles auf einem SW-RAID1-Array...?

    Daten UND Betriebssystem, alles auf einem SW-RAID1-Array...?: Hallo zusammen Wollte fragen wie man sowas macht, leider finde ich im Internet immer nur die Anleitungen wo davon ausgegangen wird dass eine sep....