RAID+LVM mount - Problem

Dieses Thema im Forum "Laufwerke / Speichermedien" wurde erstellt von lukewill, 03.06.2004.

  1. #1 lukewill, 03.06.2004
    lukewill

    lukewill Mitglied

    Dabei seit:
    03.06.2004
    Beiträge:
    26
    Zustimmungen:
    0
    Hallo,

    ich hoffe, das ist das richtige Forum, es geht um Probleme mit RAID-Level1, LVM und Festplatten.

    Zunächst etwas Historie.

    Ich habe einen Linuxserver der auf RedHat 8.0 basiert, in diesem System habe ich zwei gleiche Festplatten ( I D E) eingebaut. Beide Festplatte haben drei Partitionen, die jeweils einen RAID-Verbund Level 1 bilden.

    md0, hda1, hdb1, /boot
    md1, hda2, hdb2, /swap
    md2 / hda3 /hdb3, Volumegroup (Volume00)

    Die VG beherbergt 6 logische Volumes (LV) (jeweils mit ext3 formatiert): LogVol00_root, LogVol00_etc, LogVol00_usr, LogVol00_home, LogVol00_mail, LogVol00_var

    Im Grunde genommen sollte das eine (bomben) sichere Konfiguration sein. Letztes Wochenende war das System „abgestützt“ und ich musste es ausschalten. Danach habe ich versucht das System neu zu booten und muss leider feststellen, dass beide Platten ne Macke haben und das System nicht mehr läuft.

    Ich habe dann zunächst das Rettungssystem von Red-Hat gestartet und mit die Platten einzeln angeschaut.

    hda, partitionstabelle ist lesbar, während des Startens wird ein fehlerhafter Sector angemeckert.

    hdb, partitionstabelle nicht lesbar, während des Startens werden mehrere fehlerhafte Sectoren angemeckert.

    hdb habe ich darauf hin abgeschrieben. Ich habe dann ein knoppix gestartet, eine neue Platte hdd eingebaut, patitioniert und das RAID synchronisiert. Das hat auch soweit geklappt und ich bekomme md0 auch ins Dateisystem eingehängt.

    Des Weiteren kann ich auch vgscan laufen lassen und auch die Volumegroup aktivieren, vgdisplay zeigt auch durchaus sinnvolle Werte an, ebenso lvdisplay. Das mounten klappt aber trotzdem nicht.

    mount –t ext3 /dev/Volume00/LogVol00_home /mnt/home

    liefert

    mount: Falscher Dateisystemtyp, ungültige Optionen, der »Superblock« von /dev/Volume00/LogVol00_home ist beschädigt oder es sind zu viele Dateisysteme eingehängt

    Zu viele Dateisysteme kann ich ausschließen, also bleibt der Superblock. Die Meldung kommt aber nicht bei jedem LV, es funktionieren:
    LogVol00_usr
    LogVol00_mail
    LogVol00_opt

    nicht funktionieren dagegen:
    LogVol00_root
    LogVol00_home
    LogVol00_var

    Ich habe es auch schon mit „ext2“ anstatt „ext3“ versucht. Hat jemand eine Idee wie ich die anderen LV auch gemountet bekomme.

    Ein Backup der Daten habe ich auch, das ist aber 2 Wochen alt.

    Viele Grüße und schon mal vielen Dank
    L
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

RAID+LVM mount - Problem

Die Seite wird geladen...

RAID+LVM mount - Problem - Ähnliche Themen

  1. Kleinigkeiten für Euch, mich nicht :-) pkg_add ; DVD rw mounten

    Kleinigkeiten für Euch, mich nicht :-) pkg_add ; DVD rw mounten: Hallo, ich habe 2 Problemchen. Ich kann nichts mehr installieren. Ich brauche aber unbedingt ein Brenn-Programm. Ein schönen Partitionierer usw....
  2. Automounter konfigurieren

    Automounter konfigurieren: Moin, ich versuche relativ erfolglos den Automounter zu konfigurieren. OS ist Solaris 10 und Ziel ist es das beim z.B. cd /test der entsprechende...
  3. partition/mount point wo liegt das directory?

    partition/mount point wo liegt das directory?: Hallo zusammen! Wahrscheinlich eine 'ne blöde Frage: wie bekomme ich heraus, auf welcher Partition bzw. mount point ein Verzeichnis liegt....
  4. FTP-server frage - mount-nullfs

    FTP-server frage - mount-nullfs: Hallo ich habe einen kleinen FreeBSD-server mit pureftpd laufen. 4 lokale user + chroot_homes=yes in der conf. Klappt auch alles, jetzt würde...
  5. [CENTOS6] Gemountete Platte als Netzlaufwerk bereitstellen

    [CENTOS6] Gemountete Platte als Netzlaufwerk bereitstellen: Hey zusammen, ich bin neu in Linux und habe mir zum Lernen einen Server aufgesetzt. (32 Bit Centos 6). Nun möchte ich die gemountete...