qt-libraries installieren

Dieses Thema im Forum "C/C++" wurde erstellt von geisi, 26.10.2008.

  1. geisi

    geisi Mitglied

    Dabei seit:
    11.09.2007
    Beiträge:
    26
    Zustimmungen:
    0
    Ort:
    Süd-Steiermark, Austria
    ich möchte auf meinem server (d.h. ohne grafische oberfläche) ein programm ausführen, dass mit qt programmiert wurde.
    welche paket muss ich unter debian installieren, dass das programm ausführbar ist, möchte aber nicht die qt-entwicklungsumgebung installieren
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. .mike.

    .mike. Doppel-As

    Dabei seit:
    27.08.2006
    Beiträge:
    207
    Zustimmungen:
    0
    ich denke mal "libqt3-mt"
     
  4. geisi

    geisi Mitglied

    Dabei seit:
    11.09.2007
    Beiträge:
    26
    Zustimmungen:
    0
    Ort:
    Süd-Steiermark, Austria
    Dann bekomme ich beim Auführen des programms folgende Fehlermeldung:
    Code:
    error while loading shared libraries: libQtGui.so.4 cannot open shared object file: No such file or directory
     
  5. #4 gropiuskalle, 26.10.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Öhm... wenn es sich um ein Qt-Proggie handelt, dann wird es wohl auch eine grafische Oberfläche benötigen (worauf ja auch die Fehlermeldung hinweist). Das wird auf Deinem System also kaum hinhauen, es sei denn, Du willst doch noch einen X-Server aufsetzen (was nicht gerade eine brillante Idee wäre).

    'libQtGui.so.4' befindet sich in 'libqt4-x11'
     
  6. geisi

    geisi Mitglied

    Dabei seit:
    11.09.2007
    Beiträge:
    26
    Zustimmungen:
    0
    Ort:
    Süd-Steiermark, Austria
    In der Programmbeschreibung steht folgendes:
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. #6 gropiuskalle, 26.10.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Was für ein Programm soll denn das sein? Und wozu benötigt es als Konsolenanwendung Qt?
     
  9. geisi

    geisi Mitglied

    Dabei seit:
    11.09.2007
    Beiträge:
    26
    Zustimmungen:
    0
    Ort:
    Süd-Steiermark, Austria
    simpleloader!
    beim programm waren die dateien libQtGui.so, libQtNetwork.so und libQtCore.so. Die soll ich ins Verzeichnis /usr/lib kopieren!
    Jetzt bekomme ich die Fehlermeldung:
     
Thema:

qt-libraries installieren

Die Seite wird geladen...

qt-libraries installieren - Ähnliche Themen

  1. Packages installieren

    Packages installieren: Hallo Forum, ich kämpfe mich weiter in Solaris rein. Nun aber eine Frage zur Package Installation. Während ich an unserem Solaris 11 Server...
  2. Artikel: I2P unter Ubuntu auf dem Raspberry Pi 2 installieren

    Artikel: I2P unter Ubuntu auf dem Raspberry Pi 2 installieren: Das »Invisible Internet Project« (I2P) ist ein Overlay-Netz, welches einen hohen Grad an Anonymisierung bietet. Aufgrund seines geringen...
  3. Probleme beim installieren

    Probleme beim installieren: Moin! Ich habe mir vor ein paar Wochen einen Hyrican Intel® i5, 8192MB DDR3-RAM, 1TB Speicher + 120GB SSD,GF GTX750Ti »Military 4610 PC gekauft....
  4. Solaris 10 von USB Stick aus installieren

    Solaris 10 von USB Stick aus installieren: Hallo! Leider finde ich nichts brauchbares im Netz, deshalb melde ich mich hier. Habe einen Rechner, auf den ich Solaris 10 installieren...
  5. Redhat 7 bootloader auf Partition installieren

    Redhat 7 bootloader auf Partition installieren: Hallo zusammen, ich habe ein System das seinen bootloader (grub) im MBR liegen hat auf sda1 installiert. Nun möchte ich ein RHEL7 drunter...