qmail, dyndns, mx, mailempfang = 0 ;(

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von setti, 26.02.2006.

  1. setti

    setti Grünschnabel

    Dabei seit:
    15.02.2006
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo liebe Gemeinde,

    ich habe ein für mich derzeit nicht lösbares Problem.
    Ich beschreibe mal kurz die Situation.

    Ich besitzte einen Root Server mit folgender domain:

    84-16-xxx-xxx.internetserviceteam.com
    Die ersten Zahlen stellen gleichzeitig die IP dar.

    Da mir die Domain eindeutig zu lang war, habe ich eine statische DNS bei dyndns.org beantragt. (meinserver.ath.cx)

    Nun wollte ich mir qmail (nach anleitung von qmailrocks.org) installieren und dabei natürlich die kürzere DNS als domain-namen nehmen.
    Die Installation ging auch soweit gut.
    Der Mail-Versand klappte ohne zu murren, die mails hatten den richtigen absender (@meinserver.ath.cx).
    Doch nun fiel mir auf, dass ich gar keine Mails empfange :(
    Ich habe wirklich fast alle Möglichkeiten durchgespielt.
    Ich habe bei qmail die rcpthosts angepasst auf alle domains (localhost, 84-16-xxx-xxx.internetserviceteam.com, und meinserver.ath.cx).
    Ich habe so ziemlich überall im qmail (so denke ich) gesagt, er solle sowohl auf der meinserver.ath.cx als auch auf 84-16-xxx-xxx.internetserviceteam.com horchen was passiert.
    Ohne Erfolg.

    Schließlich fiel mir noch der MX eintrag im DynDNS interface ein.
    Also hab ich für meine "DynDNS" meinserver.ath.cx noch den MX eintrag 84-16-xxx-xxx.internetserviceteam.com hinzugefügt (mit und ohne Backup MX häkchen).

    Alles ohne Erfolg.

    Jetzte bitte ich euch.
    BITTE helft einem verzweifelten Debian-User ;(

    P.S. bei einem VServer von mir, mit richtiger Domain, ging alles sofort glatt bei der Installation von qmail.

    P.P.S Bitte sagt mir nicht, ich solle auf qmail verzichten und was anderes nehmen. Ich finde qmail für meinen bedarf recht gut.

    Für hilfreiche Antworten danke ich schonmal im voraus.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Wenn du noch nen VServer mit Mailserver hast, dann schau doch mal dort im Log, was der fuer ne Meldung bekommst, wenn du versucht eine Email an bla@meinserver.ath.cx zu versenden.
     
  4. #3 setti, 28.02.2006
    Zuletzt bearbeitet: 28.02.2006
    setti

    setti Grünschnabel

    Dabei seit:
    15.02.2006
    Beiträge:
    7
    Zustimmungen:
    0
    die mail ging erfolgreich raus.
    Habe jetzt nach langem hin und her es geschafft (fragt mich nich wie), dass die mails ankommen.

    Allerdings mit einem dicken fehler!
    Die Mails gehen nicht, wie gewollt, ins vpopmail verzeichnis (/home/vpopmail/), sondern direct ins home dir des (fals angelegten) users.
    Dort gibts dann die Datei "Maildir", welche die empfangen Mails beinhaltet.
    Wie sage ich qmail nun, dass die ins richtige Verzeichnis (/home/vpopmail/domains/meinserver.ath.cx/user/) kommen (ich weiß in der qmail/control gibts eine datei defaultdirectory, doch wie gebe ich dort günstiger weise den vpopmail pfad an (der ja abhängig vom user ist)?

    Fragen über Fragen, und eine kleine Hoffnung auf antworten.

    Vielen Dank schonmal im voraus.

    €dit: wenn ich eine mail an einen account schicke, der nicht in der /etc/passwd steht gibts ne prompte antwort vom Mailer-Daemon:

     
  5. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Nun, jetzt weiss ich wieder, warum ich lieber Postfix benutze. ;)

    Zu deinen Problemen. Irgendwo im QMail kannst du eine Homedir eintragen. Wenn du die Mailboxen, Forwards usw. in einer DB verwaltest, muss das da irgendwo drin stehen. Beachte dabei, dass das homedir immer /bla/bla und das maildir blubb/blubb/ sein muss. Wichtig ist das abschliessende Slash beim Maildir!
    Dein Problem mit den nicht vorhandenen Mailboxen und nur der Moeglichkeit an lokale User Emails zu schicken weist auf einen ziemlichen Konfigurationsfehler hin. Geh nochmal in aller Ruhe deine Konfiguration durch und stelle sicher, dass dein Mailserver Homedir, Maildir sowie die Adresse des Accounts auch wirklich kennt. Gibt es Fehler im Log, wenn du den Server startest?
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

qmail, dyndns, mx, mailempfang = 0 ;(

Die Seite wird geladen...

qmail, dyndns, mx, mailempfang = 0 ;( - Ähnliche Themen

  1. PFS für qmail

    PFS für qmail: Moin, ich würde gerne meinen qmail die nutzung von perfect forward security beibringen. Da qmail aber schon recht lange sein Dienst tut bin...
  2. Centos 5.5: Qmail lauscht nicht auf Port 25

    Centos 5.5: Qmail lauscht nicht auf Port 25: Hallo zusammen, ich habe einen frisch installierten Server mit Centos 5.5 und Parallels als Oberfläche. Der Versand von Emails funktioniert,...
  3. qmail gewappnet für 50.000+ abgehende Emails (Newsletter)?

    qmail gewappnet für 50.000+ abgehende Emails (Newsletter)?: Hallo zusammen, mein Kunde überlegt, ob er über den bei 1&1 gehosteten Rootserver seinen monatlichen Newsletter (ca. 50.000 Empfänger)...
  4. Qmail versendet keine Mails

    Qmail versendet keine Mails: Qmail versendet keine Mails, Connection died Hallo, wir betreiben hier einen Mailserver auf Basis Qmail, die lokale Zustellung funktioniert und...
  5. Qmail Anhang Größe bei Empfangsemails

    Qmail Anhang Größe bei Empfangsemails: Hallo, kann mir einer sagen wie ich bei qmail die Anhangsgröße bei Emails die ich empfange einstellen kann? Habe Plesk 9.2 installiert....