Putty + SuSE 9.0

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von gamefreaktegel, 18.10.2003.

  1. #1 gamefreaktegel, 18.10.2003
    gamefreaktegel

    gamefreaktegel Mitglied

    Dabei seit:
    03.09.2003
    Beiträge:
    40
    Zustimmungen:
    0
    Hi Leutz,

    ich hab seitdem ich SuSE 9.0 (8.0+8.2 lief ohne Probs) laufen hab nen Problem auf den Win-Rechnern mit Putty. Ich logge mich per SSH über Putty ein. Ich werde nach meinem Loginnamen gefragt und wenn ich dann mein Passwort eingebe kommt: Access Denied.

    Ich habe gelesen, dass das an Kerberos/Heimdal liegen kann... hab also alles bis auf die Kerberos-lib entfernt... aber immer noch das gleiche Prob....

    sshd läuft...


    Kann mir da einer helfen?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Wolle

    Wolle Mitglied

    Dabei seit:
    17.07.2003
    Beiträge:
    49
    Zustimmungen:
    0
    hallo,

    schau mal in deiner sshd_config nach, ob da etwas wie:
    allow root login no
    drin steht. dann einfach entsprechend ändern und neustarten.

    gruß
     
  4. #3 gamefreaktegel, 18.10.2003
    gamefreaktegel

    gamefreaktegel Mitglied

    Dabei seit:
    03.09.2003
    Beiträge:
    40
    Zustimmungen:
    0
    also ich kann mich ja auch nich als normaler user einloggen... weder root noch user geht...

    is hier irgendwas falsch? sshd_config:

    # $OpenBSD: sshd_config,v 1.65 2003/08/28 12:54:34 markus Exp $

    # This is the sshd server system-wide configuration file. See
    # sshd_config(5) for more information.

    # This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented. Uncommented options change a
    # default value.

    #Port 22
    #Protocol 2,1
    #ListenAddress 0.0.0.0
    #ListenAddress ::

    # HostKey for protocol version 1
    #HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    #HostKey /etc/ssh/ssh_host_rsa_key
    #HostKey /etc/ssh/ssh_host_dsa_key

    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 1h
    #ServerKeyBits 768

    # Logging
    #obsoletes QuietMode and FascistLogging
    #SyslogFacility AUTH
    #LogLevel INFO

    # Authentication:

    #LoginGraceTime 2m
    #PermitRootLogin yes
    #StrictModes yes

    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile .ssh/authorized_keys

    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    #IgnoreRhosts yes

    # To disable tunneled clear text passwords, change to no here!
    PasswordAuthentication no
    #PermitEmptyPasswords no

    # Change to no to disable s/key passwords
    #ChallengeResponseAuthentication yes

    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes

    # GSSAPI options
    #GSSAPIAuthentication no
    #GSSAPICleanupCreds yes

    # Set this to 'yes' to enable PAM authentication (via challenge-response)
    # and session processing. Depending on your PAM configuration, this may
    # bypass the setting of 'PasswordAuthentication'
    UsePAM yes

    #AllowTcpForwarding yes
    #GatewayPorts no
    X11Forwarding yes
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #KeepAlive yes
    #UseLogin no
    UsePrivilegeSeparation no
    #PermitUserEnvironment no
    #Compression yes
    #ClientAliveInterval 0
    #ClientAliveCountMax 3
    #UseDNS yes
    #PidFile /var/run/sshd.pid
    #MaxStartups 10

    # no default banner path
    #Banner /some/path

    # override default of no subsystems
    Subsystem sftp /usr/lib/ssh/sftp-server
     
  5. Wolle

    Wolle Mitglied

    Dabei seit:
    17.07.2003
    Beiträge:
    49
    Zustimmungen:
    0
    du solltest ganz oben das protokoll und den port ganz oben öffnen und den rest könntest du zu machen, das müsste dann gehen.
     
  6. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Also ich hab das eben bei meiner SuSE 9.0 Pro Standard Install ausprobiert.
    Dort ging es OHNE Probleme.

    Per Default ist SSH aktiviert (sogar als root !).
     
  7. #6 gamefreaktegel, 18.10.2003
    gamefreaktegel

    gamefreaktegel Mitglied

    Dabei seit:
    03.09.2003
    Beiträge:
    40
    Zustimmungen:
    0
    @wolle ... wenn alles auskommentiert is, dann werden ja die defaults genommen... hab trotzdem mal einkommentiert, aber funzt trotzdem nicht...

    @devilz ... kannst mal deine /etd/ssh/sshd_config posten?
     
  8. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    # $OpenBSD: sshd_config,v 1.65 2003/08/28 12:54:34 markus Exp $

    # This is the sshd server system-wide configuration file. See
    # sshd_config(5) for more information.

    # This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented. Uncommented options change a
    # default value.

    #Port 22
    #Protocol 2,1
    #ListenAddress 0.0.0.0
    #ListenAddress ::

    # HostKey for protocol version 1
    #HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    #HostKey /etc/ssh/ssh_host_rsa_key
    #HostKey /etc/ssh/ssh_host_dsa_key

    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 1h
    #ServerKeyBits 768

    # Logging
    #obsoletes QuietMode and FascistLogging
    #SyslogFacility AUTH
    #LogLevel INFO

    # Authentication:

    #LoginGraceTime 2m
    #PermitRootLogin yes
    #StrictModes yes

    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile .ssh/authorized_keys

    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    #IgnoreRhosts yes

    # To disable tunneled clear text passwords, change to no here!
    PasswordAuthentication no
    #PermitEmptyPasswords no

    # Change to no to disable s/key passwords
    #ChallengeResponseAuthentication yes

    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes

    # GSSAPI options
    #GSSAPIAuthentication no
    #GSSAPICleanupCreds yes

    # Set this to 'yes' to enable PAM authentication (via challenge-response)
    # and session processing. Depending on your PAM configuration, this may
    # bypass the setting of 'PasswordAuthentication'
    UsePAM yes

    #AllowTcpForwarding yes
    #GatewayPorts no
    X11Forwarding yes
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #KeepAlive yes
    #UseLogin no
    UsePrivilegeSeparation no
    #PermitUserEnvironment no
    #Compression yes
    #ClientAliveInterval 0
    #ClientAliveCountMax 3
    #UseDNS yes
    #PidFile /var/run/sshd.pid
    #MaxStartups 10

    # no default banner path
    #Banner /some/path

    # override default of no subsystems
    Subsystem sftp /usr/lib/ssh/sftp-server
     
  9. #8 gamefreaktegel, 18.10.2003
    gamefreaktegel

    gamefreaktegel Mitglied

    Dabei seit:
    03.09.2003
    Beiträge:
    40
    Zustimmungen:
    0
    tjo... is doch irgendwie gleich...

    hat noch jemand nen Vorschlag?
     
  10. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    hmm ... haste mal von ner linux kiste probiert ?

    Oder NUR von Putty ?

    Haste mal ne neuere Putty Version probiert ?
     
  11. #10 gamefreaktegel, 18.10.2003
    gamefreaktegel

    gamefreaktegel Mitglied

    Dabei seit:
    03.09.2003
    Beiträge:
    40
    Zustimmungen:
    0
    hm habs mit Putty 0.53b versucht... gibs da was ne neuere version?

    linux hab ich noch nich probiert... mach ich aber gleich ma...
     
  12. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    "The latest version is beta 0.53b."

    Ne scheint die aktuellste zu sein ... also probiers mal von nem Linux Client aus :)
     
  13. #12 gamefreaktegel, 18.10.2003
    gamefreaktegel

    gamefreaktegel Mitglied

    Dabei seit:
    03.09.2003
    Beiträge:
    40
    Zustimmungen:
    0
    ah! Von nem Linux-Client gehts!

    Super!

    Aber wie löse ich nu mein Win Prob... hmm... brauch das auch unter win... evtl. authentifiziert sich putty nicht korrekt oda so... irgendwas könnte zu streng eingestellt sein...

    hmm kann mir nu einer helfen?
     
  14. hopfe

    hopfe Haudegen

    Dabei seit:
    01.04.2003
    Beiträge:
    733
    Zustimmungen:
    0
    Ort:
    Aachen
    Bekommst du eine Fehlermeldung vom SSHD, vielleicht verwendet putty ssh1 und dein sshd verlangt ssh2?
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 gamefreaktegel, 19.10.2003
    gamefreaktegel

    gamefreaktegel Mitglied

    Dabei seit:
    03.09.2003
    Beiträge:
    40
    Zustimmungen:
    0
    Fehlermeldungen bekomme ich überhaupt keine... nur bei Putty eben: Access Denied (egal welcher login name).


    hm ssh1 / ssh2 ? wie sehe ich welche version mein sshd von suse 9.0 haben will??

    P.S.: bei devilz hat es ja gefunzt...
     
  17. Wolle

    Wolle Mitglied

    Dabei seit:
    17.07.2003
    Beiträge:
    49
    Zustimmungen:
    0
    steht in deiner sshd_config bei 'protocol', normalerweise steht dort 2,1, folglich sind beide zuglassen außer du hast es geändert. ich glaube aber du solltest nochmal in dein putty schauen was du dort für einstellungen hast!!!
     
Thema:

Putty + SuSE 9.0

Die Seite wird geladen...

Putty + SuSE 9.0 - Ähnliche Themen

  1. ssh login mit putty auf SuSE9.2 dauert ewig

    ssh login mit putty auf SuSE9.2 dauert ewig: Hallo, ist das bekannt, dass mit Putty Version 0.56 ssh login auf SuSE 9.2 System lange dauert, nachdem ich ein username angebe vergehen 11...
  2. putty,SSL komme nach Serverneustart nicht mehr rein

    putty,SSL komme nach Serverneustart nicht mehr rein: Tach Leute, ich hoffe ihr könnt mir helfen. Ich komme nachdem ich meinen Server neugestartet habe, nicht mehr als root oder anderen User hinein....
  3. Debian 6 Server ssh zugriff putty, darüber Bilder sehen nutzen, Outfiting ?

    Debian 6 Server ssh zugriff putty, darüber Bilder sehen nutzen, Outfiting ?: Hi Leute Ich habe meinen Debian Server 6 für FTP,SSH,WWW,SAMBA,OpenVPN,MUNIN, u.s.w. ohne X-Windows aufgesetzt. :brav: Hihi wie sich das schon...
  4. Putty>Server kann bekomme keine Verbindung

    Putty>Server kann bekomme keine Verbindung: Hallo Leute, hoffe das ist hier richtig. Ich habe einen ubuntu Server. Mein Problem: Nach einem Update, bekomme ich mit Putty keine...
  5. Debian: Kein Zugriff mehr über Putty oder WinScp

    Debian: Kein Zugriff mehr über Putty oder WinScp: Hallo, bin noch neu hier und hätte mal eine Frage. Hab zu Testzwecken auf einen vServer Apache2, PHP, mysql, phpmyadmin und Joomla installiert....