PulseAudio sound nur bei MPD

Dieses Thema im Forum "Sound" wurde erstellt von karloff, 27.06.2014.

  1. #1 karloff, 27.06.2014
    Zuletzt bearbeitet: 27.06.2014
    karloff

    karloff Routinier

    Dabei seit:
    09.07.2007
    Beiträge:
    317
    Zustimmungen:
    0
    Ort:
    ~/
    Moin,
    ich komm hier nicht mehr weiter, da ich kein Fehler finden kann.

    Folgendes Problem, da ich ne PCIe Soundkarte brauchte habe ich mir ne Asus Xonar DGX geholt.
    Die hat leider eher mäßigen Support, daher musste ich für Volume Controll von Alsa auf PulseAudio wechseln :/
    Der Rechner ist hauptsächlich die Aufgabe via MPD musik abzuspielen.
    Das Funktioniert jetzt auch wie ich mir das vorgestellt habe über PulseAudio.
    Leider ist es aber auch das einzige Programm das irgendwie Sound erzeugen kann.

    Alles ist dem Anschein nach in Ordnung, wenn ich mit
    pavucontrol schaue was passiert wenn ich z.B. mit VLC oder Mplayer ein MP3 wiedergebe wird mir sogar ein Lautstärke Pegel angezeigt.
    Nur leider herrscht absolute Stille.

    Hier mal ein Debug von PulseAudio, da sehe ich auch kein Problem
    Code:
    un 27 20:49:12 [pulseaudio] [pulseaudio] source-output.c:     application.process.user = "karloff"
    Jun 27 20:49:12 [pulseaudio] [pulseaudio] source-output.c:     application.process.host = "stoertebeker"
    Jun 27 20:49:12 [pulseaudio] [pulseaudio] source-output.c:     application.process.binary = "pavucontrol"
    Jun 27 20:49:12 [pulseaudio] [pulseaudio] source-output.c:     application.language = "de_DE.utf8"
    Jun 27 20:49:12 [pulseaudio] [pulseaudio] source-output.c:     window.x11.display = ":0.0"
    Jun 27 20:49:12 [pulseaudio] [pulseaudio] source-output.c:     application.process.machine_id = "228535d49cd3cadf71e64bd753918099"
    Jun 27 20:49:12 [pulseaudio] [pulseaudio] source-output.c:     module-stream-restore.id = "source-output-by-application-id:org.PulseAudio.pavucontrol"
    Jun 27 20:49:12 [pulseaudio] [pulseaudio] protocol-native.c: Final latency 490,00 ms = 240,00 ms + 250,00 ms
    Jun 27 20:49:19 [sudo] karloff : TTY=pts/1 ; PWD=/home/karloff ; USER=root ; COMMAND=/bin/tail -f /var/log/everything/current
    Jun 27 20:49:19 [sudo] pam_unix(sudo:session): session opened for user root by karloff(uid=0)
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] client.c: Created 1 "Native client (UNIX socket client)"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] protocol-native.c: Got credentials: uid=1000 gid=1000 success=1
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] sink-input.c: Created input 0 "audio stream" on combined with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] sink-input.c:     media.name = "audio stream"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] sink-input.c:     application.name = "MPlayer"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] sink-input.c:     native-protocol.peer = "UNIX socket client"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] sink-input.c:     native-protocol.version = "29"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] sink-input.c:     application.process.id = "2758"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] sink-input.c:     application.process.user = "karloff"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] sink-input.c:     application.process.host = "stoertebeker"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] sink-input.c:     application.process.binary = "mplayer"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] sink-input.c:     application.language = "C"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] sink-input.c:     window.x11.display = ":0"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] sink-input.c:     application.process.machine_id = "228535d49cd3cadf71e64bd753918099"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] sink-input.c:     module-stream-restore.id = "sink-input-by-application-name:MPlayer"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] protocol-native.c: Requested tlength=250,00 ms, minreq=20,00 ms
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] protocol-native.c: Final latency 540,00 ms = 250,00 ms + 2*20,00 ms + 250,00 ms
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c: Trying to change sample rate
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source.c: Cannot update rate, SOURCE_IS_RUNNING, will keep using 44100 Hz
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] remap.c: Using generic matrix remapping
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c: Created output 1 "Ausschlagsserkennung" on combined.monitor with sample spec float32le 1ch 25Hz and channel map mono
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c:     media.name = "Ausschlagsserkennung"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c:     application.name = "PulseAudio-Lautstärkeregler"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c:     native-protocol.peer = "UNIX socket client"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c:     native-protocol.version = "29"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c:     application.id = "org.PulseAudio.pavucontrol"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c:     application.icon_name = "audio-card"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c:     application.version = "1.0"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c:     application.process.id = "2349"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c:     application.process.user = "karloff"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c:     application.process.host = "stoertebeker"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c:     application.process.binary = "pavucontrol"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c:     application.language = "de_DE.utf8"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c:     window.x11.display = ":0.0"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c:     application.process.machine_id = "228535d49cd3cadf71e64bd753918099"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] source-output.c:     module-stream-restore.id = "source-output-by-application-id:org.PulseAudio.pavucontrol"
    Jun 27 20:49:36 [pulseaudio] [pulseaudio] protocol-native.c: Final latency 490,00 ms = 240,00 ms + 250,00 ms
    Jun 27 20:55:08 [pulseaudio] [pulseaudio] source-output.c: Freeing output 1 "Ausschlagsserkennung"
    Jun 27 20:55:08 [pulseaudio] [pulseaudio] sink-input.c: Freeing input 0 "audio stream"
    Jun 27 20:55:08 [pulseaudio] [pulseaudio] client.c: Freed 1 "MPlayer"
    Jun 27 20:55:08 [pulseaudio] [pulseaudio] protocol-native.c: Connection died.
    
    Mplayer zeigt auch keine Auffälligkeiten beim Abspielen:
    Code:
    mplayer Musik/\[Sitd\]\ -\ Lebensborn.mp3 
    MPlayer 1.1-4.7.3 (C) 2000-2012 MPlayer Team
    
    Spiele Musik/[Sitd] - Lebensborn.mp3.
    libavformat version 54.63.104 (external)
    Audio only-Dateiformat erkannt!
    Clip-Info:
     Title: Lebensborn
     Artist: [:SITD:]
     Album: Stronghold
     Year: 2003
     Comment: 
     Track: 3
     Genre: Electronic
    Load subtitles in Musik/
    ==========================================================================
    Öffne Audiodecoder: [mpg123] MPEG 1.0/2.0/2.5 layers I, II, III
    AUDIO: 44100 Hz, 2 ch, s16le, 32.0 kbit/2.27% (ratio: 4000->176400)
    Ausgewählter Audiocodec: [mpg123] afm: mpg123 (MPEG 1.0/2.0/2.5 layers I, II, III)
    ==========================================================================
    AO: [pulse] 44100Hz 2ch s16le (2 bytes per sample)
    Video: kein Video
    Starte Wiedergabe...
    A: 331.1 (05:31.1) of 331.0 (05:31.0)  0.2% 
    
    
    Beenden... (Dateiende erreicht)
    
    Kann mir da kein Reim drauf machen wieso alles bis auf mpd absolut keinen sound erzeugt.


    =========================
    Edit:
    Es scheint sich sehr warscheinlich um ein Problem mit den Berechtigungen zu handeln, da wenn man X als root startet alles funktioniert.
    Bleibt nur die Frage offen wo man permissions vergeben kann.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 karloff, 27.06.2014
    karloff

    karloff Routinier

    Dabei seit:
    09.07.2007
    Beiträge:
    317
    Zustimmungen:
    0
    Ort:
    ~/
    Hat sich geklärt im gentoo wiki steht scheisse:

    Den Schritt sollte man ausslassen, dann hat man auch wieder Sound als Mitglieder der Audio Gruppe.
     
Thema:

PulseAudio sound nur bei MPD

Die Seite wird geladen...

PulseAudio sound nur bei MPD - Ähnliche Themen

  1. PulseAudio 8.0 freigegeben

    PulseAudio 8.0 freigegeben: Das netzwerktransparente und plattformunabhängige Sound-System PulseAudio wurde in Version 8.0 freigegeben. Bis auf die Verbesserung des...
  2. CrossOver 15 unterstützt PulseAudio

    CrossOver 15 unterstützt PulseAudio: Die auf Wine basierende Software CrossOver der Firma CodeWeavers ist in Version 15.0 erschienen. Mit der Software lassen sich viele...
  3. PulseAudio 7.0 freigegeben

    PulseAudio 7.0 freigegeben: Das netzwerktransparente und plattformunabhängige Sound-System PulseAudio wurde in Version 7.0 freigegeben. Wichtige Neuerungen sind vor allem die...
  4. Pinos: »PulseAudio« für Video-Hardware

    Pinos: »PulseAudio« für Video-Hardware: Mit Pinos soll ein Framework entstehen, welches das Zusammenspiel von Video-Hardware unter Linux vereinheitlichen will. Das an PulseAudio...
  5. PulseAudio 6.0 veröffentlicht

    PulseAudio 6.0 veröffentlicht: PulseAudio, eine netzwerktransparente und plattformunabhängige Sound-Zwischenschicht für Linux und weitere Systeme, wurde knapp ein Jahr nach der...