procmail -> SPAM an spam-ordner senden

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von foexle, 09.03.2009.

  1. #1 foexle, 09.03.2009
    Zuletzt bearbeitet: 09.03.2009
    foexle

    foexle Kaiser

    Dabei seit:
    02.05.2007
    Beiträge:
    1.104
    Zustimmungen:
    0
    Ort:
    Saarbrücken
    Sers Leute,
    also ich bin nun soweit, das alle eingehenden mails geprüft werden mittels spamassasin ob es sich um eine spam handelt. Diese werden auch richtig erkannt und der Header wird verändert.

    Nun bekomme ich die SPAM-Mail allerdings in meinen Eingangsordner ...
    Ich benutze postfix in kombination mit clamsmtp, spamassasin und procmail
    Meine procmailrc sieht so aus:
    Code:
    # path for sub programs
    PATH=/usr/sbin:/usr/bin:/sbin:/bin
    DAEMON="MAILER-DAEMON@example.de"
    # top level mail directory
    TOPDIR=/home/vmail
    LOGDIR=$TOPDIR/procmail
    RCDIR=$TOPDIR/procmail
    SENDMAIL="/usr/sbin/sendmail -i -f \MAILER-DAEMON\@example.de -t $SENDER"
    
    # logging
    VERBOSE     = no
    LOGABSTRACT = yes
    LOGFILE=$LOGDIR/$RECIPIENT.log
    
    # get (virtual) user
    :0
    * RECIPIENT ?? ^\/[^\@]+
    {
      USER = $MATCH
    }
    
    # get (virtual) domain
    :0
    * RECIPIENT ?? \@\/(.*)
    {
      DOMAIN = $MATCH
    }
    
    # set default mail locations for current recipient
    MAILDIR=$TOPDIR/$DOMAIN/$USER
    DEFAULT=./
    
    :0
    * ^X-Virus-Status: Yes
    {
            /dev/null
    }
    
    :0
    * ^X-Spam-Flag: Yes
    {
      $MAILDIR/spam
    }
    # use user defined procmailrc if existant
    SWITCHRC="$RCDIR/$RECIPIENT.procmailrc"
    :0 e
    {
        EXITCODE=$?
        :0 w
        * EXITCODE ?? [75]
        {
            REC=`formail -zx"To:"`
            EXITCODE=0
            :0
            * ^X-Loop: bounce@example.de
            /dev/null
            :0
            | formail -rk -I"Subject: Mail delivery \
             failed for user: $USER (MailAdr: $REC)" \
             -A"FROM: $DAEMON" -A"Precedence: junk" \
             -A"X-Loop: bounce@example.de" | $SENDMAIL
        }
    }
    # save all mails to default mailbox as default (if no user procmailrc exists)
    :0:
    $DEFAULT
    
    
    normal solle er das doch in den spam ordner legen ?!?!
    oder seht Ihr evtl einen fehler ... die configs zu postfix und den anderen sachen findet ihr hier http://www.unixboard.de/vb3/showthread.php?t=41939

    hoffe jmd kann mir weiter helfen

    greetz


    edit:
    ok habs endlich ... sehr dummer fehler :) die klammern müssen weg bei
    Code:
    :0
    * ^X-Spam-Flag: Yes
    
      $MAILDIR/spam
    
    greetz
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

procmail -> SPAM an spam-ordner senden

Die Seite wird geladen...

procmail -> SPAM an spam-ordner senden - Ähnliche Themen

  1. fetchmail-procmail-spamassassin-cyrus problem

    fetchmail-procmail-spamassassin-cyrus problem: hiho, erstmal stelle ich mich kurz mal vor hier ... also ich komme aus dem schönen österreich, genauer gesagt: wien. bin hier per googlen auf...
  2. Fedora Core4 / Sendmail / Fetchmail / procmail / spamassassin

    Fedora Core4 / Sendmail / Fetchmail / procmail / spamassassin: Hallo, hoffe ich bin hier richtig zum o.g. Thema. Ich hatte Sendmail in FC4 eingerichtet und Fetchmail für das Abholen von pop3 genutzt. Alles...
  3. Procmail & Spamassassin Problem

    Procmail & Spamassassin Problem: Hallo zusammen Ich habe folgende Procmail Konfiguration: ------------------------------------------------- tr0nix@mailman:~$ cat...
  4. procmail problem

    procmail problem: Hallo forum. Ich habe ein dringliches procmail problem. Meine emails landen nicht wie von mir gewollt im Verzeichnis '/home/benutzername/Maildir'...
  5. fetchmail/procmail/postfix - berechtigungsproblem

    fetchmail/procmail/postfix - berechtigungsproblem: Hi, das berechtigungsproblem äußert sich dadurch, das die abgeholten mails im maildir immer root.mail gehören und nicht dem eigentlichen...