Probleme Superkaramba 0.35 zu kompilieren

Dieses Thema im Forum "KDE" wurde erstellt von Pacemaker, 19.11.2004.

  1. #1 Pacemaker, 19.11.2004
    Pacemaker

    Pacemaker Nutzung auf eigene Gefahr

    Dabei seit:
    24.10.2004
    Beiträge:
    74
    Zustimmungen:
    0
    Hallo an alle :)

    Ich möchte gern die aktuelle Version von Superkaramba für mein Debian Sarge Linux kompilieren.
    Leider bleibe ich da schon bei ./configure hängen.
    Erst fand das Skript mein QT Installation nicht.
    Da habe ich folgenden Parameter an ./configure angehängt.
    --with-qt-includes=/usr/include/qt3

    Danach fand es problemlos qt. Nur findet er jetzt die KDE Libraries nicht.
    Wo befinden die sich bei Sarge und was muss ich an das configure-Skript anhängen ?
    Goggle hatte mir schon beim ersten Problem geholfen, nur beim zweiten nicht :( .

    btw. Ich habe KDE 3.3.1 aus dem unstable-Zweig installiert. Wäre also möglich, dass da ein Problem vorliegen könnte. Bin mir nicht sicher ob ich alles wichtige aktualisiert habe.

    Habt ihr ein Lösung für mich ?

    Vielen Dank schonmal :)

    Pacemaker
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 damager, 19.11.2004
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
  4. #3 Pacemaker, 19.11.2004
    Zuletzt bearbeitet: 19.11.2004
    Pacemaker

    Pacemaker Nutzung auf eigene Gefahr

    Dabei seit:
    24.10.2004
    Beiträge:
    74
    Zustimmungen:
    0
    Die Faq enthält nix zu dem Problem.
    Das Paket kdelibs3-devel gibt's unter diesen Namen bei Debian nicht.
    Zumindest meint das apt-get.

    EDIT: Hab mal in aptitude gestöbert und kdelibs-dev gefunden und die sind auch installiert. Sind das die ? Denn da fehlt die 3 in kdelibs3-dev.
     
  5. #4 Tux-Forever, 19.11.2004
    Tux-Forever

    Tux-Forever Gamer

    Dabei seit:
    07.07.2002
    Beiträge:
    930
    Zustimmungen:
    0
    Ort:
    Rheinland Pfalz
    schonmal mit apt-cache search paketname versucht ?
    vielleicht wirds ja anders geschrieben oder heisst ganz anders
     
  6. #5 Pacemaker, 19.11.2004
    Pacemaker

    Pacemaker Nutzung auf eigene Gefahr

    Dabei seit:
    24.10.2004
    Beiträge:
    74
    Zustimmungen:
    0
    Wo sollten die KDE Libs denn bei Debian Sarge liegen ?

    Wenn ich weiß wo die liegen, kann ich mit --with-kde-libs= dem configure Skript übergeben.
     
  7. #6 webstar, 19.11.2004
    webstar

    webstar LFS-Junkie/ExRPMbuilder

    Dabei seit:
    12.04.2004
    Beiträge:
    46
    Zustimmungen:
    0
    Ort:
    Aus dem schönen Elbflorenz
    Das hier wäre eine Möglichkeit:
    http://packages.debian.org/cgi-bin/...&version=unstable&arch=i386&page=1&number=all
    Debian hat aber ein sehr mächtiges Paketverwaltungstool, welches Dir ganz bestimmt eine vollständige Liste der Dateien aus den kdelibs-Paketen liefern kann bzw. wo diese im Dateisystem zufinden sind.

    Jens
     
  8. #7 Pacemaker, 19.11.2004
    Pacemaker

    Pacemaker Nutzung auf eigene Gefahr

    Dabei seit:
    24.10.2004
    Beiträge:
    74
    Zustimmungen:
    0
    Also ich habe schon einiges probiert. Aber immer sagt mir das configure skript, dass in dem angegebenen Prefix keine KDE libs zu finden seien.

    Hat denn jemand für Debian Sarge schonmal Superkaramba kompiliert ?
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. #8 Pacemaker, 19.11.2004
    Pacemaker

    Pacemaker Nutzung auf eigene Gefahr

    Dabei seit:
    24.10.2004
    Beiträge:
    74
    Zustimmungen:
    0
    Hab jetzt mal ein einen Screensaver von kde-look.org kompiliert. Hört auf den Namen "rss-kde-0.3"
    Der benötigt auch die header und libs von qt und kde.
    Da funzt es wunderbar. Das Skript gibt an, dass die Header von KDE unter /usr/include/kde
    und die libs unter /usr/lib seien.
    Dies habe ich nun versucht bei Superkaramba zu nutzen. Habe dann folgendes eingegeben
    Hat aber nix gebracht. Das Skript will mir immernoch erzählen, dass da keine kdelibs seien.

    Was kann ich noch tun ?
     
  11. #9 webstar, 20.11.2004
    webstar

    webstar LFS-Junkie/ExRPMbuilder

    Dabei seit:
    12.04.2004
    Beiträge:
    46
    Zustimmungen:
    0
    Ort:
    Aus dem schönen Elbflorenz
    Weitere Info's hier:
    http://developer.kde.org/build/build2ver.html
    Stichwort: Variablen -> Stichwort: KDEDIR

    Jens
     
Thema:

Probleme Superkaramba 0.35 zu kompilieren

Die Seite wird geladen...

Probleme Superkaramba 0.35 zu kompilieren - Ähnliche Themen

  1. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  2. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...
  3. Forscher analysieren Durchsatzprobleme im Linux-Scheduler

    Forscher analysieren Durchsatzprobleme im Linux-Scheduler: Eine Gruppe von Forschern hat Fälle identifiziert, in denen der Scheduler im Linux-Kernel falsche Entscheidungen trifft und die CPUs nicht so gut...
  4. München: LiMux als Sündenbock für IT-Probleme?

    München: LiMux als Sündenbock für IT-Probleme?: Im Münchner Stadtrat soll später in diesem Jahr erneut über den Einsatz von Linux in der Stadtverwaltung diskutiert werden. Die Grünen vermuten,...
  5. BSI-Audit findet keine akuten Probleme in OpenSSL

    BSI-Audit findet keine akuten Probleme in OpenSSL: Das Bundesamt für Sicherheit in der Informationstechnik hat OpenSSL auf seine Sicherheit untersuchen lassen. Die Analyse zeigt vor allem, dass die...