Probleme SAMBA <-> W2k3 Domain-Trust

Dieses Thema im Forum "Samba" wurde erstellt von WolverineJR, 06.09.2006.

  1. #1 WolverineJR, 06.09.2006
    WolverineJR

    WolverineJR Jungspund

    Dabei seit:
    06.09.2006
    Beiträge:
    11
    Zustimmungen:
    0
    Hallo Leute!

    Ich hoffe endlich hier eine Antwort auf dieses verd... Problem zu finden, was mich noch in den Wahnsinn treibt. X(

    Zuerst mal die Umgebung:

    Wir haben zwei Samba-Server mit der Version 3.0.21c auf Solaris 9 im Einsatz. Davon ist einer immer aktiv, der andere als Cold-Standbye, falls der produktive Server Probleme hat.
    Zudem haben wir mehrere ActiveDirectory-Domäne mit Windows 2003 und ServicePack 1. Diese Domänen sind so organisiert, dass eine sog. "Master-Domäne" und mehrere Unterdomänen existieren. In einer Unterdomäne sind die beiden Samba-Server eingegliedert worden (mit "net ads join" usw.).

    Nun zu dem Problem:
    Innerhalb der eigenen Unterdomäne der Samba-Server funktioniert alles wunderbar ohne Probleme. Nun haben wir eine Anforderung erhalten, dass Windows-Clients aus einer anderen Unterdomäne auf die Freigaben des Samba-Servers zugreifen muss.
    Normalerweise kein Problem. Haben zwischen den beiden Unterdomänen einen Trust erzeugt.
    Bei den beiden Solaris-Samba-Servern haben wir zudem in die /etc/resolv.conf in die Zeile "search" noch den FQDN-Namen der anderen Unterdomäne eingefügt (lautet also nun folgendermaßen: "search unterdomaene1.de unterdomaene2.de"). Zudem haben wir noch die krb5.conf ergänzt. Und zwar in dem Bereich "realms" mit dem Eintrag für die Unterdomäne (also FQDN mit entsprechendem KDC und amin_server - Eintrag).

    Jetzt das absolut geniale. Auf einem Solaris-Server funktioniert das alles wunderbar (also eine Abfrage "wbinfo -u --domain=UNTERDOMAENE2" gibt alle User aus).
    Auf dem anderen Solaris-Server bekomme ich nur "Error looking up domain users".

    Beide Solaris-Server sind gleich installiert. Kerberos, Samba, winbind usw. haben alle die gleichen Versionen und wurden alle mit den gleichen Parametern kompiliert.

    Ich weiß echt nicht mehr weiter!! :(
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 phrenicus, 06.09.2006
    phrenicus

    phrenicus Routinier

    Dabei seit:
    24.05.2006
    Beiträge:
    253
    Zustimmungen:
    0
    Ort:
    Tübingen, Germany
    Hallo,

    ich kann mir bei diesem Problem eigentlich nur vorstellen, dass die beiden Server eben nicht identisch aufgesetzt sind. Welche Kerberos-Variante verwendet Ihr denn? Gibt es ein Kommando klist, mit dem Du schauen kannst, welche Kerberos-Tickets Du bekommen hast?
    Ansonsten ist ein möglicher Fallstrick DNS.
    Ich würde sehr genau vergleichen, ob wirklich alles identisch ist (Tippfehler in /etc/krb5.conf wie in Deinem Posting: amin_server statt admin_server etc.).
    Und in diesem Fall lohnt es sich vielleicht auch, das Ereignisprotokoll auf dem Domänencontroller zu lesen. Fehlgeschlagene Anmeldeversuche müsste er protokollieren und einen Grund dafür angeben.

    Gruß
     
  4. #3 WolverineJR, 06.09.2006
    WolverineJR

    WolverineJR Jungspund

    Dabei seit:
    06.09.2006
    Beiträge:
    11
    Zustimmungen:
    0
    Kommando zurück! Es geht nun alles. Hab unserem Netzwerkadmin nochmal auf die Finger gehauen, nachdem ich mittels Ethereal bemerkt habe, dass ich keinerlei Verbindung bekommen habe.
    Ist mir im übrigen aufgefallen, nachdem ich den Log-Level auf 10 gedreht habe und mir der folgende Eintrag aufgefallen ist:

    "... set_tc_type_and_flags: Could not open a connection to UNTERDOMAENE2..."

    Trotzdem Danke!!
     
Thema:

Probleme SAMBA <-> W2k3 Domain-Trust

Die Seite wird geladen...

Probleme SAMBA <-> W2k3 Domain-Trust - Ähnliche Themen

  1. Samba 3.6 on Centos probleme mit OSX 10.10

    Samba 3.6 on Centos probleme mit OSX 10.10: Hallo Zusammen Ich habe einen smb server der läuft auf einer linux Kiste und habe ein sehr großes problem. Wenn man viele files verschiebt...
  2. Samba Share auf DFS Link - Probleme

    Samba Share auf DFS Link - Probleme: Wir haben einen Win2008 R2 SP1 Server am laufen auf dem ein Verzeichnis z.B. F:\Austausch als Netzwerkshare freigegeben haben, in diesem...
  3. Samba - Acces und Mountprobleme

    Samba - Acces und Mountprobleme: Hallo, ich habe ein Problem den ich mit einem Samba 3.4.7 auf Ubuntu 10.4 laufen habe. Ich denke mir das es eigentlich kein Problem sein sollte...
  4. Probleme mit Samba

    Probleme mit Samba: Hallo Leute, ich habe zwei Problem mit Samba auf Debian Squezze. Das erste Problem ist das ich wenn ich von meinem Windows etwas auf das...
  5. Probleme mit Win7, UAC und Samba 3

    Probleme mit Win7, UAC und Samba 3: Hallo zusammen, (vorneweg möchte ich erwähnen, dass ich mich nicht gerade als Samba Profi bezeichnen würde, aber der Kollege der das...