Probleme mit WLAN-USB-Adapter und Ubuntu

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von theton, 28.12.2004.

  1. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Ich habe mir gerade 'nen WLAN-USB-Adapter von Sitecom besorgt. Beim einstecken bekomme ich vom Kernel folgende Meldungen:

    Code:
    Dec 28 17:31:55 TAPS kernel: usb 1-1: new full speed USB device using address 2
    Dec 28 17:31:55 TAPS kernel: usb 1-1: config 1 has an invalid interface number: 
    1 but max is 0
    Dec 28 17:31:55 TAPS kernel: usb 1-1: config 1 has no interface number 0
    Dec 28 17:31:57 TAPS kernel: prism2usb_init: prism2_usb.o: 0.2.1-pre21 Loaded
    Dec 28 17:31:57 TAPS kernel: prism2usb_init: dev_info is: prism2_usb
    Dec 28 17:31:57 TAPS kernel: usbcore: registered new driver prism2_usb
    Dec 28 17:31:57 TAPS usb.agent[7692]:      prism2_usb: loaded successfully
    
    Danach wird das wlan-Device aber nicht erkannt bzw. nicht angelegt. Ich benutze Ubuntu und habe versucht, es mit 'network-admin' zu konfigurieren. Damit laesst es sich nach der Konfiguration aber nicht aktivieren. Kann mir irgend jemand sagen, wie ich diese "Karte" unter Debian/Ubuntu konfigurieren kann? Und was bedeutet dieses "config 1 has no interface number 0"?
    :hilfe2:
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 qmasterrr, 28.12.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    Ort:
    Germany/NRW/Wesel
    Also, da du schon seit May dabei bist und auch schon 60Posts hast, denke ich, dass es nicht mehr notwendig ist dich auf die SuchFunktion des Boards aufmerksamm machen zu müssen. Aber irren ist Menschlich.

    Ne mal im ernst ich will garnicht wissen wieviele Threads wir zu diesem Chipsatz im Board haben.
     
  4. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    wlan-ng nicht kompilierbar

    Also, wenn man das Forum nach Prism2 durchsucht, findet man 16 Einträge, die aber leider nicht mein Problem klären. Ausserdem war es mir nicht möglich wlan-ng zu kompilieren (ja, auf diese Idee bin ich auch schon gekommen :) ). Als Fehlermeldung erhielt ich vom Compiler

    Code:
    /home/theton/downloads/linux-wlan-ng-0.2.1pre23/src/p80211/p80211conv.c: In Funktion »skb_p80211_to_ether«:
    /home/theton/downloads/linux-wlan-ng-0.2.1pre23/src/p80211/p80211conv.c:506: Warnung: implicit declaration of function `eth_hdr'
    /home/theton/downloads/linux-wlan-ng-0.2.1pre23/src/p80211/p80211conv.c:506: error: request for member `h_source' in something not a structure or union
    make[4]: *** [/home/theton/downloads/linux-wlan-ng-0.2.1pre23/src/p80211/p80211conv.o] Fehler 1
    make[3]: *** [_module_/home/theton/downloads/linux-wlan-ng-0.2.1pre23/src/p80211] Fehler 2
    
    Ich habe nun aber wenig Lust, mich in die Sourcen von wlan-ng einzuarbeiten und ich bin auch nicht unbedingt der Super-Systemprogrammierer.
     
  5. #4 qmasterrr, 28.12.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    Ort:
    Germany/NRW/Wesel
    Wenn er nicht sauber Compiliert solltest du überprüfen ob deine Kernel-Version auch compatibel ist und evtl eine andere ausprobieren.

    Übrigens scheint es ja so als wäre linux-wlan-ng bei dir schon installiert
     
  6. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Wlan-ng schon Standard in Ubuntu?

    Hmm, ich weiss ja nicht, was wlan-ng installiert, aber evtl. hat ubuntu das ja schon mit dazu gepackt.
    Ich sehe ja auch, dass die Module fuer Prism2 geladen werden -> Auszug aus lsmod-Output:

    Code:
    prism2_usb             78596  0 
    p80211                 34128  1 prism2_usb
    usbcore               115876  5 prism2_usb,ehci_hcd,uhci_hcd
    
    Aber was bedeuten diese seltsamen Kernel-Meldungen? Wenn ich mich sonst so im Netz umschaue, sehen die Kernel-Meldungen bei anderen wohl nicht so aus. Dieses 'config1 has an invalid interface number' habe ich bisher in auf meiner Suche im WWW nicht gefunden. Auch im Undernet sind die, die ich kenne, ratlos. Naja und im IRC-Net danach zu fragen halte ich für sinnlos, da bekommt man eh immer nur "schau mal bei google" als Antwort.
     
  7. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    ACPI ist schuld, aber Problem nicht geloest

    So, ich habe jetzt noch einiges rumprobiert und z.B. auch mal mit 'acpi=off' gebootet, da das ACPI auch schon bei einem meiner USB-Sticks Probleme gemacht hatte. Und siehe da, plötzlich kamen diese 'invalid interface number'-Meldungen nicht mehr und der Adapter liess sich problemlos konfigurieren.
    Nun habe ich aber einen Laptop mit einem Athlon XP mobile Prozessor und dieser würde nur auf 795MHz laufen, wenn ich kein powernow benutzen könnte. powernow benötigt aber wiederum das ACPI. Nun bin ich in ner ziemlichen Zwickmühle und hoffe, dass mir jemand da raushelfen kann. Entweder ich betreibe meinen Laptop mit 795MHz (anstatt 1,66GHz, die mit powernow moeglich sind) oder ich habe kein WLAN. Beides ist für mich eigentlich indiskutabel, was bestimmt jeder verstehen kann.
    Wie kann ich also mein ACPI austricksen, um meinen WLAN-Adapter doch noch benutzen zu können?
    Weiss jemand, warum das ACPI gerade die USB-Module so stört und kann mir sagen, wie man dieses Problem beheben kann? Vielleicht hat aber auch jemand den gleichen Rechner (einen Acer Aspire 1351XC - aus der 1350-Reihe) und hat dieses oder ein aehnliches Problem mit USB-Geraeten schonmal gelöst bekommen.
     
  8. #7 Bleuchter, 18.06.2006
    Bleuchter

    Bleuchter Grünschnabel

    Dabei seit:
    18.06.2006
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo TheTon

    dieser Beitrag ist schon älter, ich habe jedoch die gleiche Meldung mit einen SuSe Linux 9.3 das auf den aktuellen Stand ist.. Der Prism2 Treiber ist vorhanden. Da aber die USB-Schnittstelle mit dem Gerät wohl nicht initialisiert wird kann, die Hardware nicht angesprochen werden. Da ich schon seit einer Woche die verschiedensten Foren durchsucht habe, hoffe ich, das du eine Lösung gefunden hast.
     
  9. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Die Loesung liegt darin das Ding nicht an einen USB-HUB und unbedingt an einen USB2-Port zu haengen. :) Bei mir hat's funktioniert.
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 Bleuchter, 21.06.2006
    Bleuchter

    Bleuchter Grünschnabel

    Dabei seit:
    18.06.2006
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo theton,

    kannst Du das mit dem USB-HUB etwas genauer erklären, habe alle USB-ports ausprobiert und bekomme immer die gleiche Fehlermeldung mit dmesg.
     
  12. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
Thema:

Probleme mit WLAN-USB-Adapter und Ubuntu

Die Seite wird geladen...

Probleme mit WLAN-USB-Adapter und Ubuntu - Ähnliche Themen

  1. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  2. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...
  3. Forscher analysieren Durchsatzprobleme im Linux-Scheduler

    Forscher analysieren Durchsatzprobleme im Linux-Scheduler: Eine Gruppe von Forschern hat Fälle identifiziert, in denen der Scheduler im Linux-Kernel falsche Entscheidungen trifft und die CPUs nicht so gut...
  4. München: LiMux als Sündenbock für IT-Probleme?

    München: LiMux als Sündenbock für IT-Probleme?: Im Münchner Stadtrat soll später in diesem Jahr erneut über den Einsatz von Linux in der Stadtverwaltung diskutiert werden. Die Grünen vermuten,...
  5. BSI-Audit findet keine akuten Probleme in OpenSSL

    BSI-Audit findet keine akuten Probleme in OpenSSL: Das Bundesamt für Sicherheit in der Informationstechnik hat OpenSSL auf seine Sicherheit untersuchen lassen. Die Analyse zeigt vor allem, dass die...