Probleme mit Umlauten

Dieses Thema im Forum "Installation & Basiskonfiguration" wurde erstellt von jomep, 02.01.2010.

  1. #1 jomep, 02.01.2010
    Zuletzt bearbeitet: 02.01.2010
    jomep

    jomep Grünschnabel

    Dabei seit:
    02.01.2010
    Beiträge:
    1
    Zustimmungen:
    0
    Hallo,

    ich habe heute Debian Linux auf einem Rechner installiert, den ich als Fileserver benutzen möchte. Ich habe ein paar Probleme mit Umlauten:

    Als locale habe ich de_DE.UTF-8 gewählt. Ich habe Samba installiert und einen Share eingerichtet, auf den ich mit Windows-Clients zugreife.

    1. Wenn ich eine Datei anlegen möchte (über Putty, im Home Directory), dann werden die Umlaute mit einem Fragezeichen angezeigt:
    Code:
    jomep@jclbs2:~$ touch jörg; ls j*
    j?rg
    
    2. Wenn ich Umlaute über die Tastatur eingebe, dann erscheint der Umlaut erst wenn ich den nächsten Buchstaben eingebe. Wenn ich also ÄÜ eintippe, dann erscheint nur das Ä. Wenn ich danach z.B. die taste A drücke, so erscheint ÄÜA.

    3. Über die Samba Shares scheinen die Umlaute zu funktionieren.. Wenn ich dort eine Datei mit Umlauten erzeuge, wird sie auch im Share korrekt angezeigt. Wenn ich mir dieselbe Datei aber mit der Shell (Putty) anzeigen lasse, sehe ich nur Buchstabensalat

    Wie ihr seht, bin ich etwas überfordert :think:

    Habt Ihr eine Idee? Ich habe schon viel bei Google gesucht, aber nichts gefunden, was direkt relevant gewesen wäre.

    Danke
    Jörg
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Ich habe in Putty unter "Window - Translation" UTF-8 eingestellt, und nun kann ich dort die korrekten Umlaute sehen. Auch das Problem mit dem Eingeben von Umlauten über die Tastatur ist gelöst.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Probleme mit Umlauten

Die Seite wird geladen...

Probleme mit Umlauten - Ähnliche Themen

  1. Probleme mit Umlauten

    Probleme mit Umlauten: Moin! Habe mir gestern zusätzlich zu kde noch gnome zu meinem kubuntu installiert. Seitdem habe ich unter KDE Probleme mit den Umlauten....
  2. [ncurses] Probleme mit Umlauten und ein paar Sonderzeichen

    [ncurses] Probleme mit Umlauten und ein paar Sonderzeichen: Hi Ich weiß nicht ob es jetzt an C++ und ncurses oder am System liegt, ich habs mal hier rein, falls ein MOD mein, es gehört wo anders hin,...
  3. Probleme mit Umlauten

    Probleme mit Umlauten: Hallo allerseits! Seit kurzem haben wir einen neuen Server bekommen (p510 mit AIX 5.3) auf dem die Samba-Version 3.0.20 zum Einsatz kommt. Nach...
  4. RHEL4 - Probleme mit Umlauten

    RHEL4 - Probleme mit Umlauten: Hallo Leute, ich habe folgendes Problem: Auf einem RHEL4-Server werden die Umlaute nicht richtig dargestellt. Wir haben OpenLDAP und Samba...
  5. probleme mit samba & umlauten unter red hat 9

    probleme mit samba & umlauten unter red hat 9: heyho! habe mir red hat 9 installiert und habe probleme mit den umlauten in samba. habe schon in meiner smb.conf die client code page = 850...