Probleme mit Suse10.2 Grafiktreiber

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von trunksen, 11.01.2007.

  1. #1 trunksen, 11.01.2007
    trunksen

    trunksen Doppel-As

    Dabei seit:
    13.10.2006
    Beiträge:
    139
    Zustimmungen:
    0
    Ort:
    Österreich, Steiermark
    Hallo!

    Also, ich habe mir die Version Suse 10.2 installiert.
    Da ich die 3D-Beschleunigung nutzen möchte, wollte ich auch den Nvidia-Treiber installieren.
    Aja ich habe eine Geforce Go7400.
    Also hab' ich vom Yast aus erfolgreich gcc und kernel-source installiert.
    Dann hab ich mir den Grafiktreiber für Nvidia (den x86) gedownloadet und wollte ihn von der runlevel 3 aus installieren.
    Doch da kommt immer ein Fehler:

    entweder kernel-source ist nicht installiert (was sie aber ist), oder sie befindet sich in einen
    anderen Verzeichnis oder so ähnlich!

    wenn ich:
    rpm -qa|egrep 'nvidia|kernel|gcc|make' eingebe:

    Code:
    gcc-4.1.3-29
    kernel-default-2.6.18.6-jen43
    linux-kernel-headers-2.6.18.2-3
    make-3.81-23
    gcc41-gij-4.1.2_20061115-7
    gcc41-4.1.2_20061115-5
    kernel-debug-2.6.18.2-34
    libgcc41-4.1.2_20061115-5
    gcc-gij-4.1.3-29
    kernel-source-2.6.18.2-34
    
    bei cat /etc/SuSE-release:

    Code:
    openSUSE 10.2 (i586)
    VERSION = 10.2
    
    
    [/Code]

    bei /usr/sbin/hwinfo --gfxcard:

    Code:
    26: PCI 100.0: 0300 VGA compatible controller (VGA)
      [Created at pci.286]
      UDI: /org/freedesktop/Hal/devices/pci_10de_1d8
      Unique ID: VCu0.CxJLbHbWto3
      Parent ID: vSkL.rxAOeWuq8i6
      SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
      SysFS BusID: 0000:01:00.0
      Hardware Class: graphics card
      Model: "Sony GeForce Go 7400"
      Vendor: pci 0x10de "nVidia Corporation"
      Device: pci 0x01d8 "GeForce Go 7400"
      SubVendor: pci 0x104d "Sony Corporation"
      SubDevice: pci 0x81ef
      Revision: 0xa1
      Memory Range: 0xd1000000-0xd1ffffff (rw,non-prefetchable)
      Memory Range: 0xb0000000-0xbfffffff (rw,prefetchable)
      Memory Range: 0xd0000000-0xd0ffffff (rw,non-prefetchable)
      IRQ: 7 (no events)
      I/O Ports: 0x3c0-0x3df (rw)
      Module Alias: "pci:v000010DEd000001D8sv0000104Dsd000081EFbc03sc00i00"
      Driver Info #0:
        XFree86 v4 Server Module: nv
      Driver Info #1:
        XFree86 v4 Server Module: nvidia
        3D Support: yes
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #10 (PCI bridge)
    
    Ich habe es mit anderen Treibern auch bereits versucht, doch da dann immer steht das mein System ein x86 System ist, wirds wohl der richtige Treiber sein!

    was kann es dann sein?
    Muss ich die kernel.h vll in einen anderen Ordner oder so kopieren?

    mfg trunksen
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    versuch mal das hier:

    lade dir den nvidia treiber hier runter.

    dann wechsel in ein terminal, zb alt+f3, melde dich als root an, gehe dann in das verzeichnis in dem du den treiber gespeichert hast, und gib dort dann

    Code:
    sh ./NVIDIA-Linux-x86-1.0-9746-pkg1.run
    ein.

    das müsste gehen, wenn nicht, dann such einmal bei yast nach kernel sources und guck ob die wirklich da sind
     
  4. #3 Hello World, 11.01.2007
    Hello World

    Hello World Routinier

    Dabei seit:
    22.11.2006
    Beiträge:
    324
    Zustimmungen:
    0
    Abgesehen davon, dass Du nicht kernel-source sondern kernel-syms brauchst, stellt nVidia auch Pakete für OpenSuse bereit.
    ftp://download.nvidia.com/opensuse/10.2/
     
  5. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    doch man braucht die kernel sources, weis ich weil ich so auch den treiber installiere ;)
     
  6. #5 trunksen, 12.01.2007
    trunksen

    trunksen Doppel-As

    Dabei seit:
    13.10.2006
    Beiträge:
    139
    Zustimmungen:
    0
    Ort:
    Österreich, Steiermark
    Hi!

    Gut ich habe genau diesen Treiber gedownloadet.
    dort ist genau der gleiche Fehler gekommen!

    da ist bei mir ein Fehler gekommen.
    Irgendwas mit YUM oder so.

    Was könnte es sonst noch sein? :hilfe2:

    mfg trunksen
     
  7. #6 Caleb79, 12.01.2007
    Caleb79

    Caleb79 Doppel-As

    Dabei seit:
    15.10.2006
    Beiträge:
    146
    Zustimmungen:
    0
    da kommt doch eine Frage (nach der Lizenzfrage), ob du irgendwas runterladen willst (den genauen Wortlaut weiß ich jetzt nich).
    Diese Frage musst du verneinen/ablehnen.

    Dann sollte es gehen, jedenfalls ging es bei mir dann.


    Gruß, Caleb
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Probleme mit Suse10.2 Grafiktreiber

Die Seite wird geladen...

Probleme mit Suse10.2 Grafiktreiber - Ähnliche Themen

  1. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  2. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...
  3. Forscher analysieren Durchsatzprobleme im Linux-Scheduler

    Forscher analysieren Durchsatzprobleme im Linux-Scheduler: Eine Gruppe von Forschern hat Fälle identifiziert, in denen der Scheduler im Linux-Kernel falsche Entscheidungen trifft und die CPUs nicht so gut...
  4. München: LiMux als Sündenbock für IT-Probleme?

    München: LiMux als Sündenbock für IT-Probleme?: Im Münchner Stadtrat soll später in diesem Jahr erneut über den Einsatz von Linux in der Stadtverwaltung diskutiert werden. Die Grünen vermuten,...
  5. BSI-Audit findet keine akuten Probleme in OpenSSL

    BSI-Audit findet keine akuten Probleme in OpenSSL: Das Bundesamt für Sicherheit in der Informationstechnik hat OpenSSL auf seine Sicherheit untersuchen lassen. Die Analyse zeigt vor allem, dass die...