Probleme mit squidGuard

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von darthdungeon, 02.02.2007.

  1. #1 darthdungeon, 02.02.2007
    darthdungeon

    darthdungeon Jungspund

    Dabei seit:
    02.02.2007
    Beiträge:
    13
    Zustimmungen:
    0
    Hi Com,

    ich habe ein Problem mit dem squidGuard. und zwar hab ich ein Debain 3.1.2 und will auf diesem squid mit squidGuard laufen lassen. ich konnte squid ohne problme installieren und konfigurieren. er läuft ohne probleme und meine internet (http) läufft über diesen "server". nun hab ich squidGuard installiert und konfiguriert und ihn beim squid mit "redirect_program /usr/bin/squidGuard" eingetragen und squid neu gestartet. und nun läuft gar nichts mehr über port 8080 auf dem squid-rechner.
    er redirectet nicht, es kommt keine(!) website, egal ob mit konfiguration oder komplett mit leerer squidGuard.conf file (also nicht komplett leer, sondern nur ohne "effektive anweißungen"). das komische ist, das er wenn ich squid mit squidGuard support restartet hab, ein paar sekunden nach einem websetenseiten aufruf abstürtzt (laut ps aux | grep squid läuft nichts mehr!). in die squid-logs schreibt squidGuard auch nichts rein.
    ich hab schon das forum + internet durchsucht, hat alles nichts gebraucht. der squid- user ist eigentümer von /var/log/squid und den db files.
    wenn ich squid -d ingebe kommt:

    1997/08/02 13:47:22| Starting Squid Cache version 2.5.STABLE9 for i386-debian-linux-gnu...
    1997/08/02 13:47:22| Process ID 3118
    1997/08/02 13:47:22| With 1024 file descriptors available
    1997/08/02 13:47:22| Performing DNS Tests...
    1997/08/02 13:47:22| Successful DNS name lookup tests...
    1997/08/02 13:47:22| DNS Socket created at 0.0.0.0, port 1035, FD 5
    1997/08/02 13:47:22| Adding nameserver 192.168.182.1 from /etc/resolv.conf
    1997/08/02 13:47:22| helperOpenServers: Starting 5 'squidGuard' processes
    1997/08/02 13:47:22| User-Agent logging is disabled.
    1997/08/02 13:47:22| Referer logging is disabled.
    1997/08/02 13:47:22| Swap maxSize 1024000 KB, estimated 78769 objects
    1997/08/02 13:47:22| Target number of buckets: 3938
    1997/08/02 13:47:22| Using 8192 Store buckets
    1997/08/02 13:47:22| Max Mem size: 8192 KB
    1997/08/02 13:47:22| Max Swap size: 1024000 KB
    1997/08/02 13:47:22| Local cache digest enabled; rebuild/rewrite every 3600/3600 sec
    1997/08/02 13:47:22| Rebuilding storage in /var/spool/squid (CLEAN)
    1997/08/02 13:47:22| Using Least Load store dir selection
    1997/08/02 13:47:22| Set Current Directory to /var/spool/squid
    1997/08/02 13:47:22| Loaded Icons.
    1997/08/02 13:47:22| Accepting HTTP connections at 192.168.10.1, port 8080, FD 19.
    1997/08/02 13:47:22| HTCP Disabled.
    1997/08/02 13:47:22| WCCP Disabled.
    1997/08/02 13:47:22| Ready to serve requests.
    1997/08/02 13:47:22| WARNING: redirector #1 (FD 7) exited
    1997/08/02 13:47:22| WARNING: redirector #2 (FD Cool exited
    1997/08/02 13:47:22| WARNING: redirector #3 (FD 9) exited
    1997/08/02 13:47:22| Too few redirector processes are running
    FATAL: The redirector helpers are crashing too rapidly, need help!

    Anmerkung: mein cmos batterie ist leer, deshalb speichert der das datum/uhrzeit nicht und es ist nach jedem restart wieder bei 1997...

    squidGuard -d gib keine fehler aus und ihn syslog steht nur zu squid:

    Jul 31 10:09:02 localhost squid[2063]: Preparing for shutdown after 1143 requests
    Jul 31 10:09:02 localhost squid[2063]: Waiting 30 seconds for active connections to finish
    Jul 31 10:09:02 localhost squid[2063]: FD 13 Closing HTTP connection
    Jul 31 10:09:02 localhost squid[2063]: Shutting down...
    Jul 31 10:09:02 localhost squid[2063]: Closing unlinkd pipe on FD 11
    Jul 31 10:09:02 localhost squid[2063]: storeDirWriteCleanLogs: Starting...
    Jul 31 10:09:02 localhost squid[2063]: Finished. Wrote 737 entries.
    Jul 31 10:09:02 localhost squid[2063]: Took 0.1 seconds (12148.7 entries/sec).
    Jul 31 10:09:02 localhost squid[2063]: Squid Cache (Version 2.5.STABLE9): Exiting normally.
    Jul 31 10:09:02 localhost squid[2060]: Squid Parent: child process 2063 exited with status 0
    Jul 31 10:09:04 localhost rpc.statd[799]: Caught signal 15, un-registering and exiting.

    ich hab keine ahnung, wieso der abstürtz, bitte helf mir!
    vielen dank schon mal im voraus!
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 darthdungeon, 04.02.2007
    Zuletzt bearbeitet: 04.02.2007
    darthdungeon

    darthdungeon Jungspund

    Dabei seit:
    02.02.2007
    Beiträge:
    13
    Zustimmungen:
    0
    atsch! so dumm:mad: ich war mir eigentlich sicher, das ich squid als eigentümer für die config-dateien gesetzt hatte. war dann aber doch root! jetzt wo squid lese-rechte auf die config-files hat, funktioniert alles! :D
     
Thema:

Probleme mit squidGuard

Die Seite wird geladen...

Probleme mit squidGuard - Ähnliche Themen

  1. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  2. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...
  3. Forscher analysieren Durchsatzprobleme im Linux-Scheduler

    Forscher analysieren Durchsatzprobleme im Linux-Scheduler: Eine Gruppe von Forschern hat Fälle identifiziert, in denen der Scheduler im Linux-Kernel falsche Entscheidungen trifft und die CPUs nicht so gut...
  4. München: LiMux als Sündenbock für IT-Probleme?

    München: LiMux als Sündenbock für IT-Probleme?: Im Münchner Stadtrat soll später in diesem Jahr erneut über den Einsatz von Linux in der Stadtverwaltung diskutiert werden. Die Grünen vermuten,...
  5. BSI-Audit findet keine akuten Probleme in OpenSSL

    BSI-Audit findet keine akuten Probleme in OpenSSL: Das Bundesamt für Sicherheit in der Informationstechnik hat OpenSSL auf seine Sicherheit untersuchen lassen. Die Analyse zeigt vor allem, dass die...