probleme mit sonderzeichen unter debian

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von sono, 22.02.2004.

  1. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    hab da ein kleines problem mit meinem debian system .

    meine ä sehen ungefähr so aus \xe4 na ja und ein haufen sonderzeichen sehen genau so scheiße aus.

    als ich debian installiert habe hab ich eingentlich die module von wegen sprache geladen

    nls_cp850 3616 0 (unused)
    nls_iso8859-15 3392 0 (unused)

    haben die damit was zu tun , oder was muss ich ändern das mein ä auch aussieht wie ein äh ?

    hab mal versuch danach zu googeln , aber finde da mal den richtigen suchbegriff.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 armin@debian, 22.02.2004
    Zuletzt bearbeitet: 22.02.2004
    armin@debian

    armin@debian Grünschnabel

    Dabei seit:
    17.02.2004
    Beiträge:
    4
    Zustimmungen:
    0
    Ort:
    Halle, SH
    Also damit das richtig mit den Umlauten geht musst du in der Kernel-Konfig deinen Standartzeichensatz nicht nur als Modul answählen, sondern diesen auch als Standart-Zeichensatz angeben.
    Das geht so:
    File Systems -> Native Language Support
    [M/*]NLS ISO 8859-15 (Latin 9; Western European Languages with Euro)

    Und dann ganz oben in der Liste unter "Default NLS Option" das hier: iso8859-15 eingeben.

    Damit sollte eigentlich alles gegessen sein. Nochmal den Kernel rekompilieren (kernel-package), lilo ausführen, neu Booten (musst du, damit der Kernel neu reingeladen wird) und dann kannst du deine Dateinamen mit den korrekten Umlauten sehen.

    Gruß, Armin
     
  4. Gonzo

    Gonzo Muppet

    Dabei seit:
    12.10.2002
    Beiträge:
    154
    Zustimmungen:
    0
    Ort:
    Hannover
    Eigentlich sollte es schon reichen, die richtigen Locals zu konfigurieren. Dazu u. U. nochmal dpkg-reconfigure locals ausführen, dort die zu generierenden auswählen, Standard festlegen und fertig...

    Gonzo
     
  5. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    das mit dem dpkg-reconfigure locales wars ned .

    die waren eigentlich auch richtig konfiguriert , von wegen de.De @ haumichtot .

    und eigentlich hätte ich schwöre können das auch in den neuen kernel mit eingebacken habe .

    am ende gehen die zeichen "§öä" nicht . komischerweise gehen die dinger jetzt im browser schon .
    kann sie ja schreiben, nur wenn ich unter vi ein script schreibe gehe sie eben ned .
    liegt das dann eher an vi ??
    könnte man fast meinen.
     
  6. #5 sono, 24.02.2004
    Zuletzt bearbeitet: 24.02.2004
    sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    ok mein fehler

    hab den kernel noch mal frisch gebacken und jetzt gehts.
    muss wohl das letzte mal ein häckchen vergessen haben.
    :rolleyes:

    wo wir gerade beim kernelbacken sind. kennt jemand ein gutes deutsches textchen das beschreibt was die optionen die ich auswählen kann alles genau bedeuten ?

    so ungefähr 80% + - keine ahnung wieviel erklärt sich ja beim lesen ohne probleme und den rest kann man raten , aber ob ich immer richtig rate .

    hmm das könnte so sein. ihr wisst ja denken ist glücksache , und ich würde mich jetzt ned als glückspilz bezeichnen.
    mein problem beim den kernel howtos ist am ende halt nur dass du immer nur howtos findest die dir erklären wie du das ding installiert von wegen
    make menuconfig make dep make clean usw .

    denke mal ihr wisst was ich meine
     
Thema:

probleme mit sonderzeichen unter debian

Die Seite wird geladen...

probleme mit sonderzeichen unter debian - Ähnliche Themen

  1. Samba Probleme mit Sonderzeichen

    Samba Probleme mit Sonderzeichen: Hallo, ich bin gerade dabei mir unter xVM ein neues Debian 5.0 zu installieren. Darauf würde ich auch gerne ein Samba Server installieren....
  2. [ncurses] Probleme mit Umlauten und ein paar Sonderzeichen

    [ncurses] Probleme mit Umlauten und ein paar Sonderzeichen: Hi Ich weiß nicht ob es jetzt an C++ und ncurses oder am System liegt, ich habs mal hier rein, falls ein MOD mein, es gehört wo anders hin,...
  3. Probleme zw. GAIM & Trillian, ICQ - Sonderzeichen

    Probleme zw. GAIM & Trillian, ICQ - Sonderzeichen: Hallo Leute, heute ist mir mal wieder aufgefallen, dass Nachrichten, die ich per GAIM zu ICQ bzw. Trillian verschicke und diese dann auch noch...
  4. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  5. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...