Probleme mit DNS

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von SiS, 18.08.2008.

  1. SiS

    SiS Routinier

    Dabei seit:
    12.02.2007
    Beiträge:
    318
    Zustimmungen:
    0
    Hallo,

    habe nach langer Zeit mal wieder ein Problem wo ich nicht richtig weiß wo ich ansetzen soll!

    Also es geht um einen Server. Bisher lief er auf Debian Sarge wurde aber auf Etch geupdatet.

    Seit dem ist der Server nicht mehr über seinen Domainnamen erreichbar (server.intranet.aeg). Über den Namen "server" ist es weiterhin problemlos möglich!

    Das bereitet jetzt einige Probleme, da einige Programme und Scripts noch auf den langen Namen verweisen, was sich leider auch nicht ohne weiteres ändern lässt.

    Es kommt bind9 zum Einsatz.

    Wenn Ihr mehr Infos braucht dann bitte nachfragen!

    Danke schonmal fürs lesen ;)
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 flugopa, 18.08.2008
    flugopa

    flugopa Der lernwillige

    Dabei seit:
    27.05.2006
    Beiträge:
    739
    Zustimmungen:
    0
    Ort:
    München
    Welche Ausgabe erfolgt nach:
    Code:
    host server
    Hat sich evtl. die IP-Adresse geändert?
     
  4. #3 SiS, 18.08.2008
    Zuletzt bearbeitet: 18.08.2008
    SiS

    SiS Routinier

    Dabei seit:
    12.02.2007
    Beiträge:
    318
    Zustimmungen:
    0
    Okai wenigstens eine Fehlermeldung an der man ansetzen kann:

    Code:
    19:23/0 server ~ # host server
    server.intranet.aeg A record not found, server failure
    
    Bitte fleißig antworten...ich probier solange mein Glück mit Google....
    Ahja, IP ist gleich geblieben!
     
  5. kworx

    kworx Jungspund

    Dabei seit:
    05.08.2008
    Beiträge:
    15
    Zustimmungen:
    0
    kannst du bitte die Ergebnisse von...
    Code:
    $ dig intranet.aeg ns
    
    und von...
    Code:
    $ dig @ns1.der-vom-ersten-befehl-kam.aeg server.intranet.aeg
    $ dig @ns2.der-vom-ersten-befehl-kam.aeg server.intranet.aeg
    
    das selbe dann noch ohne domain...
    Code:
    $ dig @ns1.der-vom-ersten-befehl-kam.aeg server
    $ dig @ns2.der-vom-ersten-befehl-kam.aeg server
    
    und noch ein...
    Code:
    $ cat /etc/resolv.conf
    
    posten.
     
  6. #5 SiS, 18.08.2008
    Zuletzt bearbeitet: 18.08.2008
    SiS

    SiS Routinier

    Dabei seit:
    12.02.2007
    Beiträge:
    318
    Zustimmungen:
    0
    So...
    Code:
    20:16/29 server ~ # dig intranet.aeg ns
    
    ; <<>> DiG 9.3.4-P1.1 <<>> intranet.aeg ns
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 25176
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;intranet.aeg.			IN	NS
    
    ;; Query time: 0 msec
    ;; SERVER: 10.16.1.1#53(10.16.1.1)
    ;; WHEN: Mon Aug 18 21:04:11 2008
    ;; MSG SIZE  rcvd: 30
    
    
    Soo..

    Ist der Befehl Deiner Meinung nach so richtig?
    Code:
    21:10/1 server ~ # dig @10.16.1.1 server.intranet.aeg
    
    ; <<>> DiG 9.3.4-P1.1 <<>> @10.16.1.1 server.intranet.aeg
    ; (1 server found)
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 25003
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;server.intranet.aeg.		IN	A
    
    ;; Query time: 0 msec
    ;; SERVER: 10.16.1.1#53(10.16.1.1)
    ;; WHEN: Mon Aug 18 21:11:17 2008
    ;; MSG SIZE  rcvd: 37
    
    Hmm dieses Root-servers.net kommt mir komisch vor...
    Weiß einer was das sein kann oder wo das her kommt?

    Code:
    21:11/0 server ~ # dig @10.16.1.1 server
    
    ; <<>> DiG 9.3.4-P1.1 <<>> @10.16.1.1 server
    ; (1 server found)
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 59801
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 13, ADDITIONAL: 13
    
    ;; QUESTION SECTION:
    ;server.				IN	A
    
    ;; ANSWER SECTION:
    server.			0	IN	A	10.16.1.1
    
    ;; AUTHORITY SECTION:
    .			339311	IN	NS	C.ROOT-SERVERS.NET.
    .			339311	IN	NS	D.ROOT-SERVERS.NET.
    .			339311	IN	NS	E.ROOT-SERVERS.NET.
    .			339311	IN	NS	F.ROOT-SERVERS.NET.
    .			339311	IN	NS	G.ROOT-SERVERS.NET.
    .			339311	IN	NS	H.ROOT-SERVERS.NET.
    .			339311	IN	NS	I.ROOT-SERVERS.NET.
    .			339311	IN	NS	J.ROOT-SERVERS.NET.
    .			339311	IN	NS	K.ROOT-SERVERS.NET.
    .			339311	IN	NS	L.ROOT-SERVERS.NET.
    .			339311	IN	NS	M.ROOT-SERVERS.NET.
    .			339311	IN	NS	A.ROOT-SERVERS.NET.
    .			339311	IN	NS	B.ROOT-SERVERS.NET.
    
    ;; ADDITIONAL SECTION:
    A.ROOT-SERVERS.NET.	80106	IN	A	198.41.0.4
    A.ROOT-SERVERS.NET.	80106	IN	AAAA	2001:503:ba3e::2:30
    B.ROOT-SERVERS.NET.	512416	IN	A	192.228.79.201
    C.ROOT-SERVERS.NET.	258406	IN	A	192.33.4.12
    D.ROOT-SERVERS.NET.	453366	IN	A	128.8.10.90
    E.ROOT-SERVERS.NET.	512426	IN	A	192.203.230.10
    F.ROOT-SERVERS.NET.	263845	IN	A	192.5.5.241
    F.ROOT-SERVERS.NET.	332516	IN	AAAA	2001:500:2f::f
    G.ROOT-SERVERS.NET.	511720	IN	A	192.112.36.4
    H.ROOT-SERVERS.NET.	511417	IN	A	128.63.2.53
    H.ROOT-SERVERS.NET.	281288	IN	AAAA	2001:500:1::803f:235
    I.ROOT-SERVERS.NET.	258567	IN	A	192.36.148.17
    J.ROOT-SERVERS.NET.	80106	IN	A	192.58.128.30
    
    ;; Query time: 1 msec
    ;; SERVER: 10.16.1.1#53(10.16.1.1)
    ;; WHEN: Mon Aug 18 21:13:38 2008
    ;; MSG SIZE  rcvd: 495
    
    
    Und noch die resolv.conf....
    Code:
    search intranet.aeg
    nameserver 10.16.1.1
    nameserver 10.16.1.254
    
    10.16.1.254 ist der IPCop über den alles ins Netz geht....
     
  7. kworx

    kworx Jungspund

    Dabei seit:
    05.08.2008
    Beiträge:
    15
    Zustimmungen:
    0
    OK. Verstanden. Die Abfrage
    klappt nicht. Für die Zone sind keine Nameserver definiert.

    Prüf mal ob für Zone intranet.aeg ein Zonefile existiert und ob es auch geladen wird. Scheint nicht der Fall zu sein oder es ist fehlerhaft.

    Ansonten musst du ein Zonefile anlegen. Schau mal hier http://archiv.debianhowto.de/de/bind/c_bind.html .
    Scheint mir so eine Art caching only Nameserver zu sein. Normalerweise sollte der keine Rootserver zurück liefern, wenn dein DNS den Namen beantworten kann.
     
  8. SiS

    SiS Routinier

    Dabei seit:
    12.02.2007
    Beiträge:
    318
    Zustimmungen:
    0
    Zone File existiert

    /etc/bind/named.conf
    Code:
    21:17/0 server /etc/bind # cat named.conf
    // This is the primary configuration file for the BIND DNS server named.
    //
    // Please read /usr/share/doc/bind9/README.Debian.gz for information on the 
    // structure of BIND configuration files in Debian, *BEFORE* you customize 
    // this configuration file.
    //
    // If you are just adding zones, please do that in /etc/bind/named.conf.local
    
    include "/etc/bind/named.conf.options";
    
    // prime the server with knowledge of the root servers
    zone "." {
    	type hint;
    	file "/etc/bind/db.root";
    };
    
    // be authoritative for the localhost forward and reverse zones, and for
    // broadcast zones as per RFC 1912
    
    zone "localhost" {
    	type master;
    	file "/etc/bind/db.local";
    };
    
    zone "127.in-addr.arpa" {
    	type master;
    	file "/etc/bind/db.127";
    };
    
    zone "0.in-addr.arpa" {
    	type master;
    	file "/etc/bind/db.0";
    };
    
    zone "255.in-addr.arpa" {
    	type master;
    	file "/etc/bind/db.255";
    };
    
    // zone "com" { type delegation-only; };
    // zone "net" { type delegation-only; };
    
    // From the release notes:
    //  Because many of our users are uncomfortable receiving undelegated answers
    //  from root or top level domains, other than a few for whom that behaviour
    //  has been trusted and expected for quite some length of time, we have now
    //  introduced the "root-delegations-only" feature which applies delegation-only
    //  logic to all top level domains, and to the root domain.  An exception list
    //  should be specified, including "MUSEUM" and "DE", and any other top level
    //  domains from whom undelegated responses are expected and trusted.
    // root-delegation-only exclude { "DE"; "MUSEUM"; };
    
    include "/etc/bind/named.conf.local";
    
    include "/etc/bind/named.conf.linuxmuster";
    
    /etc/bind/named.conf.options
    Code:
    21:19/0 server /etc/bind # cat named.conf.options
    options {
    	directory "/var/cache/bind";
    
    	// If there is a firewall between you and nameservers you want
    	// to talk to, you might need to uncomment the query-source
    	// directive below.  Previous versions of BIND always asked
    	// questions using port 53, but BIND 8.1 and later use an unprivileged
    	// port by default.
    
    	// query-source address * port 53;
    
    	// If your ISP provided one or more IP addresses for stable 
    	// nameservers, you probably want to use them as forwarders.  
    	// Uncomment the following block, and insert the addresses replacing 
    	// the all-0's placeholder.
    
    	forwarders {
    		10.16.1.254;
    	};
    	# Enable the next entry to prefer usage of the name 
    	# server declared in the forwarders section.
    
    	forward first;
    
    	# The listen-on record contains a list of local network
    	# interfaces to listen on. Optionally the port can be 
    	# specified. Default is to listen on all interfaces found
    	# on your system. The default port is 53.
    
    	#listen-on port 53 { 127.0.0.1; };
    	listen-on port 53 { 10.16.0.0/12; };
    
    	# The listen-on-v6 record enables or disables listening
    	# on IPV6 interfaces. Allowed values are 'any' and 'none'
    	# or a list of addresses. IPv6 can only be used with 
    	# kernel 2.4 in this release.
    
    	#listen-on-v6 { any; };
    
    	# The next three statements may be needed if a firewall
    	# stands between the local server and the internet.
    
    	#query-source address * port 53;
    	#transfer-source * port 53;
    	#notify-source * port 53;
    
    	# The allow-query record contains a list of networks or
    	# IP-addresses to accept and deny queries from. The 
    	# default is to allow queries from all hosts.
    
    	#allow-query { 127.0.0.1; };
    	allow-query { 10.16.0.0/12; };
    
    	# If notify is set to yes (default), notify messages are
    	# sent to other name servers when the the zone data is
    	# changed. Instead of setting a global 'notify' statement
    	# in the 'options' section, a separate 'notify' can be
    	# added to each zone definition.
    
    	notify no;
    
    	auth-nxdomain no;    # conform to RFC1035
    
    };
    

    /etc/bind/named.conf.local besteht nur aus Kommentaren! Also wohl unwichtig....


    /etc/bind/named.conf.linuxmuster
    Code:
    21:23/0 server /etc/bind # cat named.conf.linuxmuster
    //
    // Do any local configuration here
    //
    
    // Consider adding the 1918 zones here, if they are not used in your
    // organization
    //include "/etc/bind/zones.rfc1918";
    
    include "/etc/bind/rndc.key";
    
    zone "intranet.aeg" {
    	type master;
    	file "/etc/bind/db.linuxmuster";
    	allow-update { key rndc-key; };
    	notify yes;
    };
    
    zone "10.in-addr.arpa" {
    	type master;
    	file "/etc/bind/db.10";
    	allow-update { key rndc-key; };
    	notify yes;
    };
    
    @Kworx:
    Du hast ja auch schon in meinem Thread auf linuxforen.de geantwortet...
     
  9. kworx

    kworx Jungspund

    Dabei seit:
    05.08.2008
    Beiträge:
    15
    Zustimmungen:
    0
    Ja, läuft aber ein wenig durcheinander, weil die Infos teilweise hier und teilweise auf http://www.linuxforen.de/ verteilt sind.

    Sicher mal deine bind Konfiguration und änder danach mal folgendes:

    Das ist soweit OK.
    Code:
    ### /etc/bind/named.conf.linuxmuster
    zone "10.in-addr.arpa" {
    	type master;
    	file "/etc/bind/db.10";
    	allow-update { key rndc-key; };
    	notify yes;
    };
    zone "intranet.aeg" {
    	type master;
    	file "/etc/bind/db.linuxmuster";
    	allow-update { key rndc-key; };
    	notify yes;
    };
    
    Die Zeile einfach deaktivieren.
    Code:
    ### /etc/bind/named.conf.options
    #	forward first;
    
    Die bestehende /etc/bind/db.linuxmuster ersetzt du einfach mit der
    Code:
    ### /etc/bind/db.linuxmuster
    $TTL 3600
    @       IN SOA  server.intranet.aeg. postmaster.intranet.aeg. (
                    2004031538
                    10800
                    3600
                    604800
                    38400)
                    IN  NS	server.intranet.aeg.
                    IN  MX	10 server.intranet.aeg.
    
    server		IN A	10.16.1.1
    
    Dann starte mal den bind neu und versuch noch mal die Befehle (dig) vom Anfang des Threads.

    Brauchst du die dynamischen Updates von den IP Adressen? Falls nicht, dann würde ich die noch abspecken.
    Code:
    ### /etc/bind/named.conf.linuxmuster
    zone "10.in-addr.arpa" {
    	type master;
    	file "/etc/bind/db.10";
    };
    zone "intranet.aeg" {
    	type master;
    	file "/etc/bind/db.linuxmuster";
    };
    
     
  10. SiS

    SiS Routinier

    Dabei seit:
    12.02.2007
    Beiträge:
    318
    Zustimmungen:
    0
    Alles probiert. Bisher kein Erfolg. Die Ausgabe von dig ist soweit gleich geblieben, aber das schau ich mir nachher nochmal an.
     
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. kworx

    kworx Jungspund

    Dabei seit:
    05.08.2008
    Beiträge:
    15
    Zustimmungen:
    0
    Falls das noch nicht klappt würde ich...

    1. die bind Konfigurationsdateien sichern
    2. das bind Konfigurationsverzeichnis löschen
    3. bind mit reinstall und force neu installieren
    4. die Standard Konfiguration testen
    5. die nötigen Änderungen in den Konfigurationsdateien vornehmen
     
  13. SiS

    SiS Routinier

    Dabei seit:
    12.02.2007
    Beiträge:
    318
    Zustimmungen:
    0
    Okai werde ich vielleicht nochmal probieren. Sonst muss ich mir wohl die Mühe machen und die Scripte ändern....
     
Thema:

Probleme mit DNS

Die Seite wird geladen...

Probleme mit DNS - Ähnliche Themen

  1. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  2. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...
  3. Forscher analysieren Durchsatzprobleme im Linux-Scheduler

    Forscher analysieren Durchsatzprobleme im Linux-Scheduler: Eine Gruppe von Forschern hat Fälle identifiziert, in denen der Scheduler im Linux-Kernel falsche Entscheidungen trifft und die CPUs nicht so gut...
  4. München: LiMux als Sündenbock für IT-Probleme?

    München: LiMux als Sündenbock für IT-Probleme?: Im Münchner Stadtrat soll später in diesem Jahr erneut über den Einsatz von Linux in der Stadtverwaltung diskutiert werden. Die Grünen vermuten,...
  5. BSI-Audit findet keine akuten Probleme in OpenSSL

    BSI-Audit findet keine akuten Probleme in OpenSSL: Das Bundesamt für Sicherheit in der Informationstechnik hat OpenSSL auf seine Sicherheit untersuchen lassen. Die Analyse zeigt vor allem, dass die...