Probleme mit apt/Synaptic

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von tjb, 16.09.2005.

  1. tjb

    tjb Foren As

    Dabei seit:
    26.06.2005
    Beiträge:
    94
    Zustimmungen:
    0
    Hallo,

    ich habe mehrere Probleme mit apt für suse.

    1.Bei vielen Programmen, die ich über synaptic installieren will, erhalte ich folgende Fehlermeldung (u. a. bei ksensors, gkrellm):
    Code:
    E: Error(s) while checking package signatures:
    0 unsigned package(s)
    1 package(s) with unknown signatures
    0 package(s) with illegal/corrupted signatures
    2. Synaptic zeigt Limewire als defektes Paket an. Limewire ließ sich jedoch, nachdem ich j2re 1.5 installiert hatte, ohne Abhängigkeitsprobleme mit yast installieren. Kann ich synaptic irgendwie dazu bringen diesen "Konflikt" zu ignorieren?

    3. (eher unabhängig von apt) Bei vielen rpms fehlen die Programmsymbole/Icons, so z.B. bei Limewire. Bei Firefox verschwanden die Icons, nachdem ich auf KDE 3.4.2 upgedatet hatte.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    zu 1.
    entweder die GPG Keys importieren oder "apt --no-checksig ...."

    zu 2.
    suse 9.3 oder 10.0 rc1 ? - limewire is bei mir gar nicht in den apt archiven verfügar ...
    was meckert er denn genau ?
    (unsaubere installation sind nich sehr prickelnd!)

    zu 3.
    ja das habe ich hier auch, allerdings liegt das wohl echt an den maintainern :(
    (im moment isses nur OOo, Firefox, Gnomemeeting und ein paar keine tools ...)
     
  4. #3 tjb, 16.09.2005
    Zuletzt bearbeitet: 16.09.2005
    tjb

    tjb Foren As

    Dabei seit:
    26.06.2005
    Beiträge:
    94
    Zustimmungen:
    0
    zu 1.: Wie kann ich denn die keys importieren?

    zu 2.: Ich habe Suse 9.3. Synaptic meckert, dass das Paket defekt sei, und will es daher entfernen. Es scheint ja in synaptic auch keine Möglichkeit zu geben, dieses Paket zu "sperren".

    In yast hat limewire den "Geschützt-Status":
    Dieses Paket ist installiert und sollte nicht verändert werden, da unaufgelöste Abhängigkeiten zu anderen Paketen bestehen oder auftreten könnten. Verwenden Sie diesen Status für Pakete von Drittanbietern, die nicht von neueren, auf der Distribution vorhandenen Versionen überschrieben werden sollen.
     
  5. tjb

    tjb Foren As

    Dabei seit:
    26.06.2005
    Beiträge:
    94
    Zustimmungen:
    0
    zu 1: Problem gelöst: GPG::Check auf false gesetzt

    zu 2: apt-get -s install LimeWireLinux.rpm spuckt folgendes aus:
    Code:
    ...
    Selecting LimeWire-free for 'LimeWireLinux.rpm'
    LimeWire-free ist bereits die neueste Version.
    You might want to run `apt-get --fix-broken install' to correct these:
    Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
      LimeWire-free: Hängt ab von: j2re (>= 1.4.1) aber es ist nicht installierbar
    E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution)
    .

    Ich habe es jetzt nicht ausprobiert, weil ich befürchte dass fix-broken install das Programm löscht.
     
  6. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Ist das LimeWire-Packet von der SuSE CD ?
    Probier mal das Packet zu löschen und dann per apt zu reinstallieren ....

    Geht das ?
     
  7. #6 tjb, 16.09.2005
    Zuletzt bearbeitet: 16.09.2005
    tjb

    tjb Foren As

    Dabei seit:
    26.06.2005
    Beiträge:
    94
    Zustimmungen:
    0
    Das Limewire-Paket ist von Limewire selbst. Ich habe das Paket deinem Tipp folgend deinstalliert und versucht mittels apt install LimeWireLinux.rpm zu installieren:
    Lese Paketlisten... Fertig
    Erzeuge Abhängigkeitsbaum... Fertig
    Selecting LimeWire-free for 'LimeWireLinux.rpm'
    Einige Pakete konnten nicht installiert werden. Dies könnte bedeuten,
    dass Sie eine unmögliche Situation angefordert haben oder, falls Sie die
    instabile Distribution verwenden, dass einige benötigte Pakete noch nicht
    erzeugt oder aus 'Incoming' verschoben worden sind.

    Da Sie nur eine einzelne Operation angefordert haben, ist es extrem
    wahrscheinlich, dass das Paket schlichtweg nicht installierbar ist und
    ein Bugreport über dieses Paket eingereicht werden sollte.
    Die folgende Information könnte helfen die Sitation zu beheben:

    Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
    LimeWire-free: Hängt ab von: j2re (>= 1.4.1) aber es ist nicht installierbar
    E: Fehlerhafte Pakete


    Diese Fehlermeldung erhielt ich auch bei yast. Ich hatte dann j2re 1.5 mit apt installiert und ich konnte Limewire problemlos mittels yast installieren. Warum apt herummeckert verstehe ich nicht. Erkennt apt die mit apt installierten Pakete nicht?
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Sollte eigentlich, vielleicht hatte apt mal probleme damit .... gut das es jetzt läuft ;)
     
  10. #8 tjb, 16.09.2005
    Zuletzt bearbeitet: 16.09.2005
    tjb

    tjb Foren As

    Dabei seit:
    26.06.2005
    Beiträge:
    94
    Zustimmungen:
    0
    Was meinst du damit? Apt/Synaptic will nach wievor Limewire löschen!

    Problem gelöst: Ich habe mir jetzt von der Limewire-Seite das zip-Archiv für andere Betriebssysteme heruntergeladen und starte das Programm jetzt über das Shell-Skript :)
     
Thema:

Probleme mit apt/Synaptic

Die Seite wird geladen...

Probleme mit apt/Synaptic - Ähnliche Themen

  1. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  2. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...
  3. Forscher analysieren Durchsatzprobleme im Linux-Scheduler

    Forscher analysieren Durchsatzprobleme im Linux-Scheduler: Eine Gruppe von Forschern hat Fälle identifiziert, in denen der Scheduler im Linux-Kernel falsche Entscheidungen trifft und die CPUs nicht so gut...
  4. München: LiMux als Sündenbock für IT-Probleme?

    München: LiMux als Sündenbock für IT-Probleme?: Im Münchner Stadtrat soll später in diesem Jahr erneut über den Einsatz von Linux in der Stadtverwaltung diskutiert werden. Die Grünen vermuten,...
  5. BSI-Audit findet keine akuten Probleme in OpenSSL

    BSI-Audit findet keine akuten Probleme in OpenSSL: Das Bundesamt für Sicherheit in der Informationstechnik hat OpenSSL auf seine Sicherheit untersuchen lassen. Die Analyse zeigt vor allem, dass die...