Probleme beim join einer Domain

Dieses Thema im Forum "Samba" wurde erstellt von tkrieger, 18.12.2006.

  1. #1 tkrieger, 18.12.2006
    tkrieger

    tkrieger Grünschnabel

    Dabei seit:
    18.12.2006
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo,

    mein Samba PDC mit OpenLDAP akzeptiert keine Computeranmeldungen an der Domain. Zuvor hat es noch funktioniert allerdings auch mit gelegentlichen tücke (2 mal anmelden vor erfolgsmeldung etc..). Nach kurzer Forschung schien der NSS Dienst dafür verantwortlich gewesen zu sein. Meines erachtens findet Samba die Computer Accounts nicht mehr, obwohl sie bereits eingetragen sind beim LDAP Server. Der Windows Client meldet jeweils nur "Der Benutzer konnte nicht gefunden werden!". Entspricht auch der Rückgabe vom slapd Daemon, jedoch schaut man mit einem ldapsearch in den ldap Baum so wird das Konto angegeben.

    Die anderen Windows Clients (die bereits angemeldet sind) haben kein Problem sich (beim Benutzerlogin) anzumelden.

    Wenn ich "getent passwd" eingebe bekomme ich unter Linux alle LDAP Benutzer Accounts aber keine Maschinenaccounts.

    Mein libnss-ldap.conf:

    host 127.0.0.1
    base dc=meinedomain,dc=de
    ldap_version 3
    nss_base_passwd ou=People,dc=meinedomain,dc=de
    nss_base_passwd ou=Computers,dc=meinedomain,dc=de
    nss_base_group ou=Group,dc=meinedomain,dc=de

    Die selben nss einträge sind unter slapd.conf zu finden.

    Ich hoffe mir kann eventuell jemand einen Tip geben, bin immoment doch ein wenig am Zweifeln.

    Gruß

    Thomas Krieger
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. mcas

    mcas Routinier

    Dabei seit:
    29.12.2005
    Beiträge:
    398
    Zustimmungen:
    0
    Welche Fehlermeldung hast du denn genau... meine Glaskugel ist gerade als Schneekugel unterwegs ;-)
     
  4. #3 tkrieger, 19.12.2006
    Zuletzt bearbeitet: 19.12.2006
    tkrieger

    tkrieger Grünschnabel

    Dabei seit:
    18.12.2006
    Beiträge:
    2
    Zustimmungen:
    0
    Fehler wurde beim LDAP gemeldet...

    Hi,

    sorry hätte vielleicht noch ein paar "Fakten" mehr einbringen können. Der LDAP Daemon meldet meist etwas in dieser Form:

    Dec 19 08:37:41 server slapd[32557]: connection_get(44): got connid=6403
    Dec 19 08:37:41 server slapd[32557]: connection_read(44): checking for input on id=6403
    Dec 19 08:37:41 server slapd[32557]: ber_get_next on fd 44 failed errno=11 (Resource temporarily unavailable)

    -------------------------------
    In den FAQ der OpenLDAP Homepage steht das "failed errno=11" kein kritischer Fehler ist.
    -------------------------------

    Dec 19 08:37:41 server slapd[32557]: do_search
    Dec 19 08:37:41 server slapd[32557]: >>> dnPrettyNormal: <ou=People,dc=mydomain,dc=de>
    Dec 19 08:37:41 server slapd[32557]: <<< dnPrettyNormal: <ou=People,dc=mydomain,dc=de>, <ou=people,dc=mydomain,dc=de>
    Dec 19 08:37:41 server slapd[32557]: ==> limits_get: conn=6403 op=3 dn="[anonymous]"
    Dec 19 08:37:41 server slapd[32557]: => bdb_search
    Dec 19 08:37:41 server slapd[32557]: bdb_dn2entry("ou=people,dc=mydomain,dc=de")
    Dec 19 08:37:41 server slapd[32557]: search_candidates: base="ou=people,dc=mydomain,dc=de" (0x00000003) scope=2
    Dec 19 08:37:41 server slapd[32557]: => bdb_dn2idl( "ou=people,dc=mydomain,dc=de" )
    Dec 19 08:37:41 server slapd[32557]: <= bdb_dn2idl: id=45 first=3 last=149
    Dec 19 08:37:41 server slapd[32557]: => bdb_equality_candidates (objectClass)
    Dec 19 08:37:41 server slapd[32557]: => key_read
    Dec 19 08:37:41 server slapd[32557]: <= bdb_index_read: failed (-30990)
    Dec 19 08:37:41 server slapd[32557]: <= bdb_equality_candidates: id=0, first=0, last=0
    Dec 19 08:37:41 server slapd[32557]: => bdb_equality_candidates (objectClass)
    Dec 19 08:37:41 server slapd[32557]: => key_read
    Dec 19 08:37:41 server slapd[32557]: <= bdb_index_read 63 candidates
    Dec 19 08:37:41 server slapd[32557]: <= bdb_equality_candidates: id=63, first=9, last=152
    Dec 19 08:37:41 server slapd[32557]: => bdb_equality_candidates (uid)
    Dec 19 08:37:41 server slapd[32557]: => key_read
    Dec 19 08:37:41 server slapd[32557]: <= bdb_index_read 1 candidates
    Dec 19 08:37:41 server slapd[32557]: <= bdb_equality_candidates: id=1, first=152, last=152
    Dec 19 08:37:41 server slapd[32557]: bdb_search_candidates: id=0 first=3 last=0
    Dec 19 08:37:41 server slapd[32557]: bdb_search: no candidates
    Dec 19 08:37:41 server slapd[32557]: send_ldap_result: conn=6403 op=3 p=3
    Dec 19 08:37:41 server slapd[32557]: send_ldap_response: msgid=4 tag=101 err=0
    Dec 19 08:37:41 server slapd[32557]: connection_get(44): got connid=6403
    Dec 19 08:37:41 server slapd[32557]: connection_read(44): checking for input on id=6403
    Dec 19 08:37:41 server slapd[32557]: do_search
    Dec 19 08:37:41 server slapd[32557]: ber_get_next on fd 44 failed errno=11 (Resource temporarily unavailable)
    Dec 19 08:37:41 server slapd[32557]: >>> dnPrettyNormal: <ou=Computers,dc=mydomain,dc=de>
    Dec 19 08:37:41 server slapd[32557]: <<< dnPrettyNormal: <ou=Computers,dc=mydomain,dc=de>, <ou=computers,dc=mydomain,dc=de>
    Dec 19 08:37:41 server slapd[32557]: send_ldap_result: conn=6403 op=4 p=3
    Dec 19 08:37:41 server slapd[32557]: send_ldap_response: msgid=5 tag=101 err=32

    Zum Ende wird jeweils err=32 ausgegeben und es sieht so aus als ob auch in den Baumzweigen "Computers und Peoples" gesucht wird. (Stehen jeweils für die Benutzer und Client Rechner in der Domaine.)
    Beim Windows Client erscheint anschließend "Der Benutzer konnte nicht gefunden werden" als Fehlermeldung und die Anmeldung wird abgebrochen.
    Ich hoffe euch fällt vielleicht etwas weiteres auf.

    Gruß

    Thomas
     
Thema:

Probleme beim join einer Domain

Die Seite wird geladen...

Probleme beim join einer Domain - Ähnliche Themen

  1. Probleme beim installieren

    Probleme beim installieren: Moin! Ich habe mir vor ein paar Wochen einen Hyrican Intel® i5, 8192MB DDR3-RAM, 1TB Speicher + 120GB SSD,GF GTX750Ti »Military 4610 PC gekauft....
  2. Probleme beim Ubuntu-Update

    Probleme beim Ubuntu-Update: Bei der Aktualisierung von Ubuntu 13.04 auf die neueste Ubuntu-Version 13.10 kann es unter bestimmten Konstellationen zu Problemen kommen....
  3. Probleme beim lesen einer CD

    Probleme beim lesen einer CD: Hallo zusammen, ich habe eine Daten-CD mit xfburn unter Fedora 15 erstellt. Diese muss ich bei uns in der Uni-Bibliothek abgeben. Auf der CD...
  4. Probleme beim mounten eines Serververzeichnisses auf einen Client

    Probleme beim mounten eines Serververzeichnisses auf einen Client: Hallo zusammen, ich habe folgendes Problem: Wir haben einen NIS-Server mit einem User root und PW xyz. Auf diesem wurde ein Verzeichnis...
  5. probleme beim installieren von rpm unixODBC (libODBC) und anderen packages

    probleme beim installieren von rpm unixODBC (libODBC) und anderen packages: Hallo! Ich kenne mich nicht wirklich gut aus mit dem rpm. Nichts desto trotz hat man mir die Bürde auferlegt mich mit nem RedHat Server (RHEL...