Probleme beim Einrichten einer WLAN-Verbindung

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von wladimir-blumen, 12.02.2007.

  1. #1 wladimir-blumen, 12.02.2007
    wladimir-blumen

    wladimir-blumen Mitglied

    Dabei seit:
    05.12.2006
    Beiträge:
    38
    Zustimmungen:
    0
    Hallo zusammen,

    momentan habe ich Probleme bei der Einrichtung einer Wlan-Verbindung. Und zwar habe ich den WLAN-Usb-Stick von ZyXEL ZyAIR G-220. Die Treiber habe ich erfolgreich installiert.

    Installationsschritte:
    Download der Treiber von http://zd1211.ath.cx/download/zd1211-driver-r83.tgz
    Treiber habe ich dann entpackt.
    In den Dateien zd1205.c zd1205_proc.c und zd1211.c habe ich #include <linux/config.h> in #include <linux/autoconf.h> geändert.
    Dann habe ich make und make install ausgeführt und alias wlan0 zd1211 in die /etc/modprobe.conf eingefügt.
    Anschließend habe ich neugestartet und Folgendes in die Konsole eingegeben:

    Code:
    Hannes:/home/hannes # ifconfig wlan0 up
    Hannes:/home/hannes # ifconfig wlan0 192.168.1.30 netmask 255.255.255.0 up
    Hannes:/home/hannes # iwconfig wlan0 essid MEINEESSID
    Hannes:/home/hannes # iwconfig wlan0 key s:MEINKEY
    Hannes:/home/hannes # route add default gw 192.168.1.1
    
    Dann habe ich eine Internetverbindung bekommen. Nach dem nächsten Neustart war die Internetverbindung allerdings wieder weg. Deshalb die Frage:
    Wie bekomme ich eine dauerhafte WLAN-Verbindung hin, die auch beim Starten automatisch hergestellt wird?
    Kann man die Verbindung auch über Yast einrichten? Hat bei mir bisher nämlich nicht geklappt.

    Vielen Dank und Grüße,


    Hannes
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 blueshark, 12.02.2007
    blueshark

    blueshark Doppel-As

    Dabei seit:
    09.02.2007
    Beiträge:
    107
    Zustimmungen:
    0
    Ort:
    Bremen
    In /etc/conf.d/ gibt es eine Datei (heißt je nach Distri andres) in dieser Datei kannst du alles einstellen, was du brauchst.
    Da du wohl Suse hast, kannst du alles ganz kompfortabel via Yast einrichten. Die GUI hier ist sehr intuitiv.
     
  4. #3 wladimir-blumen, 12.02.2007
    wladimir-blumen

    wladimir-blumen Mitglied

    Dabei seit:
    05.12.2006
    Beiträge:
    38
    Zustimmungen:
    0
    Ich habe Suse 10.2 und bei mir gibt's nur den Pfad /etc/cron.d/ Dort ist allerdings keine Datei vorhanden.
    Ich habe bereits probiert, die Verbindung über Yast einzurichten, hat aber nie geklappt. Ich bräuchte dafür eine Step-By-Step Anleitung, da ich einen USB-Stick für die Wlan benutze und der nicht aufgelistet wird.
    Wie sieht den diese Datei in /etc/conf.d/ bei dir aus?
     
  5. hades

    hades SUN-User

    Dabei seit:
    10.02.2007
    Beiträge:
    206
    Zustimmungen:
    0
    Ort:
    Biberach an der Riß
    Wenn du einen USB-Stick benutzt waere es unter Umstaenden sinnvoll die WLan-Verbindung mit Hilfe eines Scripts aufzubauen. Damit sparst du dir eben die Tipparbeit.
    Bei mir war damals das Problem, dass ich den USB-WLan-Adapter nur ab und zu drin hatte und ich den Zugang dadurch jedes Mal neu einrichten musste, aber mit Shellscript gabs keine Probleme...
     
  6. #5 supersucker, 12.02.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Ich hab gerade kein Suse zur Hand, aber du hast 2 Möglichkeiten:

    - Die fürs Wlan benötigten Dateien selber editieren. Wo du die findest kann dir bestimmt ein Suse-Jünger erläutern. Irgendwo unter /etc/network oder /etc/sysconfig vermute ich mal

    - du trägst die iwconfig-Zeilen einfach in deine /etc/rc.local oder /etc/boot.local ein, fertig.
     
  7. #6 wladimir-blumen, 12.02.2007
    wladimir-blumen

    wladimir-blumen Mitglied

    Dabei seit:
    05.12.2006
    Beiträge:
    38
    Zustimmungen:
    0
    Mit Skripten habe ich bisher überhaupt keine Ahnung. Ich würde diese Option nur nutzen, wenn's nicht anders funktioniert.

    Die beiden Dateien existieren nicht auf meinem System.

    Ich weiß, dass in diesem Ordner /etc/sysconfig/network diese Konfigurationsdateien rein müssen, aber wie die genau aussehen muss. Keine Ahnung!
     
  8. #7 blueshark, 12.02.2007
    blueshark

    blueshark Doppel-As

    Dabei seit:
    09.02.2007
    Beiträge:
    107
    Zustimmungen:
    0
    Ort:
    Bremen
    Hatte überlesen, dass es sich um einen USB-Stick handelt.

    Ich würde an deiner Stelle etwas Energie in das Lesen von Docs, Tuts, Handbüchern, etc. invesiteren und ein schönes Script mit ivman schreiben. So erhälst du eine saubere nachhaltige Lösung ;-)
     
  9. #8 supersucker, 12.02.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Mea culpa, ich meinte auch unter init.d, also:

    Code:
    /etc/init.d/rc.local
    Wenn auch da nicht vorhanden:

    Dann erstell dir z.b. die /etc/init.d/rc.local und trag folgendes ein:

    Code:
    #! /bin/sh
    deine iwconfig-commands....
    
    oder warte am Besten bis einer der sich mit Suse auskennt diesen Thread liest und dir sagt welche Dateien du direkt editieren musst..:D

    Oder du machst das halt, wie es auch vorgesehen ist, mit yast. Wenn du meinst "das klappt nicht mit yast", was trägst du genau ein und gibt es Fehlermeldungen?
     
  10. #9 wladimir-blumen, 12.02.2007
    Zuletzt bearbeitet: 12.02.2007
    wladimir-blumen

    wladimir-blumen Mitglied

    Dabei seit:
    05.12.2006
    Beiträge:
    38
    Zustimmungen:
    0
    Ok. Ich werd's mal probieren.

    Also die entscheidende Frage ist, was ich in die folgenden Felder eintragen muss:
    Gerätetyp:
    Konfigurationsname:
    Name der Hardware-Konfiguration:
    Modulname:
    Optionen:

    Ich weiß nur, dass mein USB-Stick unter wlan0 in der modprobe.conf eingetragen ist. Und das Modul zd1211 heißt. Ich habe so langsam meine Zweifel, ob das mit yast wirklich zu bewerkstelligen ist. Am besten wäre, wenn mir ein SUSE-Anwender mit USB-Wlan-Stick seine Datei aus /etc/sysconfig/network postet.
     
  11. #10 Yogibaer, 12.02.2007
    Yogibaer

    Yogibaer Routinier

    Dabei seit:
    01.11.2006
    Beiträge:
    330
    Zustimmungen:
    0
    WLAN ZD1211 Einrichtung

    Hallo,
    ich habe dieses Teil an meiner Suse 10.2 dran und komme damit nach dem booten ins INET. Ich habe nach dem Modulerstellen mit Yast alles in die Netzwerkkonfiguration eingetragen und mit der Steuerung ifup und DHCP bootet alles. Es gibt zwar beim Booten im WLAN-config Teil ein paar rote Meldungen, aber alles läuft mit WPA Verschlüsselung. Mit dem Networkmanager hat es nie funktioniert.
    Also:
    Netzwerkeinstelluingen, Netzwerksteuerung mit ifup, Netzwerkkarte Wlan0 einrichten, Treiber entweder zd1211, zd1211b oder zd1211rw (der wird schon in 10.2 mitgeliefert, brauchtest also nicht selber bauen, wusste ich aber auch nicht vorher). Danach noch Verschlüsselung einrichten, starten sollte so laufen.

    Hilft Dir das?
    Yogibaer
     
  12. #11 wladimir-blumen, 12.02.2007
    wladimir-blumen

    wladimir-blumen Mitglied

    Dabei seit:
    05.12.2006
    Beiträge:
    38
    Zustimmungen:
    0
    Hallo Yogibaer,

    Wie geht es dann weiter??? Tut mir leid, wenn ich so doof frage, aber ich muss wissen, was ich in die folgenden Felder eintragen soll. Nach "Hinzufügen" kommt ein Fenster mit verschiedenen Feldern. Was muss ich da rein???? ?(
    GERÄTETYP:
    KONFIGURATIONSNAME:
    NAME DER HARDWARE-KONFIGURATION:
    MODULNAME:
    OPTIONEN:
    HÄCKCHEN BEI "PCMCIA" ODER BEI USB???

    Der Rest ist mir dann klar. Bitte sag mir doch einfach, was in die jeweiligen Felder reingehört oder poste mal deine Konfigurationsdatei.
     
  13. #12 Yogibaer, 12.02.2007
    Yogibaer

    Yogibaer Routinier

    Dabei seit:
    01.11.2006
    Beiträge:
    330
    Zustimmungen:
    0
    zd1211 Einträge

    Ich sitze momentan vor einer XP-Kiste, deshalb kann ich nicht nachschauen. Ich glaube aber, dass folgendes einzutragen ist:
    Also, bei
    GERÄTETYP:Ethernet (glaube ich)
    KONFIGURATIONSNAME:WLAN0
    NAME DER HARDWARE-KONFIGURATION: Kannst Du glaube ich selber aussuchen oder frei lassen
    MODULNAME:zd1211, zd1211b oder zd1211rw (je nachdem, welchen Du brauchst)
    OPTIONEN: Keine Optionen
    HÄCKCHEN BEI "PCMCIA" ODER BEI USB??? gar nichts

    Falls das nicht ausreichend ist, melde Dich, dann kann ich Dir heute Abend alles genauer aufschreiben.
    Viel Erfolg
    Yogibaer
     
  14. #13 wladimir-blumen, 12.02.2007
    wladimir-blumen

    wladimir-blumen Mitglied

    Dabei seit:
    05.12.2006
    Beiträge:
    38
    Zustimmungen:
    0
    Hat leider nicht geklappt. Habe bei Gerätetyp "Ethernet" und "Drahtlos" ausprobiert.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Yogibaer, 12.02.2007
    Yogibaer

    Yogibaer Routinier

    Dabei seit:
    01.11.2006
    Beiträge:
    330
    Zustimmungen:
    0
    Fehlermeldungen

    Was gibt denn das Yast als Fehlermeldung raus? Oder bekommst du nur keine Verbindung? was sagt iwconfig und ifconfig? Welche Startmethode hast Du denn gewaehlt? Vielleicht muss noch ein dhclient als root angegeben werden. Oder hast Du kein Gateway angegeben?
    Gib bitte noch ein paar weitere Angaben.

    Bis bald

    Yogibaer
     
  17. #15 wladimir-blumen, 12.02.2007
    wladimir-blumen

    wladimir-blumen Mitglied

    Dabei seit:
    05.12.2006
    Beiträge:
    38
    Zustimmungen:
    0
    Yast gibt keine Fehlermeldung aus. In der /var/log/boot.msg steht:
    Code:
    Setting up network interfaces:
        lo        
        lo        IP address: 127.0.0.1/8   
    done    eth0      device: nVidia Corporation nForce2 Ethernet Controller (rev a1)
        eth0      configuration: eth-id-00:0c:6e:06:10:6b
        eth0      (DHCP) . . <notice>startproc: execve (/opt/kde3/bin/kdm) [ /opt/kde3/bin/kdm ], [ CONSOLE=/dev/console ROOTFS_FSTYPE=ext3 TERM=linux SHELL=/bin/sh ROOTFS_FSCK=0 INIT_VERSION=sysvinit-2.86 KDEROOTHOME=/root/.kdm REDIRECT=/dev/tty1 COLUMNS=156 PATH=/bin:/sbin:/usr/bin:/usr/sbin vga=0x31a RUNLEVEL=5 SPLASHCFG=/etc/bootsplash/themes/SuSE/config/bootsplash-1280x1024.cfg PWD=/ LANG=de_DE.UTF-8 PREVLEVEL=N LINES=60 QT_SYSTEM_DIR=/usr/share/desktop-data SHLVL=2 HOME=/ XCURSOR_THEME=crystalwhite WINDOWMANAGER=/usr/bin/kde SPLASH=yes splash=silent ROOTFS_BLKDEV=/dev/hda8 selinux=0 _=/sbin/startproc DAEMON=/opt/kde3/bin/kdm ]
    . . . no IP address yet... backgrounding. 
    waiting
        wlan0     
                  No configuration found for wlan0
    unusedWaiting for mandatory devices:  eth-id-00:0c:6e:06:10:6b wlan-WLAN0 __NSC__
    14 12 10 9 8 7 6 4 <notice>checkproc: /opt/kde3/bin/kdm 3387
    3 2 0 
        eth0      device: nVidia Corporation nForce2 Ethernet Controller (rev a1)
        eth0      configuration: eth-id-00:0c:6e:06:10:6b
        eth0      dhcpcd is still waiting for data
    waiting
        eth0      interface could not be set up until now
    failed    wlan-WLAN0                          No interface found
    Code:
    ifconfig
    eth0      Protokoll:Ethernet  Hardware Adresse 00:0C:6E:06:10:6B
              UP BROADCAST NOTRAILERS MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 Sendewarteschlangenlänge:1000
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
              Interrupt:177 Basisadresse:0x2000
    
    lo        Protokoll:Lokale Schleife
              inet Adresse:127.0.0.1  Maske:255.0.0.0
              inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:131 errors:0 dropped:0 overruns:0 frame:0
              TX packets:131 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 Sendewarteschlangenlänge:0
              RX bytes:6303 (6.1 Kb)  TX bytes:6303 (6.1 Kb)
    
    Code:
    iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wlan0     802.11b/g NIC  ESSID:""
              Access Point: Not-Associated
              Encryption key:off
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  invalid crypt:0  invalid misc:0
    
    sit0      no wireless extensions.
    Code:
    lsusb
    Bus 003 Device 001: ID 0000:0000
    Bus 002 Device 002: ID 07cc:0201 Carry Computer Eng., Co., Ltd
    Bus 002 Device 001: ID 0000:0000
    Bus 001 Device 005: ID 04b8:0005 Seiko Epson Corp. Stylus Printer
    Bus 001 Device 002: ID 0586:3401 ZyXEL Communications Corp.
    Bus 001 Device 003: ID 05e3:0605 Genesys Logic, Inc. USB 2.0 Hub [ednet]
    Bus 001 Device 001: ID 0000:0000
    Code:
    Hannes:/home/hannes # lsmod
    Module                  Size  Used by
    xt_pkttype              6016  6
    ipt_LOG                10624  10
    xt_limit                6912  10
    snd_pcm_oss            53376  0
    snd_mixer_oss          21248  1 snd_pcm_oss
    snd_seq                60272  0
    snd_seq_device         12812  1 snd_seq
    fglrx                 532312  38
    af_packet              29320  2
    button                 10896  0
    battery                14340  0
    ac                      9476  0
    ip6t_REJECT             9344  3
    xt_tcpudp               7296  13
    ipt_REJECT              9472  3
    xt_state                6272  12
    iptable_mangle          7040  0
    iptable_nat            11524  0
    ip_nat                 21804  1 iptable_nat
    iptable_filter          7168  1
    ip6table_mangle         6528  0
    ip_conntrack           52960  3 xt_state,iptable_nat,ip_nat
    nfnetlink              11032  2 ip_nat,ip_conntrack
    ip_tables              17604  3 iptable_mangle,iptable_nat,iptable_filter
    ip6table_filter         7040  1
    ip6_tables             18756  2 ip6table_mangle,ip6table_filter
    x_tables               18180  10 xt_pkttype,ipt_LOG,xt_limit,ip6t_REJECT,xt_tcpudp,ipt_REJECT,xt_state,iptable_nat,ip_tables,ip6_tables
    ipv6                  263584  19 ip6t_REJECT
    nls_iso8859_1           8320  2
    nls_cp437               9984  2
    vfat                   16640  2
    fat                    55324  1 vfat
    nls_utf8                6272  1
    ntfs                  210580  1
    loop                   20488  0
    dm_mod                 60184  0
    sg                     38044  0
    sd_mod                 24576  0
    capability              7380  0
    dazuko                 57868  0
    usblp                  17792  0
    usb_storage            82112  0
    scsi_mod              136712  3 sg,sd_mod,usb_storage
    zd1211                281324  0
    tuner                  61864  0
    saa7134               116704  0
    video_buf              28676  1 saa7134
    compat_ioctl32          5504  1 saa7134
    ir_kbd_i2c             13072  1 saa7134
    ir_common              32004  2 saa7134,ir_kbd_i2c
    videodev               26880  1 saa7134
    v4l1_compat            16388  2 saa7134,videodev
    v4l2_common            26240  3 tuner,saa7134,videodev
    ide_cd                 42272  0
    snd_intel8x0           36764  2
    cdrom                  38432  1 ide_cd
    snd_ac97_codec         95648  1 snd_intel8x0
    snd_ac97_bus            6400  1 snd_ac97_codec
    snd_pcm                86916  3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
    snd_timer              27908  2 snd_seq,snd_pcm
    ohci1394               37040  0
    snd                    61188  12 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
    soundcore              13792  1 snd
    snd_page_alloc         14472  2 snd_intel8x0,snd_pcm
    ieee1394              102584  1 ohci1394
    ohci_hcd               23428  0
    ehci_hcd               34696  0
    i2c_nforce2            11136  0
    forcedeth              44804  0
    i2c_core               25216  4 tuner,saa7134,ir_kbd_i2c,i2c_nforce2
    shpchp                 40224  0
    usbcore               114896  5 usblp,usb_storage,zd1211,ohci_hcd,ehci_hcd
    nvidia_agp             12316  1
    pci_hotplug            35136  1 shpchp
    agpgart                35528  2 fglrx,nvidia_agp
    parport_pc             42084  1
    lp                     15652  0
    parport                39752  2 parport_pc,lp
    ext3                  141192  2
    mbcache                12804  1 ext3
    jbd                    70324  1 ext3
    edd                    13892  0
    fan                     8964  0
    amd74xx                17692  0 [permanent]
    thermal                18568  0
    processor              34664  1 thermal
    ide_disk               20480  7
    ide_core              129992  4 usb_storage,ide_cd,amd74xx,ide_disk
    
    Startmethode: Beim automatisch Booten starten
    Über DHCP zugewiesene IP-Adresse
    Beim Gateway habe ich nichts angegeben -> Hier müsste ich die folgenden Felder angeben:
    ZIEL:
    GATEWAY:
    NETZMASKE:
    GERÄT:
    OPTIONEN:
    Auch hier habe ich keine Ahnung, was da genau rein muss. IP-Adresse von meinem Router ist 192.168.1.1. Der Router vergibt die Adresse der Clients automatisch. Das ist alles, was ich weiß.
     
Thema:

Probleme beim Einrichten einer WLAN-Verbindung

Die Seite wird geladen...

Probleme beim Einrichten einer WLAN-Verbindung - Ähnliche Themen

  1. Probleme beim installieren

    Probleme beim installieren: Moin! Ich habe mir vor ein paar Wochen einen Hyrican Intel® i5, 8192MB DDR3-RAM, 1TB Speicher + 120GB SSD,GF GTX750Ti »Military 4610 PC gekauft....
  2. Probleme beim Ubuntu-Update

    Probleme beim Ubuntu-Update: Bei der Aktualisierung von Ubuntu 13.04 auf die neueste Ubuntu-Version 13.10 kann es unter bestimmten Konstellationen zu Problemen kommen....
  3. Probleme beim lesen einer CD

    Probleme beim lesen einer CD: Hallo zusammen, ich habe eine Daten-CD mit xfburn unter Fedora 15 erstellt. Diese muss ich bei uns in der Uni-Bibliothek abgeben. Auf der CD...
  4. Probleme beim mounten eines Serververzeichnisses auf einen Client

    Probleme beim mounten eines Serververzeichnisses auf einen Client: Hallo zusammen, ich habe folgendes Problem: Wir haben einen NIS-Server mit einem User root und PW xyz. Auf diesem wurde ein Verzeichnis...
  5. probleme beim installieren von rpm unixODBC (libODBC) und anderen packages

    probleme beim installieren von rpm unixODBC (libODBC) und anderen packages: Hallo! Ich kenne mich nicht wirklich gut aus mit dem rpm. Nichts desto trotz hat man mir die Bürde auferlegt mich mit nem RedHat Server (RHEL...