Probleme beim Back Track installieren, auf HD zugreifen und mit Ark...

Dieses Thema im Forum "Sonstige Linux Distributionen" wurde erstellt von Nightking, 18.07.2007.

  1. #1 Nightking, 18.07.2007
    Nightking

    Nightking Grünschnabel

    Dabei seit:
    18.07.2007
    Beiträge:
    2
    Zustimmungen:
    0
    Tag auch :)

    Also...
    1.
    wenn ich Back Track installieren möchte, geht es Sekunden schnell und wenn ich den PC neustarte ist nichts passiert, auch wenn ich nachher die Festplatte durchsuche. (Hab Win Xp Sp2 installiert)

    2.
    Wie kann ich auf die HD, also auf die Dateien die ich unter Win gespeichert habe, zugreifen? Wenn ich Files durchsuche kommen einfach die Ordner der Live CD.

    3.
    Wenn ich etwas auf dem Desktop speichere kann ich es per Shell nicht aufrufen. Beispiel, wenn ich cd /root/desktop ausführe sagt er mir das er nichts findet.

    4.
    Wenn ich eine .zip Datei öffnen will, kommt das Ark abgestürzt ist und so n Programm zum Anaylsieren (hab den Name vergessen sorry).

    Wär nett wenn mir jemand helfen könnte. Danke :)
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #3 Nightking, 18.07.2007
    Zuletzt bearbeitet: 18.07.2007
    Nightking

    Nightking Grünschnabel

    Dabei seit:
    18.07.2007
    Beiträge:
    2
    Zustimmungen:
    0
    Danke für deine schnelle Antwort! Werd ich gleich mal ausprobieren und sagen obs geht :)!

    Edit:

    Zu 1) Les nachher mal die .pdf in ruhe durch 2) Habs gepackt :) 3) Ok, is wohl irgendwo vergessen gegangen xD 4) geht jetzt, da ich ja aufn Desktop zugreifen kann, frag mich aber trotzdem wiso Ark nicht geht... egal :)
     
  4. #4 Bademeester, 27.08.2007
    Zuletzt bearbeitet: 27.08.2007
    Bademeester

    Bademeester Grünschnabel

    Dabei seit:
    27.08.2007
    Beiträge:
    4
    Zustimmungen:
    0
    Hey Leutz hab auch BT2 final und wollte es installieren aber hab vorher nochma gegoogelt und hier im Forum nen Txt gefunden.Die pdf von offensive-security is ganz gut aber ich hab noch en paar Bugs gefunden die Andreas behoben hat.Hier der Beitrag, is bisl lang aber hilfreich:

    « Verkehrschaos in Heilbronn
    Die “Ewige Stadt” »
    Installation von BackTrack 2 Final unter VMWare
    Published May 10th, 2007 in Linux.

    Diese Anleitung beschreibt das Vorgehen bei der Installation der Security Live-CD BackTrack in einer virtuellen Umgebung und die Hürden die dabei zu überwinden sind. Die Vorteile einer Festinstallation liegen auf der Hand: Man benötigt keine CD, muss nicht die aktuelle Arbeitsumgebung verlassen um in das Live-System zu booten und Einstellungen werden direkt gespeichert. Die Festinstallation ist also die ideale Lösung, so lang man keine native Treiberunterstützung von z.B. W-LAN-Karten im PCMCIA-Slot benötigt.

    Eine fertige Anleitung (”BackTrack Hard Drive Installation”, PDF) wird bereits von den Entwicklern der CD bereitgestellt und dient als Grundlage dieser Beschreibung.(Diese URL kopieren)

    http://backtrack.offensive-security.com/index.php?title=Howto#Dual_Boot_Backtrack_and_Ubuntu

    Wurden die Partitionen wie in der o.g. Anleitung über fdisk angelegt und das Dateisystem darauf eingerichtet, kann anschließend mit der Installation begonnen werden. Wichtig ist, dass vor dem Start des “BackTrack Installers” die Partitionen wie folgt gemounted werden:


    cd /tmp
    mkdir boot
    mkdir bt2
    mount /dev/sda1 boot
    mount /dev/sda3 bt2

    Der Installer wird anschließend mit folgenden Optionen konfiguriert:

    * Source (BackTrack-CD): /boot
    * Install BackTrack to: /tmp/bt2
    * Write MBR to: /dev/sda
    * Installation method: Real

    Nach Abschluss des Kopiervorgangs schreibt die offizielle Anleitung vor, die CD aus dem Laufwerk zu entnehmen und neu zu starten. Doch dann schon wenig später das böse Erwachen: Das eben in der virtuellen Maschine installierte BackTrack bootet nicht - warum?
    Grund dafür ist, dass die Installationsroutine vergisst, den Linux-Kernel auf die Festplatte zu kopieren und den Bootloader in den MBR zu schreiben.
    Vielen Dank für diesen Hinweis an meinen Kollegen Steffen Tröscher.

    Das wird nun in wenigen Schritten nachgeholt.

    Zunächst muss das Terminal geöffnet und darin folgende Schritte ausgeführt werden:


    cp /boot/vmlinuz /tmp/bt2/boot/
    cp /boot/splash.bmp /tmp/bt2/boot/
    chroot /tmp/bt2/
    lilo

    Zur Erläuterung: Die ersten beiden Schritte kopieren den komprimierten Linux-Kernel wie er beim Booten geladen wird auf die Festplatte. Im zweiten Schritt muss sozusagen über chroot das Root-Verzeichnis des aktuellen Systems auf die frisch installierte Version geändert werden um darin den Bootloader (lilo) zu installieren.

    Nach diesen Maßnahmen noch über den Befehl exit die Chroot-Umgebung verlassen und das eben installierte BackTrack das erste Mal in der virtuellen Maschine starten.

    Installation der VMWare-Tools

    Um die VMWare Tools in BackTrack 2 zu installieren, sind folgende Schritte notwendig.

    1. Im VMWare Menü den Eintrag VM -> Install VMWare Tools wählen.
    2. Anschließend den von VMWare virtuell als CD bereitgestellten Datenträger mounten: mount /mnt/hdc_cdrom
    3. Nun die VMWare-Tools in das cd /tmp-Verzeichnis kopieren: cp /mnt/hdc_cdrom/VMWareTools*.tar.gz /tmp und dort entpacken: tar xvzf VMWareTools*.tar.gz
    4. Für die reibungslose Installation der VMWare-Tools in BackTrack müssen nun noch einige Symlinks und Dummy-Dateien eingerichtet werden:

    for x in 0 1 2 3 4 5 6
    do
    ln -s /etc/rc.d/ /etc/rc$x.d
    done
    touch /etc/init.d/network /etc/init.d/networking

    Grundsätzlich könnte an dieser Stelle nun die Installation gestartet werden - wäre da nicht noch ein Problem :-) Spätestens beim Versuch das Modul vmxnet (Netzwerktreiber für VMWare) zu kompilieren reagiert die Installation mit folgender Fehlermeldung:


    Building the vmxnet module.
    Using 2.6.x kernel build system.
    make: Entering directory `/tmp/vmware-config1/vmxnet-only’
    make -C /lib/modules/2.6.20-BT-PwnSauce-NOSMP/build/include/.. SUBDIRS=$PWD SRCR
    OOT=$PWD/. modules
    make[1]: Entering directory `/usr/src/linux-2.6.20′
    CC [M] /tmp/vmware-config1/vmxnet-only/vmxnet.o
    /tmp/vmware-config1/vmxnet-only/vmxnet.c: In function `vmxnet_netpoll’:
    /tmp/vmware-config1/vmxnet-only/vmxnet.c:1058: error: too many arguments to func
    tion `vmxnet_interrupt’
    make[2]: *** [/tmp/vmware-config1/vmxnet-only/vmxnet.o] Error 1
    make[1]: *** [_module_/tmp/vmware-config1/vmxnet-only] Error 2
    make[1]: Leaving directory `/usr/src/linux-2.6.20′
    make: *** [vmxnet.ko] Error 2
    make: Leaving directory `/tmp/vmware-config1/vmxnet-only’
    Unable to build the vmxnet module.

    Glücklicherweise wird gleich mitgeliefert, an welcher Stelle dieser Fehler seine Ursache hat:
    vmxnet.c:1058: error: too many arguments to function `vmxnet_interrupt'

    Kurze Analyse ergab folgendes Problem:

    Zeilen 991 - 997 definieren die Methode vmxnet_interrupt wie folgt:

    #if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 19)
    static compat_irqreturn_t
    vmxnet_interrupt(int irq, void *dev_id, struct pt_regs * regs)
    #else
    static compat_irqreturn_t
    vmxnet_interrupt(int irq, void *dev_id)
    #endif

    Eine Abfrage der Kernel-Version von BackTrack ergibt: 2.6.20-BT-PwnSauce-NOSMP - AHA! Die Kernelversionsnummer ist also nicht kleiner als 2.6.19 wodurch gemäß oben beschriebenem Quelltext die Methode vmxnet_interrupt mit zwei Parametern aufgerufen werden muss.
    Ein Blick in die beim Kompilieren Fehler verursachende Zeile 1058 zeigt aber, dass hier diese Unterscheidung nicht mehr getroffen wird (davon auf jeden Fall betroffen sind VMware Workstation Versionen < = 5.5.4).

    Zeile 1058:

    vmxnet_interrupt(dev->irq, dev, NULL);

    Eigentlich werden bei aktueller Kernelversion (2.6.20) zwei Parameter definiert, letztendlich aber drei übergeben. Die Fehlermeldung too many arguments to function `vmxnet_interrupt’ war also Goldrichtig :-)

    Jetzt wissen wir, wo der Fehler liegt, behoben ist er aber noch nicht. Dazu sind folgende Schritte notwendig:


    bt ~ # cd /tmp
    bt tmp # mkdir vmxnet
    bt tmp # cp /tmp/vmware-tools-distrib/lib/modules/source/vmxnet.tar /tmp/vmxnet/
    bt tmp # cd vmxnet
    bt vmxnet # tar xf vmxnet.tar
    bt vmxnet # wget http://www.andreas-kurtz.de/wp-content/uploads/2007/05/vmxnet.patch
    bt vmxnet # patch -b vmxnet-only/vmxnet.c vmxnet.patch
    patching file vmxnet-only/vmxnet.c
    bt vmxnet # tar cf vmxnet.tar vmxnet-only
    bt vmxnet # cp vmxnet.tar /tmp/vmware-tools-distrib/lib/modules/source/vmxnet.tar

    Die meisten Schritte sind intutitiv klar. Zur Erklärung wie ich den Patch gestaltet habe: In Zeile 1058 wird zukünftig auch die Unterscheidung nach Kernel-Version getroffen und entsprechend viele Argumente übergeben. Anschließend sieht die korrigierte Methode so aus:


    static void
    vmxnet_netpoll(struct net_device *dev)
    {
    disable_irq(dev->irq);
    #if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 19)
    vmxnet_interrupt(dev->irq, dev, NULL);
    #else
    vmxnet_interrupt(dev->irq, dev);
    #endif
    enable_irq(dev->irq);
    }

    Nun sind wir fast am Ende angelangt und können die VMWare-Tools installieren. Zunächst noch die aktuelle Netzwerkverbindung herunterfahren, dass es zu keinen Problemen kommt:


    ifconfig eth0 down
    rmmod pcnet32

    Und dann endlich die lang ersehnte Installation starten:


    /tmp/vmware-tools-distrib/vmware-install.pl

    Alle Fragen des Installers sind eigentlich mit Default-Werten zu bestätigen.

    Anschließend sollte in der Datei /etc/modprobe.d/blacklist noch der Eintrag blacklist pcnet32 hinzugefügt werden, so dass beim nächsten Starten auch wirklich das eben kompilierte vmxnet-Modul geladen wird.

    Ein vollständides VMWare-Image (sog. Virtual Appliance) von BackTrack 2 Final mit installierten VMWare-Tools steht hier zum Download bereit (624 MB).http://www.andreas-kurtz.de/wp-content/uploads/2007/05/BackTrack2.rar
    12 Votes | Average: 3.58 out of 512 Votes | Average: 3.58 out of 512 Votes | Average: 3.58 out of 512 Votes | Average: 3.58 out of 512 Votes | Average: 3.58 out of 5 (12 votes, average: 3.58 out of 5)
    Loading ... Loading ...
    19 Responses to “Installation von BackTrack 2 Final unter VMWare”
    Feed for this Entry Trackback Address


    eine Anleitung zur Installation von BackTrack in einer DualBoot-Konfiguration findest du hier: http://backtrack.offensive-security.com/index.php?title=Howto#Dual_Boot_Backtrack_and_Ubuntu
    6. 6 mich May 22nd, 2007 at 10:48 am



    Hi Andy,

    bei mir hat alles super geklappt bis auf den 2ten Schritt hier:

    cp /boot/vmlinuz /tmp/bt2/boot/
    cp /boot/splash.map /tmp/bt2/boot/
    9. 9 sven May 22nd, 2007 at 6:56 pm

    Es kommt der Fehler:
    cp: cannot stat ‘/boot/splash.map’ : No such file or directory
    Die Datei ist auch nicht in der bt2final.iso .
    Oder hab ich was übersehn?
    Danke im Vorraus
    Sven
    10. 10 sven May 23rd, 2007 at 10:29 am

    Ok hat sich erledigt, habe einfach splash.bmp anstelle von splash.map genommen.
    11. 11 bin4ry May 27th, 2007 at 2:33 pm

    Hey Andy,

    deine anleitung ist sehr gut. Nur im letzten schritt, während der ausführung des perl-sckirpts zur installation der vmware tools, koomt der fehler, dass er services.sh nicht nach /etc/init.d/vmware-tools kopieren kann.
    12. 12 Florian Roth May 28th, 2007 at 8:32 pm

    Hallo!
    Ich musste noch das Verzeichnis /etc/pam.d anlegen bevor ich /usr/bin/vmware-config-tools.pl starten konnte.
    13. 13 Andy May 29th, 2007 at 11:44 am

    Danke für den Hinweis auf die /boot/splash.bmp - ist korrigiert :-)
    14. 14 ph0o Jun 1st, 2007 at 12:45 am

    Is zwar bisl Gequatsche bei aber das geht!!!
     
  5. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Probleme beim Back Track installieren, auf HD zugreifen und mit Ark...

Die Seite wird geladen...

Probleme beim Back Track installieren, auf HD zugreifen und mit Ark... - Ähnliche Themen

  1. Probleme beim installieren

    Probleme beim installieren: Moin! Ich habe mir vor ein paar Wochen einen Hyrican Intel® i5, 8192MB DDR3-RAM, 1TB Speicher + 120GB SSD,GF GTX750Ti »Military 4610 PC gekauft....
  2. Probleme beim Ubuntu-Update

    Probleme beim Ubuntu-Update: Bei der Aktualisierung von Ubuntu 13.04 auf die neueste Ubuntu-Version 13.10 kann es unter bestimmten Konstellationen zu Problemen kommen....
  3. Probleme beim lesen einer CD

    Probleme beim lesen einer CD: Hallo zusammen, ich habe eine Daten-CD mit xfburn unter Fedora 15 erstellt. Diese muss ich bei uns in der Uni-Bibliothek abgeben. Auf der CD...
  4. Probleme beim mounten eines Serververzeichnisses auf einen Client

    Probleme beim mounten eines Serververzeichnisses auf einen Client: Hallo zusammen, ich habe folgendes Problem: Wir haben einen NIS-Server mit einem User root und PW xyz. Auf diesem wurde ein Verzeichnis...
  5. probleme beim installieren von rpm unixODBC (libODBC) und anderen packages

    probleme beim installieren von rpm unixODBC (libODBC) und anderen packages: Hallo! Ich kenne mich nicht wirklich gut aus mit dem rpm. Nichts desto trotz hat man mir die Bürde auferlegt mich mit nem RedHat Server (RHEL...