Problem unter Fedora Core 5 und ssh

Dieses Thema im Forum "RedHat,Fedora & CentOS" wurde erstellt von gnoovy, 23.11.2006.

  1. gnoovy

    gnoovy Eroberer

    Dabei seit:
    20.02.2004
    Beiträge:
    73
    Zustimmungen:
    0
    hi leutz,


    folgendes Problem. Möchte mit rsync und ssh eine sichere Verbindung aufbauen, um spätere Aktionen mittels Linux-HA durchzuführen. Habe erst den Key generiert: Auf Server namends "Server"


    ssh-keygen -t rsa -b 2048


    Habe alles ohne Passwort generiert, da rsync bei der automatischen Verbindung da anscheinend Probleme hat. Habe den öffentlichen Schlüssel nun auf den Client "Client" kopiert. Danach mittels vi authorized_keys diese Datei erstellt. Mit cat *.pub >> authorized_keys den Inhalt in die keys-Datei kopiert. In der /etc/ssh/sshd_config habe ich auf beiden Maschinen Passwordauthentification auf no gesetzt. Von "Server" auf "Client" kann ich mittels ssh <ip-adresse> ohne Passwort zugreifen. Dauert allerdings ein bisschen. Von "Client" auf "Server" kann ich nicht zugreifen. Es kommt immer die Meldung Permission denied (publickey,gssapi-with-mic). Was kann ich da tun?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 intelinsider, 24.11.2006
    intelinsider

    intelinsider coffee addicted

    Dabei seit:
    30.04.2005
    Beiträge:
    333
    Zustimmungen:
    0
    Ort:
    Tor zur Welt [Hamburg/Barmbek]
    Ich wuerde meinen da sind noch ein paar Grobe Fehler drin.
    Halte dich mal an diese beiden Leitfaeden,
    1.
    2.


    mfg ii
     
  4. gnoovy

    gnoovy Eroberer

    Dabei seit:
    20.02.2004
    Beiträge:
    73
    Zustimmungen:
    0
    hi leutz,


    also habe bei dom1 mit ssh-keygen -t dsa den key ohne passphrase generiert. Dann den id_dsa.pub auf dom2 kopiert und beide Server neu gestartet. Von dom1 auf dom2 wird keine Passwortabfrage mehr durchgeführt, von dom2 zu dom1 allerdings wird noch eine Passwortabfrage durchgeführt. Bei Eingabe des Root-Passwortes komme ich dann auf den Server, warum?

    Hier mal die sshd_config beider Rechner

    dom1:

    # $OpenBSD: sshd_config,v 1.73 2005/12/06 22:38:28 reyk Exp $

    # This is the sshd server system-wide configuration file. See
    # sshd_config(5) for more information.

    # This sshd was compiled with PATH=/usr/local/bin:/bin:/usr/bin

    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented. Uncommented options change a
    # default value.

    #Port 22
    #Protocol 2,1
    Protocol 2
    #AddressFamily any
    #ListenAddress 0.0.0.0
    #ListenAddress ::

    # HostKey for protocol version 1
    #HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    #HostKey /etc/ssh/ssh_host_rsa_key
    #HostKey /etc/ssh/ssh_host_dsa_key

    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 1h
    #ServerKeyBits 768

    # Logging
    # obsoletes QuietMode and FascistLogging
    #SyslogFacility AUTH
    SyslogFacility AUTHPRIV
    #LogLevel INFO

    # Authentication:

    #LoginGraceTime 2m
    #PermitRootLogin yes
    #StrictModes yes
    #MaxAuthTries 6

    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile /root/.ssh/authorized_keys

    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    #IgnoreRhosts yes

    # To disable tunneled clear text passwords, change to no here!
    #PasswordAuthentication yes
    #PermitEmptyPasswords no
    PasswordAuthentication yes

    # Change to no to disable s/key passwords
    #ChallengeResponseAuthentication yes
    ChallengeResponseAuthentication no

    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes
    #KerberosGetAFSToken no

    # GSSAPI options
    #GSSAPIAuthentication no
    GSSAPIAuthentication yes
    #GSSAPICleanupCredentials yes
    GSSAPICleanupCredentials yes

    # Set this to 'yes' to enable PAM authentication, account processing,
    # and session processing. If this is enabled, PAM authentication will
    # be allowed through the ChallengeResponseAuthentication mechanism.
    # Depending on your PAM configuration, this may bypass the setting of
    # PasswordAuthentication, PermitEmptyPasswords, and
    # "PermitRootLogin without-password". If you just want the PAM account and
    # session checks to run without PAM authentication, then enable this but set
    # ChallengeResponseAuthentication=no
    #UsePAM no
    UsePAM yes

    # Accept locale-related environment variables
    AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
    AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
    AcceptEnv LC_IDENTIFICATION LC_ALL
    #AllowTcpForwarding yes
    #GatewayPorts no
    #X11Forwarding no
    X11Forwarding yes
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #TCPKeepAlive yes
    #UseLogin no
    #UsePrivilegeSeparation yes
    #PermitUserEnvironment no
    #Compression delayed
    #ClientAliveInterval 0
    #ClientAliveCountMax 3
    #ShowPatchLevel no
    #UseDNS yes
    #PidFile /var/run/sshd.pid
    #MaxStartups 10
    #PermitTunnel no

    # no default banner path
    #Banner /some/path

    # override default of no subsystems
    Subsystem sftp /usr/libexec/openssh/sftp-server

    ********************************+
    ********************************

    dom2:

    # $OpenBSD: sshd_config,v 1.73 2005/12/06 22:38:28 reyk Exp $

    # This is the sshd server system-wide configuration file. See
    # sshd_config(5) for more information.

    # This sshd was compiled with PATH=/usr/local/bin:/bin:/usr/bin

    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented. Uncommented options change a
    # default value.

    #Port 22
    #Protocol 2,1
    Protocol 2
    #AddressFamily any
    #ListenAddress 0.0.0.0
    #ListenAddress ::

    # HostKey for protocol version 1
    #HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    #HostKey /etc/ssh/ssh_host_rsa_key
    #HostKey /etc/ssh/ssh_host_dsa_key

    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 1h
    #ServerKeyBits 768

    # Logging
    # obsoletes QuietMode and FascistLogging
    #SyslogFacility AUTH
    SyslogFacility AUTHPRIV
    #LogLevel INFO

    # Authentication:

    #LoginGraceTime 2m
    #PermitRootLogin yes
    #StrictModes yes
    #MaxAuthTries 6

    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile .ssh/authorized_keys

    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    #IgnoreRhosts yes

    # To disable tunneled clear text passwords, change to no here!
    #PasswordAuthentication yes
    #PermitEmptyPasswords no
    PasswordAuthentication yes

    # Change to no to disable s/key passwords
    #ChallengeResponseAuthentication yes
    ChallengeResponseAuthentication no

    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes
    #KerberosGetAFSToken no

    # GSSAPI options
    #GSSAPIAuthentication no
    GSSAPIAuthentication yes
    #GSSAPICleanupCredentials yes
    GSSAPICleanupCredentials yes

    # Set this to 'yes' to enable PAM authentication, account processing,
    # and session processing. If this is enabled, PAM authentication will
    # be allowed through the ChallengeResponseAuthentication mechanism.
    # Depending on your PAM configuration, this may bypass the setting of
    # PasswordAuthentication, PermitEmptyPasswords, and
    # "PermitRootLogin without-password". If you just want the PAM account and
    # session checks to run without PAM authentication, then enable this but set
    # ChallengeResponseAuthentication=no
    #UsePAM no
    UsePAM yes

    # Accept locale-related environment variables
    AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
    AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
    AcceptEnv LC_IDENTIFICATION LC_ALL
    #AllowTcpForwarding yes
    #GatewayPorts no
    #X11Forwarding no
    X11Forwarding yes
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #TCPKeepAlive yes
    #UseLogin no
    #UsePrivilegeSeparation yes
    #PermitUserEnvironment no
    #Compression delayed
    #ClientAliveInterval 0
    #ClientAliveCountMax 3
    #ShowPatchLevel no
    #UseDNS yes
    #PidFile /var/run/sshd.pid
    #MaxStartups 10
    #PermitTunnel no

    # no default banner path
    #Banner /some/path

    # override default of no subsystems
    Subsystem sftp /usr/libexec/openssh/sftp-server


    Besten Dank !!!
     
  5. Lumpi

    Lumpi Haudegen

    Dabei seit:
    14.06.2006
    Beiträge:
    663
    Zustimmungen:
    0
    Ort:
    Dessau
    Hallo,

    IMHO musst du nun die "Geschichte" für dom2 wiederholen...

    Gruß Lumpi
    Anmerkung: leg die "config" bitte in einen
    Code:
    -Block
     
  6. gnoovy

    gnoovy Eroberer

    Dabei seit:
    20.02.2004
    Beiträge:
    73
    Zustimmungen:
    0
    hi leutz,


    ok werde mit dem Code in Zukunft drauf achten, sorry. Also habe alles auf dom2 wiederholt, jetzt ist die situation genau anders herum. Von dom2 auf dom1 komme ich jetzt endlich ohne Passwort drauf, von dom1 auf dom2 allerdings wird jetzt ein Passwort verlagnt
     
  7. #6 intelinsider, 27.11.2006
    intelinsider

    intelinsider coffee addicted

    Dabei seit:
    30.04.2005
    Beiträge:
    333
    Zustimmungen:
    0
    Ort:
    Tor zur Welt [Hamburg/Barmbek]
    Dann wird bei der Umkonfigurierung irgendwo etwas ueberschrieben was fuer den jeweiligen Client / Server wichtig ist wo genau es jetzt hackelt kann ich nicht sagen, meine Vermutung tendiert dazu das die Schluessel sich untereinander in die Quere kommen, bzw der letzte einfach ueberschrieben wird.


    mfg ii
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Problem unter Fedora Core 5 und ssh

Die Seite wird geladen...

Problem unter Fedora Core 5 und ssh - Ähnliche Themen

  1. Kernel 3 Kompilierungsproblem unter XEN

    Kernel 3 Kompilierungsproblem unter XEN: Hallo, Ich habe eine openSuse 12.1 und SLES 11 SP1 unter XEN 4.1.2 im HVM Modus laufen. Wenn ich für die beiden System einen neuen Kernel...
  2. Probleme mit Raid1-Wiederherstellung unter Debian squeeze - Grub2 startet nicht

    Probleme mit Raid1-Wiederherstellung unter Debian squeeze - Grub2 startet nicht: Hallo, ich habe Probleme mit der Raid1-Wiederherstellung unter Debian squeeze - Grub2 startet nicht. Ich habe folgende Partitionen (2...
  3. Problem mit Firefox 4 unter Arch Linux x64

    Problem mit Firefox 4 unter Arch Linux x64: Hi, Ich wollte heute den neuen Firefox via Pacman installiern. Jedoch erhalte ich nach der Installation nur folgende Meldung:...
  4. MSI NVIDIA GeForce 8400GS Problemlos unter Linux?

    MSI NVIDIA GeForce 8400GS Problemlos unter Linux?: Hi, hat jemand Erfahrung mit (MSI) NVIDIA GeForce 8400GS GraKas? laufen die Out-Of-The-Box? oder steht da erst noch Treiberbastelei an? Danke !
  5. Soundproblem unter Ubuntu 10.04

    Soundproblem unter Ubuntu 10.04: Hallo! Ich habe mir neulich nach langer Linuxpause mal wieder ein Ubuntu installiert (10.04) und bin damit bisher auch sehr zufrieden. Einzig...