Problem nach Update auf KDE 3.3 Xserver und Soundserver stürzen ab

Dieses Thema im Forum "KDE" wurde erstellt von ctx23, 25.09.2004.

  1. ctx23

    ctx23 Grünschnabel

    Dabei seit:
    29.03.2003
    Beiträge:
    8
    Zustimmungen:
    0
    Ort:
    germany
    Hallo,
    ich habe mal wieder ein Problem und kann es irgendwie nicht lösen. Ich habe ein Update von KDE3.2 auf KDE3.3 gemacht. Melde ich mich jetzt über KDM oder GDM an läuft alles ohne Problem, möchte ich jedoch den Benutzer abmelden oder einfach nur die Sitzung schließen meldet KDE sich ab und wenige Sekunden später wenn eigentlich der Loginmanager erscheinen sollte lande ich in der Konsole. Starte ich dann KDM oder GDM erneut und melde mich mit dem gleichen Benutzer an habe ich keinen Sound mehr, bekomme folgenden Hinweis:

    Sound server informational message:
    Error while initializing the sound driver:
    device: default can't be opened for playback (Permission denied)
    The sound server will continue, using the null output device.

    Soweit ich weiß hat sich an den Berechtigungen seit der letzten Sitzung nichts geändert und es laufen auch keine Prozesse vom jenem Benutzer die den Soundserver blockieren könnten. Aber jetzt kommts erst melde ich mich jetzt ab funktioniert alles wie es soll ich lande in KDM oder GDM natürlich alles ohne Sound. Kann es sein das der Xserver aufgrund von alsa oder arts abstürzt? Ich kann mir da keinen Reim drauf machen bei KDE3.2 hatte alles noch 99% funktioniert.

    Ich benutze den Xserver vor X.Org in Version 6.7.0-r1 mit einer Nvidia GeForce4 MX, KDE 3.3.0, arts 1.3.0 und kernel-2.6.7

    Ich hoffe ihr könnt mir helfen und sorry falls es da Thema schon gibt ich habe jedoch nicht mit meinen Problemen gefunden.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Hmmm ... welche Distro ? (Oder hab ich das eben überlesen ?)
     
  4. #3 Messair, 25.09.2004
    Messair

    Messair Grünschnabel

    Dabei seit:
    07.03.2004
    Beiträge:
    1
    Zustimmungen:
    0
    Oh sorry hab vergessen ich benutze Gentoo...
    PS: Bin beim Kolegen
     
  5. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Hast du mal probiert nen neuen User anzulegen und damit zu testen ?
     
  6. #5 ctx23, 26.09.2004
    Zuletzt bearbeitet: 26.09.2004
    ctx23

    ctx23 Grünschnabel

    Dabei seit:
    29.03.2003
    Beiträge:
    8
    Zustimmungen:
    0
    Ort:
    germany
    Ja habe ich ist genau das gleich Problem... Der einzige User der Sound hat nach einer Abmeldung ist root... Hm weiß jetzt gar nicht ob er bei der Abmeldung von Root auch abschmiert werde ich nach nem Neustart mal Testen und Posten.

    ADD: Als Root kann ich mich an und abmelden wie ich lustig bin keine Probleme. Als normaler User bekomme ich die Probleme wieder und bei neuen Usern tauchen die gleichen Probleme auf
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. ctx23

    ctx23 Grünschnabel

    Dabei seit:
    29.03.2003
    Beiträge:
    8
    Zustimmungen:
    0
    Ort:
    germany
    So ich weiß zwar nicht warum kdm und gdm abstürzen aber ich weiß das nach dem absturz die benutzerrechte für /dev/sound/mixer usw. geändert werden so das nur noch root darauf zugreifen kann weiß zwar nicht wieso aber ist auch egal ich denke ich werde auf gnome oder fluxbox umsteigen
     
  9. urfie

    urfie Grünschnabel

    Dabei seit:
    12.02.2005
    Beiträge:
    2
    Zustimmungen:
    0
    Bei mir war PAM das Problem. Das hier hat geholfen...

    Bei mir war PAM das Problem. Das hier hat geholfen:
    http://www.thisishull.net/showthread.php?t=71757

     
Thema:

Problem nach Update auf KDE 3.3 Xserver und Soundserver stürzen ab

Die Seite wird geladen...

Problem nach Update auf KDE 3.3 Xserver und Soundserver stürzen ab - Ähnliche Themen

  1. Internet Problem mit Router nach PPPoe konfiguration

    Internet Problem mit Router nach PPPoe konfiguration: Hallo zusammen, ich habe mir heute irgendwie den Internetzugang zerschossen. Normalerweise lasse ich die Verbindung über einen Router laufen,...
  2. Nach IP Umstellung: SSL Problem: ssl_error_rx_record_too_long

    Nach IP Umstellung: SSL Problem: ssl_error_rx_record_too_long: Ich musste auf meinem ubuntu server die Server-IP ändern. Jetzt komme ich nicht mehr auf die https Seite, welche unter /var/www mit Zertifikat...
  3. rsync: Problem - Verzeichnisse mit Suffix umbenennen - nach 2.6.9

    rsync: Problem - Verzeichnisse mit Suffix umbenennen - nach 2.6.9: Hallo unixboard-Mitglieder, Mit rsync version 2.6.9 hat es noch funktioniert: root/lmarkus$ rsync --version...
  4. Probleme nach Update auf Suse 12.1

    Probleme nach Update auf Suse 12.1: Hallo Leute, Ich habe heute per Netzwerk-CD mein Sytem von 11.4 auf 12.1 upgegradet. Die Installtion ging ohne Fehlermeldungen von statten....
  5. apt-get problem - nach "Lese Changelogs... Fertig" geht's nicht mehr weiter...??!

    apt-get problem - nach "Lese Changelogs... Fertig" geht's nicht mehr weiter...??!: hallo zusammen, versuchte gerade gnome per apt-get install gnome zu installieren. der download klappt, aber nach der meldung "Lese...