problem mit wpa_supplicant?

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von Nemesis, 26.01.2008.

  1. #1 Nemesis, 26.01.2008
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    hi,
    mein wpa_supplicant unter ubuntu hardy macht zicken, und ich finde den fehler nicht.

    ich hab hier mal nen mitschnitt von
    Code:
    wpa_supplicant -iwlan0 -Dwext -c /etc/wpa_supplicant/wpa_supplicant.conf -d
    Code:
    Initializing interface 'wlan0' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'wext' ctrl_interface 'N/A' bridge 'N/A'
    Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' -> '/etc/wpa_supplicant/wpa_supplicant.conf'
    Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
    ctrl_interface='/var/run/wpa_supplicant'
    eapol_version=1
    ap_scan=1
    Priority group 0
       id=0 ssid='Secure'
    Initializing interface (2) 'wlan0'
    EAPOL: SUPP_PAE entering state DISCONNECTED
    EAPOL: KEY_RX entering state NO_KEY_RECEIVE
    EAPOL: SUPP_BE entering state INITIALIZE
    EAP: EAP entering state DISABLED
    EAPOL: External notification - portEnabled=0
    EAPOL: External notification - portValid=0
    SIOCGIWRANGE: WE(compiled)=22 WE(source)=21 enc_capa=0xf
      capabilities: key_mgmt 0xf enc 0xf
    WEXT: Operstate: linkmode=1, operstate=5
    Own MAC address: 00:13:e8:84:df:9f
    wpa_driver_wext_set_wpa
    wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_countermeasures
    wpa_driver_wext_set_drop_unencrypted
    Setting scan request: 0 sec 100000 usec
    Added interface wlan0
    RTM_NEWLINK: operstate=0 ifi_flags=0x1002 ()
    Wireless event: cmd=0x8b06 len=8
    Ignore event for foreign ifindex 3
    RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
    RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
    State: DISCONNECTED -> SCANNING
    Starting AP scan (specific SSID)
    Scan SSID - hexdump_ascii(len=8):
         61 65 67 65 63 65 66 65                           Secure        
    Trying to get current scan results first without requesting a new scan to speed up initial association
    Received 0 bytes of scan results (0 BSSes)
    Scan results: 0
    Selecting BSS from priority group 0
    Try to find WPA-enabled AP
    Try to find non-WPA AP
    No suitable AP found.
    Setting scan request: 0 sec 0 usec
    Starting AP scan (broadcast SSID)
    RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
    Wireless event: cmd=0x8b19 len=8
    Received 246 bytes of scan results (1 BSSes)
    Scan results: 1
    Selecting BSS from priority group 0
    Try to find WPA-enabled AP
    0: 00:0f:b5:11:7b:d4 ssid='Secure' wpa_ie_len=26 rsn_ie_len=0 caps=0x11
       selected based on WPA IE
       selected WPA AP 00:0f:b5:11:7b:d4 ssid='Secure'
    Try to find non-WPA AP
    Trying to associate with 00:0f:b5:11:7b:d4 (SSID='Secure' freq=2462 MHz)
    Cancelling scan request
    WPA: clearing own WPA/RSN IE
    Automatic auth_alg selection: 0x1
    WPA: using IEEE 802.11i/D3.0
    WPA: Selected cipher suites: group 8 pairwise 8 key_mgmt 2 proto 1
    WPA: set AP WPA IE - hexdump(len=26): dd 18 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02 00 00
    WPA: clearing AP RSN IE
    WPA: using GTK TKIP
    WPA: using PTK TKIP
    WPA: using KEY_MGMT WPA-PSK
    WPA: Set own WPA IE default - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
    No keys have been configured - skip key clearing
    wpa_driver_wext_set_drop_unencrypted
    State: SCANNING -> ASSOCIATING
    wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
    WEXT: Operstate: linkmode=-1, operstate=5
    wpa_driver_wext_associate
    Setting authentication timeout: 10 sec 0 usec
    EAPOL: External notification - EAP success=0
    EAPOL: External notification - EAP fail=0
    EAPOL: External notification - portControl=Auto
    RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
    Wireless event: cmd=0x8b06 len=8
    RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
    Wireless event: cmd=0x8b04 len=12
    RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
    Wireless event: cmd=0x8b1a len=16
    RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
    Wireless event: cmd=0x8b06 len=8
    RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
    Wireless event: cmd=0x8b04 len=12
    RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
    Wireless event: cmd=0x8b1a len=16
    RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
    Wireless event: cmd=0x8c02 len=167
    Association info event
    req_ies - hexdump(len=50): 00 08 61 65 67 65 63 65 66 65 01 08 02 04 0b 16 0c 12 18 24 32 04 30 48 60 6c dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
    resp_ies - hexdump(len=16): 01 04 82 84 8b 96 32 08 0c 12 18 24 30 48 60 6c
    WPA: set own WPA/RSN IE - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
    RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
    Wireless event: cmd=0x8b15 len=20
    Wireless event: new AP: 00:0f:b5:11:7b:d4
    State: ASSOCIATING -> ASSOCIATED
    wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
    WEXT: Operstate: linkmode=-1, operstate=5
    Associated to a new BSS: BSSID=00:0f:b5:11:7b:d4
    No keys have been configured - skip key clearing
    Associated with 00:0f:b5:11:7b:d4
    WPA: Association event - clear replay counter
    EAPOL: External notification - portEnabled=0
    EAPOL: External notification - portValid=0
    EAPOL: External notification - EAP success=0
    EAPOL: External notification - portEnabled=1
    EAPOL: SUPP_PAE entering state CONNECTING
    EAPOL: SUPP_BE entering state IDLE
    Setting authentication timeout: 10 sec 0 usec
    Cancelling scan request
    RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
    RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
    RX EAPOL from 00:0f:b5:11:7b:d4
    Setting authentication timeout: 10 sec 0 usec
    IEEE 802.1X RX: version=1 type=3 length=95
      EAPOL-Key type=254
      key_info 0x89 (ver=1 keyidx=0 rsvd=0 Pairwise Ack)
      key_length=32 key_data_length=0
      replay_counter - hexdump(len=8): 00 00 00 00 00 00 00 01
      key_nonce - hexdump(len=32): 17 f2 d4 b3 b1 a1 d1 95 25 ad ac 9c 25 72 e2 4c 65 fb 09 78 61 91 c1 45 07 ce 8a 78 52 e8 ff e6
      key_iv - hexdump(len=16): 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
      key_rsc - hexdump(len=8): 00 00 00 00 00 00 00 00
      key_id (reserved) - hexdump(len=8): 00 00 00 00 00 00 00 00
      key_mic - hexdump(len=16): 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    WPA: ignoring 8 bytes after the IEEE 802.1X data
    State: ASSOCIATED -> 4WAY_HANDSHAKE
    WPA: RX message 1 of 4-Way Handshake from 00:0f:b5:11:7b:d4 (ver=1)
    WPA: Renewed SNonce - hexdump(len=32): 9d b3 c0 f8 63 c8 a4 11 94 fe e2 66 9b be 90 e8 fa 4a 36 59 bb 59 06 c0 a9 d8 5a b6 91 66 7e 2c
    WPA: PMK - hexdump(len=32): [REMOVED]
    WPA: PTK - hexdump(len=64): [REMOVED]
    WPA: WPA IE for msg 2/4 - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
    WPA: Sending EAPOL-Key 2/4
    RX EAPOL from 00:0f:b5:11:7b:d4
    IEEE 802.1X RX: version=1 type=3 length=121
      EAPOL-Key type=254
      key_info 0x1c9 (ver=1 keyidx=0 rsvd=0 Pairwise Install Ack MIC)
      key_length=32 key_data_length=26
      replay_counter - hexdump(len=8): 00 00 00 00 00 00 00 02
      key_nonce - hexdump(len=32): 17 f2 d4 b3 b1 a1 d1 95 25 ad ac 9c 25 72 e2 4c 65 fb 09 78 61 91 c1 45 07 ce 8a 78 52 e8 ff e6
      key_iv - hexdump(len=16): 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
      key_rsc - hexdump(len=8): 00 00 00 00 00 00 00 00
      key_id (reserved) - hexdump(len=8): 00 00 00 00 00 00 00 00
      key_mic - hexdump(len=16): de 12 96 b7 85 f7 92 19 4c 42 e4 09 e1 ae 50 97
    WPA: ignoring 8 bytes after the IEEE 802.1X data
    State: 4WAY_HANDSHAKE -> 4WAY_HANDSHAKE
    WPA: RX message 3 of 4-Way Handshake from 00:0f:b5:11:7b:d4 (ver=1)
    WPA: IE KeyData - hexdump(len=26): dd 18 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02 00 00
    WPA: Sending EAPOL-Key 4/4
    WPA: Installing PTK to the driver.
    WPA: RSC - hexdump(len=6): 00 00 00 00 00 00
    wpa_driver_wext_set_key: alg=2 key_idx=0 set_tx=1 seq_len=6 key_len=32
    State: 4WAY_HANDSHAKE -> GROUP_HANDSHAKE
    RX EAPOL from 00:0f:b5:11:7b:d4
    IEEE 802.1X RX: version=1 type=3 length=127
      EAPOL-Key type=254
      key_info 0x3a1 (ver=1 keyidx=2 rsvd=0 Group Ack MIC Secure)
      key_length=32 key_data_length=32
      replay_counter - hexdump(len=8): 00 00 00 00 00 00 00 03
      key_nonce - hexdump(len=32): 17 f2 d4 b3 b1 a1 d1 95 25 ad ac 9c 25 72 e2 4c 65 fb 09 78 61 91 c1 45 07 ce 8a 78 52 e7 ff e5
      key_iv - hexdump(len=16): 4c 65 fb 09 78 61 91 c1 45 07 ce 8a 78 52 e9 ff
      key_rsc - hexdump(len=8): 7e 00 00 00 00 00 00 00
      key_id (reserved) - hexdump(len=8): 00 00 00 00 00 00 00 00
      key_mic - hexdump(len=16): b8 3c 9f 71 c1 27 de 33 eb b3 9d 9b b6 df e9 f1
    WPA: RX message 1 of Group Key Handshake from 00:0f:b5:11:7b:d4 (ver=1)
    State: GROUP_HANDSHAKE -> GROUP_HANDSHAKE
    WPA: Group Key - hexdump(len=32): [REMOVED]
    WPA: Installing GTK to the driver (keyidx=2 tx=0).
    WPA: RSC - hexdump(len=6): 7e 00 00 00 00 00
    wpa_driver_wext_set_key: alg=2 key_idx=2 set_tx=0 seq_len=6 key_len=32
    WPA: Sending EAPOL-Key 2/2
    WPA: Key negotiation completed with 00:0f:b5:11:7b:d4 [PTK=TKIP GTK=TKIP]
    Cancelling authentication timeout
    State: GROUP_HANDSHAKE -> COMPLETED
    CTRL-EVENT-CONNECTED - Connection to 00:0f:b5:11:7b:d4 completed (auth) [id=0 id_str=]
    wpa_driver_wext_set_operstate: operstate 0->1 (UP)
    WEXT: Operstate: linkmode=-1, operstate=6
    EAPOL: External notification - portValid=1
    EAPOL: External notification - EAP success=1
    EAPOL: SUPP_PAE entering state AUTHENTICATING
    EAPOL: SUPP_BE entering state SUCCESS
    EAP: EAP entering state DISABLED
    EAPOL: SUPP_PAE entering state AUTHENTICATED
    EAPOL: SUPP_BE entering state IDLE
    RTM_NEWLINK: operstate=1 ifi_flags=0x11043 ([UP][RUNNING][LOWER_UP])
    RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
    EAPOL: startWhen --> 0
    RTM_NEWLINK: operstate=1 ifi_flags=0x1043 ([UP][RUNNING])
    Wireless event: cmd=0x8b15 len=20
    Wireless event: new AP: 00:00:00:00:00:00
    Setting scan request: 0 sec 100000 usec
    Added BSSID 00:0f:b5:11:7b:d4 into blacklist
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
    State: COMPLETED -> DISCONNECTED
    wpa_driver_wext_set_operstate: operstate 1->0 (DORMANT)
    WEXT: Operstate: linkmode=-1, operstate=5
    EAPOL: External notification - portEnabled=0
    EAPOL: SUPP_PAE entering state DISCONNECTED
    EAPOL: SUPP_BE entering state INITIALIZE
    EAPOL: External notification - portValid=0
    EAPOL: External notification - EAP success=0
    RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
    und meine wpa_supplicant.conf sieht wie folgt aus:
    Code:
    eapol_version=1
    ap_scan=1
    
    network={
    	ssid="Secure"
    	scan_ssid=1
    	proto=WPA
    	key_mgmt=WPA-PSK
    	pairwise=TKIP
    	group=TKIP 
    	psk=Geheim
    	}
    hat jemand ne idee an was das ligen könnte?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 GambaJo, 26.01.2008
    GambaJo

    GambaJo Maxi King alraaaight!!!

    Dabei seit:
    08.01.2008
    Beiträge:
    171
    Zustimmungen:
    0
    Statt "Geheim" steht bei dir aber schon so ein relativ langer und kryptischer String?
     
  4. #3 Tomekk228, 26.01.2008
    Tomekk228

    Tomekk228 Lebende Foren Legende

    Dabei seit:
    14.08.2007
    Beiträge:
    2.417
    Zustimmungen:
    0
    Ort:
    /home/tomekk/
    Oh man. Ich hoffe natürlich ja :rofl:
     
  5. #4 Nemesis, 26.01.2008
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    ich glaube ich brauche dazu keinen kommentar abgeben ;)
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

problem mit wpa_supplicant?

Die Seite wird geladen...

problem mit wpa_supplicant? - Ähnliche Themen

  1. wpa_supplicant Problem gentoo

    wpa_supplicant Problem gentoo: Moin, nach langem gefriggel läuft meine wlan karte schon fast, nur noch ein prob. mit der wpa_supplicant, ich hoffe allerdings das ihr mir hier...
  2. wpa_supplicant PEAP problem

    wpa_supplicant PEAP problem: Hallo, ich habe meinen Laptop paar wochen nicht benutzt und habe Jetzt Linux neu installiert. Jedoch läuft W-Lan in der Uni nicht, bei mir...
  3. Ubuntu 8.10 - Problem: Wlan mit WPA (wpa_supplicant)

    Ubuntu 8.10 - Problem: Wlan mit WPA (wpa_supplicant): Hallo Zusammen, ich versuche gerade eine WLAN-Verbindung von meinem Samsung P35 (Intel 2200BG Netzwerkkarte) zum Router (Speedport W700V)...
  4. Virtualboxproblem

    Virtualboxproblem: Hallo Folgnedes Problem: Ich kann ohne Probleme In Debian-Sid, 64Bit und virtualbox-dkms Unixoide installieren, wenn es sich um eine...
  5. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...