Problem mit WPA beim IPW2200 Chipsatz

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von dhchris, 01.01.2007.

  1. #1 dhchris, 01.01.2007
    Zuletzt bearbeitet: 01.01.2007
    dhchris

    dhchris Racing Tux

    Dabei seit:
    13.02.2004
    Beiträge:
    374
    Zustimmungen:
    0
    Ort:
    München
    Hallo zusammen,

    ich hab meinen WLan Adapter endlich zum laufen bekommen.
    Nur das mit der WPA Verschlüsselung will so wie es scheint noch nicht funktionieren.
    Ich geb Euch mal alle meiner Meinung nach benötigten Daten und Ausgaben und hoffe, mir kann jemand weiter helfen.

    EDIT: Nun kann ich anscheinend ne Verbindung zum AP aufbauen, nur irgendwas klappt leider noch nicht.
    Keine Ahnung wo der Fehler liegt.
    Habe jetzt wie folgt verbunden: (diesmal mit -Dwext statt -Dipw)

    Code:
    [B]schleppi:/home/chris# wpa_supplicant -Dwext -i eth2 -c /etc/wpa_supplicant.conf -w[/B]
    Trying to associate with 00:01:4a:c3:d3:a7 (SSID='TuxHome' freq=0 MHz)
    Associated with 00:01:4a:c3:d3:a7
    WPA: Key negotiation completed with 00:01:4a:c3:d3:a7 [PTK=TKIP GTK=TKIP]
    CTRL-EVENT-CONNECTED - Connection to 00:01:4a:c3:d3:a7 completed (auth) [id=0 id_str=]
    
    Weiter kommt leider nichts.
    Wie gesagt verbindung ist mit nem Ausschlag von 100% da, allerdings kann ich die Verbindung so wie es scheint noch nicht nutzen.

    EDIT off: Alte Angeben ab hier...


    Code:
    [B]schleppi:/home/chris/Downloads/ipw2200-fw-3.0# dmesg | grep ipw[/B]
    ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.1.4kdmr
    ipw2200: Copyright(c) 2003-2006 Intel Corporation
    ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
    ipw2200: Detected geography ZZD (13 802.11bg channels, 0 802.11a channels)
    ipw2200: Firmware error detected.  Restarting.
    ipw2200: Failed to up device
    ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.1.4kdmr
    ipw2200: Copyright(c) 2003-2006 Intel Corporation
    ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
    ipw2200: Detected geography ZZD (13 802.11bg channels, 0 802.11a channels)
    
    Code:
    [B]schleppi:/home/chris/Downloads/ipw2200-fw-3.0# iwconfig[/B]
    eth0      no wireless extensions.
    
    lo        no wireless extensions.
    
    sit0      no wireless extensions.
    
    eth2      unassociated  ESSID:"TuxHome"
              Mode:Managed  Channel=0  Access Point: Not-Associated
              Bit Rate:0 kb/s   Tx-Power=20 dBm   Sensitivity=8/0
              Retry limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    Code:
    [B]schleppi:/home/chris/Downloads/ipw2200-fw-3.0# wpa_supplicant -D ipw -i eth2 -c /etc/wpa_supplicant.conf -w[/B]
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    Failed to set encryption.
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    Failed to set encryption.
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    Failed to set encryption.
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    Failed to set encryption.
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    Trying to associate with 00:01:4a:c3:d3:a7 (SSID='TuxHome' freq=0 MHz)
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    
    Code:
    [B]schleppi:/home/chris/Downloads/ipw2200-fw-3.0# iwlist eth2 scan[/B]
    eth2      Scan completed :
              Cell 01 - Address: 00:01:4A:C3:D3:A7
                        ESSID:"TuxHome"
                        Protocol:IEEE 802.11bg
                        Mode:Master
                        Channel:11
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                                  9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                                  48 Mb/s; 54 Mb/s
                        Quality=95/100  Signal level=-31 dBm
                        IE: WPA Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (1) : TKIP
                            Authentication Suites (1) : PSK
                        Extra: Last beacon: 88ms ago
    
    Code:
    [B]schleppi:/home/chris/Downloads/ipw2200-fw-3.0# cat /etc/wpa_supplicant.conf[/B]
    ctrl_interface=/var/run/wpa_supplicant
    eapol_version=1
    ap_scan=1
    #
    network={
            proto=WPA
            scan_ssid=1
            key_mgmt=WPA-PSK
            pairwise=TKIP
            group=TKIP
            ssid="TuxHome"
            psk=5df4a20f10fa7720ba5a292867baa5817ba615652cc36310dab936dfdb30ef5d
            }
    
    Fehlt noch was? Noch welche Angaben benötigt?
    Habe schon diverse Anleitungen ausprobiert aber bin noch nicht weiter gekommen.
    Die Firmware des IPW2200 hab ich auch frisch eingefügt.

    Gruß, Chris
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Problem mit WPA beim IPW2200 Chipsatz

Die Seite wird geladen...

Problem mit WPA beim IPW2200 Chipsatz - Ähnliche Themen

  1. Probleme beim installieren

    Probleme beim installieren: Moin! Ich habe mir vor ein paar Wochen einen Hyrican Intel® i5, 8192MB DDR3-RAM, 1TB Speicher + 120GB SSD,GF GTX750Ti »Military 4610 PC gekauft....
  2. Probleme beim Ubuntu-Update

    Probleme beim Ubuntu-Update: Bei der Aktualisierung von Ubuntu 13.04 auf die neueste Ubuntu-Version 13.10 kann es unter bestimmten Konstellationen zu Problemen kommen....
  3. KSH: Problem beim Umleiten des Fehlerkanals

    KSH: Problem beim Umleiten des Fehlerkanals: Hallo, in einen KSH Skript führe ich folgende Befehle aus RESULT=""; ERROR=""; idsldapsearch -h localhost -p $PORT -D $USER -w $PW -s sub -b...
  4. Probleme beim lesen einer CD

    Probleme beim lesen einer CD: Hallo zusammen, ich habe eine Daten-CD mit xfburn unter Fedora 15 erstellt. Diese muss ich bei uns in der Uni-Bibliothek abgeben. Auf der CD...
  5. Probleme beim mounten eines Serververzeichnisses auf einen Client

    Probleme beim mounten eines Serververzeichnisses auf einen Client: Hallo zusammen, ich habe folgendes Problem: Wir haben einen NIS-Server mit einem User root und PW xyz. Auf diesem wurde ein Verzeichnis...