Problem mit SATA Platte unter SuSE 10.0

Dieses Thema im Forum "Laufwerke / Speichermedien" wurde erstellt von _Michael_, 28.02.2006.

  1. #1 _Michael_, 28.02.2006
    _Michael_

    _Michael_ Mitglied

    Dabei seit:
    09.02.2006
    Beiträge:
    26
    Zustimmungen:
    0
    Hallo Leute,

    Habe ein ähnliches Problem wie hai13 am 1.2.2006.
    Also SATA Controller (Silicon Image 3112) eingebaut. Wird erkannt und geladen.
    Daran ne Maxtor sata platte mit 160gb. soll einfach nur daten speichern können. also kein raid oder so.
    Linux erkennt jetzt zwar an /dev/sda ein neues Gerät (vermutlich die maxtor hdd) aber wenn ich im yast oder yast2 das Partitionierungswerkzeug starte wird die platte dort nicht gelistet. Was kan ich tun bzw. wie heißt das tool von maxtor - hilft mir das?

    Grüße,

    Michael
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Keruskerfürst, 28.02.2006
    Zuletzt bearbeitet: 28.02.2006
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Gib mal fdisk -l als root in der Konsole ein.
    Dort sollten dann die Festplatten erscheinen
     
  4. #3 _Michael_, 28.02.2006
    _Michael_

    _Michael_ Mitglied

    Dabei seit:
    09.02.2006
    Beiträge:
    26
    Zustimmungen:
    0
    Danke erstmal für die Antwort.
    Klappt leider auch nicht. d.h. Es wird dort nur der SCSI Plattenverbund gelistet. Nicht aber die SATA-Platte. Noch eine Idee? bzw. eine woran es liegt dass die dort nicht drin steht?

    Beste Grüße,

    Michael
     
  5. #4 name, 28.02.2006
    Zuletzt bearbeitet: 28.02.2006
    name

    name Inactive user

    Dabei seit:
    28.08.2004
    Beiträge:
    592
    Zustimmungen:
    0
    Ort:
    Wien->127.0.0.1
    Code:
    cfdisk /dev/sda
    Was sagt denn das? Da solltest du Partitionieren koennen. Formatieren dann mit mkfs.[filesystem] /dev/sdaX
     
  6. #5 _Michael_, 28.02.2006
    _Michael_

    _Michael_ Mitglied

    Dabei seit:
    09.02.2006
    Beiträge:
    26
    Zustimmungen:
    0
    Danke auch Dir. Aber leider:

    Rückgabe:

    Fataler Fehler.
    Konnte nicht von der Festplatte lesen.

    Drücken Sie....um cfdisk zu beenden.


    Noch ne idee?

    Grüße,
    Michael
     
  7. #6 Keruskerfürst, 28.02.2006
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Mal die Festplatte auf Sata I jumpern. Siehe Festplattenanleitung.
     
  8. #7 _Michael_, 28.02.2006
    _Michael_

    _Michael_ Mitglied

    Dabei seit:
    09.02.2006
    Beiträge:
    26
    Zustimmungen:
    0
    meinst du das bringt etwas?
    Das Problem ist nämlich, dass ich nicht am rechner sitze sondern alles remote machen muss.
    Der rechner steht im rechenzentrum und daher wäre es etwas umständlich.
    Beste Grüße,

    Michael
     
  9. #8 Keruskerfürst, 28.02.2006
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    die andere Möglichkeit ist:
    der Controller wird nicht durch den Kernel unterstützt.
    Mal eine ganz aktuelle Distribution verwenden.
     
  10. #9 _Michael_, 28.02.2006
    _Michael_

    _Michael_ Mitglied

    Dabei seit:
    09.02.2006
    Beiträge:
    26
    Zustimmungen:
    0
    hmm...also du meinst n kernelupdate? müsste es sogar noch ein neueres geben.
    aber dieser chipsatz ist doch schon bestimmt über n jahr alt...
    und ganz nebenbei: der treiber für den controller wie auch der name des controllers werden im yast erkannt und zugewiesen. und er sagt mir, dass auch der treiber geladen würde...was meinst du dazu?
     
  11. #10 Keruskerfürst, 28.02.2006
    Zuletzt bearbeitet: 01.03.2006
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Ich habe gerade im Kernelsource von Suse kernel 2.6.13-15.8 nachgesehen: Es gibt dort ein Modul Sata-Sil. Dies unterstützt Sil3112. Woran es nun liegen könnte, daß die Festplatte doch nicht erkannt iwrd, kann ich nicht sagen. Gibt es im Rechner nicht einen anderen Sata Port. Z.B. einen direkt vom Chipsatz?
     
  12. #11 _Michael_, 28.02.2006
    _Michael_

    _Michael_ Mitglied

    Dabei seit:
    09.02.2006
    Beiträge:
    26
    Zustimmungen:
    0
    was meinst du mit "direkt vom chipsatz"

    also es handelt sich bei dem controller um eine einsteckkarte. diese hat 2 interne und einen externen sata anschluss.

    oder meinst du, ob das board einen eigenen sata controller hat? - nein hat es nicht.
    habe hier einen adapter von sata männlich auf pata weiblich. meinst du es könnte klappen, wenn ich daran eine pata platte anklemme und das gespann dann an den controller?

    grüße,

    michael
     
  13. #12 Keruskerfürst, 01.03.2006
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Besser: die SATA Festplatte mit einem Adapter an einen PATA Port anschließen.

    Ich habe in meinem Rechner ein nForce3 Board mit 4 Sata Anschlüssen.
    Funktioniert ohne Probleme.
     
  14. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  15. #13 Goodspeed, 01.03.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Kannst Du per lsmod mal schauen, welche Module er für SATA läd?

    Es gibt 2 Varianten:

    1. IDE-SATA -> fehlerhaft, wird nicht empfohlen
    2. SCSI-Emulation für SATA
     
  16. #14 _Michael_, 01.03.2006
    Zuletzt bearbeitet: 02.03.2006
    _Michael_

    _Michael_ Mitglied

    Dabei seit:
    09.02.2006
    Beiträge:
    26
    Zustimmungen:
    0
    Erkenntnisse

    Module Size Used by
    joydev 9408 0
    st 38944 0
    ide_cd 39684 0
    hfsplus 75140 0
    vfat 12800 0
    fat 49692 1 vfat
    subfs 7552 1
    speedstep_lib 4228 0
    freq_table 4612 0
    ipv6 242752 21
    edd 9824 0
    e100 35456 0
    uhci_hcd 32016 0
    mii 5504 1 e100
    usbcore 112512 2 uhci_hcd
    generic 4484 0 [permanent]
    pci_hotplug 26164 0
    i2c_piix4 8720 0
    i2c_core 20368 1 i2c_piix4
    intel_agp 22044 1
    agpgart 33096 1 intel_agp
    parport_pc 38980 0
    lp 11460 0
    parport 33864 2 parport_pc,lp
    dm_mod 54972 0
    reiserfs 250480 2
    processor 24380 0
    sata_sil 9476 0
    libata 48516 1 sata_sil
    sg 35744 0
    sr_mod 16420 0
    cdrom 36896 2 ide_cd,sr_mod
    sym53c8xx 78484 0
    scsi_transport_spi 20864 1 sym53c8xx
    DAC960 69832 4
    piix 9988 0 [permanent]
    sd_mod 18576 0
    scsi_mod 131304 7 st,libata,sg,sr_mod,sym53c8xx,scsi_transport_spi,sd_mod
    ide_disk 17152 0
    ide_core 122380 4 ide_cd,generic,piix,ide_disk


    das ist die rückgabe...
    irre ich mich oder ist das auf scsi basierend?

    schöne grüße,

    michael


    PS: kann es helfen, wenn ich den controller auf ein nonRAID-BIOS flashe?



    Hallo Leute,
    War gestern im Rechenzentrum und habe alle Tipps (wofür man am Rechner sein muss) ausprobiert. Erfolglos.
    Habe noch ein paar andere Sachen getestet. Fehlanzeige.
    Dann gegen 21Uhr lies ich mal dieses Maxtor Diagnose Tool die Platte prüfen. Und wer glaubts? - Ein Festplattenfehler wurde diagnostiziert!!! - Und das Proggi empfahl mir die Platte auszutauschen...Toll!
    Und ich such wie n blöder... Naja immerhin wieder was gelernt.

    Das witzige an der Sache ist nur: Die Platte ist vielleicht mal grad n halbes Jahr alt und lief bis vor einer Woche noch in nem anderen Rechner problemlos.

    Danke euch allen!

    Beste Grüße,

    Michael
     
Thema:

Problem mit SATA Platte unter SuSE 10.0

Die Seite wird geladen...

Problem mit SATA Platte unter SuSE 10.0 - Ähnliche Themen

  1. CD-ROM SATA Installationsproblem Debian 4.0r0 Etch

    CD-ROM SATA Installationsproblem Debian 4.0r0 Etch: Hallo zusammen, Wollte vor kurzem von Mandriva auf Debian umsteigen - leider wird nach dem booten von der Install-DVD im Setup mein CD-Rom...
  2. Asus P5W DH Deluxe: SATA und IDE Probleme

    Asus P5W DH Deluxe: SATA und IDE Probleme: hi, um gleich zur Sache zu kommen: Ich wollte heute auf meinem neuen System Arch Linux installieren. Das System hat folgende Komponenten:...
  3. Problem: SUSE Installation mit SATA Platte

    Problem: SUSE Installation mit SATA Platte: Hi, ich habe dummerweise während der Installation meines neuen Notebooks im BIOS den SATA Modus der Platte auf "Compatible" gestellt gehabt....
  4. Open Suse Installationsmedien nicht erkannt. SATA Problem??

    Open Suse Installationsmedien nicht erkannt. SATA Problem??: Hallo Leute, ich hab mir endlich mal einen neuen Computer genehmigt und würde auch hier gerne wieder mit SuSe und XP zweigleisig fahren. Folgende...
  5. Probleme mit SATA Raid 5 bei SLES 9

    Probleme mit SATA Raid 5 bei SLES 9: Hi Leute, hab da ein ganz ärgerliches Prblem gefunden. In dem SLES 9 ist ein Raid 5 aus 4 SATA Platten. Wenn ich den PC boote möchte er nen...