problem mit pat-get und sourcelist

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von foexle, 12.12.2008.

  1. foexle

    foexle Kaiser

    Dabei seit:
    02.05.2007
    Beiträge:
    1.104
    Zustimmungen:
    0
    Ort:
    Saarbrücken
    Hallo Leute,
    gestern ein dist-upgrade gemacht von 8.04 auf 8.10

    da gab es einige probleme die ich nun alle behoben habe ... nun hat ubuntu mir aber mein ruby 1.8.6 auf 1.8.7 geupdatet ... nun will ich wieder downgraden ...

    ich hab alles deinstalliert
    dann in die sourcelist noch das hardy repo eingebunden, indem die ältere ruby version drin ist, aber apt-get findet diese nicht
    ich hab nachgelsen und eine
    datei erstellt in /etc/apt/
    namens preference in der drin steht
    Code:
    Package: ruby
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: ruby1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: libruby1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: rdoc1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: ri1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: libgtk2-ruby1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: libdbd-sqlite3-ruby1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: libopenssl-ruby1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: libsqlite3-ruby1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: ruby1.8-dev
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: libdbi-ruby1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: libatk1-ruby1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: libpango1-ruby1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: libatk1-ruby1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: libgdk-pixbuf2-ruby1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: libglib2-ruby1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: libcairo-ruby1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: irb1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: libreadline-ruby1.8
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: rails
    Pin: release a=hardy
    Pin-Priority: 900
    
    Package: libncurses-ruby1.8
    Pin: release a=hardy
    Pin-Priority: 900
     
    aber er findet bei der installation imm ernoch nicht die richtige version ....
    was könnte ich da machen
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. L0s3r

    L0s3r Tripel-As

    Dabei seit:
    22.09.2007
    Beiträge:
    216
    Zustimmungen:
    0
    Ort:
    MV
    Hast du die aktuellen Repos (8.10) auskommentiert als du das versucht hast?
    Falls nicht würd ich das mal so versuchen. Dann apt-get update und nochmal schauen. Sollte dann klappen.
     
  4. #3 Goodspeed, 12.12.2008
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Was sagt denn
    Code:
    apt-cache policy ruby1.8
    
    Und wie sieht die sources.list derzeit aus?
     
  5. foexle

    foexle Kaiser

    Dabei seit:
    02.05.2007
    Beiträge:
    1.104
    Zustimmungen:
    0
    Ort:
    Saarbrücken
    jo sicher hat das geklappt -.- oh mann ... das war der einfachste weg ... aber neiiinnn .. ich probiere erst mal ne h rum wies auch anderst geht -.-

    dank dir hat geklappt
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

problem mit pat-get und sourcelist

Die Seite wird geladen...

problem mit pat-get und sourcelist - Ähnliche Themen

  1. Virtualboxproblem

    Virtualboxproblem: Hallo Folgnedes Problem: Ich kann ohne Probleme In Debian-Sid, 64Bit und virtualbox-dkms Unixoide installieren, wenn es sich um eine...
  2. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  3. Problem bei apt-get upgrade (Kali 2.0)

    Problem bei apt-get upgrade (Kali 2.0): Hi, seit paar Tagen habe ich einige Probs. Dachte es sei mal an der Zeit für ein Update und nun tauchen da einige Fehler auf: Es müssen noch 0 B...
  4. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...
  5. Problem mit Win-Zugriff auf SAMBA

    Problem mit Win-Zugriff auf SAMBA: Hallo rundherum, vielleicht hat jemand eine Idee... Habe jetzt schon 1 1/2 Tage damit verbraten und den Fehler nicht gefunden. Problem:...