Problem mit Kernelmodul

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Jolli, 22.09.2003.

  1. Jolli

    Jolli Grünschnabel

    Dabei seit:
    19.09.2003
    Beiträge:
    7
    Zustimmungen:
    0
    Ort:
    Siegen / NRW
    Hallo,

    habe folgendes Problem :
    Ich habe ein Kernelmodul für meine Webcam kompiliert
    und wenn ich versuche es mit insmod zu laden kommt folgende
    Meldung :
    usbvideo.o: kernel-module version mismatch
    usbvideo.o was compiled for kernel version 2.4.20-4GB
    while this kernel is version 2.4.20-4GB-athlon.

    Kann mir da jmd. nen Tipp zu geben ??
    Vielen Dank im vorraus.

    Jolli
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Andre

    Andre Foren Gott
    Moderator

    Dabei seit:
    01.04.2002
    Beiträge:
    3.876
    Zustimmungen:
    0
    hmmm..
    hast du zu bauen des Moduls vieleicht die falschen sourcen/headers benutzt?
     
  4. Jolli

    Jolli Grünschnabel

    Dabei seit:
    19.09.2003
    Beiträge:
    7
    Zustimmungen:
    0
    Ort:
    Siegen / NRW
    also ich hab mal nix an den SuSE 8.2 Sourcen geändert.
    hab mal im /usr/src/linux/Makefile rumgefummelt, dat brachte aber auch nix, dann hieß die Fehlermeldung kurioserweise :
    usbvideo.o: kernel-module version mismatch
    usbvideo.o was compiled for kernel version 2.4.20-4GB-athlon
    while this kernel is version 2.4.20-4GB-athlon.
    :)
    Ich hab aber auch kein Bock nen neuen Kernel zu compilieren,
    aber wenn sich keine Lösung auftut werd ich's wohl machen müssen.
    Könnte höchstens sein dass ich mal bei so 'nem Yast-Online Update den
    Kernel geupdatet hab *grübel*

    Jolli
     
Thema:

Problem mit Kernelmodul

Die Seite wird geladen...

Problem mit Kernelmodul - Ähnliche Themen

  1. "Probleme" mit einem Kernelmodul

    "Probleme" mit einem Kernelmodul: Hallo Leute, ich stehe gerade vor einem kleinen Problem. Ich arbeite als Hiwi an einem Institut der Uni, an der ich studiere als Helfer des...
  2. Virtualboxproblem

    Virtualboxproblem: Hallo Folgnedes Problem: Ich kann ohne Probleme In Debian-Sid, 64Bit und virtualbox-dkms Unixoide installieren, wenn es sich um eine...
  3. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  4. Problem bei apt-get upgrade (Kali 2.0)

    Problem bei apt-get upgrade (Kali 2.0): Hi, seit paar Tagen habe ich einige Probs. Dachte es sei mal an der Zeit für ein Update und nun tauchen da einige Fehler auf: Es müssen noch 0 B...
  5. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...