Problem mit Kernelkonfiguration

Dieses Thema im Forum "Gentoo" wurde erstellt von EagleMF, 21.11.2006.

  1. #1 EagleMF, 21.11.2006
    EagleMF

    EagleMF Jungspund

    Dabei seit:
    01.12.2005
    Beiträge:
    16
    Zustimmungen:
    0
    Hallo,
    ich bin seit einiger Zeit dabei, mir meinen Kernel zu konfigurieren, was jedoch irgendwie nicht so richtig will. (Ich muss dazusagen, dass ich recht neu in dieser Materie bin). Ich benutze die 2.6.18-gentoo-r2 Version und bekomme beim Booten folgende Fehlermeldung:
    meine grub.conf sieht folgendermaßen aus:
    Also ich hab vorläufig eine Kernelkonfiguration von einem Freund übernommen und die ist mittlerweile die Einzige, mit der ich mein System noch starten kann. Jedoch ist halt dieser Kernel nicht auf mein System abgestimmt, weshalb auch die meiste Hardware nicht richtig (oder überhaupt nicht) läuft. Deshalb wollt ich mir nun das ganze selbst basteln was mir allerdings nicht so ganz gelingt. Also ich bin der Meinung, dass die grub.conf richtig sein muss, da der Eintrag bis auf den Kernelnamen identisch mit dem Kernel meines Freundes ist, sodass ich vermute, dass ich irgendwie was am Kernel machen muss.
    Kann mir vielleicht jemand einen Tipp geben, nach was ich schauen muss?

    Vielen Dank
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Vermutlich enthaelt Dein Kernel nicht den Treiber fuer das Dateisystem der root-Partition. Entweder, Du kompilierst den fest hinein, oder, falls er als modul vorliegt, erstellst Du Dir eine initrd und gibst die in/boot/grub/menu.lst mit an.
     
  4. #3 nikster77, 21.11.2006
    nikster77

    nikster77 Routinier

    Dabei seit:
    15.03.2004
    Beiträge:
    307
    Zustimmungen:
    0
    Du musst halt schauen ob im Kernel
    - alle Treiber fuer deine Platten (SATA/IDE, wenn ja welcher Chipsatz, etc.)
    - alle Filesysteme (so trivial das man's gerne vergisst...)

    drin sind.

    Sag halt mal was zur Hardware, vor allem RAIDs, SATA-Platten, von dir verwendete Filesysteme, etc. dann kann dir bestimmt jemand weiterhelfen.

    edit:
    aehm... ok hda also kein sata... aber trotzdem...
     
  5. heady

    heady Routinier

    Dabei seit:
    13.12.2005
    Beiträge:
    424
    Zustimmungen:
    0
    Ort:
    im Herzen Europas
    naja irgendwie hatte ich auch die selben probleme mit dem kernel...
    ich habs aber irgendwie mit dem befehl rdev gelöst, weiß aber nicht mer ganz wie
    außerdem lief der neue kernel auf meinem laptop ziemlich mies...ka warum...
     
  6. #5 whopper, 22.11.2006
    whopper

    whopper Foren As

    Dabei seit:
    01.10.2006
    Beiträge:
    96
    Zustimmungen:
    0
    Das Problem hatte ich auch und ich habs auch irgendwie hinbekommen mit dem Kernel.

    Mein Problem waren aber die Chipsätze für den IDE-Controller AFAIK.
     
  7. #6 illtiss, 22.11.2006
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    Kann das auch an der fstab, oder der grub.conf liegen?

    Überprüfe das noch einmal. Vielleicht passt was nicht ganz mit den Festplatten bzw. Partitions Angaben.
     
  8. #7 EagleMF, 22.11.2006
    EagleMF

    EagleMF Jungspund

    Dabei seit:
    01.12.2005
    Beiträge:
    16
    Zustimmungen:
    0
    ich vermute, dass es daran liegt... muss mal schauen.
    Also zur Hardware (Laptop Samsung X20 1730 V)
    - IDE Controler
    - Chipsatz: Mobile Intel 915GM Express

    Also falsche Partitionsangaben oder Fehler in der Fstab / grub.conf kann ich ja eigentlich ausschließen, da wie gesagt der Kernel meines Freundes damit läuft.
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. name

    name Inactive user

    Dabei seit:
    28.08.2004
    Beiträge:
    592
    Zustimmungen:
    0
    Ort:
    Wien->127.0.0.1
    [X]'e mal alle pseudo filesystems beim kernel..
     
  11. #9 EagleMF, 23.11.2006
    EagleMF

    EagleMF Jungspund

    Dabei seit:
    01.12.2005
    Beiträge:
    16
    Zustimmungen:
    0
    bringt leider auch nichts...
     
Thema:

Problem mit Kernelkonfiguration

Die Seite wird geladen...

Problem mit Kernelkonfiguration - Ähnliche Themen

  1. Virtualboxproblem

    Virtualboxproblem: Hallo Folgnedes Problem: Ich kann ohne Probleme In Debian-Sid, 64Bit und virtualbox-dkms Unixoide installieren, wenn es sich um eine...
  2. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  3. Problem bei apt-get upgrade (Kali 2.0)

    Problem bei apt-get upgrade (Kali 2.0): Hi, seit paar Tagen habe ich einige Probs. Dachte es sei mal an der Zeit für ein Update und nun tauchen da einige Fehler auf: Es müssen noch 0 B...
  4. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...
  5. Problem mit Win-Zugriff auf SAMBA

    Problem mit Win-Zugriff auf SAMBA: Hallo rundherum, vielleicht hat jemand eine Idee... Habe jetzt schon 1 1/2 Tage damit verbraten und den Fehler nicht gefunden. Problem:...