Problem mit Kernel 2.6.5-7.75

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Paladin, 25.06.2004.

  1. #1 Paladin, 25.06.2004
    Paladin

    Paladin Mitglied

    Dabei seit:
    02.02.2004
    Beiträge:
    32
    Zustimmungen:
    0
    Ort:
    Köln
    Hallo zusammen!

    Ich habe mir gestern über YOU die quellen für den Kernel 2.6.5-7.75 gezogen. Der neue Kernel an sich funktioniert auch eigentlich ganz gut. Nur sobald ich mir einen neuen backe, wird dieser nicht korrekt hochgefahren.

    Normalerweise ändere ich nicht viel am Kernel. Meine vorherige Version ist der 2.6.4-54.5. Zusätzlich zu den Standardeinstellungen kompiliere ich meist nur die Unterstützung für meinen PIII Prozessor da rein. Also:

    -> 2.6.4-54.5-default = SuSE Kernel
    -> 2.6.4-54.5-Coppermine = SuSE Kernel + PIII Unterstützung

    Das hat bis jetzt auch immer ganz gut mit jeder Kernelversion funktioniert. Nur der neue 2.6.5-7.75er macht zicken. Sobald ich nämlich den neu kompilierten 2.6.5-7.75-Coppermine hochfahren will gibt es zig tausend Modulfehler (alles verweist nämlich noch auf die 2.6.5-7.75-default Module) und der Kernel selber schmeisst nach dem Start mit "uname -r" ein 2.6.5-7.75-default aus. Seltsam, da im "/boot" Verzeichnis eigentlich alles korrekt auf 2.6.5-7.75-Coppermine gelinkt ist.

    Hat da jemand 'ne Lösung zur Hand?!
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. aleph

    aleph Jungspund

    Dabei seit:
    04.03.2004
    Beiträge:
    12
    Zustimmungen:
    0
    Ort:
    Gilching
    gibt es denn unter /lib/modules auch ein entsprechendes Verzeichnis mit dem Zusatz Coppermine?
    Vielleicht hast du "make modules_install" vergessen.

    LG
    aleph
     
  4. #3 Paladin, 25.06.2004
    Paladin

    Paladin Mitglied

    Dabei seit:
    02.02.2004
    Beiträge:
    32
    Zustimmungen:
    0
    Ort:
    Köln
    Natürlich! ;)


    Edit: Bevor es falsch verstanden wird... "Natürlich", existiert das Verzeichnis.
     
  5. #4 traster, 01.07.2004
    traster

    traster Routinier

    Dabei seit:
    25.11.2003
    Beiträge:
    297
    Zustimmungen:
    0
    hallo
    hast du nach dem kernel update mit you auch die kernel-source upgedatet ?
    also bei mir war das problem das es mit dem kernel update alleine nicht getan war
    nach einem neustart des systems musste ich noch mehrere sachen updaten
    kann aber auch sein das das wiedermal nur bei mir so war
    mfg traster
     
  6. #5 Paladin, 02.07.2004
    Paladin

    Paladin Mitglied

    Dabei seit:
    02.02.2004
    Beiträge:
    32
    Zustimmungen:
    0
    Ort:
    Köln
    jep, die sourcen hab ich auch geupdatet.

    ich warte einfach mal die nächste version ab! *g*
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. ba0645

    ba0645 Grünschnabel

    Dabei seit:
    05.06.2004
    Beiträge:
    6
    Zustimmungen:
    0
    Ort:
    Bamberg, Germany
    Habe mir heute von SuSE die Version 2.6.5-7.95 gezogen. Vielleicht klappt es mit der besser.
    Ich hoffe auf eine Verbesserung meiner System-Freezes. Irgendwie ist der 2.6.5-7.75 ziemlich buggy :-(
     
  9. dkrnic

    dkrnic Grünschnabel

    Dabei seit:
    25.07.2004
    Beiträge:
    1
    Zustimmungen:
    0
    Der neue Kernel ist auch nicht anders, gel?

    Ich wollte einen Kernel "-preempt" neben dem "-default" bauen.
    SuSE erzeugt entsprechend benanntes "/lib/modules"-Verzeichnis,
    erzeugt entsprechend benannte "vmlinuz-..." und "initrd-...",
    faellt aber auf die Nase beim Starten, weil der Kernel sagt
    ueber sich, dass es immer noch "-default" heisst, wenn man
    das Kommando "get_kernel_version" ausfuehrt und dafuer
    sind die Module in "/lib/modules/*-default" ja ungeeignet.

    OK. Kann passieren. In den ersten Paar KBs von "vmlinuz-..."
    erscheint die falsche Kennung "-default" an Stelle von "-preempt".
    Hex-editieren. Hoorah! Das "get_kernel_version" sagt jetzt,
    es ist das "-preempt" Kernel, also wird unter "/lib/modules/*-preempt"
    suchen. Von wegen! Es sucht wieder unter "/lib/modules/*-default".

    Gut, denkt man. Dann tauschen wir die Kennungen, die
    "/lib/modules/*-preempt" heissen jetzt "/lib/moduels/*-default".
    Hilft es? Natuerlich nicht.

    Das Problem ist bekannt seit "-75"-Version. Man kann den
    Kernelnamen nicht aendern. Idiotisch!
     
Thema:

Problem mit Kernel 2.6.5-7.75

Die Seite wird geladen...

Problem mit Kernel 2.6.5-7.75 - Ähnliche Themen

  1. openSuse 13.2 mit Custom Kernel systemd Problem

    openSuse 13.2 mit Custom Kernel systemd Problem: Hallo, ich habe bei openSuse 13.2 einen neuen Custom Kernel (3.17.5) eingespielt. Leider kommt beim reboot des neuen Kernel folgende...
  2. LVS ARP-Problem mit Kernel 3.x

    LVS ARP-Problem mit Kernel 3.x: Hallo! Weiß jemand ob beim Kernel 3.x immernoch das "ARP-Problem" bei LVS-DR besteht? Wenn ja, gibt es dazu Abhilfen? Mfg
  3. Kernelboot Problem (ext4)

    Kernelboot Problem (ext4): Hallo, lang, lang ist's her, als ich das letzte mal gentoo auf meinem ersten amd64 Bit PC hatte und nun will ich endlich wieder zu meiner...
  4. Kernel 3 Kompilierungsproblem unter XEN

    Kernel 3 Kompilierungsproblem unter XEN: Hallo, Ich habe eine openSuse 12.1 und SLES 11 SP1 unter XEN 4.1.2 im HVM Modus laufen. Wenn ich für die beiden System einen neuen Kernel...
  5. Unbekanntes Netzwerkproblem [kernel?]

    Unbekanntes Netzwerkproblem [kernel?]: Moin, ich hab ein stranges Problem mit meiner Netzwerkkarte. Leider hab ich keine Idee woran es liegt. Das ganze ist nicht wirklich...