Problem mit KDE installation

Dieses Thema im Forum "Gentoo" wurde erstellt von GendoIkari, 11.01.2007.

  1. #1 GendoIkari, 11.01.2007
    GendoIkari

    GendoIkari Routinier

    Dabei seit:
    04.12.2006
    Beiträge:
    336
    Zustimmungen:
    0
    Ort:
    Dort wo die Sonne aufgeht...
    Ich hab folgendes prob bei der kde installation:

    (chroot) Kanotix / # emerge kde
    Calculating dependencies... done!
    >>> Emerging (1 of 13) kde-base/kdenetwork-3.5.5-r1 to /
    >>> checking ebuild checksums ;-)
    >>> checking auxfile checksums ;-)
    >>> checking miscfile checksums ;-)
    >>> checking kdenetwork-3.5.5.tar.bz2 ;-)
    >>> checking kdenetwork-3.5-patchset-01.tar.bz2 ;-)
    QA Notice: USE Flag 'kernel_linux' not in IUSE for kde-base/kdenetwork-3.5.5-r1
    * To support Video4Linux webcams in this package is required to have
    * =x11-libs/qt-3* compiled with OpenGL support.
    * Please reemerge =x11-libs/qt-3* with USE="opengl".

    !!! ERROR: kde-base/kdenetwork-3.5.5-r1 failed.
    Call stack:
    ebuild.sh, line 1555: Called dyn_setup
    ebuild.sh, line 668: Called pkg_setup
    kdenetwork-3.5.5-r1.ebuild, line 55: Called die

    !!! Please reemerge =x11-libs/qt-3* with USE="opengl".
    !!! If you need support, post the topmost build error, and the call stack if relevant.



    hab schon >emerge --unmerge qt und dann USE="opengl" emerge qt gemacht hat aber nix gebracht
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Dann zeig doch mal mit welchem Flags dein QT gebaut wurde ;)
     
  4. #3 Keruskerfürst, 11.01.2007
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Ich würde das installierte Gentoo-Basissystem booten und dann von dort aus KDE installieren.
     
  5. #4 nikaya, 11.01.2007
    Zuletzt von einem Moderator bearbeitet: 11.01.2007
    nikaya

    nikaya Guest

    Entweder das USE_Flag "opengl" global in die make.conf eintragen.Oder opengl spezifisch für dieses QT setzen:
    Code:
    echo "x11-libs/qt-3.3.6-r4 opengl" >> /etc/portage/package.use
    Oder das Flag nur einmalig mitkompilieren:
    Code:
    USE="opengl" emerge -1av =qt-3.3.6-r4
    Ich bin mir nicht sicher ob die QT-Version passt,müßte aber.
     
  6. #5 GendoIkari, 12.01.2007
    Zuletzt bearbeitet: 12.01.2007
    GendoIkari

    GendoIkari Routinier

    Dabei seit:
    04.12.2006
    Beiträge:
    336
    Zustimmungen:
    0
    Ort:
    Dort wo die Sonne aufgeht...
    Noch 13 Packete und dann das

    selbes Packet anderes Problem
    nach emerge kde
    kommt das
    ###############################################################################################
    ...
    QA Notice: USE Flag 'kernel_linux' not in IUSE for kde-base/kdenetwork-3.5.5-r1 //hab ich was im kernel falsch eingestell oder ein Flag?
    ...
    checking if UIC has KDE plugins available... no // warum net ?(
    configure: error:
    you need to install kdelibs first. // hab ich doch
    ....
    ###############################################################################################
    emerge -s kdelibs
    Searching...
    [ Results for search key : kdelibs ]
    [ Applications found : 1 ]

    * kde-base/kdelibs
    Latest version available: 3.5.5-r7
    Latest version installed: 3.5.5-r7
    Size of files: 15,164 kB
    Homepage: http://www.kde.org/
    Description: KDE libraries needed by all KDE programs.
    License: GPL-2 LGPL-2
    ############################################################################################
    ...
    If you did install kdelibs, then the Qt version that is picked up by
    this configure is not the same version you used to compile kdelibs.
    The Qt Plugin installed by kdelibs is *ONLY* loadable if it is the
    _same Qt version_, compiled with the _same compiler_ and the same Qt
    configuration settings.


    !!! Please attach the following file when filing a report to bugs.gentoo.org:
    !!! /var/tmp/portage/kdenetwork-3.5.5-r1/work/kdenetwork-3.5.5/config.log

    !!! ERROR: kde-base/kdenetwork-3.5.5-r1 failed.
    Call stack:
    ebuild.sh, line 1539: Called dyn_compile
    ebuild.sh, line 939: Called src_compile
    kdenetwork-3.5.5-r1.ebuild, line 67: Called kde_src_compile
    kde.eclass, line 169: Called kde_src_compile 'all'
    kde.eclass, line 339: Called kde_src_compile 'myconf' 'configure' 'make'
    kde.eclass, line 321: Called econf '--with-libidn' '--disable-sametime-plugin' '--disable-slp' '--without-wifi' '--disable-jingle' '--without-xmms' '--without-external-libgadu' '--with-x' '--enable-mitshm' '--without-xinerama' '--with-qt-dir=/usr/qt/3' '--enable-mt' '--with-qt-libraries=/usr/qt/3/lib64' '--disable-dependency-tracking' '--disable-debug' '--without-debug' '--disable-final' '--without-arts' '--prefix=/usr/kde/3.5' '--mandir=/usr/kde/3.5/share/man' '--infodir=/usr/kde/3.5/share/info' '--datadir=/usr/kde/3.5/share' '--sysconfdir=/usr/kde/3.5/etc' '--enable-libsuffix=64'
    ebuild.sh, line 541: Called die

    !!! econf failed
    !!! If you need support, post the topmost build error, and the call stack if relevant.
    ###################################################################################################
     
  7. #6 Keruskerfürst, 12.01.2007
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    emerge -av kdelibs
     
  8. #7 GendoIkari, 12.01.2007
    Zuletzt bearbeitet: 12.01.2007
    GendoIkari

    GendoIkari Routinier

    Dabei seit:
    04.12.2006
    Beiträge:
    336
    Zustimmungen:
    0
    Ort:
    Dort wo die Sonne aufgeht...
    und wie find ich das raus?

    hab ich, aber das hat leider nix geholfen :(
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. #8 Keruskerfürst, 12.01.2007
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Mal emerge --info posten und die Fehlerliste von KDE auf www.gentoo.org durchsuchen.
     
  11. #9 GendoIkari, 12.01.2007
    Zuletzt bearbeitet: 12.01.2007
    GendoIkari

    GendoIkari Routinier

    Dabei seit:
    04.12.2006
    Beiträge:
    336
    Zustimmungen:
    0
    Ort:
    Dort wo die Sonne aufgeht...
    Super! 1000 Dank, das war die Lösung :D

    Hab das auch vorher schon emerge, aber eben ohen "-av" hab gedacht das wär nur um zu kucken was im packet dabei is.
     
Thema:

Problem mit KDE installation

Die Seite wird geladen...

Problem mit KDE installation - Ähnliche Themen

  1. Problem bei Ubuntu 13.10 installation neben Windows 7

    Problem bei Ubuntu 13.10 installation neben Windows 7: Hallo liebe Gemeinde, ich bin absoluter Linux-Neuling und habe versucht Ubuntu 13.10 neben meinem Windows 7 zu installieren. Ich habe vor...
  2. Problem mit HSPA+ Modem Huawei E353 - Installation unmöglich?

    Problem mit HSPA+ Modem Huawei E353 - Installation unmöglich?: Hallo, Ich hoffe sehr dass mir hier jemand helfen kann :) ich versuche seit einiger Zeit leider erfolglos ein Huawei E353 USB-Modem unter Ubuntu...
  3. Aircrack installationsprobleme

    Aircrack installationsprobleme: Hallo, Ich wollte mir ''Aircrack'' installieren, da mich das Thema Internetsicherheit interessiert. Schön und gut aber ich kämpfe mit einer...
  4. LinuxMint: Installations Problem

    LinuxMint: Installations Problem: Hey Leute, wollte grad mal LinuxMint auf meinem Laptop installieren, aber leider bleibt die Installation irgendwann hängen. Ich habe die Disc...
  5. Probleme mit Installation von Software [MySQL LogIn Faild]

    Probleme mit Installation von Software [MySQL LogIn Faild]: Hi Leute, ich bin neu hier un über Googel auf euch gestoßen. Ich hab mir einen Vserver bei 1blue gemietet und möchte mich mit dem Thema Linux...