Problem mit gettext

Dieses Thema im Forum "C/C++" wurde erstellt von Scorcher24, 11.12.2008.

  1. #1 Scorcher24, 11.12.2008
    Scorcher24

    Scorcher24 AMDGuru

    Dabei seit:
    27.07.2004
    Beiträge:
    77
    Zustimmungen:
    0
    Ort:
    Nürnberg, Germany
    Hi.
    Ich hab ein Problem mit GNU gettext.
    Ich kann das Programm nur dazu bewegen unter der aktuellen Standard-Lokalen mir die Übersetzung zu liefern, auch wenn ich setlocale(LC_ALL, "French") als bsp aufrufe. Die Dateien sind korrekt vorhanden unter "<argv[0]>/i18n/<sprache>/LC_MESSAGES/MyProgram.mo" und das Verzeichnis wurde mit bindttextdomain("MyProgram", "./i18n/") gebunden. Bzw Deutsch funktioniert ja korrekt.
    Das ganze läuft unter woe32 momentan.
    Sorry, dass ich auf nem unixboard ein Windows-Problem schildere :D aber die normalen Windows-Programmierforen sind hier wenig hilfreich :P. Bitte keine Fische oder sonstige Tiere / Beleidigungen werfen :oldman, die Frage ist ernst gemeint und kein Flame / Trollversuch.
    rya.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Problem mit gettext

Die Seite wird geladen...

Problem mit gettext - Ähnliche Themen

  1. Virtualboxproblem

    Virtualboxproblem: Hallo Folgnedes Problem: Ich kann ohne Probleme In Debian-Sid, 64Bit und virtualbox-dkms Unixoide installieren, wenn es sich um eine...
  2. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  3. Problem bei apt-get upgrade (Kali 2.0)

    Problem bei apt-get upgrade (Kali 2.0): Hi, seit paar Tagen habe ich einige Probs. Dachte es sei mal an der Zeit für ein Update und nun tauchen da einige Fehler auf: Es müssen noch 0 B...
  4. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...
  5. Problem mit Win-Zugriff auf SAMBA

    Problem mit Win-Zugriff auf SAMBA: Hallo rundherum, vielleicht hat jemand eine Idee... Habe jetzt schon 1 1/2 Tage damit verbraten und den Fehler nicht gefunden. Problem:...