Problem: debian install auf laptop, ohne internet zugang

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von zonk, 29.10.2005.

  1. #1 zonk, 29.10.2005
    Zuletzt bearbeitet: 29.10.2005
    zonk

    zonk Jungspund

    Dabei seit:
    08.09.2005
    Beiträge:
    10
    Zustimmungen:
    0
    Hallo zusammen.

    Ich habe mir ein LG LW40 Laptop gekauft. (Intel Centrino, 60 Gb Sata platte, Marvell Yukon 88E8053 Netzwerkkarte)
    Nun habe ich versucht Debian testing darauf zu installieren.
    Ich benutze dazu die offiziellen Isos von "testing", aber nur die erste CD.

    Das Probelm ist nur, die eingebaute netzwerkkarte (Marvell Yukon 88E8053) wird von dem installer nicht erkannt. Auch der Wireless-chip (intel centrino benötigtes module: ipw2200) wird von dem installer nicht erkannt.

    Soweit so gut, dachte ich, man setzt ein Basissystem auf und compiliert sich die treiber für die Netzwerkkarte, die zur verfügung gestellt werden. Dann apt-get und das System damit graphisch aufsetzen.

    Leider ergeben sich bei der Installation abhänigkeiten von einem packet ("laptop..." weiss nicht mehr so genau) so dass der zugriff auf das Internet notwendig wird.

    Jetzt sitze ich hier und weiss nicht was ich tun kann um Debian zu installieren.
    Hat irgendjemand eine gute Idee?
    Würde mich über jede Hilfe freuen.

    Danke schonmal.


    zonk
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    du könntest per knoppix booten und dann das system per debotstrap und chroot aufsetzen.
     
  4. zonk

    zonk Jungspund

    Dabei seit:
    08.09.2005
    Beiträge:
    10
    Zustimmungen:
    0
    Hallo sono.

    Ja, das habe ich gestern auch noch versucht, leider ließ sich etch dadurch nicht installieren, bricht immer sofort mit einer unaufgelösten abhänigkeit ab. Es fehlt eine lib.
    Also habe ich anschliessend sid per bootstrap aufgesetzt aber leider ließ sich "base-config" nicht ausfuehren.
    Es bricht immer sofort ab.
    Ich habe dann versucht alles mögliche mit apt-get/aptitude zu installieren, aber so ganz funktioniert das nicht.
    Es treten dabei immer Fehler beim konfigurieren des Kernel auf.

    (normalerweise würde ich jetzt die Fehlermeldungen hier hin schreiben, aber ich versuche gerade meinen eigenen Kernel zu compilieren und der Rechnern ist voll ausgelastet)

    Mal sehen vielleicht klappt mein kernel selbstbau ja....

    zonk
     
  5. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    Wenn du nen Laptop hast installier mal Ubuntu breezy. Das ist Debian sehr ähnlich , aber wesentlich aktueller und unterstützt Laptops besser.

    Ich bin auf meinem Laptop von Debian zu Ubuntu umgestiegen, vor allem weil breezy sogar aktueller als Etch ist ( und stabiler ).

    Solltest du bei unbedingt bei debian bleiben wollen , dann verwende mal den server bei debotsrap :

     
  6. zonk

    zonk Jungspund

    Dabei seit:
    08.09.2005
    Beiträge:
    10
    Zustimmungen:
    0
    Hallo sono.


    Das ist der Grund warum ich versuche Debian zu installieren. Ich hatte zuerst Breezy installiert, aber der bleibt beim booten bei "Hotplug" immer hängen.(bei Hoary ebenso)
    Das ist auch ein bekanntes Problem, es scheint aber keine Lösung dazu zu geben, oder keine die ich gefunden habe. Danach habe ich dann versucht Debian zu installieren.(Damit kenne ich mich auch ein wenig aus, läuft seit einem Jahr ohne Probleme auf dem Desktop)



    Ich werde es mal testen, wenn meine weiteren Bemühungen heute scheitern.

    Ich muss auch nicht bei Debian bleiben, ich hätte nur gerne ein System was auf Debian basiert, mit Suse und RedHat/Fedora bin ich nicht glücklich gewesen.

    Mit make. Ist da was falsch dran? Bisher hat das immer funktioniert.
    Was würdest Du denn empfehlen?
    Das Problem im Moment ist das der kernel beim booten hängen bleibt mit "Kernel Panic". Er kennt wohl meine platte(bzw. den Controller) nicht (ist eine SATA platte die an Intel Centrino hardware hängt). Dabei habe ich alle treiber die irgendetwas mit SATA zu tun haben direkt in den Kernel (2.6.14) kompiliert.



    Danke ich werde auf es auf jeden Fall mal testen wenn ich nicht in kürzer Zeit das System booten kann.

    Vielen Dank für die Hilfe.


    zonk
     
  7. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    direkt falsch ist an make nichts aber wenn du dpkg-buildpackage nimmst kannst du deinen Kernel mit apt verwalten was sehr praktisch ist , finde ich.

    (Ist aber in deinem Problem nebensächlich)

    Bootet eigentlich Knoppix oder Kanotix Fehlerfrei ?

    Zur Not kannst du auch Kanotix installieren, im gegensatz zu Knoppix kann man das auch ohne größere Probleme (angeblich) auf die Festplatte hauen.

    Gruß SOno
     
  8. zonk

    zonk Jungspund

    Dabei seit:
    08.09.2005
    Beiträge:
    10
    Zustimmungen:
    0
    Hallo Sono.

    Debian mit debootstrap war irgendwie nicht zu machen. Ich versteh nicht warum. Wenn ich, wie du gesagt hast sarge, versucht habe zu installieren, dann bekam ich immer :"Failure while unpacking required packages. This will be attempted up to five times" Hat aber nie geklappt.

    Danach habe ich mich nochmal an den Rechner gesetzt und das internet durchsucht und jemanden gefunden der auch Breezy auf diesem Laptop installiert hat. Er hatte das gleiche Problem, aber keine Lösung im Netz stehen.
    Den habe ich angeschrieben und er hatte ein paar Tips, wie man das einfrieren beim booten umgehen kann. (intel HDA sound ist schuld)

    Nunja jetzt habe ich ein Ubuntu auf dem Rechner was läuft, leider ohne sound :(


    Danke aber trotzdem für deine Hilfe.

    zonk


     
  9. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    Ich hatte auch Probleme mit meinem Notebook .

    Bin gerade gestern wieder an der Installation von Breezy gescheitert. Ich bekomme auf Teufel komm raus den Grafiktreiber nicht richtig zum laufen , und eigentlich mache ich sowas nicht zu ersten mal.

    Hab zwar Sound aber wohl noch ne weile hoary, wenn dich das trösted , du bist nicht alein.

    Gruß SOno
     
  10. #9 Wolfgang, 31.10.2005
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Was hast du denn für eine Grafikkarte?
    Ich kann mich ja täuschen, aber irgendwie werde ich das Gefühl nicht los,
    dass xorg bei einiger Hardware mehr Probleme hat als XFree86.
    Woran das liegen mag, weiss ich nicht. Aber ich weiss, dass es einige Fälle gibt, wo xorg auf Teufel komm raus nicht zum richtigen Funktionieren zu bringen war, was aber mit XFree86 dann doch noch klappte.:think:

    Gruß Wolfgang
     
  11. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Wohl eher das Gegenteil ist der Fall. xorg unterstuetzt mehr Grafikkarten (und vor allem besser) als XFree86
     
  12. zonk

    zonk Jungspund

    Dabei seit:
    08.09.2005
    Beiträge:
    10
    Zustimmungen:
    0
    Wo wir gerade bei Grafikkarten sind, hat jemand von euch Erfahrungen mit der Intel GMA900 Grafikkarte? Gibts es da irgendwo treiber zum herunterladen?
    Bei Intel selber gab es die nicht.
    Im Moment laeuft der X-server zwar, aber in einer komischen Aufloesung und irgendwie nicht ganz richtig.
    Ich weiss ich kann im dem konfig-file XFREE.... rumspielen, aber eigentlich waere es mir lieb wenn es einen eigenen Treiber gaebe und der nicht mit "vesa" in den Standarteinstellungen laeuft.

    (ist das verstaendlich was ich schreibe? :think: Brauche glaub ich noch einen Kaffee)


    zonk
     
  13. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  14. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    Ich hab ne 9700 er ati mobility . Unter hoary läuft das ding dank korrekte atireiber wunderbar nur hat der aktuelle treiber in breezy nen bug und der neueste ati von ati.com zickt auch nur rum X(

    Muss mir das man in Ruhe zu gemüte führen.
     
  15. zonk

    zonk Jungspund

    Dabei seit:
    08.09.2005
    Beiträge:
    10
    Zustimmungen:
    0
    Habe die Treiber gefunden, natuerlich auf der Intel Homepage.
    Es war nur nicht klar, dass die GMA900 zu den intel 915 Graphics-chips gehoert. Nunja werde mich nachher mal daran machen diese zu installieren.

    Hat denn trotzdem jemand Erfahrungen mit den Treibern unter Linux? Laeuft alles sauber?
    Die Karte funktioniert ?


    zonk
     
Thema:

Problem: debian install auf laptop, ohne internet zugang

Die Seite wird geladen...

Problem: debian install auf laptop, ohne internet zugang - Ähnliche Themen

  1. Debian Routing Problem

    Debian Routing Problem: Liebes Forum, ich versuche über einen Debian Server eine pppoe Verbindung im Lan bereitzustellen, leider bekomme ich auf den Clients immer nur...
  2. Debian nähert sich einer Lösung des Init-Problems an

    Debian nähert sich einer Lösung des Init-Problems an: Bdale Garbee als Leiter des technischen Komitees (TC) versucht, die anstehenden Fragen zu einem neuen Init-System für Debian nun schrittweise...
  3. java-package (debian7) probleme.

    java-package (debian7) probleme.: Hallo, ich nutze neben Java für Windows, auch Java für Linux, bzw. würde es einsetzen. Unter Debian benutze ich java-package mit make-jpkg...
  4. Debian 'Squeezy' Problem bei Wlan

    Debian 'Squeezy' Problem bei Wlan: Hi! Also ich habe zu Weihnachten ein neues Netbook (Lenovo S205 :D ) bekommen und wollte heute gleich Debian Squeezy XFCE darauf installieren!...
  5. Netzwerk problembitte hilfe bin linux noob debian6

    Netzwerk problembitte hilfe bin linux noob debian6: hallo bin neu hir da her erstmal einige probleme Os ist debian6 wie richte ich den inter net zugag ein netzwerkkarte habe ich halse hin gekrigt