Problem beim Anlegen von weiteren Maschinenaccounts

Dieses Thema im Forum "Samba" wurde erstellt von panne#, 08.01.2008.

  1. #1 panne#, 08.01.2008
    Zuletzt bearbeitet: 08.01.2008
    panne#

    panne# Grünschnabel

    Dabei seit:
    08.01.2008
    Beiträge:
    1
    Zustimmungen:
    0
    Hi,

    ich habe folgendes merkwürdiges Problem beim Anlegen eines Maschinenkontos in Samba 3.0.22 auf Ubuntu-Server 6.06 LTS:
    Code:
    # pdbedit -a -m HOST$
    tdb_update_sam: SAM_ACCOUNT (host$) with no RID!
    Unable to add machine! (does it already exist?)
    /* sic! Der Hostname wird tatsächlich klein ausgegeben in der Meldung - kann da das Problem liegen?
    Und wenn - wie ändere ich das? In der Manpage zu pdbedit finde ich jdfs. keine Option, die Case-sensitivity an- oder ausschaltet... */
    Code:
    # pdbedit -x HOST$
    user HOST$ does not exist in the passdb
    # pdbedit -x -m HOST$
    machine HOST$ does not exist in the passdb
    In Linux ist der entsprechende Maschinenaccount angelegt mit
    Code:
    # /usr/sbin/useradd -c SMB_Machine -d /home/nobody -s /bin/false HOST$
    /* Entspricht dem "add machine script" in der /etc/samba/smb.conf */


    Der Fehlermeldung kann mensch ja entnehmen, das ein RID angegeben werden müsste - also habe ich es mit
    Code:
    # pdbedit -a -m HOST$ -U 2223 
    probiert, die "2223" entspricht der UID des Maschinenaccounts in der /etc/passwd.
    Leider wieder dieselbe Fehlermeldung: "tdb_update_sam: SAM_ACCOUNT (host$) with no RID! Unable to add machine! (does it already exist?)" -also zusätzlich die Option "-G 1201" benutzt, 1201 ist der Primary-Group-RID des (bislang einzigen) Clients in der passdb.tdb. Dann ist mir aufgefallen, das die User-RIDs alle >=3000 sind, also habe ich es nochmal mit "-U 3037" (dem nächsten freien RID) sowie "-U 3333" (ein RID, der jdfs. garantiert noch nicht vergeben war) probiert, sowohl mit als auch ohne Angabe des Group-RID.

    Desweiteren habe ich noch probiert, nur den Group-RID anzugeben und pdbedit den User-RID selbst vergeben zu lassen; sowie die Option "-u" zur expliziten Angabe des Usernamens zwischen -m und dem Hostnamen anzugeben.

    Edit:Auch habe ich (als erstes sogar) versucht, die Maschine vom Client selbst aus anzumelden über Arbeitsplatz->Eigenschaften->Computername->Ändern; Ergebnis war: ich sollte wie zu erwarten den Domänen-Admin-Account angeben, "Willkommen in der Domäne FOOBAR", Neustart... -und dann beim Einlogversuch eine Fehlermeldung mit der Aussage "Sie konnten nicht angemeldet werden, da das Maschinenkonto nicht in der Domäne gefunden wurde"

    Alle Befehle habe ich als root ausgeführt, die NT-Gruppen sind ordentlich auf die Unix-Gruppen gemappt (wobei, mir fällt grad auf, im Mapping der Group-RID 1201 nicht auftaucht!? -aber dennoch hat das Anmelden eines Rechners auch vorher schon funktioniert gehabt??? -leider komme ich im Moment nicht mehr an den Rechner ran (weshalb ich im Augenblick auch nicht die smb.conf mitliefern kann =/ ), aber die Gruppenzuordnung werde ich bei nächster Gelegenheit (dh. morgen) auch noch setzen. Wie gesagt, war diese Gruppe aber bislang nie gemappt, und ich konnte trotzdem einen Rechner anmelden...)

    Habt ihr Tipps, Ideen (oder gar die Lösung) für mich?
    Die reichlichen Beiträge in verschiedensten Foren, die ich gelesen habe, brachten leider keine Erleuchtung bis jetzt...

    Edit: Gruppe ist gemappt, Fehlermeldung bleibt dieselbe =( -also, ich habe wirklich keine Ahnung mehr, woran das liegen könnte. *HILFE* :(
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Problem beim Anlegen von weiteren Maschinenaccounts

Die Seite wird geladen...

Problem beim Anlegen von weiteren Maschinenaccounts - Ähnliche Themen

  1. Probleme beim installieren

    Probleme beim installieren: Moin! Ich habe mir vor ein paar Wochen einen Hyrican Intel® i5, 8192MB DDR3-RAM, 1TB Speicher + 120GB SSD,GF GTX750Ti »Military 4610 PC gekauft....
  2. Probleme beim Ubuntu-Update

    Probleme beim Ubuntu-Update: Bei der Aktualisierung von Ubuntu 13.04 auf die neueste Ubuntu-Version 13.10 kann es unter bestimmten Konstellationen zu Problemen kommen....
  3. KSH: Problem beim Umleiten des Fehlerkanals

    KSH: Problem beim Umleiten des Fehlerkanals: Hallo, in einen KSH Skript führe ich folgende Befehle aus RESULT=""; ERROR=""; idsldapsearch -h localhost -p $PORT -D $USER -w $PW -s sub -b...
  4. Probleme beim lesen einer CD

    Probleme beim lesen einer CD: Hallo zusammen, ich habe eine Daten-CD mit xfburn unter Fedora 15 erstellt. Diese muss ich bei uns in der Uni-Bibliothek abgeben. Auf der CD...
  5. Probleme beim mounten eines Serververzeichnisses auf einen Client

    Probleme beim mounten eines Serververzeichnisses auf einen Client: Hallo zusammen, ich habe folgendes Problem: Wir haben einen NIS-Server mit einem User root und PW xyz. Auf diesem wurde ein Verzeichnis...