pppoe-server...

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von Whiteghost, 09.01.2006.

  1. #1 Whiteghost, 09.01.2006
    Whiteghost

    Whiteghost Jungspund

    Dabei seit:
    09.08.2005
    Beiträge:
    13
    Zustimmungen:
    0
    Hi,

    ich hab da ein kleines Problem.

    Ich möchte einen pppoe Server betreiben. Bei RP-pppoe is der ja bei, ich bekomme es soweit das die Packete PADI PADO, PADR und PADS verschickt werden.
    Aber dann gehts net weiter.... und nach dem Timeout gehts wieder von forne los.

    ich hab mich an die anleitung von
    http://wrath.geoweb.ge/pppoe-server.html
    und von rp-pppoe-3.7.tar.gz
    gehalten hat aber nicht geholfen.

    Ich vermute es hängt an er PPP verbindung die wohl nicht aufgebaut wird. aber ich weis net warum net.

    den server starte ich mit "pppoe-server -I eth1 -K"

    bin für tipps sehr dankbar


    Code:
    pppoe-server-options
    
    auth
    require-chap
    default-mru
    default-asyncmap
    lcp-echo-interval 60
    lcp-echo-failure 5
    ms-dns 192.168.206.1
    noipdefault
    noipx
    nodefaultroute
    noproxyarp
    noktune
    netmask 255.255.255.255
    logfile /var/log/pppoe-server.log
    
    -----
    /etc/ppp/options
    
    debug
    lock
    crtscts
    nobsdcomp
    nodeflate
    nopcomp
    
    ------
    pap und chap-secret
    
    test * pass 10.0.0.2
    
    
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Ich wuerde an deiner Stelle mal die Logdateien in /var/log/ durchforsten um zu sehen, was genau denn beim Verbindungsaufbau schief geht. 'grep -r "ppp" /var/log/' koennte da ganz hilfreich sein um die entsprechenden Dateien zu finden, in denen sich Informationen dazu finden lassen.
     
  4. #3 Whiteghost, 09.01.2006
    Whiteghost

    Whiteghost Jungspund

    Dabei seit:
    09.08.2005
    Beiträge:
    13
    Zustimmungen:
    0
    also das logfile /var/log/pppd.log steht

    Code:
    using channel 87
    Using interface ppp0
    Connect: ppp0 <--> /dev/pts/1
    sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x9a5c6b09>]
    sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x9a5c6b09>]
    rcvd [LCP ConfReq id=0x1 <magic 0x2b4e7a29>]
    sent [LCP ConfAck id=0x1 <magic 0x2b4e7a29>]
    sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x9a5c6b09>]
    sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x9a5c6b09>]
    rcvd [LCP ConfReq id=0x1 <magic 0x2b4e7a29>]
    sent [LCP ConfAck id=0x1 <magic 0x2b4e7a29>]
    sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x9a5c6b09>]
    sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x9a5c6b09>]
    rcvd [LCP ConfReq id=0x1 <magic 0x2b4e7a29>]
    sent [LCP ConfAck id=0x1 <magic 0x2b4e7a29>]
    sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x9a5c6b09>]
    sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x9a5c6b09>]
    rcvd [LCP ConfReq id=0x1 <magic 0x2b4e7a29>]
    sent [LCP ConfAck id=0x1 <magic 0x2b4e7a29>]
    sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x9a5c6b09>]
    sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x9a5c6b09>]
    using channel 88
    Using interface ppp1
    Connect: ppp1 <--> /dev/pts/2
    sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x38ac78ca>]
    LCP: timeout sending Config-Requests
    Connection terminated.
    using channel 89
    Using interface ppp0
    Connect: ppp0 <--> /dev/pts/5
    Waiting for 2 child processes...
      script /usr/sbin/pppoe -n -I eth1 -e 1:00:0c:29:b6:4f:54 -S '', pid 12301
      script /usr/sbin/pppoe -n -I eth1 -e 1:00:0c:29:b6:4f:54 -S '', pid 12260
    
     
  5. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Hmm, stellt sich nur die Frage, warum er pppoe zweimal ausfuehrt. Was sagt denn das syslog dazu und die /var/log/messages?
     
  6. #5 Whiteghost, 10.01.2006
    Whiteghost

    Whiteghost Jungspund

    Dabei seit:
    09.08.2005
    Beiträge:
    13
    Zustimmungen:
    0
    syslog

    Code:
    Jan 10 08:26:26 pppoesrvtux pppoe-server[13212]: Session 1 created for client 00:0c:29:b6:4f:54 (10.67.15.1) on eth1 using Service-N
    ame ''
    Jan 10 08:26:26 pppoesrvtux pppd[13212]: pppd 2.4.3 started by root, uid 0
    Jan 10 08:26:26 pppoesrvtux pppd[13212]: using channel 103
    Jan 10 08:26:26 pppoesrvtux pppd[13212]: Using interface ppp0
    Jan 10 08:26:26 pppoesrvtux pppd[13212]: Connect: ppp0 <--> /dev/pts/1
    Jan 10 08:26:27 pppoesrvtux pppd[13212]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x6d56a387>]
    Jan 10 08:26:29 pppoesrvtux pppd[13212]: rcvd [LCP ConfReq id=0x1 <magic 0x6373a2ad>]
    Jan 10 08:26:29 pppoesrvtux pppd[13212]: sent [LCP ConfAck id=0x1 <magic 0x6373a2ad>]
    Jan 10 08:26:30 pppoesrvtux pppd[13212]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x6d56a387>]
    Jan 10 08:26:33 pppoesrvtux pppd[13212]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x6d56a387>]
    Jan 10 08:26:35 pppoesrvtux pppd[13212]: rcvd [LCP ConfReq id=0x1 <magic 0x6373a2ad>]
    Jan 10 08:26:35 pppoesrvtux pppd[13212]: sent [LCP ConfAck id=0x1 <magic 0x6373a2ad>]
    Jan 10 08:26:36 pppoesrvtux pppd[13212]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x6d56a387>]
    Jan 10 08:26:39 pppoesrvtux pppd[13212]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x6d56a387>]
    Jan 10 08:26:41 pppoesrvtux pppd[13212]: rcvd [LCP ConfReq id=0x1 <magic 0x6373a2ad>]
    Jan 10 08:26:41 pppoesrvtux pppd[13212]: sent [LCP ConfAck id=0x1 <magic 0x6373a2ad>]
    Jan 10 08:26:42 pppoesrvtux pppd[13212]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x6d56a387>]
    Jan 10 08:26:45 pppoesrvtux pppd[13212]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x6d56a387>]
    Jan 10 08:26:47 pppoesrvtux pppd[13212]: rcvd [LCP ConfReq id=0x1 <magic 0x6373a2ad>]
    Jan 10 08:26:47 pppoesrvtux pppd[13212]: sent [LCP ConfAck id=0x1 <magic 0x6373a2ad>]
    Jan 10 08:26:48 pppoesrvtux pppd[13212]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x6d56a387>]
    Jan 10 08:26:51 pppoesrvtux pppd[13212]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x6d56a387>]
    Jan 10 08:26:53 pppoesrvtux pppd[13212]: rcvd [LCP ConfReq id=0x1 <magic 0x6373a2ad>]
    Jan 10 08:26:53 pppoesrvtux pppd[13212]: sent [LCP ConfAck id=0x1 <magic 0x6373a2ad>]
    Jan 10 08:26:54 pppoesrvtux pppd[13212]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x6d56a387>]
    Jan 10 08:26:56 pppoesrvtux pppoe-server[13225]: Session 2 created for client 00:0c:29:b6:4f:54 (10.67.15.2) on eth1 using Service-N
    ame ''
    Jan 10 08:26:56 pppoesrvtux pppd[13225]: pppd 2.4.3 started by root, uid 0
    Jan 10 08:26:56 pppoesrvtux pppd[13225]: using channel 104
    Jan 10 08:26:56 pppoesrvtux pppd[13225]: Using interface ppp1
    Jan 10 08:26:56 pppoesrvtux pppd[13225]: Connect: ppp1 <--> /dev/pts/2
    Jan 10 08:26:57 pppoesrvtux pppd[13212]: LCP: timeout sending Config-Requests 
    Jan 10 08:26:57 pppoesrvtux pppd[13212]: Connection terminated.
    Jan 10 08:26:57 pppoesrvtux pppd[13212]: using channel 105
    Jan 10 08:26:57 pppoesrvtux pppd[13225]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0xd8aecded>]
    Jan 10 08:26:57 pppoesrvtux pppd[13212]: Using interface ppp0
    Jan 10 08:26:57 pppoesrvtux pppd[13212]: Connect: ppp0 <--> /dev/pts/5
    Jan 10 08:26:57 pppoesrvtux pppd[13212]: Waiting for 2 child processes...
    Jan 10 08:26:57 pppoesrvtux pppd[13212]:   script /usr/sbin/pppoe -n -I eth1 -e 1:00:0c:29:b6:4f:54 -S '', pid 13236
    Jan 10 08:26:57 pppoesrvtux pppd[13212]:   script /usr/sbin/pppoe -n -I eth1 -e 1:00:0c:29:b6:4f:54 -S '', pid 13214
    Jan 10 08:27:00 pppoesrvtux pppd[13225]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0xd8aecded>]
    Jan 10 08:27:02 pppoesrvtux pppd[13212]: sending SIGTERM to process 13236
    ...skipping...
    Jan 10 08:28:46 pppoesrvtux pppd[13369]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0xff7f8e9a>]
    Jan 10 08:28:49 pppoesrvtux pppd[13327]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x25978910>]
    Jan 10 08:28:49 pppoesrvtux pppd[13352]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x40253ff8>]
    Jan 10 08:28:49 pppoesrvtux pppd[13369]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0xff7f8e9a>]
    Jan 10 08:28:52 pppoesrvtux pppd[13327]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x25978910>]
    Jan 10 08:28:52 pppoesrvtux pppd[13352]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x40253ff8>]
    Jan 10 08:28:52 pppoesrvtux pppd[13369]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0xff7f8e9a>]
    Jan 10 08:28:55 pppoesrvtux pppd[13327]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x25978910>]
    Jan 10 08:28:55 pppoesrvtux pppd[13352]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x40253ff8>]
    Jan 10 08:28:55 pppoesrvtux pppd[13369]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0xff7f8e9a>]
    Jan 10 08:28:58 pppoesrvtux pppd[13327]: LCP: timeout sending Config-Requests 
    Jan 10 08:28:58 pppoesrvtux pppd[13327]: Connection terminated.
    Jan 10 08:28:58 pppoesrvtux pppd[13327]: using channel 114
    Jan 10 08:28:58 pppoesrvtux pppd[13327]: Using interface ppp1
    Jan 10 08:28:58 pppoesrvtux pppd[13327]: Connect: ppp1 <--> /dev/pts/15
    Jan 10 08:28:58 pppoesrvtux pppd[13327]: Waiting for 2 child processes...
    Jan 10 08:28:58 pppoesrvtux pppd[13327]:   script /usr/sbin/pppoe -n -I eth1 -e 5:00:0c:29:b6:4f:54 -S '', pid 13381
    Jan 10 08:28:58 pppoesrvtux pppd[13327]:   script /usr/sbin/pppoe -n -I eth1 -e 5:00:0c:29:b6:4f:54 -S '', pid 13329
    Jan 10 08:28:58 pppoesrvtux pppd[13352]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x40253ff8>]
    Jan 10 08:28:58 pppoesrvtux pppd[13369]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0xff7f8e9a>]
    Jan 10 08:29:01 pppoesrvtux pppd[13352]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0x40253ff8>]
    Jan 10 08:29:01 pppoesrvtux pppd[13369]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0xff7f8e9a>]
    Jan 10 08:29:03 pppoesrvtux pppd[13327]: sending SIGTERM to process 13381
    Jan 10 08:29:03 pppoesrvtux pppd[13327]: sending SIGTERM to process 13329
    Jan 10 08:29:03 pppoesrvtux pppd[13327]: tcflush failed: Bad file descriptor
    Jan 10 08:29:03 pppoesrvtux pppd[13327]: Exit.
    Jan 10 08:29:03 pppoesrvtux pppoe-server[13211]: Session 5 closed for client 00:0c:29:b6:4f:54 (10.67.15.5) on eth1
    Jan 10 08:29:03 pppoesrvtux pppoe-server[13211]: Sent PADT
    Jan 10 08:29:04 pppoesrvtux pppd[13352]: LCP: timeout sending Config-Requests 
    Jan 10 08:29:04 pppoesrvtux pppd[13352]: Connection terminated.
    Jan 10 08:29:04 pppoesrvtux pppd[13369]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0xff7f8e9a>]
    Jan 10 08:29:04 pppoesrvtux pppd[13352]: using channel 115
    Jan 10 08:29:04 pppoesrvtux pppd[13352]: Using interface ppp0
    Jan 10 08:29:04 pppoesrvtux pppd[13352]: Connect: ppp0 <--> /dev/pts/16
    Jan 10 08:29:04 pppoesrvtux pppd[13352]: Waiting for 2 child processes...
    Jan 10 08:29:04 pppoesrvtux pppd[13352]:   script /usr/sbin/pppoe -n -I eth1 -e 6:00:0c:29:b6:4f:54 -S '', pid 13403
    Jan 10 08:29:04 pppoesrvtux pppd[13352]:   script /usr/sbin/pppoe -n -I eth1 -e 6:00:0c:29:b6:4f:54 -S '', pid 13354
    Jan 10 08:29:07 pppoesrvtux pppd[13369]: sent [LCP ConfReq id=0x1 <auth chap MD5> <magic 0xff7f8e9a>]
    Jan 10 08:29:09 pppoesrvtux pppd[13352]: sending SIGTERM to process 13403
    Jan 10 08:29:09 pppoesrvtux pppd[13352]: sending SIGTERM to process 13354
    Jan 10 08:29:09 pppoesrvtux pppd[13352]: tcflush failed: Bad file descriptor
    Jan 10 08:29:09 pppoesrvtux pppd[13352]: Exit.
    Jan 10 08:29:09 pppoesrvtux pppoe-server[13211]: Session 6 closed for client 00:0c:29:b6:4f:54 (10.67.15.6) on eth1
    Jan 10 08:29:09 pppoesrvtux pppoe-server[13211]: Sent PADT
    Jan 10 08:29:10 pppoesrvtux pppd[13369]: LCP: timeout sending Config-Requests 
    Jan 10 08:29:10 pppoesrvtux pppd[13369]: Connection terminated.
    Jan 10 08:29:10 pppoesrvtux pppd[13369]: using channel 116
    Jan 10 08:29:10 pppoesrvtux pppd[13369]: Using interface ppp0
    Jan 10 08:29:10 pppoesrvtux pppd[13369]: Connect: ppp0 <--> /dev/pts/17
    Jan 10 08:29:10 pppoesrvtux pppd[13369]: Waiting for 2 child processes...
    Jan 10 08:29:10 pppoesrvtux pppd[13369]:   script /usr/sbin/pppoe -n -I eth1 -e 7:00:0c:29:b6:4f:54 -S '', pid 13425
    Jan 10 08:29:10 pppoesrvtux pppd[13369]:   script /usr/sbin/pppoe -n -I eth1 -e 7:00:0c:29:b6:4f:54 -S '', pid 13371
    Jan 10 08:29:15 pppoesrvtux pppd[13369]: sending SIGTERM to process 13425
    Jan 10 08:29:15 pppoesrvtux pppd[13369]: sending SIGTERM to process 13371
    Jan 10 08:29:15 pppoesrvtux pppd[13369]: tcflush failed: Bad file descriptor
    Jan 10 08:29:15 pppoesrvtux pppd[13369]: Exit.
    Jan 10 08:29:15 pppoesrvtux pppoe-server[13211]: Session 7 closed for client 00:0c:29:b6:4f:54 (10.67.15.7) on eth1
    Jan 10 08:29:15 pppoesrvtux pppoe-server[13211]: Sent PADT
    
    messages

    Code:
    Jan 10 08:26:26 pppoesrvtux pppd[13212]: pppd 2.4.3 started by root, uid 0
    Jan 10 08:26:26 pppoesrvtux pppd[13212]: Using interface ppp0
    Jan 10 08:26:26 pppoesrvtux pppd[13212]: Connect: ppp0 <--> /dev/pts/1
    Jan 10 08:26:56 pppoesrvtux pppd[13225]: pppd 2.4.3 started by root, uid 0
    Jan 10 08:26:56 pppoesrvtux pppd[13225]: Using interface ppp1
    Jan 10 08:26:56 pppoesrvtux pppd[13225]: Connect: ppp1 <--> /dev/pts/2
    Jan 10 08:26:57 pppoesrvtux pppd[13212]: LCP: timeout sending Config-Requests 
    Jan 10 08:26:57 pppoesrvtux pppd[13212]: Connection terminated.
    Jan 10 08:26:57 pppoesrvtux pppd[13212]: Using interface ppp0
    Jan 10 08:26:57 pppoesrvtux pppd[13212]: Connect: ppp0 <--> /dev/pts/5
    Jan 10 08:27:02 pppoesrvtux pppd[13212]: tcflush failed: Bad file descriptor
    Jan 10 08:27:02 pppoesrvtux pppd[13212]: Exit.
    Jan 10 08:27:08 pppoesrvtux pppd[13263]: pppd 2.4.3 started by root, uid 0
    Jan 10 08:27:08 pppoesrvtux pppd[13263]: Using interface ppp0
    Jan 10 08:27:08 pppoesrvtux pppd[13263]: Connect: ppp0 <--> /dev/pts/6
    Jan 10 08:27:27 pppoesrvtux pppd[13225]: LCP: timeout sending Config-Requests 
    Jan 10 08:27:27 pppoesrvtux pppd[13225]: Connection terminated.
    Jan 10 08:27:27 pppoesrvtux pppd[13225]: Using interface ppp1
    Jan 10 08:27:27 pppoesrvtux pppd[13225]: Connect: ppp1 <--> /dev/pts/7
    Jan 10 08:27:33 pppoesrvtux pppd[13225]: tcflush failed: Bad file descriptor
    Jan 10 08:27:33 pppoesrvtux pppd[13225]: Exit.
    Jan 10 08:27:39 pppoesrvtux pppd[13263]: LCP: timeout sending Config-Requests 
    Jan 10 08:27:39 pppoesrvtux pppd[13263]: Connection terminated.
    Jan 10 08:27:39 pppoesrvtux pppd[13263]: Using interface ppp0
    Jan 10 08:27:39 pppoesrvtux pppd[13263]: Connect: ppp0 <--> /dev/pts/9
    Jan 10 08:27:44 pppoesrvtux pppd[13263]: tcflush failed: Bad file descriptor
    Jan 10 08:27:44 pppoesrvtux pppd[13263]: Exit.
    Jan 10 08:27:56 pppoesrvtux pppd[13317]: pppd 2.4.3 started by root, uid 0
    Jan 10 08:27:56 pppoesrvtux pppd[13317]: Using interface ppp0
    Jan 10 08:27:56 pppoesrvtux pppd[13317]: Connect: ppp0 <--> /dev/pts/10
    Jan 10 08:28:26 pppoesrvtux pppd[13327]: pppd 2.4.3 started by root, uid 0
    Jan 10 08:28:27 pppoesrvtux pppd[13327]: Using interface ppp1
    Jan 10 08:28:27 pppoesrvtux pppd[13327]: Connect: ppp1 <--> /dev/pts/11
    Jan 10 08:28:28 pppoesrvtux pppd[13317]: LCP: timeout sending Config-Requests 
    Jan 10 08:28:28 pppoesrvtux pppd[13317]: Connection terminated.
    Jan 10 08:28:28 pppoesrvtux pppd[13317]: Using interface ppp0
    Jan 10 08:28:28 pppoesrvtux pppd[13317]: Connect: ppp0 <--> /dev/pts/12
    Jan 10 08:28:33 pppoesrvtux pppd[13352]: pppd 2.4.3 started by root, uid 0
    Jan 10 08:28:33 pppoesrvtux pppd[13317]: tcflush failed: Bad file descriptor
    Jan 10 08:28:33 pppoesrvtux pppd[13317]: Exit.
    Jan 10 08:28:33 pppoesrvtux pppd[13352]: Using interface ppp0
    Jan 10 08:28:33 pppoesrvtux pppd[13352]: Connect: ppp0 <--> /dev/pts/13
    Jan 10 08:28:39 pppoesrvtux pppd[13369]: pppd 2.4.3 started by root, uid 0
    Jan 10 08:28:39 pppoesrvtux pppd[13369]: Using interface ppp2
    Jan 10 08:28:39 pppoesrvtux pppd[13369]: Connect: ppp2 <--> /dev/pts/14
    Jan 10 08:28:58 pppoesrvtux pppd[13327]: LCP: timeout sending Config-Requests 
    Jan 10 08:28:58 pppoesrvtux pppd[13327]: Connection terminated.
    Jan 10 08:28:58 pppoesrvtux pppd[13327]: Using interface ppp1
    Jan 10 08:28:58 pppoesrvtux pppd[13327]: Connect: ppp1 <--> /dev/pts/15
    Jan 10 08:29:03 pppoesrvtux pppd[13327]: tcflush failed: Bad file descriptor
    Jan 10 08:29:03 pppoesrvtux pppd[13327]: Exit.
    Jan 10 08:29:04 pppoesrvtux pppd[13352]: LCP: timeout sending Config-Requests 
    Jan 10 08:29:04 pppoesrvtux pppd[13352]: Connection terminated.
    Jan 10 08:29:04 pppoesrvtux pppd[13352]: Using interface ppp0
    Jan 10 08:29:04 pppoesrvtux pppd[13352]: Connect: ppp0 <--> /dev/pts/16
    Jan 10 08:29:09 pppoesrvtux pppd[13352]: tcflush failed: Bad file descriptor
    Jan 10 08:29:09 pppoesrvtux pppd[13352]: Exit.
    Jan 10 08:29:10 pppoesrvtux pppd[13369]: LCP: timeout sending Config-Requests 
    Jan 10 08:29:10 pppoesrvtux pppd[13369]: Connection terminated.
    Jan 10 08:29:10 pppoesrvtux pppd[13369]: Using interface ppp0
    Jan 10 08:29:10 pppoesrvtux pppd[13369]: Connect: ppp0 <--> /dev/pts/17
    Jan 10 08:29:15 pppoesrvtux pppd[13369]: tcflush failed: Bad file descriptor
    Jan 10 08:29:15 pppoesrvtux pppd[13369]: Exit.
    
     
  7. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Hmm, also entweder hat dein pppd keine Moeglichkeit auf dein /dev/pts/X zuzugreifen oder deine Timeouts sind zu klein wuerde ich mal auf den ersten Blick sagen. Folgendes findet man zu deinem Fehler, wenn man mal ein wenig googlet:

    LCP_INTERVAL=20 (put 60 or anything bigger than 20)
    LCP_FAILURE=3 (put 5 or anything higher than 3)
    PPPOE_TIMEOUT=80 (raise to 120 or higher)
    PPPOE_EXTRA="mtu 1444 mru 1500"
    PPPD_EXTRA="mtu 1444 mru 1500" (sometime using a MTU too high might lead to problem, my ISP)

    Also einfach mal entsprechende Einstellungen in der Konfiguration eintragen und mal schauen, ob es dann besser geht, oder ob dann der gleiche oder neue Fehler auftauchen. Mich machen vor allem folgende Zeilen aus deiner messages stutzig:

    Jan 10 08:29:10 pppoesrvtux pppd[13369]: LCP: timeout sending Config-Requests
    ...
    Jan 10 08:29:10 pppoesrvtux pppd[13369]: Connect: ppp0 <--> /dev/pts/17
    Jan 10 08:29:15 pppoesrvtux pppd[13369]: tcflush failed: Bad file descriptor

    Das sind definitiv die einzigen "richtigen" Fehler die auftauchen, daher auch meine Schlussfolgerungen.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

pppoe-server...