ppp schlaeft ein

Dieses Thema im Forum "OpenBSD" wurde erstellt von rikola, 16.10.2006.

  1. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Ich habe im Heimnetzwerk einen OpenBSD 3.6 Rechner, der prima laeuft. Gestern wollte ich auf einem anderen PC OpenBSD 3.9 installieren, da er etwas stromsparender ist. Bei der Einrichtung habe ich mich an das 3.6er System gehalten.

    Auf beiden Rechnern laeuft ppp -ddial, um sich mittels pppoe mit dem DSL-Provider (Arcor) zu verbinden. Ausserdem laeuft pf.

    Wenn man neu bootet, kann man von allen Rechner im Netzwerk ins Internet.
    Nach etwa 10-15 min jedoch scheint ppp auf dem neuen Rechner (3.9) einzuschlafen: ifconfig zeigt die Verbindung an, jedoch kommt man selbst von dem Rechner selber nicht mehr ins Internet. Das Heimnetz funktioniert weiterhin. Wenn man mit 'top' nachsieht, dann ist der Status von ppp und pppoe 'SLEEP' .

    Kann es daran liegen, dass die Prozesse schlafen? Und wenn ja, wie kann ich sie wieder aufwecken, bzw. verhindern, dass sie einschlafen? Wenn nein, woran koennte es sonst noch liegen?

    Das Problem tritt mit und ohne laufendem apmd auf.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. juedan

    juedan Guest

    Hallo rikola,

    gibt es vielleicht Prozesse im System, die enorme Rechenleistung ziehen?
    Ist das DSL-Modem in Ordnung, stimmt die Verkabelung, ist das Kabel in Ordnung?
    Kannst Du im Rechner BIOS einstellen, ob und wann eine Komponente in den Sleep-Mode fällt? Kannst Du vielleicht über den apmd Parameter bei den einzelnen Geräten einstellen. Da ich FreeBSD benutze habe ich keinen Zugriff auf die man-page von apmd und über das Web erhalte ich keine Infos.

    Viele Grüße

    Jürgen
     
  4. midar

    midar Jungspund

    Dabei seit:
    22.01.2007
    Beiträge:
    14
    Zustimmungen:
    0
    Du nutzt Userland PPPoE. Das ist seit einiger Zeit schon abgelöst durch Kernel-PPPoE. Da dies eigentlich ein kompletter rewrite ist, würde ich vorschlagen, daß du es mal damit probierst. Die CPU-Last ist dadurch auch bedeutend geringer.
     
Thema:

ppp schlaeft ein