postgresql-server läuft, aber pgadmin will nicht verbinden...

Dieses Thema: "postgresql-server läuft, aber pgadmin will nicht verbinden..." im Forum "SQL und Datenbanken" wurde erstellt von supersucker, 27.02.2005.

  1. #1 supersucker, 27.02.2005
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    moin zusammen,

    hab folgendes problem:

    hab mir den postgresql-server (7.4.7-3.FC3.1, fedora 3) installiert sowie webmin, beide laufen auch, das heisst ich kann über webmin auf dem postgre-server datenbanken erstellen, tabellen erstellen, befüllen, sql-commands direkt ausführen usw......

    dummerweise soll das was ich da mache später auf einem system laufen auf dem über pg-admin auf die db zugegriffen werden soll
    ok, also hab ich pgadmin per yumex installiert, pgadmin gestartet, wenn ich jetzt allerdings auf den postgre-server zugreifen will über pgadmin mit "neuen server hinzufügen", krieg ich folgende fehlermeldung:

    Error connecting to the server: could not connect to server: Verbindungsaufbau abgelehnt
    Is the server running on host "127.0.0.1" and accepting
    TCP/IP connections on port 5432?

    die antwort ist beides mal ja, server läuft auf localhost (hab ich auch so in der verbindungsdialogbox angegeben) und er lauscht auf port 5432 (hab ich über die webmin-postgre-configseite so angegeben)....

    hat jemand ne idee woran das problem liegen könnte? kann mit der fehlermeldung aus oben beschriebenen gründen nicht viel anfangen.......

    thx im voraus!
     
  2. #2 supersucker, 27.02.2005
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    oops,

    sorry, hab gerade eben erst gesehen dass es ein eigenes sql-db forum gibt
    vielleicht könnte ein freundlicher admin meinen beitrag dahin verschieben?

    thx
     
  3. #3 lordlamer, 27.02.2005
    lordlamer

    lordlamer Haudegen

    Dabei seit:
    15.05.2003
    Beiträge:
    703
    Zustimmungen:
    0
    Ort:
    hamburg
    hi!

    du musst dafür die pg_hba.conf anpassen. dort musst du sagen von wo aus wer zugreifen darf. default darf von aussen keiner zugreifen. default gehts eigentlich nur von local ohne tcp glaube ich.

    mfg frank
     
  4. #4 supersucker, 08.03.2005
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    hi,

    erstmal danke für den tip, hat aber leider nix gebracht weil der postgre-server auf der gleichen maschine läuft wie der client und in der pg_hba.conf steht ja:

    # CAUTION: The default configuration allows any local user to connect
    # using any PostgreSQL user name, including the superuser, over either
    # Unix-domain sockets or TCP/IP. If you are on a multiple-user
    # machine, the default configuration is probably too liberal for you.
    # Change it to use something other than "trust" authentication.
    #
    # If you want to allow non-local connections, you need to add more
    # "host" records. Also, remember TCP/IP connections are only enabled
    # if you enable "tcpip_socket" in postgresql.conf.

    # TYPE DATABASE USER IP-ADDRESS IP-MASK METHOD

    # IPv4-style local connections:
    host all all 127.0.0.1 255.255.255.255 trust
    # IPv6-style local connections:
    #host all all ::1 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff trust

    # Using sockets credentials for improved security. Not available everywhere,
    # but works on Linux, *BSD (and probably some others)

    local all all ident sameuser

    das müsste doch dann eigentlich auch klappen.......damn......:-(

    da ich mit diesem problem immer noch nicht weiter gekommen bin, nehm ich jetzt einfach psql und wenn ich unbedingt was über ein graphisches interface machen will nehm ich webmin........
     
  5. hopfe

    hopfe Haudegen

    Dabei seit:
    01.04.2003
    Beiträge:
    733
    Zustimmungen:
    0
    Ort:
    Aachen
    Auch wenn du dir sicher bist das Postgres auf den Port 5432 lauscht überprüfe es am besten noch einmal.
    entweder mit
    Code:
    nestat -apt | grep post
    oder mit
    Code:
    nmap localhost
    .
    Solltest du hier keine Ausgabe zu Postgres finden, kontrollier ob in der /var/lib/pgsql/data/postgresql.conf der Parameter tcpip_socket auf true gesetzt ist.
     
Thema: postgresql-server läuft, aber pgadmin will nicht verbinden...
Besucher kamen mit folgenden Suchen
  1. pgadmin III 7.4.7

    ,
  2. postgres server läuft nicht mehr tcp/ip

Die Seite wird geladen...

postgresql-server läuft, aber pgadmin will nicht verbinden... - Ähnliche Themen

  1. Problem mit mysqld und postgresql-server

    Problem mit mysqld und postgresql-server: hi, ich hab im bootlog folgende fehlermeldungen: Sat Mar 17 12:59:22 2007: Starting MySQL database server: mysqld . . . . . . . . . . . . . ....
  2. postgresql-server update problem

    postgresql-server update problem: hi zusammen, hab wieder mal ein problem, bei dem ich eure hilfe brauche : bei fedora 3 ist ja freundlicherweise schon ein postgreserver...
  3. Unterstützung für Ubuntu 15.04 läuft aus

    Unterstützung für Ubuntu 15.04 läuft aus: Neun Monate nach der Veröffentlichung endet die Unterstützung für Ubuntu 15.04 am 4. Februar. Benutzer sollten bis zu diesem Zeitpunkt auf Ubuntu...
  4. Anmeldung für LUG-Camp 2016 läuft

    Anmeldung für LUG-Camp 2016 läuft: Vom Donnerstag, den 5. Mai, bis zum Sonntag, den 8. Mai 2016, findet im badischen Bruchsal das mittlerweile 17. Treffen der Linux User Groups aus...
  5. GSoC2015: Bewerbungsfrist für Studenten läuft

    GSoC2015: Bewerbungsfrist für Studenten läuft: Nachdem Google vor knapp zwei Wochen die Liste der akzeptierten Projekte veröffentlichte, können sich ab sofort nun auch Studenten für die...