Postfix als Relay-Agent für Microsoft Exchange 2007 unter CentOs 5.9 einrichten

Dieses Thema im Forum "RedHat,Fedora & CentOS" wurde erstellt von gnoovy, 17.06.2013.

  1. gnoovy

    gnoovy Eroberer

    Dabei seit:
    20.02.2004
    Beiträge:
    73
    Zustimmungen:
    0
    hi zusammen,

    ich möchte Postfix als Relay-Agent für Nagios einrichten um Status-Mails über einen Microsoft Exchange Server 2007 intern im Betrieb an ausgewählte User zu versenden.
    Hierfür habe ich auf dem Exchange-Server einen connector für postfix im hub-transport Bereich eingerichtet. Sofern ich den Connector auf "Anonyme Benutzer" konfiguriere kann ich problemlos Mails versenden.
    Sobald ich diesen Punkt deaktiviere, erhalte ich eine Fehlermeldung in den Postfix maillog "530 5.7.1 client was not authenticated".
    Was mache ich hier noch falsch?

    main.cf
    generic
    saslpw
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 18.06.2013
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Lass doch einfach mal den smtpd von Postfix mit '-v' als Parameter laufen und schau woran die Authentifizierung scheitert. Dadurch sollte im Log einiges mehr auftauchen.
     
  4. gnoovy

    gnoovy Eroberer

    Dabei seit:
    20.02.2004
    Beiträge:
    73
    Zustimmungen:
    0
    Wenn ich /usr/libexec/postfix/smtpd - v eingebe bringt er mir "smtpd: fatal: do nut run this command by hand". Muss ich das anders ausführen?
     
  5. #4 bitmuncher, 18.06.2013
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Ja, du musst die Anpassung in der master.cf machen. Dort ist definiert wie Postfix die einzelnen Befehle/Daemonen handhabt und wie der Datenfluss im Server aussieht.
     
  6. gnoovy

    gnoovy Eroberer

    Dabei seit:
    20.02.2004
    Beiträge:
    73
    Zustimmungen:
    0
    habe ich gemacht. Dann geht er in einen Timeout. Das normale maillog liefert folgendes. Hilft das schon weiter?:

    Domänen und Userangaben habe ich durch Variablen in Form von <Variable> demaskiert.

     
  7. #6 bitmuncher, 18.06.2013
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Hm, das hilft nicht wirklich weiter. Interessant wäre ja vor allem zu erfahren mit welcher Methode sich der Postfix authentifizieren will, ob er es überhaupt versucht und welcher Username verwendet wird. Auf jeden Fall solltest du mal die Authentifizierung erzwingen indem du 'smtp_sasl_security_options = noanonymous' setzt.
     
  8. gnoovy

    gnoovy Eroberer

    Dabei seit:
    20.02.2004
    Beiträge:
    73
    Zustimmungen:
    0
    Hi bitmuncher,

    hmm... wie bekommt man das am Besten raus? Wenn ich diese Option setze bringt er genau das gleiche Log in der Maillog. Kannst du mir nochmals genau beschreiben wie ich das Logging auf debug setzen muss?
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. #8 tgruene, 19.06.2013
    tgruene

    tgruene Routinier

    Dabei seit:
    02.02.2012
    Beiträge:
    418
    Zustimmungen:
    0
    in /var/log/auth.log sollte das auch drinstehen, denke ich.
     
  11. gnoovy

    gnoovy Eroberer

    Dabei seit:
    20.02.2004
    Beiträge:
    73
    Zustimmungen:
    0
    Hi zusammen,

    eine auth.log existiert bei mir leider nicht :hilfe2: :headup:
     
Thema:

Postfix als Relay-Agent für Microsoft Exchange 2007 unter CentOs 5.9 einrichten

Die Seite wird geladen...

Postfix als Relay-Agent für Microsoft Exchange 2007 unter CentOs 5.9 einrichten - Ähnliche Themen

  1. postfix - fputs-error

    postfix - fputs-error: Ich hoffe, dass sich wer von euch mit postfix bzw. der Fehlermeldung auskennt. Ich habe nach dem Youtube-Video postfix eingerichtet: [MEDIA] Nun...
  2. Mein Server Ubuntu 14.04.3 LTS versendet spam (postfix/dovecot)

    Mein Server Ubuntu 14.04.3 LTS versendet spam (postfix/dovecot): Mir wurde gerade von meinem Hoster mitgeteilt, daß mein Server bai abusix.org geblacklistet wurde. Wenn ich in die logs schaue, so sehe ich z.B.:...
  3. postfix/dovecot/cyrus sasl: basic conf

    postfix/dovecot/cyrus sasl: basic conf: Moin! postfix/dovecot habe ich soweit, dass man Mails empfangen kann. Das war kein Problem. Ich weiß, dass es hunderte Seiten gibt, wie man...
  4. Postfix cfg, Antwort wenn abgelehnt.

    Postfix cfg, Antwort wenn abgelehnt.: Moin, ich hab in letzter Zeit feststellen dürfen das mout-xforward.web.de & mout-xforward.gmx.net immer wieder auf der spamhaus blocklist...
  5. Postfix 3.0 mit neuen Funktionen

    Postfix 3.0 mit neuen Funktionen: Die Entwickler des freien Mailservers Postfix haben Version 3.0 mit mehreren Verbesserungen und Optimierungen freigegeben. Zeitgleich kündigten...