PHP Development (PDT)

Dieses Thema im Forum "Anwendungen" wurde erstellt von Lightstorm, 22.09.2008.

  1. #1 Lightstorm, 22.09.2008
    Zuletzt bearbeitet: 22.09.2008
    Lightstorm

    Lightstorm Foren As

    Dabei seit:
    13.08.2008
    Beiträge:
    99
    Zustimmungen:
    0
    Nach verzweifeltem rumklicken und ein paar kleinen Wutanfällen habe ich es nicht geschafft mit dem PHP Development für Eclipse eine PHP Datei zu erstellen.

    Bei Windows hatte ich das Teil 1.0.3 Stable Build von hier runtergeladen:
    http://download.eclipse.org/tools/pdt/downloads/
    PDT All-in-One

    Dann entpackt und die Datei "eclipse" im Ordner gestartet, im Programm konnte ich unter File>New ein PHP Project erstellen.

    Aber mit der Linux Version gibs unter File>New kein PHP Auswahl, nirgendwo ein Wort mit PHP, ich kann keine PHP Dateien erstellen, dann versuchte ich mal eine PHP Datei mit eclipse zu öffnen, aber nein es wird automatisch mit gedit geöffnet, zum verrückt werden.

    Was mache ich falsch? Wie kann ich nun PHP Dateien damit öffnen und erstellen?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. daboss

    daboss Keine Macht für niemand!

    Dabei seit:
    05.01.2007
    Beiträge:
    1.294
    Zustimmungen:
    0
    Ort:
    sydney.australia.world
    Eventuell fehlen dir einige Abhängikeiten?

    Also, ich hab PDT immer über den Update-Manager installiert. (Der Link für den UM ist http://download.eclipse.org/tools/pdt/updates/ ).

    Mit Ganymede (3.4) allerdings gab's am Anfang noch kein dazu passendes PDT, und ich bin deswegen auf PHPEclipse umgestiegen. (Der Link für den UM wäre http://phpeclipse.sourceforge.net/update/releases/ ). Und das hat mir gleich viel mehr getaugt, wie PDT. Vor allem, weil's meiner Meinung nach um einiges stabiler funktioniert.
     
  4. foexle

    foexle Kaiser

    Dabei seit:
    02.05.2007
    Beiträge:
    1.104
    Zustimmungen:
    0
    Ort:
    Saarbrücken
    schau doch erst mal ob du überhaupt die php perspektive hast, wenn das nicht der fall ist, dann ist das plugin nicht installiert und dann machste das was mein vorredner schon gesagt hat

    alternativ kannst du auch inter Help ->Softwareupdates-> Manage Configuration nachschaun ob es da PHPEclipse gibt
     
  5. #4 sim4000, 22.09.2008
    sim4000

    sim4000 Lebende Foren Legende

    Dabei seit:
    12.04.2006
    Beiträge:
    1.933
    Zustimmungen:
    0
    Ort:
    In meinem Zimmer
    Ich habe Eclipse sowie das PHP AddOn über den Paketmanager (pacman) installiert.
    Schon mal bei dir geschaut, ob es in den Repos drin ist?

    Hast ja leider keine Distri angegeben....
     
  6. #5 Lightstorm, 22.09.2008
    Zuletzt bearbeitet: 22.09.2008
    Lightstorm

    Lightstorm Foren As

    Dabei seit:
    13.08.2008
    Beiträge:
    99
    Zustimmungen:
    0
    Ich habe Debian etch, in den Paketquellen ist nur das normale eclipse oder so, ich sah nichts von PHP eclipse.

    Ok ich versuche es über den Update Manager zu installieren, ich wähle "PDT Features SDK" aus, die Quelle ist der Link von @daboss, ja der Links ist mehrmals drin, aus versehen.
    http://img356.imageshack.us/my.php?image=log1dp1.jpg

    Klicke dann auf install...
    Daraufhin ladet es einige Zeit.

    Dann kommt diese Meldung:
    The software items you selected may not be valid with you current installation. Do you want to open the wizard anyway review the selections

    Ich klicke yes und es erscheint ein neues Fenster wo unten das steht:
    Cannot complete the request. See the details.
    Unsatisfied dependency: [org.eclipse.php_feature.feature.group 1.0.2.v20080102-79-7GE7QYGHNGPGY] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.feature.group/[2.0.0,3.0.0)
    Unsatisfied dependency: [org.eclipse.php_feature.feature.group 1.0.2.v20080102-79-7GE7QYGHNGPGY] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.feature.group/[2.0.0,3.0.0)
    Unsatisfied dependency: [org.eclipse.php.sdk_feature.feature.group 1.0.2.v20080102-2-384D2_RHATdIRZIZaq8RZHIOHQ] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.php_feature.feature.group/[1.0.2.v20080102-79-7GE7QYGHNGPGY,1.0.2.v20080102-79-7GE7QYGHNGPGY]

    http://img218.imageshack.us/my.php?image=log2zs9.jpg

    Dazu muss ich sagen, als ich es vorhin machte gabs da zwei Einträge, einmal die Version 1.0.2 und 1.0.3.
    Wenn ich ein Markierung von einem entferne ladet es und die Markierung ist weg und es passiert nix.
    Ich kann nicht auf Finsh klicken, ich habe versucht irgendwas auszuwählen, beide abgewählt, eine ausgewählt, ich kann nur auf cancel klicken.


    Ich habe als Ausgangs Version die eclipse classic runtergeladen wo ich dann den PDT Feature installieren wollte.

    Ich kriege langsam richtigen Hass auf diesen Programm, Stunden sind vergangen und es will nicht, nicht nur das es nicht einfach funktioniert, es ist so was von lahm, das ist echt unglaublich X(
     
  7. daboss

    daboss Keine Macht für niemand!

    Dabei seit:
    05.01.2007
    Beiträge:
    1.294
    Zustimmungen:
    0
    Ort:
    sydney.australia.world
    Was ist mit dem PHPEclipse-PlugIn? Oder willst du partout nur PDT?

    PDT scheint generell immer noch relativ problematisch zu sein, laut diesem Threat.

    /Edit: In dem verlinkten Threat gibt's allerdings noch zwei Links mit Hinweisen, was zu tun ist, damit's laufen könnte
     
  8. #7 Lightstorm, 22.09.2008
    Zuletzt bearbeitet: 22.09.2008
    Lightstorm

    Lightstorm Foren As

    Dabei seit:
    13.08.2008
    Beiträge:
    99
    Zustimmungen:
    0
    Ich gibs auf glaube ich, ich blicke nicht durch, diese Vielfalt von eclipse ist mir zu verwirrend, das einzige was ich will ist eclipse wo ich wie früher php coden kann.

    Ehrlich, ich bin ein Anfänger, ich habe keine Ahnung was PDT überhaupt ist, ich dachte jetzt damit hätte ich das PHP Plugin.

    Mit dem Link was du mir für den Update Manager gegeben hast gabs nur die drei Sachen die du auf dem Bild siehst: PDT Features, PDT Features SKD und Uncatogorized.
    Mehr gabs nicht zum auswählen.

    Werde mir wohl ein anderes Programm suchen, aber ich glaube es gibt kein kostenloses das Autoverollständigung und Syntax Fehlererkennung für PHP hat oder doch?

    Nur deswegen habe ich eclipse benutzt, ich finde diese gigantischen Java Programme (genau wie Azureus) sind noch viel zu träge, der Update Manager hat ein Resourcenverbrauch als ob ich ein modernes 3D Spiel am laufen habe der gerade den PC voll auslastet, wer wird da nicht wütend wenns dann auch nicht funktioniert.

    Trotzdem vielen dank für die Hilfe :)
     
  9. daboss

    daboss Keine Macht für niemand!

    Dabei seit:
    05.01.2007
    Beiträge:
    1.294
    Zustimmungen:
    0
    Ort:
    sydney.australia.world
    Oben hatte ich ja noch geschrieben:

    und dir damit noch einen Link zu einem alternativen PHP-Plugin gegeben.

    PDT sind die PHP Development Tools, nur ein (von mehreren) Plugin, mit dem man Eclipse PHP beibringen kann. So wie ich's verstanden hab, sind die PDT eine Abspaltung von PHPEclipse ('n anderes Plugin, mit dem man Eclipse PHP-fähig macht)
     
  10. #9 Lightstorm, 22.09.2008
    Lightstorm

    Lightstorm Foren As

    Dabei seit:
    13.08.2008
    Beiträge:
    99
    Zustimmungen:
    0
    Geht der Link bei dir? Bei mir steht da An error has been encountered in accessing this page. usw.
    Eclipse akzeptiert den Link auch nicht.
     
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. daboss

    daboss Keine Macht für niemand!

    Dabei seit:
    05.01.2007
    Beiträge:
    1.294
    Zustimmungen:
    0
    Ort:
    sydney.australia.world
    Hmmm, sorry, den Link hatte ich so in meinem Eclipse. Hatte vergessen, den raus zu nehmen, als ich gemerkt hatte, das ich da was verwechselt habe, beim PHPEclipse installieren :/

    http://phpeclipse.sourceforge.net/update/stable/1.2.x/ sollte funktionieren
     
  13. #11 Lightstorm, 22.09.2008
    Lightstorm

    Lightstorm Foren As

    Dabei seit:
    13.08.2008
    Beiträge:
    99
    Zustimmungen:
    0
    Endlich! Es hat geklappt! :)
    Habe PHPeclipse installieren können und es funktioniert.
    Vielen Dank! Hier wird einem echt gut geholfen, klasse, jetzt geh ich endlich schlafen, die Nacht war anstrengend.
     
Thema:

PHP Development (PDT)

Die Seite wird geladen...

PHP Development (PDT) - Ähnliche Themen

  1. 10 Jahre Open Source Automation Development Lab

    10 Jahre Open Source Automation Development Lab: Das Open Source Automation Development Lab (OSADL) feiert sein 10-jähriges Bestehen. Ziel der Organisation ist es, Linux für den industriellen...
  2. ARM Dual Core oder Quad Core Development Board gesucht

    ARM Dual Core oder Quad Core Development Board gesucht: Hallo, Kennt wer ein gutes Development Board mit einem ARM Dual Core oder Quad Core Prozessor? Möchte gerne die Welt der 8-Bit Microcontroller...
  3. Java Development Kit 8 mit sechs Monaten Verspätung freigegeben

    Java Development Kit 8 mit sechs Monaten Verspätung freigegeben: Oracle hat sein Java Development Kit (JDK) 8 mit rund einem halben Jahr Verspätung freigegeben. Glanzlicht dieser Veröffentlichung sind die lange...
  4. Application Manager (m/w) - im Team Operations Development Hosting

    Application Manager (m/w) - im Team Operations Development Hosting: Guten Tag, wir suchen für einen unserer Kunden einen Application Manager (m/w) - im Team Operations Development Hosting. Die 1&1 Internet AG...
  5. Wir suchen einen Praktikanten für Software Development!!!

    Wir suchen einen Praktikanten für Software Development!!!: Wir suchen einen engagierten und kreativen Praktikanten der sich nicht davor scheut, Eigenverantwortung zu übernehmen. Eigeninitiative, Effizienz,...