PHP 5.1 per apt-get auf Debian Etch installieren

Dieses Thema im Forum "Installation & Basiskonfiguration" wurde erstellt von blueunderground, 12.12.2007.

  1. #1 blueunderground, 12.12.2007
    blueunderground

    blueunderground Mitglied

    Dabei seit:
    13.10.2005
    Beiträge:
    28
    Zustimmungen:
    0
    Hi,

    wer kann mir sagen wie ich per apt-get install, nicht die aktuelle Version von PHP 5.2.X auf ein Debian Etch installiere, sondern die PHP 5.1.X Version ?

    Vielen Dank!

    Blue
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. cremi

    cremi Dude

    Dabei seit:
    15.02.2004
    Beiträge:
    329
    Zustimmungen:
    0
    Ort:
    AUT/Ktn
  4. #3 supersucker, 12.12.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Code:
     To select a particular version of the package, append “=<version>” to the package name: for instance,
               “aptitude install apt=0.3.1”. Similarly, to select a package from a particular archive, append “/<archive>” to
               the package name: for instance, “aptitude install apt/experimental”.
    
    Sollte mit apt-get auch gehen.
     
  5. #4 blueunderground, 12.12.2007
    Zuletzt bearbeitet: 12.12.2007
    blueunderground

    blueunderground Mitglied

    Dabei seit:
    13.10.2005
    Beiträge:
    28
    Zustimmungen:
    0

    Hi,
    das war mir schon klar.
    Wenn man unter Debian Etch:

    apt-get install php5 eingibt installiert er PHP 5.2.X, ich möchte aber per apt-get install PHP 5.1 installieren.

    Bei apt-get install php5 holt er sich immer nur die Aktuelle.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Die Sache funktioniert mit apt-get nicht, und bei aptiude auch nicht :-(

    server1:~# aptitude install php=5.1 oder aptitude install php5=5.1

    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Lese erweiterte Statusinformationen
    Initialisiere Paketstatus... Fertig
    Lese Task-Beschreibungen... Fertig
    Erzeuge Tag-Datenbank... Fertig
    Konnte Paket »php« nicht finden und mehr als 40 Pakete
    enthalten »php« in ihrem Namen:
    Die folgenden Pakete werden zurückgehalten:
    e2fslibs e2fsprogs libblkid1 libcomerr2 libkrb53 libss2 libssl0.9.8 libuuid1
    0 Pakete aktualisiert, 0 zusätzlich installiert, 0 werden entfernt und 8 nicht aktualisiert.
    Muss 0B an Archiven herunterladen. Nach dem Entpacken werden 0B zusätzlich belegt sein.
     
  6. #5 Goodspeed, 12.12.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Warum will man eine veraltete PHP5-Version installieren??
     
  7. #6 slackfan, 13.12.2007
    slackfan

    slackfan König

    Dabei seit:
    18.04.2006
    Beiträge:
    809
    Zustimmungen:
    0
    Ort:
    Bonn
    Verstehe ich auch nicht. In php5.2 wurden zwar ein paar (sehr) alte Zöpfe abgeschnitten, aber in dem Fall, dass man das wirklich brauchen sollte, ist der Einsatz von php3 oder 4 doch sinnvoller als von 5.1.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. #7 blueunderground, 13.12.2007
    blueunderground

    blueunderground Mitglied

    Dabei seit:
    13.10.2005
    Beiträge:
    28
    Zustimmungen:
    0
    Kundenwunsch, aber ich werde das dem Kunden beibringen das es aus sicherheitsrelevanten Gründen Sinn macht, auf 5.2.x zu gehen, Danke für Eure Hilfe ! :-)

    Aber noch ne Frage, wie kann ich am einfachsten Module nachinstallieren ? außer per apt-get install X.deb, sprich Module die es als deb Paket noch nicht gibt, Danke !
     
  10. #8 supersucker, 13.12.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Nachtrag:

    Hab's gerade nochmal selber geprüft, php V.5.1 ist wirklich nicht mehr in den repositories:

    Code:
    aptitude show php5 -v
    Package: php5
    State: not installed
    Version: 5.2.3-1ubuntu6.2
    Priority: optional
    Section: web
    Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Uncompressed Size: 20.5k
    Architecture: all
    Compressed Size: 1082
    Filename: pool/main/p/php5/php5_5.2.3-1ubuntu6.2_all.deb
    MD5sum: 77c1c2ec676628707caf5588962f0f45
    Archive: gutsy-updates, gutsy-security
    Depends: libapache2-mod-php5 (>= 5.2.3-1ubuntu6.2) | php5-cgi (>= 5.2.3-1ubuntu6.2), php5-common (>= 5.2.3-1ubuntu6.2)
    Description: server-side, HTML-embedded scripting language (meta-package)
     This package is a meta-package that, when installed, guarantees that you have at least one of the four server-side versions
     of the PHP5 interpreter installed.  Removing this package won't remove PHP5 from your system, however it may remove other
     packages that depend on this one. 
     
     PHP5 is an HTML-embedded scripting language. Much of its syntax is borrowed from C, Java and Perl with a couple of unique
     PHP-specific features thrown in. The goal of the language is to allow web developers to write dynamically generated pages
     quickly. 
     
     Homepage: http://www.php.net/
    
    Package: php5
    State: not installed
    Version: 5.2.3-1ubuntu6
    Priority: optional
    Section: web
    Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Uncompressed Size: 20.5k
    Architecture: all
    Compressed Size: 1078
    Filename: pool/main/p/php5/php5_5.2.3-1ubuntu6_all.deb
    MD5sum: 1e359b018260d1af46c4a02165a8b17b
    Archive: gutsy
    Depends: libapache2-mod-php5 (>= 5.2.3-1ubuntu6) | php5-cgi (>= 5.2.3-1ubuntu6), php5-common (>= 5.2.3-1ubuntu6)
    Description: server-side, HTML-embedded scripting language (meta-package)
     This package is a meta-package that, when installed, guarantees that you have at least one of the four server-side versions
     of the PHP5 interpreter installed.  Removing this package won't remove PHP5 from your system, however it may remove other
     packages that depend on this one. 
     
     PHP5 is an HTML-embedded scripting language. Much of its syntax is borrowed from C, Java and Perl with a couple of unique
     PHP-specific features thrown in. The goal of the language is to allow web developers to write dynamically generated pages
     quickly. 
     
     Homepage: http://www.php.net/
    
     
Thema:

PHP 5.1 per apt-get auf Debian Etch installieren

Die Seite wird geladen...

PHP 5.1 per apt-get auf Debian Etch installieren - Ähnliche Themen

  1. debian lenny updaten per apt-get?

    debian lenny updaten per apt-get?: hallo zusammen habe auf meinem sparc-rechner nun wieder debian lenny installiert, da das besser läuft als "squeeze" und "wheezy". nun wollte...
  2. apt-get - Debian-Pakete abrufen

    apt-get - Debian-Pakete abrufen: Ein Kollege und ich streiten uns ein wenig. Mein Freund meinte: Mein Linuxlehrer hat mir empfohlen bei der Debian-Installation die...
  3. Debian zerschossen!! apt-get ist kaputt

    Debian zerschossen!! apt-get ist kaputt: Hallo, Ich habe ausversehen mit folgenden commando: apt-get --purge remove usbutils libusb-0.1-4 hotplug mein debian 5 zerschossen, apt-get...
  4. DEBIAN Java install über apt-get

    DEBIAN Java install über apt-get: Hallo, Kann ich bei debian java über apt-get installieren wenn ja welches befehl muss ich eingeben ??? mfg klicky
  5. Problem bei apt-get upgrade (Kali 2.0)

    Problem bei apt-get upgrade (Kali 2.0): Hi, seit paar Tagen habe ich einige Probs. Dachte es sei mal an der Zeit für ein Update und nun tauchen da einige Fehler auf: Es müssen noch 0 B...