Pfad zu den htdocs ändern

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von sim4000, 24.09.2006.

  1. #1 sim4000, 24.09.2006
    sim4000

    sim4000 Lebende Foren Legende

    Dabei seit:
    12.04.2006
    Beiträge:
    1.933
    Zustimmungen:
    0
    Ort:
    In meinem Zimmer
    hallo leute.

    Ich würde gerne den Pfad zu den htdocs ändern. So das meine htdocs in meinem home-verzeichnis sind.

    Die vergesse ich immer zu sichern wenn ich mal neu aufsetze.
    Kann mir jemand sagen wie das geht?
    Mfg, sim4000.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Mµ*e^13.5_?¿, 24.09.2006
    Mµ*e^13.5_?¿

    Mµ*e^13.5_?¿ Routinier

    Dabei seit:
    21.02.2006
    Beiträge:
    453
    Zustimmungen:
    0
  4. mcas

    mcas Routinier

    Dabei seit:
    29.12.2005
    Beiträge:
    398
    Zustimmungen:
    0
    Das geht über die httpd.conf mit dem Parameter "DocumentRoot". Es gibt aber auch die Möglichkeit aus den Homeverzeichnissen Seiten einzubinden. Leider habe ich den Parameter vergessen. Steht aber bestimmt im Kommentar.
     
  5. #4 sim4000, 24.09.2006
    sim4000

    sim4000 Lebende Foren Legende

    Dabei seit:
    12.04.2006
    Beiträge:
    1.933
    Zustimmungen:
    0
    Ort:
    In meinem Zimmer
    Der eintrag fehlte in meiner httpd.conf. Wenn ich ihn hinzufüge und dann auf http://localhost/website zugreifen will, bekomme ich 403. gibts noch was was ich machen muss?

    Mfg, sim4000.
     
  6. #5 Mµ*e^13.5_?¿, 24.09.2006
    Mµ*e^13.5_?¿

    Mµ*e^13.5_?¿ Routinier

    Dabei seit:
    21.02.2006
    Beiträge:
    453
    Zustimmungen:
    0
    Dafür sorgen, dass der Webserver auch auf das Verzeichnis und die Daten zugreifen darf?
     
  7. grey

    grey -=[GHOST]=-

    Dabei seit:
    28.07.2006
    Beiträge:
    303
    Zustimmungen:
    0
    Ich würde mal schwer drauf tippen, daß der User, unter welchem der Webserver läuft, keine leserechte in deinem /home/***, bzw. keine leserechte für die aufgerufene Datei hat
     
  8. #7 sim4000, 24.09.2006
    sim4000

    sim4000 Lebende Foren Legende

    Dabei seit:
    12.04.2006
    Beiträge:
    1.933
    Zustimmungen:
    0
    Ort:
    In meinem Zimmer
    Darf er ja. Hab den verzeichnis die gleichen rechte gegeben wie den alten htdocs gegeben. klappt aber nicht.

    Mfg, sim4000.
     
  9. grey

    grey -=[GHOST]=-

    Dabei seit:
    28.07.2006
    Beiträge:
    303
    Zustimmungen:
    0
    Und die Files, welche du aufrufst?

    BTW: Es wäre interessant, was in deinen Error-Logs steht.
     
  10. #9 Mµ*e^13.5_?¿, 24.09.2006
    Mµ*e^13.5_?¿

    Mµ*e^13.5_?¿ Routinier

    Dabei seit:
    21.02.2006
    Beiträge:
    453
    Zustimmungen:
    0
    Es sollte auch in Apache-Konfiguration drinstehen, dass auch das Verzeichnis zugegriffen werden darf.
    Also
    Code:
    <Directory /home/blah/dein_document_root>
        Order Allow,Deny
        Allow from All
    </Directory>
    
     
  11. #10 sim4000, 24.09.2006
    sim4000

    sim4000 Lebende Foren Legende

    Dabei seit:
    12.04.2006
    Beiträge:
    1.933
    Zustimmungen:
    0
    Ort:
    In meinem Zimmer
    Code:
    [Sat Sep 23 15:02:21 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Sat Sep 23 15:02:21 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sat Sep 23 15:02:22 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 15:02:22 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 15:02:22 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 15:02:23 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 15:02:23 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 15:02:23 2006] [notice] Apache/2.2.0 (Linux/SUSE) configured -- resuming normal operations
    [Sat Sep 23 15:05:22 2006] [notice] caught SIGTERM, shutting down
    [Sat Sep 23 15:06:34 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Sat Sep 23 15:06:34 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sat Sep 23 15:06:37 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 15:06:37 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 15:06:37 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 15:06:37 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 15:06:37 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 15:06:37 2006] [notice] Apache/2.2.0 (Linux/SUSE) configured -- resuming normal operations
    [Sat Sep 23 17:26:55 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 17:47:27 2006] [notice] caught SIGTERM, shutting down
    [Sat Sep 23 21:08:54 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Sat Sep 23 21:08:54 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sat Sep 23 21:08:56 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 21:08:56 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 21:08:56 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 21:08:56 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 21:08:56 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 21:08:56 2006] [notice] Apache/2.2.0 (Linux/SUSE) configured -- resuming normal operations
    [Sat Sep 23 22:20:15 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Sat Sep 23 22:20:15 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sat Sep 23 22:20:16 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 22:20:16 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 22:20:16 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 22:20:16 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 22:20:16 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sat Sep 23 22:20:16 2006] [notice] Apache/2.2.0 (Linux/SUSE) configured -- resuming normal operations
    [Sun Sep 24 00:17:17 2006] [notice] caught SIGTERM, shutting down
    [Sun Sep 24 00:19:51 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Sun Sep 24 00:19:52 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sun Sep 24 00:19:52 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 00:19:52 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 00:19:52 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 00:19:52 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 00:19:52 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 00:19:52 2006] [notice] Apache/2.2.0 (Linux/SUSE) configured -- resuming normal operations
    [Sun Sep 24 00:53:48 2006] [notice] caught SIGTERM, shutting down
    [Sun Sep 24 01:06:31 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Sun Sep 24 01:06:31 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sun Sep 24 01:06:32 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:06:32 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:06:32 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:06:32 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:06:32 2006] [notice] Apache/2.2.0 (Linux/SUSE) configured -- resuming normal operations
    [Sun Sep 24 01:06:32 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:06:45 2006] [error] [client 127.0.0.1] client denied by server configuration: /home/sim4000/htdocs/website
    [Sun Sep 24 01:06:45 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:06:46 2006] [error] [client 127.0.0.1] client denied by server configuration: /home/sim4000/htdocs/favicon.ico
    [Sun Sep 24 01:06:46 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:06:46 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:06:50 2006] [error] [client 127.0.0.1] client denied by server configuration: /home/sim4000/htdocs/, referer: http://localhost/website
    [Sun Sep 24 01:06:50 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:07:19 2006] [notice] caught SIGTERM, shutting down
    [Sun Sep 24 01:07:20 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Sun Sep 24 01:07:20 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sun Sep 24 01:07:21 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:07:21 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:07:21 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:07:21 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:07:21 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:07:21 2006] [notice] Apache/2.2.0 (Linux/SUSE) configured -- resuming normal operations
    [Sun Sep 24 01:07:25 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:07:25 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:07:42 2006] [notice] caught SIGTERM, shutting down
    [Sun Sep 24 01:07:43 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Sun Sep 24 01:07:43 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sun Sep 24 01:07:44 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:07:44 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:07:44 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:07:44 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:07:44 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:07:44 2006] [notice] Apache/2.2.0 (Linux/SUSE) configured -- resuming normal operations
    [Sun Sep 24 01:07:56 2006] [error] [client 127.0.0.1] client denied by server configuration: /home/sim4000/htdocs/website
    [Sun Sep 24 01:07:56 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:07:57 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:08:58 2006] [error] [client 127.0.0.1] client denied by server configuration: /home/sim4000/htdocs/website
    [Sun Sep 24 01:08:58 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:17:45 2006] [notice] caught SIGTERM, shutting down
    [Sun Sep 24 01:17:46 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Sun Sep 24 01:17:46 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sun Sep 24 01:17:46 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:17:46 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:17:46 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:17:46 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:17:46 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:17:46 2006] [notice] Apache/2.2.0 (Linux/SUSE) configured -- resuming normal operations
    [Sun Sep 24 01:17:51 2006] [error] [client 127.0.0.1] client denied by server configuration: /home/sim4000/htdocs/website
    [Sun Sep 24 01:17:51 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    [Sun Sep 24 01:17:51 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
    
     
  12. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  13. #11 Wolfgang, 24.09.2006
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Hallo
    Du hast die Dokumentation zum Apache nicht wirklich gelesen.
    Versuch es nochmal, und sag was du nicht verstanden hast.
    Beachte auch, dass Verzeichnisse Ausführungsrechte brauchen, um darin existierende Dateien auflistbar zu machen.

    Im Übrigen bist du wahrscheinlich gerade dabei, ein Sicherheitsloch zu öffnen.
    Wenn das nur im privaten Netzwerk passiert, ist das eventuell vertretbar.
    Nur sollte dir das bewusst sein.

    Gruß Wolfgang
     
  14. #12 sim4000, 30.09.2006
    sim4000

    sim4000 Lebende Foren Legende

    Dabei seit:
    12.04.2006
    Beiträge:
    1.933
    Zustimmungen:
    0
    Ort:
    In meinem Zimmer
    Ich habs endlich geschafft.
    Das stand bei mir in der Datei /etc/apache2/default-server.conf
    Code:
    #
    # Global configuration that will be applicable for all virtual hosts, unless
    # deleted here, or overriden elswhere.
    # 
    
    DocumentRoot "/home/sim4000/htdocs"
    
    #
    # Configure the DocumentRoot
    #
    <Directory "/home/sim4000/htdocs">
    	# Possible values for the Options directive are "None", "All",
    	# or any combination of:
    	#   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    	#
    	# Note that "MultiViews" must be named *explicitly* --- "Options All"
    	# doesn't give it to you.
    	#
    	# The Options directive is both complicated and important.  Please see
    	# http://httpd.apache.org/docs-2.2/mod/core.html#options
    	# for more information.
    	Options None
    	# AllowOverride controls what directives may be placed in .htaccess files.
    	# It can be "All", "None", or any combination of the keywords:
    	#   Options FileInfo AuthConfig Limit
    	AllowOverride None
    	# Controls who can get stuff from this server.
    	Order allow,deny
    	Allow from all
    </Directory>
    Und da hab ich nur an zwei stellen den Pfad verändert.
    Dann noch mit
    Code:
    # rcapache2 restart
    den Apache neustarten, fertig.

    Das ist ja nur ein Testserver, wenn ich mal an meiner Webpage bastel. Und von außen nicht erreichbar.

    Herzlichen Dank an alle für eure Hilfe.
    Mfg, sim4000.
     
Thema:

Pfad zu den htdocs ändern

Die Seite wird geladen...

Pfad zu den htdocs ändern - Ähnliche Themen

  1. Löschen mit Wildcard wenn Space im Pfad ist?

    Löschen mit Wildcard wenn Space im Pfad ist?: Hallo zusammen weder rm "/var/lib/vmware/Virtual Machines/Virtual Machine/"*.lck -R noch rm "/var/lib/vmware/Virtual...
  2. Suche Dateinpfad in .txt

    Suche Dateinpfad in .txt: Hallo, mein Problem ist folgendes: Ich habe Textdatein in denen zwei für mich relevante Dinge stehen. Zum einen die Zeile: Enabled:...
  3. Wie einen Pfad zur Vereinfachung mittels Shellskript wechseln

    Wie einen Pfad zur Vereinfachung mittels Shellskript wechseln: Ich muß häufiger in 2 bestimmte Verzeichnisse auf 3. oder 4. Ebene wechseln. Um nicht permanent cd /ordnerA/ordnerB/ordnerC... usw eingeben zu...
  4. sed mit basename verknüpfen - oder anders Dateipfade in Dateien mit regex ersetzen?

    sed mit basename verknüpfen - oder anders Dateipfade in Dateien mit regex ersetzen?: Hallo, mein Ziel ist es ein Script zu schreiben, das eine CSS-Datei entgegen nimmt und in dieser Datei Pfade ersetzt. Ich möchte bspw....
  5. HowTo? : CentOS Kickstart / angepasste Installation mit mehren Installationspfaden

    HowTo? : CentOS Kickstart / angepasste Installation mit mehren Installationspfaden: Hallo, leider habe ich zu meinem Anliegen keine Ressourcen gefunden, auch nicht im Installationshandbuch von RedHat.. Ich möchte CentOS /...