perl: warning: Setting locale failed.

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Apulanta, 11.12.2003.

  1. #1 Apulanta, 11.12.2003
    Apulanta

    Apulanta Moderatorte

    Dabei seit:
    16.05.2003
    Beiträge:
    434
    Zustimmungen:
    0
    Ort:
    HH
    Hallo,
    ich hab folgendes Problem beim dist-upgrade:

    Ist auch nicht schlimm, es funktioniert noch alles, aber es nervt.

    Ich hab natürlich schon diverses bzgl. der locales versucht, aber weder ein "dpkg-reconfigure locales" noch manuelles editieren von /etc/environment oder /etc/locales.gen bringen irgendwas.


    Hab ich irgendwas übersehen?

    Grüße, Apu
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. JoBi

    JoBi Eroberer

    Dabei seit:
    17.07.2003
    Beiträge:
    63
    Zustimmungen:
    0
    Ort:
    Regensburg
    Hi,

    was gibt denn "locale" bei Dir aus?
    Und hast Du eine Ländereinstellung aus der Liste von "locale -a" benutzt?
     
  4. #3 Apulanta, 11.12.2003
    Apulanta

    Apulanta Moderatorte

    Dabei seit:
    16.05.2003
    Beiträge:
    434
    Zustimmungen:
    0
    Ort:
    HH
    So, jetzt gehts... hab alles noch mal von vorne gemacht, also " dpkg-reconfigure localeconf" und dann als root " set-language-env -E".

    Gruß, Apu
     
  5. JoBi

    JoBi Eroberer

    Dabei seit:
    17.07.2003
    Beiträge:
    63
    Zustimmungen:
    0
    Ort:
    Regensburg
    Selbst ist der Mann/Frau ;)

    Grüße, Josef
     
  6. #5 Apulanta, 11.12.2003
    Apulanta

    Apulanta Moderatorte

    Dabei seit:
    16.05.2003
    Beiträge:
    434
    Zustimmungen:
    0
    Ort:
    HH
    Jo...jetzt hab ich noch ein kleines bis mittelschweres foomatic-filters-Problem, aber das nehm ich dann morgen in Angriff..

    Gruß von der Apu
     
  7. #6 StefanRHRO, 07.03.2006
    StefanRHRO

    StefanRHRO Jungspund

    Dabei seit:
    07.03.2006
    Beiträge:
    18
    Zustimmungen:
    0
    hallo, ich habe an sich das gleiche problem, nur nicht mit root... :D
    das heißt, wenn ich root bin, funzen die locale einstellungen und als "normaler" user nicht.
    aber hier mal meine locale als root:
    Code:
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Kann LC_ALL nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden
    LANG=de_DE.UTF-8
    LANGUAGE=de_DE:de:en_US:en
    LC_CTYPE=de_DE
    LC_NUMERIC="de_DE.UTF-8"
    LC_TIME="de_DE.UTF-8"
    LC_COLLATE="de_DE.UTF-8"
    LC_MONETARY="de_DE.UTF-8"
    LC_MESSAGES="de_DE.UTF-8"
    LC_PAPER="de_DE.UTF-8"
    LC_NAME="de_DE.UTF-8"
    LC_ADDRESS="de_DE.UTF-8"
    LC_TELEPHONE="de_DE.UTF-8"
    LC_MEASUREMENT="de_DE.UTF-8"
    LC_IDENTIFICATION="de_DE.UTF-8"
    LC_ALL=
    und hier mal als user:
    Code:
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    LANG=de_DE
    LANGUAGE=de_DE:de:en_GB:en
    LC_CTYPE="de_DE"
    LC_NUMERIC="de_DE"
    LC_TIME="de_DE"
    LC_COLLATE="de_DE"
    LC_MONETARY="de_DE"
    LC_MESSAGES="de_DE"
    LC_PAPER="de_DE"
    LC_NAME="de_DE"
    LC_ADDRESS="de_DE"
    LC_TELEPHONE="de_DE"
    LC_MEASUREMENT="de_DE"
    LC_IDENTIFICATION="de_DE"
    LC_ALL=
    weiß einer wie ich das abstellen kann?
     
  8. #7 Wolfgang, 07.03.2006
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Hallo

    Schreib halt in deine entsprechende .bashrc die gewünschten Variablen rein und exportiere diese.

    e.g.
    LC_ALL=de_DE@euro
    export LC_ALL

    On the Fly entweder sources ~./bashrc oder einfach direkt exportieren.

    Gruß Wolfgang
     
  9. sawa

    sawa Grünschnabel

    Dabei seit:
    18.07.2006
    Beiträge:
    5
    Zustimmungen:
    0
    alter thread, neues problem =)

    habe folgendes problem..

    Code:
    bla:~# locale
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    LANG=de_DE@euro
    LANGUAGE=de_DE:de:en_GB:en
    LC_CTYPE="de_DE@euro"
    LC_NUMERIC="de_DE@euro"
    LC_TIME="de_DE@euro"
    LC_COLLATE="de_DE@euro"
    LC_MONETARY="de_DE@euro"
    LC_MESSAGES="de_DE@euro"
    LC_PAPER="de_DE@euro"
    LC_NAME="de_DE@euro"
    LC_ADDRESS="de_DE@euro"
    LC_TELEPHONE="de_DE@euro"
    LC_MEASUREMENT="de_DE@euro"
    LC_IDENTIFICATION="de_DE@euro"
    LC_ALL=de_DE@euro
    
    wie geh ich da am besten vor?
    habe schon versucht in der .bashrc die fehlenden vars zu setzen bzw. dann zu exportieren. hat nicht weitergeholfen..
     
  10. #9 Wolfgang, 21.07.2006
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Hallo

    Gib mal
    locale -a
    ein.
    Aus den dort zur Verfügung stehenden locale kannst du deine userspezifische locale einstellen.
    Du musst aber auch die entsprechende Variable in der dem user zugeteilten ~/.bashrc eintragen.
    root hat eine andere als der user usw.

    Gruß Wolfgang
     
  11. sawa

    sawa Grünschnabel

    Dabei seit:
    18.07.2006
    Beiträge:
    5
    Zustimmungen:
    0
    locale -a gibt mir folgendes aus..

    Code:
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_COLLATE to default locale: No such file or directory
    C
    POSIX
    
    versteh ich nicht ganz.
     
  12. #11 Wolfgang, 21.07.2006
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Hallo

    Du hast schlichtweg aus welchenGgründen auch immer keine locales generiert.
    Wenn du locales installiert hast, dann versuch doch mal ein
    dpkg-reconfigure locales

    Das setzt natürlich voraus, dass die entsprechenden Schriften und Pakete vorhanden sind.

    Oder schau dir mal das hier an
    oder das hier an.

    Gruß Wolfgang
     
  13. sawa

    sawa Grünschnabel

    Dabei seit:
    18.07.2006
    Beiträge:
    5
    Zustimmungen:
    0
    vielen dank.
    funktioniert nun einwandfrei.
    wie hast du diese artikel gefunden?
     
  14. mumpf

    mumpf Grünschnabel

    Dabei seit:
    09.09.2006
    Beiträge:
    1
    Zustimmungen:
    0
    Hallo Wolfgang

    Wollte mich für die links bedanken. Gemäss "Die Sprache auf Deutsch umstellen", Dein zweiter link, habe ich localeconf installiert mittels sudo apt-get install localeconf. Schon während der Installation wird localeconf aufgerufen und ich konnte so die Schweizer environment-settings setzen.

    Hat wunderbar funktioniert.

    mumpf

    P.S. Die Original Debian-wikis auf Deutsch produzieren bei mir eher mehr Fragen, als dass sie helfen. Schade.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 geruempelkammer, 25.03.2007
    geruempelkammer

    geruempelkammer Grünschnabel

    Dabei seit:
    25.03.2007
    Beiträge:
    1
    Zustimmungen:
    0
    Hallo,

    ich habe auch ein Problem mit den Spracheinstellungen und ich verzweifle grade daran.

    dpkg-reconfigure locales
    dpkg-reconfigure localesconf

    hat beides nichts gebracht.

    in meiner .bashrc habe ich zusätzlich folgendes eingetragen (da stand vorher nichts davon drin, weiss nicht ob das normal ist):
    Code:
    LANG=de_DE@euro
    LANGUAGE=de_DE@euro
    export LANG
    export LANGUAGE
    LC_ALL=de_DE@euro
    export LC_ALL
    bei locale -a erhalte ich folgende rückmeldung:
    Code:
    locale: Cannot set LC_COLLATE to default locale: No such file or directory
    C
    POSIX
    de_AT.utf8
    de_BE.utf8
    de_CH.utf8
    de_DE.utf8
    de_DE@euro
    de_LU.utf8
    en_AU.utf8
    en_BW.utf8
    en_CA.utf8
    en_DK.utf8
    en_GB.utf8
    en_HK.utf8
    en_IE.utf8
    en_IN
    en_NZ.utf8
    en_PH.utf8
    en_SG.utf8
    en_US.utf8
    en_ZA.utf8
    en_ZW.utf8
    
    und ein Aufruf von locale zeigt mir folgendes:
    Code:
    locale: Cannot set LC_ALL to default locale: No such file or directory
    LANG=de_DE@euro
    LANGUAGE=de_DE@euro
    LC_CTYPE="de_DE@euro"
    LC_NUMERIC="de_DE@euro"
    LC_TIME="de_DE@euro"
    LC_COLLATE="de_DE@euro"
    LC_MONETARY="de_DE@euro"
    LC_MESSAGES="de_DE@euro"
    LC_PAPER="de_DE@euro"
    LC_NAME="de_DE@euro"
    LC_ADDRESS="de_DE@euro"
    LC_TELEPHONE="de_DE@euro"
    LC_MEASUREMENT="de_DE@euro"
    LC_IDENTIFICATION="de_DE@euro"
    LC_ALL=de_DE@euro
    
    Meiner Meinung nach sieht das nicht ganz schlecht aus. Nur das neuerdings der größte Teil meines OS in englisch ist. Das stört mich noch nicht einmal so, besser wäre es natürlich einheitlich, aber die Sonderzeichen und Umlaute funktionieren im Systen nicht mehr. Im Firefox schon, wie man sehen kann. Gaim im Übrigen auch. Größtes Problem ist derzeit skype, wobei ich auch gerne alles wieder einheitlich auf deutsch hätte.

    Ich hoffe echt auf eure Hilfe!
     
  17. chich

    chich Grünschnabel

    Dabei seit:
    28.03.2007
    Beiträge:
    1
    Zustimmungen:
    0
    kann es sein, dass du die oem-installation von kubuntu genommen hast? funktioniert bei dir kde-benutzerverwaltung?
     
Thema:

perl: warning: Setting locale failed.

Die Seite wird geladen...

perl: warning: Setting locale failed. - Ähnliche Themen

  1. Linux Foundation: Hyperledger-Projekt startet mit 30 Mitgliedern

    Linux Foundation: Hyperledger-Projekt startet mit 30 Mitgliedern: Das Hyperledger-Projekt der Linux Foundation will eine neue Form der dezentralisierten Kontoführung nach dem Prinzip der »distributed ledger« bei...
  2. Perl 6 offiziell vorgestellt

    Perl 6 offiziell vorgestellt: Wie erwartet, ist die Version C(hristmas) von Perl 6 veröffentlicht worden. Perl 6 stellt nicht, wie der Name suggeriert, einen Nachfolger von...
  3. Perl: 20 Jahre CPAN

    Perl: 20 Jahre CPAN: Vor 20 Jahren wurde das erste Modul in das Comprehensive Perl Archive Network (CPAN) hochgeladen, woran Neil Bowers mit einem Abriss der...
  4. Perl 5.22.0 freigegeben

    Perl 5.22.0 freigegeben: Die neue Version 5.22 von Perl bringt den Anwendern mehr Sicherheit bei Eingabedateien, Unicode 7.0 und zahlreiche weitere Verbesserungen....
  5. [Perl] Perl OO Methodenaufruf in anderem Objekt

    [Perl] Perl OO Methodenaufruf in anderem Objekt: Hallo, Ich bin dabei in Perl ein Pokerspiel zu programmieren, hänge aber momentan an einem Problem, wo ich nicht weiterkomme. Ich habe die...