PERL: Installieren von RRDs.pm schlägt fehl

Dieses Thema im Forum "Ruby, php, Perl, Python ..." wurde erstellt von pc-nico, 09.06.2008.

  1. #1 pc-nico, 09.06.2008
    pc-nico

    pc-nico Tripel-As

    Dabei seit:
    15.09.2005
    Beiträge:
    209
    Zustimmungen:
    0
    Hallo,

    ich versuche gerade RRDs.pm zu installieren um anschließende die Applikation Mailgraph
    zu verwenden.

    ich habe erfolgreich rrdtool-1.2.27 compeliert und installiert... danach kann man
    aus den Sourcen vom rrdtool das shared Perl Modul installieren...leider schlägt dies
    mit folgender Meldung fehl:

    Code:
    [root@server perl-shared]# perl Makefile.PL
    Writing Makefile for RRDs
    [root@server perl-shared]# make test
    gcc -c  -I../../src -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -Wdeclaration-after-statement -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables   -DVERSION=\"1.2027\" -DXS_VERSION=\"1.2027\" -fPIC "-I/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE"  -DPERLPATCHLEVEL=8 RRDs.c
    RRDs.c: In Funktion »XS_RRDs_xport«:
    RRDs.c:428: Warnung: Variable »targ« wird nicht verwendet
    RRDs.c:427: Warnung: Variable »RETVAL« wird nicht verwendet
    RRDs.xs:332: Warnung: Variable »row_cnt« wird nicht verwendet
    Running Mkbootstrap for RRDs ()
    chmod 644 RRDs.bs
    rm -f blib/arch/auto/RRDs/RRDs.so
    gcc  -shared -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -L/usr/local/lib RRDs.o -L../../src/.libs/  -lrrd  -o blib/arch/auto/RRDs/RRDs.so      \
               -lm -lpng -lz -lfreetype     \
    
    chmod 755 blib/arch/auto/RRDs/RRDs.so
    cp RRDs.bs blib/arch/auto/RRDs/RRDs.bs
    chmod 644 blib/arch/auto/RRDs/RRDs.bs
    PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
    t/base....Can't load '/root/mailgraph-1.14/rrdtool-1.2.27/bindings/perl-shared/blib/arch/auto/RRDs/RRDs.so' for module RRDs: librrd.so.2: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/DynaLoader.pm line 230.
     at t/base.t line 20
    Compilation failed in require at t/base.t line 20.
    BEGIN failed--compilation aborted at t/base.t line 20.
    t/base....dubious
            Test returned status 2 (wstat 512, 0x200)
    DIED. FAILED tests 1-7
            Failed 7/7 tests, 0.00% okay
    Failed Test Stat Wstat Total Fail  Failed  List of Failed
    -------------------------------------------------------------------------------
    t/base.t       2   512     7   13 185.71%  1-7
    Failed 1/1 test scripts, 0.00% okay. 7/7 subtests failed, 0.00% okay.
    make: *** [test_dynamic] Fehler 2
    
    kann mir jemand vllt einen Tipp geben? Die besagten Dateien existieren....
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

PERL: Installieren von RRDs.pm schlägt fehl

Die Seite wird geladen...

PERL: Installieren von RRDs.pm schlägt fehl - Ähnliche Themen

  1. activeperl lässt sich nicht installieren...

    activeperl lässt sich nicht installieren...: hallo, ich lerne mit perl zu programmieren und will auf linux umsteigen, da ich leider noch windows xp benutze. was kann ich machen?
  2. Linux Foundation: Hyperledger-Projekt startet mit 30 Mitgliedern

    Linux Foundation: Hyperledger-Projekt startet mit 30 Mitgliedern: Das Hyperledger-Projekt der Linux Foundation will eine neue Form der dezentralisierten Kontoführung nach dem Prinzip der »distributed ledger« bei...
  3. Perl 6 offiziell vorgestellt

    Perl 6 offiziell vorgestellt: Wie erwartet, ist die Version C(hristmas) von Perl 6 veröffentlicht worden. Perl 6 stellt nicht, wie der Name suggeriert, einen Nachfolger von...
  4. Perl: 20 Jahre CPAN

    Perl: 20 Jahre CPAN: Vor 20 Jahren wurde das erste Modul in das Comprehensive Perl Archive Network (CPAN) hochgeladen, woran Neil Bowers mit einem Abriss der...
  5. Perl 5.22.0 freigegeben

    Perl 5.22.0 freigegeben: Die neue Version 5.22 von Perl bringt den Anwendern mehr Sicherheit bei Eingabedateien, Unicode 7.0 und zahlreiche weitere Verbesserungen....