Performanceprobleme mit dem Jdeveloper

Dieses Thema im Forum "Anwendungen" wurde erstellt von juan_, 10.04.2009.

  1. juan_

    juan_ König

    Dabei seit:
    22.01.2004
    Beiträge:
    992
    Zustimmungen:
    0
    Ort:
    Berlin
    Guten Morgen beisammen,

    Ich wollte mir gestern die neue Version des JDevelopers auf meinem Rechner (Lenny - 2.6.26-1-686) installieren, habe aber schon beim Start der Installationsroutine gemerkt, dass es sehr träge ist:
    ich musste nach jedem Dialogfenster 10 - 30 mins warten, bis ich auf Weiter klicken konnte, nach gefühlten 10h, als es dann endlich zur eigentliche Installation kam (die eigentlich recht schnell ging), hatte ich wieder Hoffnung, zumal auch der Start echt flott von Statten ging (im Vergleich zu der ~1min bei meinem Notebook mit ca. gleicher Hardware). Aber nach dem Start gehts genauso lahm weiter. Ich kann nicht ein Dialog öffnen, ohne lange warten zu müssen.

    Fehler gibt es weder in der Konsole noch so. Das Problem besteht auch mit älteren Releases. Hat vielleicht jemand Ahnung, was da nicht passen könnte? Ich bin eigentlich auf dem neust-möglichen Stand (was Lenny angeht). Braucht ihr irgendwelche Infos?
    Grafiktreiber sind auch installiert, falls jetzt jemand an sowas denkt (die Gui ist ja schon recht Overkill ;))..

    Vielen Dank für die Tipps.

    CIao
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 10.04.2009
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Wie sieht deine Java-Konfiguration auf beiden System aus?
     
  4. juan_

    juan_ König

    Dabei seit:
    22.01.2004
    Beiträge:
    992
    Zustimmungen:
    0
    Ort:
    Berlin
    ist das die jvm.cfg ?
     
  5. #4 supersucker, 11.04.2009
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Jein, aber poste trotzdem mal die von beiden Systemen.

    Eigentlich meinte ich:

    Was sagt:

    Code:
    env | grep -i java
    und

    Code:
    java -version
    auf beiden Systemen?
     
  6. juan_

    juan_ König

    Dabei seit:
    22.01.2004
    Beiträge:
    992
    Zustimmungen:
    0
    Ort:
    Berlin
    Hallo,
    die jvm.cfg sieht auf beiden Systemen so aus:
    Code:
    #/etc/java-1.5.0-sun/jvm.cfg
    -client IF_SERVER_CLASS -server
    -server KNOWN
    -hotspot ALIASED_TO -client
    -classic WARN
    -native ERROR
    -green ERROR
    
    Code:
    env | grep -i java
    
    gibt es auf keinem der Systeme und java -version sagt:
    Code:
    pc# java -version
    java version "1.5.0_17"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_17-b04)
    Java HotSpot(TM) Server VM (build 1.5.0_17-b04, mixed mode
    
    
    notebook# java -version
    java version "1.6.0_0"
    IcedTea6 1.3.1 (6b12-0ubuntu6.4) Runtime Enviroment (build 1.6.0_ß-b12)
    OpenJDK Server VM (build 1.6.0_0-b12, mixed-mode)
    
    Danke
     
  7. #6 supersucker, 11.04.2009
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Ok, da haben wir doch schon einen Kandidaten für den Fehler -> unterschiedliche Java-Versionen:

    Wo ist nun das Problem, auf dem notebook oder auf dem PC?

    Du musst ja nun nur die Java-Versionen entsprechend anpassen.

    Ach ja, und setz bei der Gelegenheit am Besten auch noch gleich JAVA_HOME auf die richtigen Verzeichnisse.
     
  8. juan_

    juan_ König

    Dabei seit:
    22.01.2004
    Beiträge:
    992
    Zustimmungen:
    0
    Ort:
    Berlin
    Hi,
    der Fehler liegt beim PC. Irgendwie bekomm ich das sch*ß Ding aber gerade nicht geupdatet.. naja, bin vielleicht einfach bisschen müde ;)

    Ich melde mich morgen - nach einem hoffentlich fehlerlosen Update - wieder ;)


    Schönen Abend noch!
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. #8 supersucker, 11.04.2009
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Ein

    Code:
    aptitude install sun-java6-jdk
    sollte zum Updaten ausreichen.....:)

    (Kann natürlich sein, das das Paket unter Debian anders heißt, bin gerade unter Ubuntu unterwegs)
     
  11. juan_

    juan_ König

    Dabei seit:
    22.01.2004
    Beiträge:
    992
    Zustimmungen:
    0
    Ort:
    Berlin
    Wär auch zu einfach gewesen ;)
    Hab zwar das Paket installiert (Version ist gleicht geblieben), aber die Performance hat sich nur leicht verbessert.

    Wieso wurde das Update nicht bei einem Upgrade installiert?

    ciao
     
Thema:

Performanceprobleme mit dem Jdeveloper

Die Seite wird geladen...

Performanceprobleme mit dem Jdeveloper - Ähnliche Themen

  1. Performanceprobleme ?

    Performanceprobleme ?: Hi, ich sitze hier im Firmen LAN und merke gerade das wir heute eine ganz grässliche Performance haben. Geht das nur mir so auf unixboard.de...