pdf-Viewer fressen zu viel RAM

Dieses Thema im Forum "Anwendungen" wurde erstellt von Gott_in_schwarz, 05.05.2010.

  1. #1 Gott_in_schwarz, 05.05.2010
    Gott_in_schwarz

    Gott_in_schwarz ar0

    Dabei seit:
    22.04.2007
    Beiträge:
    546
    Zustimmungen:
    0
    Ort:
    Niedersachsen
    Moin,
    ich hab einige ebooks die quasi einfach hochauflösende Bilder sind. Wenn ich mir sowas in evince oder pdfview anschau, kommt es zu extremen lags (Maus reagiert kaum noch, das ganze System wird für 30Sekunden oder so völlig unbenutzbar).
    Ich schätze das es am RAM liegt, ich hab nur 512mb.
    Wenn ich auf top achte siehts ungefähr so aus:
    Vom startup aus verbraucht evince konstant ca. 75% CPU oder so und der Speicher geht schnell auf 50%.
    Wenn ich dann nix mache geht der CPU verbrauch runter, RAM-Konsum bleibt gleich. Aber sobald ich zB 5 Seiten weiter springe geht die RAM Benutzung recht fix gegen 70% (CPU Verbrauch geht auch wieder hoch) und dann ist meistens schon armageddon: top reagiert nicht mehr, alles steht still, ... (Bis entweder evince von alleine abbricht oder ich es irgendwie abtöte.)

    Ich hatte zwischenzeitlich auch einen /etc/security/limits.conf Eintrag, kann mich aber schon nicht mehr erinnern was der genau war. Der Effekt war jedenfalls, dass evince einfach auf dem "Speicherpeak" gekillt wurde, was sicherlich besser ist als nichts, aber das Problem nicht wirklich löst.
    (Wenns irgendwie mit der limits.conf geht wäre das super. Aber ich weiß nichtmal welchen "Typ" man da genau braucht um den RAM-footprint zu begrenzen. Ich glaub ich hab damals entweder "as" oder "memlock" benutzt. Tips sind willkommen.)


    Ein "workaround" ist pdftoppm, allerdings ist das auch nicht unbedingt das wahre.

    Also, kann ich spezifische Programme irgendwie am RAMoklauf hindern?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 marcellus, 05.05.2010
    marcellus

    marcellus Kaiser

    Dabei seit:
    09.05.2007
    Beiträge:
    1.392
    Zustimmungen:
    0
    Wenn du riesengroße bilder anschauen willst kostet es einfach viel ram die darzustellen. Die limits kannst du dir normalerweise aber sparen, wenn du den swap abdrehst kommts nicht zu solchen extremen lags, sondern der kernel würgt den hungrigsten prozess ab und gut ist.

    Du sollte vielleicht schauen, ob du mit xpdf mehr spaß hast, bzw probier die pdfs entweder in einzelseiten zu zerreißen, oder ein texterkennungsprogramm drüber laufen zu lassen.
     
  4. #3 Gott_in_schwarz, 05.05.2010
    Gott_in_schwarz

    Gott_in_schwarz ar0

    Dabei seit:
    22.04.2007
    Beiträge:
    546
    Zustimmungen:
    0
    Ort:
    Niedersachsen
    Naja, eine Seite passt ja auch locker innen RAM, aber evince scheint immer im Hintergrund wild rum zu cachen, was meinen PC dann schnell in die Knie zwingt.

    Joar, wie gesagt, pdftoppm.

    Tatsächlich hab ich xpdf früher ausschließlich benutzt. Aber wenn das längere Zeit aktiv ist stürzt es gerne mal ab, vor allem wenn man Text auswählt, deswegen bin ich quasi zu evince übergegangen. Aber es scheint wesentlich speicherökonomischer als evince zu sein, Tatsache.
     
  5. #4 bytepool, 05.05.2010
    bytepool

    bytepool Code Monkey

    Dabei seit:
    12.07.2003
    Beiträge:
    791
    Zustimmungen:
    0
    Ort:
    /home/sweden/göteborg
    Hi,
    Wenn du Debian oder einen Ableger wie Ubuntu benutzt, koennte das eventuell daran liegen bzw. gelegen haben, dass xpdf lange Zeit (mehrere Jahre) nicht richtig maintained wurde.
    Da gab es dann in Debian letztes Jahr einige Diskussion zu, und seit ein paar Monaten ist da wieder etwas Bewegung drin und scheint wieder aktiv maintained zu werden. Bei Interesse siehe diesen Bug: http://bugs.debian.org/527840

    D.h. eventuell muesstest du einfach mal ein neueres Paket oder eine von Source installierte Version ausprobieren.

    mfg,
    bytepool
     
  6. #5 kartoffel200, 06.05.2010
    kartoffel200

    kartoffel200 AMD Fanboy Since 2003

    Dabei seit:
    12.03.2007
    Beiträge:
    938
    Zustimmungen:
    0
    Ort:
    L wie localhost
    Meine Version von evince (2.22.2) die aus Debian stürzt nicht ab doch ich hab 4GB RAM. Vielleicht ist es ja nur ein Bug deiner Version, welche du immer auch nutzen magst.

    Ich schaff es nicht den RAM Verbrauch, auch bei PDFs mit mehreren Hochauflösenden Bildern zu strapazieren.
     
  7. #6 marcellus, 06.05.2010
    marcellus

    marcellus Kaiser

    Dabei seit:
    09.05.2007
    Beiträge:
    1.392
    Zustimmungen:
    0
    Mit ghostscript kann man sich auch pdfs ansehen, das sollte auch halbwegs ram sparend sein, weil immer nur eine seite auf einmal angezeigt wird, wär vllt auch noch eine option.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. #7 tuxlover, 06.05.2010
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    Ort:
    berlin
    Oder wenn du nicht auf die Bilder sondern nur auf den Text angewiesen bist, kannst du pdfs auch auf der Konsole betrachten mit pdftotext und das geht so:

    Code:
    pdftotext /home/meins/Desktop/inhalt.pdf | less 
    
     
  10. #8 Onkel Jürgen, 06.05.2010
    Onkel Jürgen

    Onkel Jürgen Doppel-As

    Dabei seit:
    27.11.2007
    Beiträge:
    114
    Zustimmungen:
    0
    Ort:
    Tübingen
Thema:

pdf-Viewer fressen zu viel RAM

Die Seite wird geladen...

pdf-Viewer fressen zu viel RAM - Ähnliche Themen

  1. Suse hat mein Win98 gefressen :(

    Suse hat mein Win98 gefressen :(: Lief irgendwie eigentlich immer naja nun ergab sich jedenfalls folgendes prob. hab neben win98 auf meinem lappi nun auch suse 9.2 installiert...